Jump to content
  • 1

Frequent crashing in 1.2.1, Solutions?


Question

PC Specs for reference:

Windows 7 Pro

i5-6600K @ 4.7Ghz

EVGA GTX 970 SC

32 Gb of RAM

KSP 1.2.1 on a HDD

Mods: KER, EVE, Distant Objects, Tweakscale, Planet Shine, Scatterer, SVE

The game seems to crash at random, but it always does during flight scenes in an atmosphere. Perhaps too many visual mods? I am running the 64 bit version from the Steam interface.

Some crash logs for those tech savvies out there. Any help or suggestions? Vanilla KSP is doing the same, if not more frequently.

https://www.dropbox.com/sh/0wu21xnm51c1zjh/AAARqHkNAApFjNkwyVGmU8KDa?dl=0

https://www.dropbox.com/sh/ihqkcjgbely37m9/AAAN6lc8qtBmLWepCxumOr3Ba?dl=0

https://www.dropbox.com/sh/4hnw5hbnpcyla21/AACVzRLG_SffFqRpOPmUNBd0a?dl=0

https://www.dropbox.com/sh/2rgehonkp68lf2u/AAAyesa4AtJWiLnhEkh-vwUia?dl=0

 

The crashes all reference this part:

Context:
RDI:    0x8e2c7d30  RSI: 0x9004d800  RAX:   0x6c803b6e
RBX:    0x00000000  RCX: 0x001ee9d0  RDX:   0x00000001
RIP:    0x3fa5bc67  RBP: 0x00000198  SegCs: 0x00000033
EFlags: 0x00010202  RSP: 0x001ee920  SegSs: 0x0000002b
R8:    0x041f0f30  R9: 0x001ee9d0  R10:   0xffffffff
R11:    0x0001828a  R12: 0x2b810060  R13:   0x001ee9d0
R14:    0x00000001  R15: 0x00000000

Is there anything wrong with it?

The game seems to crash every time it approaches 30% RAM or approximately 9GB.

Edited by NightshineRecorralis
Moar crashes
Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 1
5 hours ago, NightshineRecorralis said:

Just ran it with the Windows test, no problem at all.

I tried it @ 4.4Ghz and the stock 3.5Ghz, no change in behavior

Hi,  is it any coincidence this all started happening since your thread today when we got hung up on drag and aerodynamic performance?

If so you might have started using aero forces display (f12) or gone into the debug menu and brought up the aero data gui like you see on most of my screenshots.   There is a bug in 1.2.1 where enabling either of these causes an access violation crash 5-10 minutes later.   The workaround is to disable   "highlight fx" in the graphics options off the game main menu.   I'm amazed such a catastrophic bug hasn't gone more widely reported, just shows how few people actually try to optimise the aerodynamics of their aircraft... 

Link to post
Share on other sites
  • 0

1.2.1 nor 1.2 haven't crashed for me outside a (meanwhile fixed) KAC bug. If your vanila 1.2.1 is crashing I would start running memory tests, I wouldn't exclude the possibility of corrupt memory, given how stable 1.2 tends to be.

Edited by Kerbart
Link to post
Share on other sites
  • 0
13 minutes ago, Foxster said:

The obvious thing is to remove the visual mods one at a time until the crashing stops.

Vanilla KSP still crashes for me.

8 minutes ago, Kerbart said:

1.2.1 nor 1.2 haven't crashed for me outside a (meanwhile fixed) KAC bug. If your vanila 1.2.1 is crashing I would start running memory tests, I wouldn't exclude the possibility of corrupt memory, given how stable 1.2 tends to be.

I do editing on this computer, and I've used almost 30GB of RAM at once, so it should be fine, I think.

Link to post
Share on other sites
  • 0
1 hour ago, NightshineRecorralis said:

Vanilla KSP still crashes for me.

I do editing on this computer, and I've used almost 30GB of RAM at once, so it should be fine, I think.

But you don't know for sure. Because you're not checking it. Instead of running a check while  you're sleeping—and confirming or dismissing a hardware problem—you prefer uncertainty? And expecting energy from the community to solve a problem that might be caused by something they have no control over? Ok.

Link to post
Share on other sites
  • 0
2 hours ago, NightshineRecorralis said:

i5-6600K @ 4.7Ghz

Obvious as it may be, also test without the overclock. KSP seems to be very sensitive to this - I've had it crashing on an OC that I couldn't fault with the usual stress-testing stuff.

Link to post
Share on other sites
  • 0
1 hour ago, Kerbart said:

But you don't know for sure. Because you're not checking it. Instead of running a check while  you're sleeping—and confirming or dismissing a hardware problem—you prefer uncertainty? And expecting energy from the community to solve a problem that might be caused by something they have no control over? Ok.

Just ran it with the Windows test, no problem at all.

47 minutes ago, steve_v said:

Obvious as it may be, also test without the overclock. KSP seems to be very sensitive to this - I've had it crashing on an OC that I couldn't fault with the usual stress-testing stuff.

I tried it @ 4.4Ghz and the stock 3.5Ghz, no change in behavior

Link to post
Share on other sites
  • 0

 

Just now, AeroGav said:

Hi,  is it any coincidence this all started happening since your thread today when we got hung up on drag and aerodynamic performance?

If so you might have started using aero forces display (f12) or gone into the debug menu and brought up the aero data gui like you see on most of my screenshots.   There is a bug in 1.2.1 where enabling either of these causes an access violation crash 5-10 minutes later.   The workaround is to disable   "highlight fx" in the graphics options off the game main menu.   I'm amazed such a catastrophic bug hasn't gone more widely reported, just shows how few people actually try to optimise the aerodynamics of their aircraft... 

Not really, but it has been occurring much more frequently when I did start looking at my f12 key. I'll try it out, thanks!

Link to post
Share on other sites
  • 0
25 minutes ago, AeroGav said:

Hi,  is it any coincidence this all started happening since your thread today when we got hung up on drag and aerodynamic performance?

If so you might have started using aero forces display (f12) or gone into the debug menu and brought up the aero data gui like you see on most of my screenshots.   There is a bug in 1.2.1 where enabling either of these causes an access violation crash 5-10 minutes later.   The workaround is to disable   "highlight fx" in the graphics options off the game main menu.   I'm amazed such a catastrophic bug hasn't gone more widely reported, just shows how few people actually try to optimise the aerodynamics of their aircraft... 

This is good information I was not aware of.  Sorry to interrupt this post, but I too get pretty consistent crashes similar to the original poster, and I do use the F12 aero display as well as have "hightlight fx" enabled.  Thanks for the tip, I will give it a try.

 

Link to post
Share on other sites
  • 0
On 13.11.2016 at 0:13 AM, AeroGav said:

Hi,  is it any coincidence this all started happening since your thread today when we got hung up on drag and aerodynamic performance?

If so you might have started using aero forces display (f12) or gone into the debug menu and brought up the aero data gui like you see on most of my screenshots.   There is a bug in 1.2.1 where enabling either of these causes an access violation crash 5-10 minutes later.   The workaround is to disable   "highlight fx" in the graphics options off the game main menu.   I'm amazed such a catastrophic bug hasn't gone more widely reported, just shows how few people actually try to optimise the aerodynamics of their aircraft... 

Just want to confirm that the game will crash a while after using the aero forces display. What a weird bug! Would never have thought of that on my own. 

Link to post
Share on other sites
  • 0

I've been doing mod dev since 1.2 came out and just now starting getting frequent memory crashes on 2 different machines ( I dev on one and QA test on another). This only recently started happening for me, I immediately thought driver update or Windows patch.

I can report that disabling Highlight FX did stop the crashing I could could reproduce.

Link to post
Share on other sites
  • 0

I have a very similar mod set (no KER at the moment, have Kopernicus installed), and get basically this same crash.... 6 of them the last day I played, it only seemed to happen in the atmosphere... this thread gives me hope for solving it

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...