NAD5

[1.6] Contract Pack: Kerbin Air Force [KAF]

Recommended Posts

Requires contract configurator: https://github.com/jrossignol/ContractConfigurator/releases/tag/1.26.0
and BD armory: https://github.com/PapaJoesSoup/BDArmory/releases

IF THE AIRCRAFT DON'T FLY:
Go into advanced difficulty options, disable require signal for control. This can also be found in the cheat menu.
May not be necessary, only happens to a few people.

e7QkwZQ.jpg

KAF is a small contract pack featuring various intercepting and dog-fighting missions, pitting your user made aircraft and air defense systems up against a variety of Russian aircraft.

Enemies include:
MIG 15, MIG 21, MIG 25P, MIG 25BM (SEAD), SU 25, SU 25T and the SU 27

Each successful mission will net you a small amount of science, reputation and funds.
It is recommended that you extend your phys distance to make the most of this mod.


Download: http://spacedock.info/mod/1060/Contract Pack: Kerbin Air Force [KAF]





I plan to slowly add more missions and aircraft.

Please leave any feedback, suggestions or requests in the comments!

Many thanks to TheKurgan for testing and fixing this mod

Edited by NAD5
Credits

Share this post


Link to post
Share on other sites

cKan Mod Manager doesn't always populate the ContractPacks folder so it can make it difficult for 1st time users to install contracts so compressing the GameData folder with the mod inside would help.

I am doing the Kerbin Air Force Mission Eliminate Enemy FOB and unfortunately all of the targets are either upside down or sideways on spawn causing all the targets to get destroyed on spawn.

Edited by dcompart

Share this post


Link to post
Share on other sites

I love this mod but there is 1 problem: I have absolutely NO idea where I can find the target planes. it doesn't tell me or show on the map. Do I need to save the aircraft in the SPH because it's nowhere to be found

Share this post


Link to post
Share on other sites
7 hours ago, dcompart said:

cKan Mod Manager doesn't always populate the ContractPacks folder so it can make it difficult for 1st time users to install contracts so compressing the GameData folder with the mod inside would help.

I am doing the Kerbin Air Force Mission Eliminate Enemy FOB and unfortunately all of the targets are either upside down or sideways on spawn causing all the targets to get destroyed on spawn.

Thanks for the advice, I have updated the mod to contain the gamedata location. As for the FOB mission I was having problems getting turrets to spawn correctly, my SAM would spawn sideways no matter what I did, the other turrets had no issues however. I'll look into what Volwen did for his KoF pack to make enemies spawn correctly to hopefully fix this issue. For the meantime I have replaced that mission with 4 enemy aircraft to destroy.

[EDIT] I should be able to use the pitch parameter to stop ground units from spawning sideways, I'll try to fix that up the next time I've got access to my home computer

 

4 hours ago, Dark_Derp said:

I love this mod but there is 1 problem: I have absolutely NO idea where I can find the target planes. it doesn't tell me or show on the map. Do I need to save the aircraft in the SPH because it's nowhere to be found

Thanks Dark_Derp, are the aircraft actually spawning? If they are I am unsure of why there locations do not show, as they have been showing for the time I've been testing it. If they are not spawning at all then the mod is incorrectly installed, likely the pathing to the ship directory is incorrect (I had this problem occur a lot when I was in the beginning stages of creating this pack) make sure there are ships installed in the following filepath: GameData/ContractPacks/KAF/ships

This could likely be caused by what dcompart mentioned above with the file pathing if you used CKAN, unfortunately I've always manually installed my mods so I have on experience with this tool.

Alternatively you can try the updated download on spaceport with correct file pathing and let me know if there are any more problems.
 

Edited by NAD5

Share this post


Link to post
Share on other sites
9 hours ago, NAD5 said:

Thanks for the advice, I have updated the mod to contain the gamedata location. As for the FOB mission I was having problems getting turrets to spawn correctly, my SAM would spawn sideways no matter what I did, the other turrets had no issues however. I'll look into what Volwen did for his KoF pack to make enemies spawn correctly to hopefully fix this issue. For the meantime I have replaced that mission with 4 enemy aircraft to destroy.

[EDIT] I should be able to use the pitch parameter to stop ground units from spawning sideways, I'll try to fix that up the next time I've got access to my home computer

 

Thanks Dark_Derp, are the aircraft actually spawning? If they are I am unsure of why there locations do not show, as they have been showing for the time I've been testing it. If they are not spawning at all then the mod is incorrectly installed, likely the pathing to the ship directory is incorrect (I had this problem occur a lot when I was in the beginning stages of creating this pack) make sure there are ships installed in the following filepath: GameData/ContractPacks/KAF/ships

This could likely be caused by what dcompart mentioned above with the file pathing if you used CKAN, unfortunately I've always manually installed my mods so I have on experience with this tool.

Alternatively you can try the updated download on spaceport with correct file pathing and let me know if there are any more problems.
 

 
 
 

Thank you for helping, I did not temper with any of the folders and I installed it like I do with every other mod I install. the planes do not seem to spawn at all. I also install every mod manually.

Edited by Dark_Derp
Grammar mistakes

Share this post


Link to post
Share on other sites
1 hour ago, Dark_Derp said:

Thank you for helping, I did not temper with any of the folders and I installed it like I do with every other mod I install. the planes do not seem to spawn at all. I also install every mod manually.

installed the latest version, now there are no contracts showing up.

Share this post


Link to post
Share on other sites
29 minutes ago, Dark_Derp said:

installed the latest version, now there are no contracts showing up.

Hmm, that is very weird, try pressing f10 to bring up the contract debug bar. Does KAF appear there? If so is it red or yellow? If it is red or yellow there should be some kind of failure log at the bottom. Let me know if you find anything and I'll see what I can do to fix it.

Share this post


Link to post
Share on other sites

I'm having a problem with aggressor planes just falling out of the sky, not trying to fly just falling.

Share this post


Link to post
Share on other sites
7 minutes ago, Eskandare said:

I'm having a problem with aggressor planes just falling out of the sky, not trying to fly just falling.

Due to the way Contract Configurator and KSP handle aircraft spawning there is actually a decoupler 2km below the plane, when the plane spawns the decoupler ejects or is destroyed, no matter how high the aircraft is placed it will be teleported to the ground when it spawns, hence the decoupler. From here the aircraft will fall until they gain enough thrust to fly, so for the first 10-20 seconds of spawning they will be in an easy to kill falling state. Are the planes falling straight to the ground for you? If so are you running anything that would change flight characteristics such as FAR? I have had some issues with planes engines not igniting, however all of them have been switched to already ignited in the craft files.

Share this post


Link to post
Share on other sites

Yes they are falling straight into the ground, I fixed a few by editing them in the SPH but a couple have issues still.

Share this post


Link to post
Share on other sites
4 minutes ago, Eskandare said:

Yes they are falling straight into the ground, I fixed a few by editing them in the SPH but a couple have issues still.

How odd, what exactly did you do to fix them in the SPH and what issues still persist? I'll see what I can do to get that sorted out

Share this post


Link to post
Share on other sites

Oddly the CoM was far blow the craft, may be a thing for the invisi-coupler but only a couple maintained flight, others I had to shift the CoM back or CoL forward so that stable flight could be achieved.

Edit: Discovered they possibly needed an antenna.

Edited by Eskandare

Share this post


Link to post
Share on other sites
2 hours ago, NAD5 said:

Hmm, that is very weird, try pressing f10 to bring up the contract debug bar. Does KAF appear there? If so is it red or yellow? If it is red or yellow there should be some kind of failure log at the bottom. Let me know if you find anything and I'll see what I can do to fix it.

 

when i press f10 nothing happens.

Share this post


Link to post
Share on other sites
8 hours ago, Dark_Derp said:

when i press f10 nothing happens.

Apologies, I meant alt + f10, if nothing still pops up try reinstalling contract configurator

 

 

9 hours ago, Eskandare said:

Oddly the CoM was far blow the craft, may be a thing for the invisi-coupler but only a couple maintained flight, others I had to shift the CoM back or CoL forward so that stable flight could be achieved.

Edit: Discovered they possibly needed an antenna.

Hmm, that would make sense with the Loud and Clear update, as the craft require a probe core to function. I haven't had any problems with the CoM and CoL, there are decent gaps between them but they handled fine in my flight tests and autopilot fights. I would put my money on the antenna being the problem, I haven't experienced any issues yet, but I'll try to see what I can do to fix this up next time I get a chance, hopefully later today.

Out of curiosity what mods are you using? I've tested the crafts and contracts on a stock and heavily modified version of KSP without issue, but I wouldn't rule out a mod conflict of some sort either.

Share this post


Link to post
Share on other sites

Is there a way to dictate the heading a craft spawns in with contracts? lon, lat, alt is pretty self explanatory, but I'm curious how to dictate the heading of the spawned craft. 

Figured it out... I was off 90 degrees on my heading.

Edited by dcompart

Share this post


Link to post
Share on other sites
20 minutes ago, dcompart said:

Is there a way to dictate the heading a craft spawns in with contracts? lon, lat, alt is pretty self explanatory, but I'm curious how to dictate the heading of the spawned craft.

I don't believe you can make the craft face a certain direction currently, but the pitch parameter works perfectly. I have managed to make the ground units spawn correctly, the new update features 1 eliminate SAM site mission and the return of the eliminate FOB mission, I noticed the SAM launcher faced some issues when I mucked with the team and guard mode, however in it's spawned state it works fine. 

Share this post


Link to post
Share on other sites
59 minutes ago, NAD5 said:

I don't believe you can make the craft face a certain direction currently, but the pitch parameter works perfectly. I have managed to make the ground units spawn correctly, the new update features 1 eliminate SAM site mission and the return of the eliminate FOB mission, I noticed the SAM launcher faced some issues when I mucked with the team and guard mode, however in it's spawned state it works fine. 

I found the heading parameter, I can change the heading of the spawns now.

Share this post


Link to post
Share on other sites
Just now, dcompart said:

I found the heading parameter, I can change the heading of the spawns now.

Awesome, that will certainly help if I ever need to make something face a specific direction

Share this post


Link to post
Share on other sites
11 hours ago, NAD5 said:

Hmm, that would make sense with the Loud and Clear update, as the craft require a probe core to function. I haven't had any problems with the CoM and CoL, there are decent gaps between them but they handled fine in my flight tests and autopilot fights. I would put my money on the antenna being the problem, I haven't experienced any issues yet, but I'll try to see what I can do to fix this up next time I get a chance, hopefully later today.

Out of curiosity what mods are you using? I've tested the crafts and contracts on a stock and heavily modified version of KSP without issue, but I wouldn't rule out a mod conflict of some sort either.

Just part mods, and a few plugins Contract Configurator, BDA, EL, TCA, USI, FireSpitter, EVE, Scatterer, Planet Shine, TweakScale, Tweakable Everything, DM stuff...  nothing that should effect the BDA autopilot or stock flight characteristics.

Edited by Eskandare

Share this post


Link to post
Share on other sites
1 hour ago, Eskandare said:

Just part mods, and a few plugins Contract Configurator, BDA, EL, TCA, USI, FireSpitter, EVE, Scatterer, Planet Shine, TweakScale, Tweakable Everything, DM stuff...  nothing that should effect the BDA autopilot or stock flight characteristics.

i use a lot of different mods installed including BDA, quiztech continued, KAX, KIS, KAS, hullcam, simple construction, hangar mod, NAS, escape pods  and more. (i cant think of anymore as i am not on my main pc right now.)

Share this post


Link to post
Share on other sites
1 hour ago, Eskandare said:

Just part mods, and a few plugins Contract Configurator, BDA, EL, TCA, USI, FireSpitter, EVE, Scatterer, Planet Shine, TweakScale, Tweakable Everything, DM stuff...  nothing that should effect the BDA autopilot or stock flight characteristics.

Yeah those are basically the mods I'm running as well, very odd that the craft aren't working on your end. I've updated KAF so all the craft have an antenna, I'm pretty sure the probe cores have a built in antenna, but for backup I've put some basic antennas on the front of the craft.

Unfortunately there is not much else I can think of that would resolve this issue, hopefully this works though!

Share this post


Link to post
Share on other sites
35 minutes ago, NAD5 said:

Yeah those are basically the mods I'm running as well, very odd that the craft aren't working on your end. I've updated KAF so all the craft have an antenna, I'm pretty sure the probe cores have a built in antenna, but for backup I've put some basic antennas on the front of the craft.

Unfortunately there is not much else I can think of that would resolve this issue, hopefully this works though!

I'll continue to tinker with it. 

Share this post


Link to post
Share on other sites
On 14-11-2016 at 0:09 PM, NAD5 said:

Hmm, that is very weird, try pressing f10 to bring up the contract debug bar. Does KAF appear there? If so is it red or yellow? If it is red or yellow there should be some kind of failure log at the bottom. Let me know if you find anything and I'll see what I can do to fix it.

 
 
 

installed latest update, enemy planes are still not visible on the map. probably not spawning at all. contracts have returned, though.

Edited by Dark_Derp
forgot something

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.