Jump to content

[KSP 1.12.1+] Galileo's Planet Pack [v1.6.6] [23 Sept 2021]


Galileo
 Share

Recommended Posts

18 minutes ago, MarethyuGamer said:

After I decided to delete Grannus to get rid of solar panels bug, the surface of Gael turned black. Are these events connected, and if so is there a way to fix it? I didn't install any mods or change anything else in between, only deleted Grannus's .bin and .cfg files.

One does not simply delete Grannus and not break their game. :P Please put those files back and use infinite EC until our next release (or you install and unlock retractable solar panels and nuclear reactors).

13 minutes ago, erik84 said:

I that mm.dll file did not understand it very well as it works, if i mod each one of them has its MM file but with a different version, mod with the MM minor version works with a more up to date version? But then I wonder why every mod must have its MM? I make a trivial example, Galileo has a MM 1.8.0 then put a KER mod (I did not mind at the moment) that has a MM version equal to or less the same mode works the same? How can the library be updated if the mod is different? May be silly questions but legitimate for me

Each mod includes an MM file assuming that they will be the only mod installed by a player, to ensure that the mod itself is always able to load. As for you, the player, always make sure that there is only one MM and only the latest version in your install, compatible with your version of KSP.

3 hours ago, Xevelous said:

Hey there, I hope this situation hasn't been solved already, but I hope you can help me out.

 

after doing a basic install with textures and GPP and Kopernikus the game moved on to the black loading screen with the loading icon and doesn't move on from that, is there a simple fix for this I am not aware of?

Please follow the install instructions exactly, and retrace your steps. ModularFlightIntegrator (part of Kopernicus) must be present. If you feel it's something beyond the instructions, send logs.

Link to comment
Share on other sites

1 hour ago, JadeOfMaar said:

Please follow the install instructions exactly, and retrace your steps. ModularFlightIntegrator (part of Kopernicus) must be present. If you feel it's something beyond the instructions, send logs.

So I did some digging around and had to use the kopernicus file from CKAN and it worked perfectly. Maybe somethings wrong with the download link they've got, I dunno. Thanks though, I hope this might fix some other peoples' problems in the future

Link to comment
Share on other sites

Just now, JebThrillMaster said:

Hello, just threw the mod onto a new kerbal install and i'm having weird lighting issues at night in game. The landscape just appears as if it is lit by the sun when the sky is projecting stars and all. Anyone else experience the same?

Are you using Kopernicus 1.3.0-5 or 1.3.0-4? v5 added in some new lighting stuff so you should use v4 until we update GPP.

Link to comment
Share on other sites

Sent an unmanned probe out to Icarus to see what the fuss was all about. The pictures just came back and Jebediah Gaelan likes what he sees. We will be sending some satellites and surface probes out to gather more info before risking any Gaelan lives though. Looks like it will be over 2 months until our next launch window, but that gives us plenty of time to prepare. 

 

Link to comment
Share on other sites

First of all, THANK YOU for this great mod. this has rejuvenated my interest in Kerbal again.

 

I seem to have one issue.

at the loading screen, it shows all the Galileo screens, but the "witty loading tips" are all displayed at once, across the screen from top to bottom. I have installed the LSM that came in the optional mods folder.

what could be the issue?

Thanks

Link to comment
Share on other sites

16 minutes ago, Data said:

I seem to have one issue.

Did you by chance put the LoadingScreenManager folder somewhere other than the top level of GameData? (That is, did you put inside GPP or another mod's folder? ...It is unknown if this is indeed a bad thing to do.)

Or do you have a crap-load of mods installed? one of them (if so) must be causing this.

Link to comment
Share on other sites

7 minutes ago, JadeOfMaar said:

Did you by chance put the LoadingScreenManager folder somewhere other than the top level of GameData? 

Yes, I did put it in the top level inside GameData, like all the mods.

7 minutes ago, JadeOfMaar said:

Or do you have a crap-load of mods installed? one of them (if so) must be causing this.

Yes, a huge crap load LOL.

I guess I'll have to start to isolate the bad apple in my basket.

I just thought someone else would have had the same problem and figured it out. Thanks for the tip.

Edited by Data
Link to comment
Share on other sites

a new install of 1.30.

ran it once and copied GPP and LSM only. No other mods.

Still the same issue. here is the part in my log:

Spoiler

[LOG 02:51:36.001] [LSM] Loading configuration file:  D:/Kerbal/Kerbal 130/KSP_x64_Data/../GameData/LoadingScreenManager/PluginData/LoadingScreenManager.cfg
[WRN 02:51:36.002] File 'D:/Kerbal/Kerbal 130/GameData/LoadingScreenManager/PluginData/LoadingScreenManager/LoadingScreenManager.cfg' does not exist

[LOG 02:51:37.820] [LSM] LoadingScreenManager v1.01 activated
[LOG 02:51:37.822] [LSM] ** WARNING - Game Database Loader is not where expected.
[LOG 02:51:37.823] [LSM] Finding image files...
[LOG 02:51:37.825] [LSM] ... Added image path:  D:/Kerbal/Kerbal 130/GameData/GPP/GPP_LSM/
[LOG 02:51:37.825] [LSM] 15 image files found
[LOG 02:51:37.826] [LSM] Custom tips file:  GameData/GPP/GPP_LSM/tips.txt
[LOG 02:51:37.827] [LSM] 1 custom tips loaded
[LOG 02:51:38.460] [LSM] 15 slides set
[LOG 02:51:38.460] [LSM] ** WARNING:  Not enough images available (15) to meet requested number of slides (60).
[LOG 02:51:38.461] [LSM] LoadingScreenManager v1.01 finished

why does it say v1.01?

in the version file it says 1.20

Spoiler

{
  "NAME": "LoadingScreenManager",
  "URL": "http://ksp-avc.cybutek.net/version.php?id=486",
  "VERSION": {
    "MAJOR": 1,
    "MINOR": 2,
    "PATCH": 0,
    "BUILD": 0
  },
  "KSP_VERSION": {
    "MAJOR": 1,
    "MINOR": 3,
    "PATCH": 0
  }
}

 

Link to comment
Share on other sites

On 8/17/2017 at 4:13 PM, Galileo said:

Did you download and install GPP_textures 2.0.0? If you think you did, check and make sure you have the GPP_Texures folder in the GPP folder. 

At the moment, the renamer code won't allow it for whatever reason. You can edit the persistent save file however for the time being

I downloaded and reinstalled GPP textures pack I checked and made sure it was version 2.0.0 however the infinite loading screen persisted

Link to comment
Share on other sites

I'm having a weird issue when I try to start a game with this mod where I can't access the VAB and when I go into the research center or mission control I can't exit again. The only way to recover is to forcefully close the game.

I saw someone else report a similar issue so I deleted the renamer but that doesn't seem to have worked for me. I'm about to go through a huge debugging process when I get home because I have a fairly long list of mods installed and I don't get this issue when I run just GPP or when I run everything else without GPP. I was wondering if anyone could save me some time if they know of any mods that are confirmed to be incompatible. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...