Galileo

[KSP 1.4.5] Galileo's Planet Pack [v1.6.3.1] [03 Aug 2018]

Recommended Posts

3 minutes ago, kraden said:

That makes good sense, and thanks for that!

Unfortunately I can't open the readme file in the download... I should probably get something so I can open those...

I had read the primary bullet and was like, "ok, cool. Stuff for modders and people who understand programming" and proceeded to skip the three sub-bullets :P I will make sure to read more carefully in the future :rolleyes:

Thanks again for the update!

Any text editor will open it (notepad, word) just right click and  click "open with" and choose notepad.

Share this post


Link to post
Share on other sites

Came here with the textures problem, see the fix, thanks guys.

I am curious why they are a separate download now?

Share this post


Link to post
Share on other sites
6 minutes ago, DSM20T said:

Came here with the textures problem, see the fix, thanks guys.

I am curious why they are a separate download now?

Just posted one page back and in the op, and in the readme 

 

Edited by Galileo

Share this post


Link to post
Share on other sites
7 hours ago, Galileo said:

Just posted one page back and in the op, and in the readme 

 

Ah, you can see that not reading things very closely is a recurring issue for me :)   Love your work, thank you.

Share this post


Link to post
Share on other sites

I have a problem with sunflares in 1.2.3, this times with a only GPP, clouds and scatterer on a clean 1.2.2 install. This is what it looks like:

wCX3wWy.png

This is what my GameData folder looks like:

BlCuOPB.png

Default scatterer settings, although turning "sunflare shader" option in the scatterer on or off doesn't make any difference (no restart, I don't remember if it is needed in this case). This is a log file from a short run: KSP_GPPCloudScatterer123

Version 1.2.2 worked fine, as far as I can tell, though I have to say my flares never looked anything like the screenshot in the post above. At least they weren't dull small orbs.

Share this post


Link to post
Share on other sites
13 minutes ago, Shiolle said:

I have a problem with sunflares in 1.2.3, this times with a only GPP, clouds and scatterer on a clean 1.2.2 install. This is what it looks like:

I noted this in the install instructions for GPP 1.2.3 that the Scatterer files organization changed again. Unfortunately that breaks anyone's custom sunflares, but it makes sunflare customization (and even packing and sharing) more convenient per star. That is the GPP default sunflare.

I should have highlighted this like I highlighted GPP_CareerSaver.

On 11/16/2016 at 3:55 PM, JadeOfMaar said:

If you need to change the sunflare for either or both stars in GPP, you must now look into the following places for your operation:

  1. GPP\GPP_Scatterer\Sunflares\[Star]\ to change the images, and the Scatterer_sunflare{} node inside the respective config file beside them.
     
  2. If you have changed your sunflare sizes before, be aware that the configs are separate again and stored beside the sunflare images in step 1. There is no longer any scatterer cfg file in GPP\GPP_Configs\
Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
26 minutes ago, JadeOfMaar said:

I noted this in the install instructions for GPP 1.2.3 that the Scatterer files organization changed again. Unfortunately that breaks anyone's custom sunflares, but it makes sunflare customization (and even packing and sharing) more convenient per star.

Thank you for the answer. I've read that passage, but I don't have any custom sunflares. I mean, that is 100% stock GPP install on a clear KSP. Also, I don't really understand what the numbers in that file mean, so I don't know what exactly I need to fix. Previously (in GPP 1.1) there was a separate Ciro.cfg to use with scatterer, so perhaps I will try to find the difference between Ciro config in 1.2.2 and 1.2.3, but I though that recent changes should have removed the need to do it.

P. S. Maybe I have misunderstood what you're saying. Do you mean that the screenshot I posted is how it should look like without any sunflare mods installed? I am certain then that 1.2.2 sunflares looked very different and much better too.

Edited by Shiolle

Share this post


Link to post
Share on other sites
20 minutes ago, Shiolle said:

Previously (in GPP 1.1) there was a separate Ciro.cfg to use with scatterer, so perhaps I will try to find the difference between Ciro config in 1.2.2 and 1.2.3, but I though that recent changes should have removed the need to do it.

The separate Ciro.cfg back then was only to enable a properly colored stock sunflare when Scatterer was not installed, but now, that is controlled by an MM toggle. There's no need to have the "Alternate Ciro config" as in GPP v1.1. The default GPP sunflare now is rather pale and bright thanks to some guy :D whose name will not be called and who asked for a specific pale sunflare.

Share this post


Link to post
Share on other sites
6 minutes ago, JadeOfMaar said:

The separate Ciro.cfg back then was only to enable a properly colored stock sunflare when Scatterer was not installed, but now, that is controlled by an MM toggle. There's no need to have the "Alternate Ciro config" as in GPP v1.1. The default GPP sunflare now is rather pale and bright thanks to some guy :D whose name will not be called and who asked for a specific pale sunflare.

Thank you for clarification. I get it now.

Share this post


Link to post
Share on other sites
8 minutes ago, insert_name said:

having trouble getting my save to load, it also shows Kerbin at the start screen now.

https://drive.google.com/file/d/0B6K7Fe_8sdcJUlJESjdPT2E4Wms/view?usp=sharing

Yep. That will happen when you don't install the GPP textures. its linked in the OP, Install instructions, and in the Readme if you need to find it :wink:

Edited by Galileo

Share this post


Link to post
Share on other sites

Just an FYI that I'm sure most people here already know but Dummy TUCO here just discovered.  I originally purchased and installed KSP via Steam.  The default setting on Steam is to auto-update programs.

Today I fired up Steam to check on other games and didn't notice the KSP update running in the background...ooops...and it updated KSP to version 1.3...which blew out Kopernicus  ....which blew out GPP and everything else dependent on Kopernicus etc....

1 - It seems that the only way to freeze the updates on Steam is to select "Only update this game when I launch it"

I always run KSP via a shortcut to the 64 bit exe.

(Please feel free to correct my statement if incorrect; if there is another way to lock in the version please let me know)

2 - Does anyone know if we can select and install older versions of KSP via Steam?  If so, can you help me out and tell me how to install KSP 1.2.2 via Steam?

3 - Modders: How difficult will it be to upgrade most Mods to be compatible with version 1.3, just curious?

So anyway, I learned another hard lesson...bummer :(

 

 

Edited by Tuko

Share this post


Link to post
Share on other sites
12 minutes ago, Tuko said:

Just an FYI that I'm sure most people here already know but Dummy TUCO here just discovered.  I originally purchased and installed KSP via Steam.  The default setting on Steam is to auto-update programs.

Today I fired up Steam to check on other games and didn't notice the KSP update running in the background...ooops...and it updated KSP to version 1.3...which blew out Kopernicus  ....which blew out GPP and everything else dependent on Kopernicus etc....

1 - It seems that the only way to freeze the updates on Steam is to select "Only update this game when I launch it"

I always run KSP via a shortcut to the 64 bit exe.

(Please feel free to correct my statement if incorrect; if there is another way to lock in the version please let me know)

2 - Does anyone know if we can select and install older versions of KSP via Steam?  If so, can you help me out and tell me how to install KSP 1.2.2 via Steam?

3 - Modders: How difficult will it be to upgrade most Mods to be compatible with version 1.3, just curious?

So anyway, I learned another hard lesson...bummer :(

 

 

Right click on it in steam. Under "properties" there should be some options for betas. Old versions can be found there I believe. Going from memory.

In the future, copy the whole directory from steam and mod/play the copy. That way you'll always have a clean install on steam and your modded game will not break from updates. 

Edited by JohnnyPanzer

Share this post


Link to post
Share on other sites
Just now, JohnnyPanzer said:

Right click on it in steam. Under "properties" therr should be some options for betas. Old versions can be found there I believe. Going from memory.

In the future, copy the whole directory from steam and mod/play The copy. That way you'll always have a clean install on steam and you're modded game will not break from updates. 

Ahhhhh, Yesssss, Panzer you're the best.

I can't play anything else but KSP/GPP anymore

Thanks Again for pointing that out to me :)

 

Share this post


Link to post
Share on other sites
9 minutes ago, Tuko said:

Just an FYI that I'm sure most people here already know but Dummy TUCO here just discovered.  I originally purchased and installed KSP via Steam.  The default setting on Steam is to auto-update programs.

Today I fired up Steam to check on other games and didn't notice the KSP update running in the background...ooops...and it updated KSP to version 1.3...which blew out Kopernicus  ....which blew out GPP and everything else dependent on Kopernicus etc....

1 - It seems that the only way to freeze the updates on Steam is to select "Only update this game when I launch it"

I always run KSP via a shortcut to the 64 bit exe.

(Please feel free to correct my statement if incorrect; if there is another way to lock in the version please let me know)

2 - Does anyone know if we can select and install older versions of KSP via Steam?  If so, can you help me out and tell me how to install KSP 1.2.2 via Steam?

3 - Modders: How difficult will it be to upgrade most Mods to be compatible with version 1.3, just curious?

So anyway, I learned another hard lesson...bummer :(

1) If you run Steam, you can opy your install folder to a different location.  I copy mine to my HomeDir using the version number.  I have KSP-1.1.0, KSP-1.1.1, KSP-1.1.2, KSP-1.1.3, KSP-1.2.0, KSP-1.2.1, and KSP-1.2.2.  I didn't copy the 1.2.29 since it was a beta, and I haven't yet moved my 1.3.0 install.  This way you can keep your old games, mods, etc even when steam auto-updates you.

2) you can choose the previous version in steam, under the Beta tab on your game settings in Steam.  I'd pick the 1.2.2, download it, install it, copy it else where then restore the setting to keep the game up to date.  Then you can run 1.2.2 while you wait for the mods to catch up.

3) This is a rather large update for the modders.  Depending on the mod itself it can be as simple as a recompile or as complex as a complete re-write.

 

 

Share this post


Link to post
Share on other sites
1 minute ago, azander said:

1) If you run Steam, you can opy your install folder to a different location.  I copy mine to my HomeDir using the version number.  I have KSP-1.1.0, KSP-1.1.1, KSP-1.1.2, KSP-1.1.3, KSP-1.2.0, KSP-1.2.1, and KSP-1.2.2.  I didn't copy the 1.2.29 since it was a beta, and I haven't yet moved my 1.3.0 install.  This way you can keep your old games, mods, etc even when steam auto-updates you.

2) you can choose the previous version in steam, under the Beta tab on your game settings in Steam.  I'd pick the 1.2.2, download it, install it, copy it else where then restore the setting to keep the game up to date.  Then you can run 1.2.2 while you wait for the mods to catch up.

3) This is a rather large update for the modders.  Depending on the mod itself it can be as simple as a recompile or as complex as a complete re-write.

 

 

Excellent advice and i'm going to do exactly as you suggest.

Thanks for the help :D

 

Share this post


Link to post
Share on other sites

Kopernicus just updated for 1.3 BUT GPP in its current will not work correctly. I will update here very shorty. 

Share this post


Link to post
Share on other sites

Please remove this post, I put it in the wrong thread.

Edited by daawgees
Moved to different thread.

Share this post


Link to post
Share on other sites
51 minutes ago, Galileo said:

Kopernicus just updated for 1.3 BUT GPP in its current will not work correctly. I will update here very shorty. 

Yeah, Thomas P. updated that quickly.

I loaded a clean KSP 1.3 version and then ran it once.

Next I loaded Kopernicus 1.3(Modular Flight Integrator too) with just GPP plus GPP textures and it seems ok so far but Galileo will know better then anyone what might be broken...

33 minutes ago, astroheiko said:

Astro - Looks like you're planning an invasion lol.

Share this post


Link to post
Share on other sites
12 minutes ago, Tuko said:

Astro - Looks like you're planning an invasion lol.

Imagine the colony ships that he'll build. :o All he's done so far is plant flags and get science.

14 minutes ago, Tuko said:

Next I loaded Kopernicus 1.3(Modular Flight Integrator too) with just GPP plus GPP textures and it seems ok so far but Galileo will know better then anyone what might be broken...

Yeah, there's more to things than GPP visibly loading right. Several gameplay features may be broken. And in Galileo's case, optimized code is a top priority.

Share this post


Link to post
Share on other sites
On 5/25/2017 at 9:17 AM, insignx9 said:

I did each time, I tried it once without running it vanilla just to test. I've tried it by running without mods just to the main screen, then loading in GPP, and I've tried it by starting a new game and then deleting the save file just to see if that made a difference which it did not. 

Sorry it's taken me a while to respond, I'm at work now but I'll take a screen shot when I get home tonight. For the most part it looks the same as the screen shot in the walk through before I KSP, after I boot some other files start to show, I remember one being named community tech tree or something, which is strange because I didn't have community tech tree installed in any of my tests? 

I may not have done that. For some reason I vaguely remember GPP_textures being in the GPP folder by default? Maybe I'm wrong there. I'll give it a try when I get home tonight. 

 

Thank you guys so much for your help, I honestly didn't expect a reply so quickly. I'll follow up tonight :) 

Sorry it's taken so long to respond. I just tried what what was suggested 

I uninstalled, deleted the old gamedata and started fresh, booted once without mods and then added 

Here's my gamedata folder each time I've tried by following the walkthrough

I also tried dropping the GPP_Texture folder under GPP as suggested as seen below 

Weird enough, I got this error that 1.2.3 was not supported 

Just for the hell of it I tried with 1.2.2 I tried it like this and with Kopernicus and modular flight like the 1.2.3 installs instructs, both didn't work I got the same error you see above saying I need to use 1.2.2 even though that's whats installed.

And I just saw 1.3 was released, didn't even notice. I see other people aren't having an issue with it. I don't have a saved backup of 1.2.3, could that be part of my issue? 

Edited by insignx9

Share this post


Link to post
Share on other sites

No update until we figure out what in kopernicus is breaking GPP. More changes to kopernicus and ksp than the change logs suggest. Might be a long while

Edited by Galileo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.