Galileo

[KSP 1.4.5] Galileo's Planet Pack [v1.6.3.1] [03 Aug 2018]

Recommended Posts

1 minute ago, vagabond77 said:

I had the same problem and I found a way to make everything work by eliminating some folders of Making History. After, of course, missions can no longer be created and new launch points are eliminated, but GPP and Kerbal-konstructs work and new parts of the expansion can be used. Now I'm not in front of the PC, in the day I should be able to show you which folders I deleted so you can do a test.

Thank you.  I'll watch this space.

Share this post


Link to post
Share on other sites
11 hours ago, Steven Mading said:

But I really miss my Making history parts, like the R7-style side boosters, and the ball-shaped command pods.  Is it possible to get just the parts from Making History, without getting the launch sited from it, by JUST copying over the parts folder only?  Or does this cause problems if some of the parts need to use things in DLL's that are part of the rest of Making History?

 

9 hours ago, vagabond77 said:

I had the same problem and I found a way to make everything work by eliminating some folders of Making History. After, of course, missions can no longer be created and new launch points are eliminated, but GPP and Kerbal-konstructs work and new parts of the expansion can be used. Now I'm not in front of the PC, in the day I should be able to show you which folders I deleted so you can do a test.

In the path ... \ GameData \ SquadExpansion \ MakingHistory you have to delete everything except the folders:
Localization
Parts
Spaces

I understand that the change is really cheap but currently I have installed more than 100 mods and I have been running a career for about 3 months without problems.

In any case, if you have other mods besides GPP I suggest you add them gradually to identify any problems.

FLY SAFE. :)

Edited by vagabond77

Share this post


Link to post
Share on other sites

KSP 1.5 just came out, I just checked steam, so odd I just came back into ksp. Yes I'm doing a series like a tv show with some other ksp players, we're gonna have original music and all, I was gonna do a normal playthrough of gpp as well on my own new channel but looks like that will have to wait a bit.. Ah the age old getting set for ksp then updates change everything

Share this post


Link to post
Share on other sites

PS the KSP tv show like series is still in production, we just started, we got a concept theme song already

Share this post


Link to post
Share on other sites
16 minutes ago, The-Doctor said:

Anyone have success using GPP in 1 5.1?

Yea, I've been playing with it and didn't run into noticeable problems. I used CKAN and set CKAN to include 1.4.x compatible mods. Then I just told it to install the 1.4.x version of GPP and let CKAN pick my dependencies. This is risky with such a complicated mod, but it appeared to work for me. 

That said - remember this is an unsupported setup, so I'd avoid bugging our fantastic modders for help if you run into issues. If you run into probs I can try to help via PM to avoid clogging up this thread. I'm not an expert though, so can only share what I've tried.

 

Edited by Tyko

Share this post


Link to post
Share on other sites
On 10/29/2018 at 10:07 AM, vagabond77 said:

 

In the path ... \ GameData \ SquadExpansion \ MakingHistory you have to delete everything except the folders:
Localization
Parts
Spaces

Just did this, and it's working.  Thank you for the advice.

Share this post


Link to post
Share on other sites
7 hours ago, Tyko said:

Yea, I've been playing with it and didn't run into noticeable problems. I used CKAN and set CKAN to include 1.4.x compatible mods. Then I just told it to install the 1.4.x version of GPP and let CKAN pick my dependencies. This is risky with such a complicated mod, but it appeared to work for me. 

That said - remember this is an unsupported setup, so I'd avoid bugging our fantastic modders for help if you run into issues. If you run into probs I can try to help via PM to avoid clogging up this thread. I'm not an expert though, so can only share what I've tried. 

 

how did you set ckan to allow you to download 1.4.x mods? That's all really I'd need, thanks

Share this post


Link to post
Share on other sites
32 minutes ago, The-Doctor said:

how did you set ckan to allow you to download 1.4.x mods? That's all really I'd need, thanks

Go to the Settings menu and select Compatible KSP versions. Then you can check boxes for all the versions you want it to show as compatible. Definitely recommend turning those compatibilities off once you've done your install so you don't accidentally install other mods

 

Share this post


Link to post
Share on other sites
On 10/31/2018 at 12:29 PM, The-Doctor said:

Anyone have success using GPP in 1 5.1?

Yep, and GEP too even though it says not to use it. I just kept my 1.4.5 installs and updated Kopernicus.

Share this post


Link to post
Share on other sites
On 10/28/2018 at 11:12 PM, Steven Mading said:

...and I was getting a bug whenever attempting to recover a craft from Gael's KSC where an exception would abort operations during the saving-game step and thus prevent all scene switching when landed at KSC (you had to kill the game and re-run it since you couldn't even quit the game though the menus without it trying to do the save-game step.)  I suspected this bug might also be because of Making history's extra launch site infrastructure because the exception was in a stock KSP routine that seemed to be trying to test whether or not the landed ship was near the KSC.

This is a bug in the stock code (it's actually from the really bad optimization advice they handed out a while ago to modders about preferring for loops over foreach loops, this caused them to loop through a different array than they were accessing which can't happen if you use a foreach...). It's actually going to occur for any Kopernicus pack that removes launch sites using a Kopernicus before 1.50-1. Update Kopernicus and you won't experience this bug any longer. As for the launch sites in random places, I have not experienced that issue.

Share this post


Link to post
Share on other sites

Hello!!! I use GPP Secondary, how to make sure that ciro does not revolve around kerbol and was not his companion , is it possible that siro was a separate star .

Share this post


Link to post
Share on other sites
22 minutes ago, serg1983 said:

Hello!!! I use GPP Secondary, how to make sure that ciro does not revolve around kerbol and was not his companion , is it possible that siro was a separate star .

There is no changing that. Everything orbits the central body (Sun). That's how KSP works. They way things look and work wouldn't be much different if it could be changed (without adding problems to gameplay).

Share this post


Link to post
Share on other sites
On 11/1/2018 at 4:46 AM, Tyko said:

Yea, I've been playing with it and didn't run into noticeable problems. I used CKAN and set CKAN to include 1.4.x compatible mods. Then I just told it to install the 1.4.x version of GPP and let CKAN pick my dependencies. This is risky with such a complicated mod, but it appeared to work for me. 

That said - remember this is an unsupported setup, so I'd avoid bugging our fantastic modders for help if you run into issues. If you run into probs I can try to help via PM to avoid clogging up this thread. I'm not an expert though, so can only share what I've tried.

 

Damn, I haven't been on here in like a year, now I have a suggen urge to play KSP again. Do your launchsites work? If I remove KSC++ as said in the installation instructions, none of the other launchsites are displayed. If I do the reverse and remove kerbal konstructs, only KSC and KSC2 display, however I can't switch launchsites. But, If I have KSC++ and Kerbal Konstructs, it displays all the launchsites, but none of them are functional. I'm sure this is because the mod is outdated, but I just want to see if there's any sort of workaround or if i've done something wrong.

EDIT: I just realised that KSC++ has nothing to do with changing launchsites, my bad.

Edited by Duski

Share this post


Link to post
Share on other sites
14 hours ago, Duski said:

Damn, I haven't been on here in like a year, now I have a suggen urge to play KSP again. Do your launchsites work? If I remove KSC++ as said in the installation instructions, none of the other launchsites are displayed. If I do the reverse and remove kerbal konstructs, only KSC and KSC2 display, however I can't switch launchsites. But, If I have KSC++ and Kerbal Konstructs, it displays all the launchsites, but none of them are functional. I'm sure this is because the mod is outdated, but I just want to see if there's any sort of workaround or if i've done something wrong.

EDIT: I just realised that KSC++ has nothing to do with changing launchsites, my bad.

Not sure. I play in a rescaled system but KSC++/Kerbal Constructs seem to have probs with scaling. I still use KSC Switcher and the old GPP config for it from an older GPP version - which works just fine in a scaled system.

Edited by Tyko

Share this post


Link to post
Share on other sites
4 hours ago, Tyko said:

Not sure. I play in a rescaled system but KSC++/Kerbal Constructs seem to have probs with scaling. I still use KSC Switcher and the old GPP config for it from an older GPP version - which works just fine in a scaled system.

Awesome, I managed to get mine working, but I can only change the launchsite from SPH and VAB. I wish I could get rid of the objects around the base but keep the site switching though, its a big perf hit for me.

Share this post


Link to post
Share on other sites
16 hours ago, Duski said:

Awesome, I managed to get mine working, but I can only change the launchsite from SPH and VAB. I wish I could get rid of the objects around the base but keep the site switching though, its a big perf hit for me.

I’m traveling right now. PM me and when I’m back Monday  i’ll see if I can help you further 

Share this post


Link to post
Share on other sites
12 hours ago, Tyko said:

I’m traveling right now. PM me and when I’m back Monday  i’ll see if I can help you further 

Seemed to have disappeared by itself, none of the extra KSC is there. So, win I guess? 

Share this post


Link to post
Share on other sites
28 minutes ago, xuelong said:

the land around ksc are red,is that normal or a bug

After I noticed the like/reaction from you I remembered to update that post. The links were outdated.

I assume you're facing the LandControl bug (which has been long fixed)

Spoiler

Untitled-1.png

 

Share this post


Link to post
Share on other sites

I'm hoping someone can help me with a conflict I'm experiencing. I'm running GPP on 1.4.5. I've tried to install Strategia (and of course Custom Barn Kit), but when I do, I have this issue where I can't recover vessels. Obviously that's a huge problem. When I remove Strategia and CBK, it goes away. I'd really like to employ Strategia, so if anyone has any insights into why this is happening, please let me know. thanks, Andrew

Share this post


Link to post
Share on other sites
41 minutes ago, Eaten by Black Hole said:

Does Gaelans count as Kerbal?

Gaelans are kerbal just as earthlings are human.

Share this post


Link to post
Share on other sites
5 hours ago, Eaten by Black Hole said:

If you say "no", i would remove GPP and contiune stock with Kerbals.

Why?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.