Jump to content

[KSP 1.8.1+] Galileo's Planet Pack [v1.6.4] [01 July 2020]


Recommended Posts

2 minutes ago, OhioBob said:

Grannus' properties are based on this:  http://www.pas.rochester.edu/~emamajek/EEM_dwarf_UBVIJHK_colors_Teff.txt

From that table we're using:

Spectral type:  M2V
Effective temperature:  3550 K
Luminosity:  10^-1.57 = 0.026915 x Sun
Mass:  0.48 x Sun

and from temperature and luminosity,

Radius = SQRT(0.026915*(5772/3550)^4) = 0.4337 x Sun

where 5772 K is effective temperature of Sun.

The in-game color of Grannus is artistic license and is not meant to be a true representation of what it would look like.

I wouldn't mind making it realistic looking, I just don't know exactly what it would really look like

Link to post
Share on other sites
6 hours ago, Galileo said:

I wouldn't mind making it realistic looking, I just don't know exactly what it would really look like

Well, we could change Grannus' color to match its type, or we could change its type to match its color, or we could do some combination of both.  At its current color, it would probably actually be a brown dwarf.  If we want to keep it a M2 red dwarf, it would be a lighter orange.  The chart provided by MaxL_1023 is a pretty good guide (current temperature = 3550 K).

550px-Color_temperature_black_body_radia

That's the color it would appear from a distance.  Up close it would probably look white to the human eye.  This is because our eyes tend to perceive very bright objects as white regardless of what the true color is.  From the surface of a habitable planet, the star and sky would probably look a lot more like Earth than what you would think.  From the following we see that the sky would probably be a very pale blue or white.

star3sky.jpg

(edit)

According to MaxL_1023's color chart, the color at a temperature of 3550 K is about 255,192,129.  And according to the second chart, the sky color is about 235,245,255.

 

Edited by OhioBob
Link to post
Share on other sites
5 hours ago, IuliusCaesar said:

Dear Community, 

I require help getting  this mod to work. Having explored every  corner of the normal KSP solar system,  I hoped to explore this pack, later adding KSPIE. However, I am currently  caught in a strange bootloop.

What I've done so far:

1, Clean  KSP install, ran the game once.

2. Installed Kopernikus, ran it.

3. Installed GPP, game loaded fine. However, when starting a new game, the game never passed the loading screen. The little star system animation keeps playing, the game doesn't  freeze, it doesn't progress either.

Is there anything I can do to alleviate this problem? 

Thanks  in advance! 

 

P.S,: I am running in 64 bit mode, I have 8 GB Ram, a 2 day old Win 10 installation, a GTX 970mx and 2 i7 kernels.

 

Did you install ModularFlightIntegrator (part of Kopernicus)? Otherwise, share a copy of your output log and optionally a screenshot of your GameData.

@OhioBob @MaxL_1023 I wouldn't mind a bright orange (and bigger?) Grannus much if it's going that direction.

Link to post
Share on other sites
3 hours ago, JadeOfMaar said:

@OhioBob @MaxL_1023 I wouldn't mind a bright orange (and bigger?) Grannus much if it's going that direction.

If we want to keep Grannus a distinct orange color and maybe shift the color of the alien skies from slightly blue to slightly orange, then I would suggest possibly making Grannus a type M6.  The properties for type M6V are:

Effective temperature:  2850 K
Luminosity:  10^-3.02 = 0.000955 x Sun
Mass:  0.11 x Sun
Radius:  SQRT(0.000955*(5772/2850)^4) = 0.13 x Sun

According to the color charts, this would make the star about 255,168,83 and the skies about 255,234,195.  Of course the luminosity of this star is puny, placing the habitable zone at about 0.03 AU.

With Grannus' current properties (type M2V), its color is about 255,192,129 and the skies about 235,245,255.  The habitable zone is centered at about 0.16-0.17 AU.

ColorComparison1.png

(Of course the foliage would probably not be green under a red dwarf star.)

EDIT - Added type M4V and M8V to image for further comparison.
 

Edited by OhioBob
Link to post
Share on other sites
8 minutes ago, IuliusCaesar said:

Hello! Thanks for your reply!

Please remove all that and put into Dropbox, OneDrive, Pastebin or so. It's too much to put in a forum post.

I also can't read your screenshot, it's tiny.

There's an exception concerning Thalia. I'm suspecting a corrupt download. Try re-downloading GPP.

Edited by JadeOfMaar
thalia exception?
Link to post
Share on other sites

Well, I redownloaded GPP two times now, and tried starting... still the same problem.

I have no idea why this is happening, never have I experienced any problems with various other mods, e.g. KSPIE or KIS and KAS. I'll reinstall KSp and report back to you.

Link to post
Share on other sites

Because of Grannus:

To be honest. The fact of being able to perform a flyby at Grannus was challenging enough for me. Do you think it is possible to visit a potential companion with the stockparts and land on it? I would sacrifice myself for test purposes!!!:D

 

Something else:

The exploration of the Hox System slowly comes to the end. Everything has been explored and I am on my way home. The transfer window planner tells me i would need 31 years and 138 days travel time for a 100km orbit around Gael. I then tried to enter a course manually and for "only" 2250 m/s more I could reach a flight duration of 12 years and 140 days. I also have the water for JadeOfMar.:D

One picture from Argo. By the way: I had strong Framedrops at Argo.

oFafgB8.jpg

The entire report is here:

Argo Exploring

Greetings

Link to post
Share on other sites

Huzzah!

After re-installing and redownloading everything, it's working now. The solution was as simple as it's stupid: Broken Windows security access rights. Although I executed KSP aas an admin, the game itself somehow wasnt allowed to change anything inside of the program files folder. I then re-installed steam and KSP in a different place and everything is working like a charm!

Thanks a lot for your patience and suggestions!

Link to post
Share on other sites
8 hours ago, IuliusCaesar said:

Thanks a lot for your patience and suggestions!

You're the one who should be getting thanks for patience. I'm sure anyone else with your problem would have ragequit. And this is only the second time I've come to know that "running as admin" was a factor in KSP problems.

10 hours ago, astroheiko said:

I also have the water for JadeOfMar

Excellent! :) The science guys will be all over it. When I get back to you, we'll let you know if you can keep half or grab all you want...say...for the next time you dive at Grannus. :D 

Dude, you just keep pumping out awesome screenshots. I may have to do something about that and ASAP. #challengeaccepted

I could possibly make radiator panels use ArgoWater instead of Ec. Hmm.

Edited by JadeOfMaar
Link to post
Share on other sites
35 minutes ago, MaxL_1023 said:

When I try to take a screenshot it comes close to crashing my computer. 

Well, with the hundreds of screenshots that have come from others playing GPP, I think it's safe to say that it's probably something to do with either your mods or maybe your hardware and not with GPP.

I have a feeling you are just poking fun at your rig again though :wink:

Edited by Galileo
Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

 The science guys will be all over it.

I still have some potatoes in the cellar. Maybe they can make a mash with the water and make some Moonshine ... uuum ... Argoshine. Jeb would be delighted. If it works, I can shoot a Distille to Argo.:D

Link to post
Share on other sites
2 hours ago, Galileo said:

Well, with the hundreds of screenshots that have come from others playing GPP, I think it's safe to say that it's probably something to do with either your mods or maybe your hardware and not with GPP.

I have a feeling you are just poking fun at your rig again though :wink:

I have 8gb ram - its my rig. GPP uses more than 90% of my memory, so I am definitely getting swapping related lag. 

Link to post
Share on other sites
3 minutes ago, MaxL_1023 said:

I am getting rid of EVE - it might make a difference. What else uses a lot of memory besides parts?

EVE doesn't really hurt your ram THAT much. It relies mostly on you GPU. 

What kind of CPU are you working with?

 

Link to post
Share on other sites
2 minutes ago, MaxL_1023 said:

Intel Quad-Core Q9400. I think my problem might be hard disk data transfer - windows flags that as being pretty bad. 

Probably. Have you considered getting a small ssd? Just to get you by until you can get something more substantial?

Edited by Galileo
Link to post
Share on other sites

I can't really afford one atm, but later in the year I should be able to. I think another problem is a couple part mods - a lot of parts I thought I deleted must have found their way back in when I updated the mods. FASA is a big offender - I only want 3 or 4 parts from it. 

Link to post
Share on other sites
4 minutes ago, MaxL_1023 said:

I can't really afford one atm, but later in the year I should be able to. I think another problem is a couple part mods - a lot of parts I thought I deleted must have found their way back in when I updated the mods. FASA is a big offender - I only want 3 or 4 parts from it. 

FASA is really hard on the CPU for sure. Part mods in general kill CPU performance. They don't really hurt ram much, but your CPU will be murdered if you have large part packs installed. I usually go through the part packs I want and removed parts I know I'll never use. 

Edited by Galileo
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...