Galileo

[KSP 1.8.1+] Galileo's Planet Pack [v1.6.4] [01 July 2020]

Recommended Posts

Iota's orbital/rotation period should be 495,456.27 seconds.

Share this post


Link to post
Share on other sites
49 minutes ago, OhioBob said:

Iota's orbital/rotation period should be 495,456.27 seconds.

And in old money...

495456.27 / 60 = 8274.2711666666666666666666666667 minutes
8274.27116666 / 60 = 137.90451944444444444444444444444 hours
137.904519444 / 6 = 22.984086574074074074074074074074 days

...22 days, 5.9045194444444444444444444444444 hours
...22 days, 5 hours, 54.27 minutes
...22 days, 5 hours, 54 minutes, 16.27 seconds

Holy crap I got the right decimal on the end :o 

Not what it says in game though... it's very close to 22:5:37... Unless having a 0.001 eccentricity is knackering my numbers? 

Edited by eddiew

Share this post


Link to post
Share on other sites
8 hours ago, eddiew said:

495456.27 / 60 = 8274.2711666666666666666666666667 minutes

You must have accidently hit a wrong key because the answer you got is 496456.27 divided by 60.  You have an extra 1000 seconds in there.  The correct result is,

22 days, 5 hours, 37 minutes, 36.27 seconds.

Share this post


Link to post
Share on other sites

@Galileo I don't know if you are the one who maintains this mod's CKAN upload, but for some reason during the download CKAN fails to acquire GPP Textures because the server denies it access. This mod is really complicated for me to install manually, so I hope this is fixed

On another note, I did get the mod running (without scatterer because of how much of a damn FPS hog it is) and I have noticed this absolutely awful problem with the location of the KSC.

It's night, but you should still be able to see the serious clipping on the administration, lower half of the runway and a bunch of the KSC++ objects which are supposed to be compatible with this mod.

It's really a major eyesore and actually will probably cause serious problems launching anything from the SPH.

Edited by Pavel ☭

Share this post


Link to post
Share on other sites
4 hours ago, OhioBob said:

You must have accidently hit a wrong key because the answer you got is 496456.27 divided by 60.  You have an extra 1000 seconds in there.  The correct result is,

22 days, 5 hours, 37 minutes, 36.27 seconds.

:blush::blush::blush::blush::blush::blush::blush::blush::blush:

Share this post


Link to post
Share on other sites
4 hours ago, Pavel ☭ said:

@Galileo I don't know if you are the one who maintains this mod's CKAN upload, but for some reason during the download CKAN fails to acquire GPP Textures because the server denies it access. This mod is really complicated for me to install manually, so I hope this is fixed

On another note, I did get the mod running (without scatterer because of how much of a damn FPS hog it is) and I have noticed this absolutely awful problem with the location of the KSC.

It's night, but you should still be able to see the serious clipping on the administration, lower half of the runway and a bunch of the KSC++ objects which are supposed to be compatible with this mod.

It's really a major eyesore and actually will probably cause serious problems launching anything from the SPH.

The issue is not GPP, you are using Rescale and you simply did not install KKtoSD like it recommends in the rescale thread... as for CKAN, everything works as intended, so keep trying. 

And yes, GPP can run just fine without scatterer, but due to how it’s handled in ckan, it has to be made a “requirement”. just simply delete the scatterer folder from gamedata 

Edited by Galileo

Share this post


Link to post
Share on other sites

Several years later, @OhioBob's numbers remain correct and Gael still does not have line of sight on my secret thing :) 

(If I knew how, I'd make it some sort of clever contract that only puts it there when you have reached Iota's orbit but... that's too hard for my tiny mind to handle. I'll just cheat it in when the time is right.)

Share this post


Link to post
Share on other sites

I have finally constructed a vessel which can achieve LTO in my 2.5x save. It has taken so long to design and build a craft that works and is small enough to be transported there efficiently (well its still pretty big but its about as small as I could get it). 

So I present for your viewing pleasure, my craft reaching LTO to Hans Zimmer's "Flight" 

 

Share this post


Link to post
Share on other sites

I'm also having a problem with CKAN and the GPP textures. I get a 403 "forbidden" error while trying to install the planet pack. Unfortunately because it is listed as a dependency for the pack, I cannot install GPP through CKAN, even if I download the mod separately. Any solution? 

Share this post


Link to post
Share on other sites
2 hours ago, JadeOfMaar said:

GPP Resonant Orbit Calculator

Plotting your satellite constellations is finally easy. Stock-scale only, atm. I'll add rescale editions soon™

https://jjwadeforever.wixsite.com/kerbal/resonant-orbit-1x

Very nice, however, there's already a website that will do this.  It comes preloaded with the stock planets, but it does allow you to add your own planets.  It's actually designed for RemoteTech, but it works perfectly well for any satellites.  It also includes orbital eclipse periods and calculates battery requirements as well as EC production requirements.

In addition to giving you the orbital parameters for launching a satellite constellation from a single carrier spacecraft (useful for everywhere *except* Gael), it also gives you the timing for launching satellites individually, which is how one would usually do it around Gael.

https://ryohpops.github.io/kspRemoteTechPlanner/#/planner

EDIT:  I suggest that when you select "dive orbit", you show the resonant orbit's periapsis rather than its apoapsis.  Also, showing the atmosphere height and the SOI may be useful, especially if the resonant orbit goes near either one.

Edited by AG5BPilot

Share this post


Link to post
Share on other sites

I conducted a small search and didn't find this addressed:

Distant Object Enhancement is dimming the Skybox when pointing the camera in the direction of Grannus, but the skybox remains bright when the camera is pointed at Ciro. Since the DOE settings only specify body names and color, I can only guess why it thinks Grannus is the system primary.

Share this post


Link to post
Share on other sites
1 hour ago, AG5BPilot said:

Very nice, however, there's already a website that will do this.  It comes preloaded with the stock planets, but it does allow you to add your own planets. 

-snip-

EDIT:  I suggest that when you select "dive orbit", you show the resonant orbit's periapsis rather than its apoapsis.  Also, showing the atmosphere height and the SOI may be useful, especially if the resonant orbit goes near either one.

Ooooh, fascinating. I'll see if I can change the current script to use the dive orbit's Pe rather than Ap. The atmosphere already shows; it's the faint gray circle around the colored one representing the body. It will show the geosync altitude and SOI edge too but only if your orbits are near to or will cross them.

9 minutes ago, danfarnsy said:

Distant Object Enhancement is dimming the Skybox when pointing the camera in the direction of Grannus, but the skybox remains bright when the camera is pointed at Ciro.

I've never had this problem, or heard of it from anyone else. You might want to share some logs.

Share this post


Link to post
Share on other sites
On 12/18/2017 at 5:53 AM, Galileo said:

The issue is not GPP, you are using Rescale and you simply did not install KKtoSD like it recommends in the rescale thread... as for CKAN, everything works as intended, so keep trying. 

And yes, GPP can run just fine without scatterer, but due to how it’s handled in ckan, it has to be made a “requirement”. just simply delete the scatterer folder from gamedata 

Except I did install KKtoSD. I guess it wasn't mounted or isn't working for some reason? By Rescale do you mean upscaling the planet size? I didn't intend to do this, I just installed GPP as normal and did not notice that.

Share this post


Link to post
Share on other sites

Finished putting together my 1.3.1 GPP build, bit less than 100 mods, all working nicely.

One last thing remains: a graphical mod that adds nice volumetric clouds. What's the best recommended for GPP? I'm using Rescale at 10.625x (earth size)

Specs: i7 8700k @5ghz, GTX 1080ti @5760x1080, 32gb ram ddr4 3000mhz.

Share this post


Link to post
Share on other sites
3 hours ago, JeeF said:

Finished putting together my 1.3.1 GPP build, bit less than 100 mods, all working nicely.

One last thing remains: a graphical mod that adds nice volumetric clouds. What's the best recommended for GPP? I'm using Rescale at 10.625x (earth size)

Specs: i7 8700k @5ghz, GTX 1080ti @5760x1080, 32gb ram ddr4 3000mhz.

Probably the one included in the GPP download...

Share this post


Link to post
Share on other sites
4 hours ago, Galileo said:

Probably the one included in the GPP download...

ok... maybe my mods are not working that well then, as I have no clouds.

Strange... all other mods are parts mods, nothing related with visuals. :confused:

https://ibb.co/mCkWaR

I do have a thin hazy layer that resembles clouds, but definitely nothing volumetric

Edited by JeeF

Share this post


Link to post
Share on other sites
11 minutes ago, JeeF said:

ok... maybe my mods are not working that well then, as I have no clouds.

Strange... all other mods are parts mods, nothing related with visuals. :confused:

https://ibb.co/mCkWaR

I do have a thin hazy layer that resembles clouds, but definitely nothing volumetric

Read the instructions again and make sure you did everything and did it correctly.  You have to install the Clouds folder from GPP, and you have to download and install EVE.

Share this post


Link to post
Share on other sites
7 minutes ago, OhioBob said:

Read the instructions again and make sure you did everything and did it correctly.  You have to install the Clouds folder from GPP, and you have to download and install EVE.

Dammit to hell. I installed EVE but my installation went wrong and I scrapped it and then I forgot to install EVE the second time. My apologies, I'll bang my head in the wall a bit.

Thanks for the help!

Share this post


Link to post
Share on other sites

UPDATE

Changelog:

v1.5.99 -forced-to-make-d3d11-work

  • Small changes to make DirectX 11 work. TU users rejoice!
  • Fixes the renamer and enables it to work with career saves again.

Download and install instructions linked in the OP

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

UPDATE

Safe to install during career, or better to wait till I start new game?

BTW, I love the mod so far, I had some issues with kerbal sliding (and unable to use jetpack during the slide) on not really slope steep on IOTA, but I think it's just a thing with the lack of friction in KSP.

Share this post


Link to post
Share on other sites
5 hours ago, jamqdlaty said:

Safe to install during career, or better to wait till I start new game?

BTW, I love the mod so far, I had some issues with kerbal sliding (and unable to use jetpack during the slide) on not really slope steep on IOTA, but I think it's just a thing with the lack of friction in KSP.

It’s safe to install over a career, yes. As for sliding, I am certain that’s a stock though thing. I have seen it in my stock play through as well.

Share this post


Link to post
Share on other sites

Is it possible to update from 1.5.3 to 1.88 without a fresh install? I had so much difficulties getting my game with all the mods running, so I really would prefer not to reinstall :wink: 

 

Merry Christmas! 

Share this post


Link to post
Share on other sites
2 hours ago, Phil Kerman said:

Is it possible to update from 1.5.3 to 1.88 without a fresh install? I had so much difficulties getting my game with all the mods running, so I really would prefer not to reinstall :wink: 

 

Merry Christmas! 

I pulled it off, but it's no guarantee. The instructions are as specific as they are for a reason. You could always make a temporary folder to hold your mods while reinstalling/updating.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.