Jump to content

[1.7] KVV - Kronal Vessel Viewer = Exploded ship view


Recommended Posts

13 minutes ago, HalcyonSon said:

Umm... hate to tell you, but your naming and propulsion are all wrong.  That ship most closely resembles the US Navy's LCS-2 Independence class, which have four waterjets and are roughly 127m in length.  The scaling, particularly in the superstructure, is also off but it is only a game :wink:  

And you know what it would be difficult for me to care any less, , all it is is a  vague resemblance of an LCS nothing more  was never intended to be, and was just a handy subject on which to test the plugin,,,   and spends most of it's lives being blown to bits and sunk

Link to post
Share on other sites
2 hours ago, SpannerMonkey(smce) said:

And you know what it would be difficult for me to care any less, , all it is is a  vague resemblance of an LCS nothing more  was never intended to be, and was just a handy subject on which to test the plugin,,,   and spends most of it's lives being blown to bits and sunk

Sounds about right for the LCS after all! :)

Link to post
Share on other sites
17 hours ago, HalcyonSon said:

Umm... hate to tell you, but your naming and propulsion are all wrong.  That ship most closely resembles the US Navy's LCS-2 Independence class, which have four waterjets and are roughly 127m in length.  The scaling, particularly in the superstructure, is also off but it is only a game :wink:  

@HalcyonSon This thread is about the KVV mod, not about specific vessels. 

Link to post
Share on other sites

Loving this mod, makes taking vanity shots of my ships for publishing on KerbalX so much easier.  I have a few things that I would like to raise as suggestions.

 

1) I am noticing that the lighting in the KVV window will vary depending on WHERE the vessel is in the SPH/VAB AND if its ventral or dorsal view.  Is there any way to have say a universal light or something to even out the lighting? You will see what I mean in the screenshots.

2) The ability to select specific angles to auto rotate to, such as Ventral, Dorsal, Front, Back, Lateral.  I think these would make things easier as you don't have to eyeball your front, rear and lateral views.

 

 

 

Edited by stali79
Link to post
Share on other sites
  • 2 weeks later...

I love the idea of this mod, but can't get it to work.

I've saved the files to the game data folder like the other mods I use.

When KSP launches it asks me if I'd like to keep KVV updated, however once I'm in game there is no KVV button in the VAB.

Any ideas?

KSP 1.2.2

 

Link to post
Share on other sites
On 29/12/2016 at 5:36 AM, Dirty Frank said:

I love the idea of this mod, but can't get it to work.

I've saved the files to the game data folder like the other mods I use.

When KSP launches it asks me if I'd like to keep KVV updated, however once I'm in game there is no KVV button in the VAB.

Any ideas?

KSP 1.2.2

Try reinstalling ? Start by deleting your KronalUtils folder in GameData, re-download and copy the downloaded folder back to GameData.

Link to post
Share on other sites
19 hours ago, Li0n said:

Try reinstalling ? Start by deleting your KronalUtils folder in GameData, re-download and copy the downloaded folder back to GameData.

Tried that twice actually, even downloaded it from the alternate source.  Same results.  Each time I reinstalled it asked if I wanted to keep KVV updated, so it recognizes the mod is there, but still no button in the VAB.

Link to post
Share on other sites
3 hours ago, Dirty Frank said:

Tried that twice actually, even downloaded it from the alternate source.  Same results.  Each time I reinstalled it asked if I wanted to keep KVV updated, so it recognizes the mod is there, but still no button in the VAB.

Works fine for me on 1.2.2 so I suspect it's a conflict with another mod. Can you post your output.log and a screenshot of your GameData folder ?

Link to post
Share on other sites

Well, the only other mod I'm running right now is Kerbal Engineer.  So, I uninstalled both, then reinstalled them at the same time.  Now they both appear in VAB, so, I think you were right, must have been something getting mixed up between them.  

Thank you very much LiOn, for your time and suggestions!!  Works great now!

Now I have to go make some blueprints!

 

 

Link to post
Share on other sites
  • 3 weeks later...

I’d really love an option to label each part.  An easy-to-lay-out approach could be to put a number next to each part, and then add a legend to one side, or the bottom, listing each part name next to the corresponding number.

(If this exists and I overlooked it, my apologies!)

Link to post
Share on other sites
50 minutes ago, meyerweb said:

I’d really love an option to label each part.  An easy-to-lay-out approach could be to put a number next to each part, and then add a legend to one side, or the bottom, listing each part name next to the corresponding number.

(If this exists and I overlooked it, my apologies!)

I'd really love that also.  Are  you willing to write the code?

Seriously, I didn't write this, I'm only maintaining it.  If someone would write the code, I'd gladly incorporate it

Link to post
Share on other sites
On 1/17/2017 at 0:30 PM, linuxgurugamer said:

I'd really love that also.  Are  you willing to write the code?

Seriously, I didn't write this, I'm only maintaining it.  If someone would write the code, I'd gladly incorporate it

I wish I could!  kOS and Javascript are about the upper limit of my programming abilities, I’m afraid.

Link to post
Share on other sites
  • 2 weeks later...

The mod isn't working for me, or the button just isn't there. I haven't kerbalism in install so it shouldn't be problem. Want any logs?

 

What can cause dissapeared icon?

Oh, sorry for post, I was in hurry and haven't time for reading the posts above. I'll try reinstall my mods then...even when I have 100 of them. :D

Edited by Toonu
Link to post
Share on other sites
21 hours ago, Toonu said:

The mod isn't working for me, or the button just isn't there. I haven't kerbalism in install so it shouldn't be problem. Want any logs?

 

What can cause dissapeared icon?

Oh, sorry for post, I was in hurry and haven't time for reading the posts above. I'll try reinstall my mods then...even when I have 100 of them. :D

Always provide a log.  It can't hurt, and if available I can look at it immediately.

 

Link to post
Share on other sites

Actually reinstall helped. But thanks for efforts. One question, why is Kerbalism incopatible? :D I haven't problem with that, just curious...because I wanted that mod...

Link to post
Share on other sites
1 hour ago, Toonu said:

Actually reinstall helped. But thanks for efforts. One question, why is Kerbalism incopatible? :D I haven't problem with that, just curious...because I wanted that mod...

I have no idea why, just that when it's installed, it has lots of segfaults.  It is very intrusive, and is probably trying to do something which this mod wasn't designed to do, but I have no idea what.

 

Link to post
Share on other sites
6 hours ago, eberkain said:

Any way to make it compatible with Kerbalism?  

You are more than welcome to look at it.

I did, but Kerbalism is so intrusive that I just gave up.  I have no idea what it's doing or how.

Link to post
Share on other sites
On 11/24/2016 at 0:10 PM, linuxgurugamer said:

Note that I have been unable to get the Edge Detect shaders to work properly, so I've disabled that option.  Frankly, I'm not sure they ever worked.  If someone who has knowledge here wishes to help, please contact me

Oh they definitely worked. This was a setting I used for every image I took because it allowed me to expand the width of the edges, which allowed me to better define parts in my blueprints and even let me color them differently like this:

Sounding Rocket MkIII (11/27/15)

In addition to the colored stages, the close-up of the payload in the upper-right the image is enhanced by thicker than normal black lines outlining the part details, which I get by setting the Edge Detect Normal Power to 1.28

Maybe @blackrack or @Waz could provide some help with the shaders. Would very much like to see this back in for v1.2.2

Link to post
Share on other sites
12 hours ago, Drew Kerman said:

Oh they definitely worked. This was a setting I used for every image I took because it allowed me to expand the width of the edges, which allowed me to better define parts in my blueprints and even let me color them differently like this:

Sounding Rocket MkIII (11/27/15)

In addition to the colored stages, the close-up of the payload in the upper-right the image is enhanced by thicker than normal black lines outlining the part details, which I get by setting the Edge Detect Normal Power to 1.28

Maybe @blackrack or @Waz could provide some help with the shaders. Would very much like to see this back in for v1.2.2

I use KVV in combination with Gimp to achieve the same result.

Also by doing it this way I believe you're able to achieve more than KVV currently offers. I know it's not a one stop shop deal, but I think the results are more than satisfactory. 

Still kudos to linuxgurugamer for maintaining this mod among the plethora of other mods under his maintenance.

Respect,

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...