Jump to content

[KSP 1.3.0->1.5.*] Mod Pods


TiktaalikDreaming
 Share

Recommended Posts

49 minutes ago, lurkoholic said:

That's the one.  If I hadn't been on mobile I would have sent you there. But, I get lazy on mobile. :)

 

And yeah, it is definitely one of those searches you need to tell Google "no I do not mean this other unrelated thing, stop showing me those dammit".

Link to comment
Share on other sites

I've started working on a 1.4 update for this.  Clearly with all the fussing, the first thing I needed to do was update the side of the Mk2-3 pod to reflect Take 2 changes.

QaBLTnX.png

Not super happy with how the warranty text adjustment to hardware worked, so may end up picking a different section of the EULA.  (also, that's at twice the resolution I'd be dumping into the game, don't want to kill people's RAM use).

This is basically just a silly post to let people know I'm not dead or anything.  The existing mod seems to work fine in the updated game.

 

(Oh, and updated the download links with the github locations for anyone wanting development versions)

Edited by TiktaalikDreaming
Link to comment
Share on other sites

Are you allowed to take the old three seat command pod to integrate it to Mod Pods without changing the layout of the ladders/hatches?  Because it will soon disappear from the game (it still hasn't if we look closely for save integrity sake)

However, I recon that having every hatch/ladder centered to the same spot helps designing ships a lot as I had quite some unrest trying to figure out how to use your parts to make interplanetary ships with a MPL on them.

Have you considred the possibility to add some ladder on the side of the service bay to  integrate it better onto a lander?

I used it on a Duna lander with also the rhomboid aerospike engine to make a kinda Mars mission as envisaged in the 70s.  I put fout very big landing legs from I don't know which other mod, that made a super stable and fuel efficient lander for Duna. I added lots of chutes too (repacked by the crew), so I guess it can land back on Kerbin on its own legs !

I also use your parts as an addition to Alcubierre Warp drive prts for added functionality, man those service bays surely contain alot of things. Many batteries and science equipments in one, many Xenon gas tanks in the other and I'm good to go.

Glad to heat that you are working on a new version !

Link to comment
Share on other sites

49 minutes ago, Quoniam Kerman said:

Are you allowed to take the old three seat command pod to integrate it to Mod Pods without changing the layout of the ladders/hatches?  Because it will soon disappear from the game (it still hasn't if we look closely for save integrity sake)

However, I recon that having every hatch/ladder centered to the same spot helps designing ships a lot as I had quite some unrest trying to figure out how to use your parts to make interplanetary ships with a MPL on them.

Have you considred the possibility to add some ladder on the side of the service bay to  integrate it better onto a lander?

I used it on a Duna lander with also the rhomboid aerospike engine to make a kinda Mars mission as envisaged in the 70s.  I put fout very big landing legs from I don't know which other mod, that made a super stable and fuel efficient lander for Duna. I added lots of chutes too (repacked by the crew), so I guess it can land back on Kerbin on its own legs !

I also use your parts as an addition to Alcubierre Warp drive prts for added functionality, man those service bays surely contain alot of things. Many batteries and science equipments in one, many Xenon gas tanks in the other and I'm good to go.

Glad to heat that you are working on a new version !

I suspect the old pod will stay until at least 1.5.  The dev version (github version) has a quick fix that I'll roll out and mark as 1.4 compatible.  I'm a bit slow at the moment due to lack of time.  But in the long run, it makes sense to either provide my own pod in that size bracket, or adapt to the new stock.

Link to comment
Share on other sites

Hi, question here... I've got a little issue with the 2-3 LFO service module (using a 1.2.2 version :rolleyes:, but I don't see any difference in the .cfg with the latest), the antenna pops out as soon as the part is picked in the VAB or loaded into the flight scene. Now, I'm also using Kerbalism, which messes with some things, but the workaround I used for the ModuleDeployableAntenna node with SXT doesn't seem to be working here. I think maybe Kerbalism uses its own animation module or something. Here's the MM file I'm trying to use.:

@PART[mk2to3ServM]
{
  MODULE
  {
    name = Antenna
    type = low_gain
    cost = 0.3
    dist = 7e8
    rate = 0.156
  }
  
    MODULE
  {
    name = ModuleAnimationGroup
    deployAnimationName = antenna
    moduleType = Antenna
  }
  
    !MODULE[ModuleDeployableAntenna] {}

  MODULE:NEEDS[FeatureReliability]
  {
    name = Reliability
    type = Antenna
    title = Antenna
    redundancy = Communication
    repair = true
    mtbf = 12596000 // 8y
    extra_cost = 2.0
    extra_mass = 1.0
  }

  !MODULE[ModuleDataTransmitter] {}

  @description = This is a test.
}

Anything jump out here? I don't even care about making the thing work, really I just don't want it to pop out right away. :P

Link to comment
Share on other sites

  • 2 weeks later...
3 hours ago, Daniel Prates said:

I never noticed this on spacedock's mod description:

"Size 15 to Size 16
from 18.75m to 20m"

So we will eventually get the flying pyramids of kegipt? :sticktongue:

The original motivator was to have a giant pod type thing to put on top of my second stage nexus. So yes. But the eventually is still a long way off

Link to comment
Share on other sites

  • 1 month later...
4 hours ago, Quoniam Kerman said:

1.4.3 might have messed up with your RCS equipped pods. I still haven't tried your mod on 1.4.x though.

RCS only got messed up in 1.4 if it was using the older module. I'm fairly sure I only used the newer moduleRCSFX for the pods.

Link to comment
Share on other sites

On 4/8/2018 at 5:23 AM, CatastrophicFailure said:

Hi, question here... I've got a little issue with the 2-3 LFO service module (using a 1.2.2 version :rolleyes:, but I don't see any difference in the .cfg with the latest), the antenna pops out as soon as the part is picked in the VAB or loaded into the flight scene. Now, I'm also using Kerbalism, which messes with some things, but the workaround I used for the ModuleDeployableAntenna node with SXT doesn't seem to be working here. I think maybe Kerbalism uses its own animation module or something. Here's the MM file I'm trying to use.:

@PART[mk2to3ServM]
{
  MODULE
  {
    name = Antenna
    type = low_gain
    cost = 0.3
    dist = 7e8
    rate = 0.156
  }
  
    MODULE
  {
    name = ModuleAnimationGroup
    deployAnimationName = antenna
    moduleType = Antenna
  }
  
    !MODULE[ModuleDeployableAntenna] {}

  MODULE:NEEDS[FeatureReliability]
  {
    name = Reliability
    type = Antenna
    title = Antenna
    redundancy = Communication
    repair = true
    mtbf = 12596000 // 8y
    extra_cost = 2.0
    extra_mass = 1.0
  }

  !MODULE[ModuleDataTransmitter] {}

  @description = This is a test.
}

Anything jump out here? I don't even care about making the thing work, really I just don't want it to pop out right away. :P

Somehow I missed this when it was posted.

I suspect the issue is your animation name.  That's baked into the mu file and needs to match, so change to 
animationName = Extend
And it might work

Link to comment
Share on other sites

  • 4 months later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...