flywlyx

[1.9.X]Aircraft Carrier Accessories

Recommended Posts

Love this mod! It's made my dream of trapping and launching planes from a boat come true. Just one question. I've been having a bug where if I land a plane, activate the brakes and then go into physical timewarp, the plane tends to shake itself to death. Starting from 2x or 3x warp, the shaking is noticeable; once it reaches 4x, parts start exploding. Seems to happen whether or not the plane is connected to any tie down points.

 

Is there any way to deal with this issue? Otherwise, I was thinking of using the Hangar mod to store the planes as I'd like to use physical timewarp when driving the ship.

Share this post


Link to post
Share on other sites

Very interesting mod, i've just downloaded it but the pre-made enterprise doesn't show up in the SPH ship list

Share this post


Link to post
Share on other sites
On 6/5/2019 at 9:01 PM, First Flight said:

What's with the tie down not showing wires with the fixed point? No matter where I place the tie downs and points, whether they're extremely close or a good distance between them, no green or pink lines show. I'm stopped right in between the tie downs, yet nothing shows. 

Try adjust the range and clear the space in between, some part has bigger collision than the visual model.

On 6/15/2019 at 9:53 PM, bvsveera said:

Love this mod! It's made my dream of trapping and launching planes from a boat come true. Just one question. I've been having a bug where if I land a plane, activate the brakes and then go into physical timewarp, the plane tends to shake itself to death. Starting from 2x or 3x warp, the shaking is noticeable; once it reaches 4x, parts start exploding. Seems to happen whether or not the plane is connected to any tie down points.

 

Is there any way to deal with this issue? Otherwise, I was thinking of using the Hangar mod to store the planes as I'd like to use physical timewarp when driving the ship.

Yes, please use hanger, there is no way to help this issue unless we totally remove gravity.

Share this post


Link to post
Share on other sites

I built a craft and tried to launch it from a catapult and it just disintegrated immediately. The same thing also happened while landing. Any advice?

Share this post


Link to post
Share on other sites
On 7/24/2019 at 3:40 AM, byong614 said:

I built a craft and tried to launch it from a catapult and it just disintegrated immediately. The same thing also happened while landing. Any advice?

Any log or video?

Share this post


Link to post
Share on other sites
On 7/24/2019 at 10:40 AM, byong614 said:

I built a craft and tried to launch it from a catapult and it just disintegrated immediately. The same thing also happened while landing. Any advice?

Did you use KSS Nimitz? It has a problem with invisible colliders since 1.4 so it destroys everything that touches it.

Share this post


Link to post
Share on other sites
On 11/5/2019 at 2:56 AM, Manul said:

Did you use KSS Nimitz? It has a problem with invisible colliders since 1.4 so it destroys everything that touches it.

Yeah, I used Eskandere's stuff. That explains a lot hehe

Share this post


Link to post
Share on other sites
4 hours ago, byong614 said:

Yeah, I used Eskandere's stuff. That explains a lot hehe

Liaoning is absolutely safe to land|takeoff, Enterprise is mostly safe. "Mostly" means nothing explodes during takeoff or landing but there are some Keter-class anomalies on the deck if a plane gets trapped inside the game crashes. Kerbals just safely fall through the deck. LBPCVS Single part hull from SMmarine also has invisible colliders that destroy everything that moves faster than 10m/s.

Share this post


Link to post
Share on other sites
On 11/9/2019 at 4:56 AM, Manul said:

Liaoning is absolutely safe to land|takeoff, Enterprise is mostly safe. "Mostly" means nothing explodes during takeoff or landing but there are some Keter-class anomalies on the deck if a plane gets trapped inside the game crashes. Kerbals just safely fall through the deck. LBPCVS Single part hull from SMmarine also has invisible colliders that destroy everything that moves faster than 10m/s.

KSP has a major problem on the multi mesh collider now, old MOD might suffer from it since the bug was not there back then.

Share this post


Link to post
Share on other sites
6 hours ago, flywlyx said:

KSP has a major problem on the multi mesh collider now

Looks like a Unity problem. That can be fixed only by Unity update (and it will break a bunch of other mods). I tried to explore how deep is the rabbit hole and found that all large hull parts from SMmarine have their colliders messed up now.

Edited by Manul

Share this post


Link to post
Share on other sites
6 hours ago, Manul said:

Looks like a Unity problem. That can be fixed only by Unity update (and it will break a bunch of other mods). I tried to explore how deep is the rabbit hole and found that all large hull parts from SMmarine have their colliders messed up now.

Not a Unity problem, same part works perfectly in previous version KSP will be messed up in new version. It is not only happened in 1.8 through, Enterprise has been updated a while ago.

 

Share this post


Link to post
Share on other sites
4 hours ago, flywlyx said:

It is not only happened in 1.8 through, Enterprise has been updated a while ago.

Nimitz got it's destructive colliders after updating to Unity 5. Didn't try to land on aircraft carriers in 1.8 yet, can't land on a carrier with no landing gear (KF and KSPWheel haven't been updated yet)... actually I can but it will be destructive regardless of destructive colliders. :)

Edited by Manul

Share this post


Link to post
Share on other sites

Tested some aircraft carriers in 1.8.1 and I have good news. Nimitz made by @Eskandare and LBPCVS carrier by @SpannerMonkey(smce) do not have destructive colliders anymore and now they are absolutely safe to land or takeoff. Some other hulls from SMmarine that used to have collider issues work well in 1.8.1 
Enterprise had invisible walls near aircraft lifts (just simple colliders not these ghostlike you can pass through) now they are gone. Invisible holes in the deck still remain but getting trapped doesn't crash the game anymore. Couldn't check Liaoning because when I approach the carrier jumps into the air (sometimes up to one thousand meters) and hits my aircraft if I'm not fast enough to pull up. I think, I shouldn't place ships of this size on the runway.

Edited by Manul

Share this post


Link to post
Share on other sites
4 hours ago, Manul said:

Tested some aircraft carriers in 1.8.1 and I have good news. Nimitz made by @Eskandare and LBPCVS carrier by @SpannerMonkey(smce) do not have destructive colliders anymore and now they are absolutely safe to land or takeoff. Some other hulls from SMmarine that used to have collider issues work well in 1.8.1 
Enterprise had invisible walls near aircraft lifts (just simple colliders not these ghostlike you can pass through) now they are gone. Invisible holes in the deck still remain but getting trapped doesn't crash the game anymore. Couldn't check Liaoning because when I approach the carrier jumps into the air (sometimes up to one thousand meters) and hits my aircraft if I'm not fast enough to pull up. I think, I shouldn't place ships of this size on the runway.

THis is a good news. 

Could you take a screenshoot to indicate where the hole is?

Share this post


Link to post
Share on other sites
On 11/16/2019 at 12:25 AM, flywlyx said:

Could you take a screenshoot to indicate where the hole is?

Actually they aren't holes just the deck ends not where it ends. Not as dangerous as holes near airplane lifts that used to trap planes in 1.7
yGTTGXW.png

fmKHKaG.png

xFL8cWP.png

ThuWw0Z.png

iBZ7BtT.png

Share this post


Link to post
Share on other sites

Does anyone else have this issue I'm having? Trying to reload throws a nullref at ReloadableRail.PartSnapshot()

Hd2Tj0I.png

Another seemingly random question - when successfully reloaded, does staging completely break? As in the staging bar disappears and you cannot trigger any staging actions.

Share this post


Link to post
Share on other sites
3 hours ago, CrayzeeMonkey said:

Trying to reload throws a nullref at ReloadableRail.PartSnapshot()

Exactly the same:

[ERR 17:07:13.970] Module FuelCap threw during OnFixedUpdate: System.NullReferenceException: Object reference not set to an instance of an object
  at ProtoPartModuleSnapshot..ctor (PartModule module) [0x00031] in <3e135473f56a45478d738eb041ebd6cb>:0
  at ProtoPartSnapshot..ctor (Part PartRef, ProtoVessel protoVessel, System.Boolean preCreate) [0x0033f] in <3e135473f56a45478d738eb041ebd6cb>:0
  at ProtoPartSnapshot..ctor (Part PartRef, ProtoVessel protoVessel) [0x00000] in <3e135473f56a45478d738eb041ebd6cb>:0
  at ReloadableRail.PartSnapshot (Part part) [0x00029] in <32563f7703da41898ac1abdc58f04b6c>:0
  at ReloadableRail.Resupply () [0x000c5] in <32563f7703da41898ac1abdc58f04b6c>:0
  at FuelCap.OnFixedUpdate () [0x0033d] in <32563f7703da41898ac1abdc58f04b6c>:0
  at Part.ModulesOnFixedUpdate () [0x000bd] in <3e135473f56a45478d738eb041ebd6cb>:0

Share this post


Link to post
Share on other sites
53 minutes ago, Manul said:

Exactly the same:

*big bad stacktrace*

Try this fix. Download the .dll and replace the original .dll with this one.

I want to know if, with the new dll, you can reload the rail successfully, any other related errors occur, and any effects it might have on staging.

https://www.dropbox.com/s/21a9epxskkj39dr/ACA.dll?dl=0

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, CrayzeeMonkey said:

I want to know if, with the new dll, you can reload the rail successfully, any other related errors occur, and any effects it might have on staging.

Rearmed and refueled successfully... staging..... never cared about it but yes, it broke.

1g6vRJK.png

Got some error messages while reloading

Spoiler

[LOG 08:14:57.783] [HighLogic]: EasyCobra32
 pressed a button.
[LOG 08:15:42.575] Node(0.0, 0.1, -1.0)
[LOG 08:15:42.588] Ready to errorbahaAim120 (Part)srfAttach
[LOG 08:15:42.590] Attach new part {0} to {1}: srcNodeId={2}, tgtNode={3}bahaAim120 (Part)Type-AdvancedFlanker (Lynx CAS2) (Vessel)srfAttach
[LOG 08:15:42.591] Wait for part {0} to get alive...
[ERR 08:15:42.625] Module FuelCap threw during OnFixedUpdate: System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
  at System.ThrowHelper.ThrowInvalidOperationException (System.ExceptionResource resource) [0x0000b] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at System.Collections.Generic.List`1+Enumerator[T].MoveNextRare () [0x00013] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at System.Collections.Generic.List`1+Enumerator[T].MoveNext () [0x0004a] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at FuelCap.OnFixedUpdate () [0x00363] in <c9fb2b129d8340d1a572f0fe754162de>:0
  at Part.ModulesOnFixedUpdate () [0x000bd] in <3e135473f56a45478d738eb041ebd6cb>:0

[LOG 08:15:42.702] Node(0.0, 0.1, -1.0)
[LOG 08:15:42.711] Ready to errorbahaAim120 (Part)srfAttach
[LOG 08:15:42.711] Attach new part {0} to {1}: srcNodeId={2}, tgtNode={3}bahaAim120 (Part)Type-AdvancedFlanker (Lynx CAS2) (Vessel)srfAttach
[LOG 08:15:42.711] Wait for part {0} to get alive...
[ERR 08:15:42.714] Module FuelCap threw during OnFixedUpdate: System.InvalidOperationException: Collection was modified; enumeration operation may not execute.
  at System.ThrowHelper.ThrowInvalidOperationException (System.ExceptionResource resource) [0x0000b] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at System.Collections.Generic.List`1+Enumerator[T].MoveNextRare () [0x00013] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at System.Collections.Generic.List`1+Enumerator[T].MoveNext () [0x0004a] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at FuelCap.OnFixedUpdate () [0x00363] in <c9fb2b129d8340d1a572f0fe754162de>:0
  at Part.ModulesOnFixedUpdate () [0x000bd] in <3e135473f56a45478d738eb041ebd6cb>:0

[LOG 08:15:43.027] Part {0} is in state {1}bahaAim120 (Part)ACTIVE
[LOG 08:15:43.116] Part {0} is in state {1}bahaAim120 (Part)ACTIVE
[LOG 08:15:57.084] [UIMasterController]: HideUI
[LOG 08:16:40.244] [UIMasterController]: ShowUI
[LOG 08:16:51.343] SCREENSHOT!!
[LOG 08:17:02.058] SCREENSHOT!!
[LOG 08:17:27.786] SCREENSHOT!!
[LOG 08:17:34.867] SCREENSHOT!!

 

Edited by Manul

Share this post


Link to post
Share on other sites
28 minutes ago, CrayzeeMonkey said:

I wonder if someone can explain why this is necessary

I think it's needed to do this. But something has gone wrong.

Share this post


Link to post
Share on other sites
Posted (edited)

Do the lifts of the carriers work? If yes, they do not work for me

Edited by VoidCosmos

Share this post


Link to post
Share on other sites

Hello,

I have been having a problem with the catapults where they tug the plane all they way into the ship resulting in the destruction of the cockpit and most of the plane. Is there any fix?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.