Jump to content
  • 0

Camera flicker after a crash


katateochi
 Share

Question

I've been meaning to report this for a while, and until a few moments ago I was sure this was a stock game problem, but now I'm not so sure.
So I'm posting here to find out if others have had this problem and if it's known to be caused by a particular mod or if it has been reported as a stock issue.

Anyway, almost every time I have a high velocity crash, particularly when at KSC the camera flickers rapidly between two positions. See spoiler to see what I mean (spoilered because this gif should probably come with an epilepsy warning!)

Spoiler

TBPiCaK.gif

I'm sure I've had this happen in a pure stock install, but I can't seem to recreate it now. 
I'm fairly sure it has to do with crashing nearby another landed vessel, but maybe not. 

Has anyone else come across this glitch?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
10 minutes ago, katateochi said:

Has anyone else come across this glitch?

Yes. I keep having this, with my pure stock install.

It seems to happen especially if I follow the crash into terrain with the camera zoomed in fairly close, or positioned at an angle where the camera ends up under the terrain when the crash happens (ie. when watching from an angle slightly under the craft).

It does seem to happen more often around the KSC though, and come to think of it I do have other vessels nearby: a rover with some kerbals and a couple of flags.

Link to comment
Share on other sites

  • 0
20 hours ago, swjr-swis said:

Yes. I keep having this, with my pure stock install.

It seems to happen especially if I follow the crash into terrain with the camera zoomed in fairly close, or positioned at an angle where the camera ends up under the terrain when the crash happens (ie. when watching from an angle slightly under the craft).

It does seem to happen more often around the KSC though, and come to think of it I do have other vessels nearby: a rover with some kerbals and a couple of flags.

Me too, exactly as you describe.  Looks to be toggling the camera's position each frame.  My framerate is limited to 60Hz.

Not only on crashes though, I have seen this happen once or twice when simply moving the camera around.  Seems worse when using a SpaceNavigator 3D mouse in camera mode.

Link to comment
Share on other sites

  • 0

So it does happen in a pure stock game. I've still not been able to setup a quicksave where it reliably happens but that might be to do with the camera angle, I'll experiment with that. 

Do either of you have a quicksave where you can make this happen reliably? I'll put together a bug report once I've got that. 

Link to comment
Share on other sites

  • 0
6 hours ago, katateochi said:

Do either of you have a quicksave where you can make this happen reliably? I'll put together a bug report once I've got that.

One way I can reproduce it reliably is in a fresh new save, launch the standard first pod-on-a-flea straight up from the launch pad - leave out the parachute. Zoom in close and angle the camera just below the pod and watch it crash.

If it doesn't happen automatically, you can also angle the camera slowly down after the crash. It appears to happen when the position of the camera clips into the terrain, or into a building/tower. Zoom level doesn't matter when you do it that way.

I think the one particular case you show is when the crash is with high enough speed that the craft 'penetrated' a good bit into the terrain before the game registers the destruction, but the above gives the same effect.

Edited by swjr-swis
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...