Jump to content

Kerbal Space Program 1.2.2 is live!


Recommended Posts

On 12/9/2016 at 1:33 PM, klgraham1013 said:

The problem is when a work around becomes an excuse for a bug.

Sure, I get that, but you can't project that onto everyone who shares a workaround.  Using workarounds as excuses for bugs is a Squad issue, not a player issue.

Link to post
Share on other sites

Since the update, I have had a problem with parts not showing up in the VAB. I am playing in career mode and have set so that new parts require an initial purchase. Anything that hasn't had that initial purchase just doesn't show up at all now, so I have no way to purchase things.

Link to post
Share on other sites
On 12/9/2016 at 7:36 PM, RentedTritium said:

In this version my game locks up every 6th second.

This is almost certainly a garbage collection induced stutter.

On 12/9/2016 at 7:36 PM, RentedTritium said:

Probably it's a mod checking something inappropriately though since it seems like I'm the only one.

Stock installs also suffer from garbage collection induced stutter.  You certainly aren't the only one, try searching the forum for the word "stutter" and then go look at the thread linked in my sig...

Link to post
Share on other sites
8 hours ago, TV4Fun said:

Since the update, I have had a problem with parts not showing up in the VAB. I am playing in career mode and have set so that new parts require an initial purchase. Anything that hasn't had that initial purchase just doesn't show up at all now, so I have no way to purchase things.

I believe the purchasing is done on the R&D building, and they only show up in the VAB after purchased.

Link to post
Share on other sites
19 minutes ago, monstah said:

I believe the purchasing is done on the R&D building, and they only show up in the VAB after purchased.

Only partially correct. Parts can be purchased in R&D, or ad-hoc in the VAB or SPH. Parts that have been researched but not purchased yet appear in the VAB like this, and can be purchased:

ymSdUj4.png

(that's the most trivial example I could think of, with a stock moderate difficulty game, accepting and completing the first two contracts, researching a couple of nodes in R&D but not purchasing any parts)

That said, this was a stock 1.2.2 career game, installed via Steam - everything seems to be working the way I'd expect. If @TV4Fun is actually having problems with 1.2.2 I'd suggest they file a more detailed report in the appropriate forum.

Edited by stibbons
Link to post
Share on other sites
34 minutes ago, Space Crystal said:

I...I...I... aaargh. why doesn't it work? every time I try to launch ksp 1.2.2 is just stops loading right at the start.

why? has it been solved? have the dev's been informed? help!

 

Try with a purely stock game if you haven't already. If the problem persists, post a thread over in Technical Support, and be sure to include your logs.

Link to post
Share on other sites
On 08.12.2016 at 5:06 AM, Red Iron Crown said:

Some people must not be aware of the upvote system on the bugtracker. Think a bug is important and needs to be fixed? Document it properly there and upvote the ones that are important to you.

Would you please give a screenshot, I can't find the upvote button.

Link to post
Share on other sites
38 minutes ago, Red Iron Crown said:

Hmm, I thought that voting was enabled for everyone (been a while since I had a regular account on the tracker). I'll have to ask about it.

I'd like that, I haven't seen the option as well.

Link to post
Share on other sites
7 hours ago, Red Iron Crown said:

Hmm, I thought that voting was enabled for everyone (been a while since I had a regular account on the tracker). I'll have to ask about it.

A bit of testing has revealed a bit of a glitch with the tracker regarding the voting system, it's being investigated. 

Link to post
Share on other sites

So the update broke all my stuff too.....again.

I wish there were a better method so the mods don't break, but as a dev myself, I get it.

I wanna say thank you to SQUAD for the update and thank you to all the modders out there working to make this game so awesome. 

Also as a Steam player on linux I don't launch from Steam. I also note that if you are in Steam and if you right click your game, enter properties, enter Betas you should have betas for 1.0.5 and 1.1.3. A bunch of the mods I like are still maxxed at one of these versions. I suspect that if your mod doesn't work well in 1.2.2 and if you have this available in Steam that you can launch a compatible version to give the modders some time.

I am playing 64bit 1.2.2 on linux mint through Steam (I run the program directly not through the Steam button) and I am running a TON of mods. This is the first program I am trying to run on linux (ever) and without this forum I wouldn't have had a chance at making it 'fly'. So lastly, thank you to the folks posting fixes and suggestions on this forum.

Link to post
Share on other sites
2 hours ago, TriggerAu said:

Heya, can you let us know what got broked for you. Do you mean the version checking on mods saying its unsupported or mods not working on 1.2.2?

I ignore the nags about unsupported versions. I get them today with Near Future mods and I just play right on through.

Steam updated me to 1.2.2 and when I chose to start either a new game in any mode or to open an existing game I got a black screen that never went away. It was just black and after 5 minutes it was still just black. I booted Windows 10 and Linux Mint and experienced the same issue with either OS until I purged the game data folder (except SQUAD of course). I was running similar mods on both OSes at the time although I rarely look at Windows anymore.

I was using CKAN at the time and ModuleManager 2.7.5

I do get an unsupported mod message for TweakScale and have not been able to reinstall that and have it work correctly in 1.2.2. 

Impossible Innovations powered craft burn through massive amounts of fuel on the launch pad in < 1 second. If I install that one by itself it works, but when I install the rest of the mods I like there seems to be a conflict that did not exist before. This is nothing against that mod, it is due to a conflict with another mod or mods but I did not see it until 1.2.2.

I had trouble with Solaris Hypernautics but I don't remember what it was and I am not trying to run that mod today.

My core mods (the ones I don't like to play without) are Chatterer, Kerbal Engineer, Stock Alike Surface Lights and the mod that shows better burn times for maneuver nodes. These work fine today on 1.2.2 and none are the conflict mod for Impossible Innovations.

Sometimes, when I return to the main complex, it is underwater. I find this hilarious and a screen refresh fixes the issue. I think this is a Scatterer thing but I don't know if it was caused by 1.2.2 as I only started playing with it after the 1.2.2 update that caused me to purge GameData.

Killer game BTW. Do NOT take anything I said here as a complaint. I like tweaking things and I don't get bummed when I have to restart a game, format C:, or when I crash my drone. It's best to just make repairs and use lessons learned to be better for next time.

Keep it up. :) 

 

Edited by CranialRectosis
Link to post
Share on other sites

I'm happy this fix came out, my game wouldn't run for more than 5-10 minutes i'd get off the launch pad and the game would crash, over and over, this patch fixed literally everything thanks devs. you're the bomb. (1200 hours and never had a gamebreaking bug.. maybe immersion but not the game.)

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...
On 12/22/2016 at 3:18 PM, Agustin said:

DOes 1.2.2 break my saved game from 1.2 in any way?

If you have mods that are not compatible yet with 1.2.2, then yes, your saves will not be usable as you may have ships with unsupported, non-existing parts.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...