Jump to content
  • 0

Menu items dissapearing after going fullscreen


buildmad22
 Share

Question

15 answers to this question

Recommended Posts

  • 0

Unable to reproduce the issue here.

This appears specific with KSP install and/or system specs, but to diagnose further info is required. WRT what described here, please provide output_log.txt, list of system specifications, detailed explanation of the actions performed before the issue showed, info on the KSP install (clean new? upgrade?).

Also, could you run a test with no previous settings.cfg (in KSP root folder; don't delete the file but move it in a safe place so to restore afterwards) and report if the issue still shows? (believe it may have something that confuses KSP). In case there is no issue with a clean settings.cfg, would you provide that old settings.cfg you had so we could have a look at the possible cause?

Link to comment
Share on other sites

  • 0

Thanks for the effort, unfortunately we can't get files directly from your C: drive. Best option is to upload those to a shared online service (e.g., Dropbox; also pastebin works fine for textual files like those) then provide the link here for us to retrieve them. Also, don't forget the other info we need (e.g. the system specs, please run the dxdiag.exe from Start/command window and save the output in a file, then share it).

Pity the error still happens with a fresh settings.cfg, really hoped it could help quickly solve your issue. Well, only means we will have to spend some more time trying to get to the heart of it.

EDIT: oh, if you don't mind to run another thing that may also help with the issue: 1. Open your settings.cfg with a text editor (even Notepad does fine); 2. localize the line with "FULLSCREEN = ...", if you had KSP running in a window (like I understand from the description) it should read "... = False"; 3. change the above so to read "FULLSCREEN = True"; save the settings.cfg (without any other modification), now KSP should start already in FullScreen (and hopefully with all menu items displayed).

Link to comment
Share on other sites

  • 0

settings:http://pastebin.com/fpNqbmi0

log:http://pastebin.com/vxzLDQNE

When I go fullscreen on the loading screen before the menu the buttons come up fine, it's only if I go fullscreen on the menu

specs: Operating System: Windows 7 Professional 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.161007-0600)
           Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
       System Model: Vostro 220s Series
               BIOS: Default System BIOS
          Processor: Intel(R) Core(TM)2 Duo CPU     E7500  @ 2.93GHz (2 CPUs), ~2.9GHz
             Memory: 4096MB RAM
Available OS Memory: 3070MB RAM
          Page File: 3649MB used, 2490MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: Using System DPI
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7601.17514 32bit Unicode

Edited by buildmad22
Added specs
Link to comment
Share on other sites

  • 0

@buildmad22, is that output_log.txt you pasted complete (9307 lines),  or had anything more? because if so it would seem like KSP stopped working, so it didn't draw the menu.

Should you confirm so, that would already give some indication of what could be happening.

However I haven't clear how you went fullscreen with that session.  I know only about going fullscreen from the Settings Menu (right after the loading is completed, from the main menu) or by changing the settings.cfg; I am tempted to understand from your last post that the screen shows fine when you are already in fullscreen at loading time (therefore, settings.cfg with FULLSCREEN = True), but not when you have to make so from the settings menu (however, that output_log you pasted doesn't show you actually entered the settings menu, and that leaves me in the dark).

Link to comment
Share on other sites

  • 0
18 minutes ago, buildmad22 said:

Alt + enter

I never tried it but I never even expected that to work in KSP.

Do you still have the border, or is it true fullscreen? I'm guessing based on the image size that it still has a border, which means KSP is resizing on the fly. Maybe the menu resizes incorrectly and is off the screen?

I'd change the settings in the menus instead, and while you're at it set it to true fullscreen. You'll love it. :)

Link to comment
Share on other sites

  • 0
4 minutes ago, Tex_NL said:

[Alt] + [Enter] toggles between windowed and true full screen. I've been using it for years.

I had to set up fullscreen as "fake" (windowed but no border) when I first started playing or I couldn't record it, so I've never looked back from that. Nice to know it works!

Edited by 5thHorseman
Link to comment
Share on other sites

  • 0

I'm going to ask around if Alt+Enter is actually supported. Could be it was many versions ago, but now it seems to circumvent the way KSP manages settings, so it can't make things right. Just because that, I'm considering this issue would not be rated a bug, so no fix would be made for it.

As @5thHorseman said, better use the Settings Menu.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...