Jump to content

[1.5.1] AoA Technologies - Maintenance & Development thread


Wolfair corp.
 Share

Recommended Posts

13 hours ago, Stone Blue said:

It *should* be... just make sure you have all the dependencies updated for 1.9.1... if you then have issues with something, please post back, with details, logs, and steps on how to reproduce any issues. Needless to say, back up your save(s) before installing/running on 1.9.1

oh, and as far as RPM, there is an "adopted" version by JohnnyOThan for 1.8.1+ that you should be using.

Okay. I just got scared that the game will crash

Link to comment
Share on other sites

  • 2 months later...
On 6/17/2020 at 12:30 PM, baihaqima said:

hello do i need ksp ver 1.4.5 to use this? i used ksp 1.8.1 and it said its unsupported. any response would be appriciated thanks.

 

You will be able to use it on 1.8.1, it may say its unsupported but it still works suprisingly. 

Link to comment
Share on other sites

1 hour ago, LF_Ion said:

You will be able to use it on 1.8.1, it may say its unsupported but it still works suprisingly. 

It works in 1.9.1.

Link to comment
Share on other sites

  • 2 years later...
  • 2 months later...

[EXC 21:59:54.878] NullReferenceException: Object reference not set to an instance of an object
    BDArmory.Modules.ModuleWeapon.GetInfo () (at <dadbcdf9b9ad46c1a220dccbea06d76f>:0)
    PartLoader.CompilePartInfo (AvailablePart newPartInfo, Part part) (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
    PartLoader+<CompileParts>d__56.MoveNext () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
    UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <12e76cd50cc64cf19e759e981cb725af>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
 

I am gettting this error, stopping me from getting into the game. Has anyone ever encountered this?

Link to comment
Share on other sites

@coyotepunk05 I imagine AoA is *supposed* to be used with/supported by BD Armory, but that mod isnt even mentioned in AoA's OP... vOv

But that error you posted, seems to be thrown by one of the BD Armory plugins. And since AoA thread is kinda old & slow here, I suggest going over to the BD Armory thread, to see if they can help there.

But first, double chec you have the correct & most up-to-date version(s) of any BD Armory mods you have... I know several of the BDA mods have changed hands a few times since AoA was made/last updated.... vOv

Also, I suggest reading the OP on this thread, and learn how to post your logs correctly. Providing logs right off the bat, with a support request, will moar likely get you an answer, and quicker, too ;)
 


Then post here: (I believe this is the current, main) BDA thread:

 

Edited by Stone Blue
Link to comment
Share on other sites

16 hours ago, Stone Blue said:

@coyotepunk05 I imagine AoA is *supposed* to be used with/supported by BD Armory, but that mod isnt even mentioned in AoA's OP... vOv

As long as BDA+ supports legacy weapon and radar configs from BDAc it should be compatible. I've been using AoAtech since 1.3 and didn't run into problems with BDA/DBAc/BDA+

 

On 1/2/2023 at 9:03 AM, coyotepunk05 said:

I am gettting this error, stopping me from getting into the game. Has anyone ever encountered this?

Check your BDArmory install. Since AoA tech is loaded first (due to it's folder name starting with "A") it may just be the first mod that triggered BDA problems. You might have a gamedata folder inside gamedata folder or have a messed up install with a mix of different versions of BDAc/BDA+.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...