Jump to content

[1.5.1] AoA Technologies - Maintenance & Development thread


Wolfair corp.
 Share

Recommended Posts

  • 3 weeks later...
4 hours ago, DiscoveryPlanet said:

sir will you updated this mod to ksp 1.4.x ???

Is it not working on 1.4? They just added languages support and minor bigfixing, I think, nothing that would corrupt the mod.

Please tell me if it's not working in 1.4.x.

Link to comment
Share on other sites

On 5/4/2018 at 3:23 PM, Wolfair corp. said:

Is it not working on 1.4? They just added languages support and minor bigfixing, I think, nothing that would corrupt the mod.

Please tell me if it's not working in 1.4.x.

I've done a test and everything work...I discovered this mod this morning, it's a wonderful mod! I love the rafale cockpit!

Edited by Coca992
Link to comment
Share on other sites

  • 1 month later...

Awesome looking cockpits. And Rafale is the best, perfectly fits the MK2 cross section and the wing sections (or canards) fit to both sides of this cockpit just as planned. (unfortunately it's the worst for flying in IVA but I hope it's internals are under construction).

Got the JSIVariableAnimator error when using KU34 and Cobra cockpits, it affects the HUD pitch ladder and velocity vector. After adding a RasterPropMonitorComputer module in config files the error has gone and the HUD seems to work. Also the Rafale has science experiment and science container modules missing so it can't do the crew report.

Did anyone try to board the Rafale cockpit in space? My kerbals wasted all the EVA propellant but did not make it, so I had to dock another vessel to my spaceplane to use it as an airlock. I don't know if it's a bug or I'm just not good at getting kerbals into cockpit without integrated ladder.

NyXZ1NALE3Y.jpg

Spoiler

Fixing raptor HUD:

If you have a JSIVariableAnimator error just add this to cockpit config file in the modules section
MODULE
{
    name = RasterPropMonitorComputer
}

If you had a long flight around Kerbin in rafale cockpit to make a crew report and have just noticed that it has no such option, ask Bill to add this to your onboard computer's cfg. And don't forget to land before he does this, it's not a good idea to reboot your flight management system in the air. 

    MODULE
    {
        name = ModuleScienceExperiment
        experimentID = crewReport
        experimentActionName = #autoLOC_502009 //#autoLOC_502009 = Crew Report
        resetActionName = #autoLOC_502010 //#autoLOC_502010 = Discard Crew Report
        reviewActionName = #autoLOC_502200 //#autoLOC_502200 = Review Report
        useStaging = False
        useActionGroups = True
        hideUIwhenUnavailable = True
        rerunnable = True
        xmitDataScalar = 1.0
        usageReqMaskInternal = 5
        usageReqMaskExternal = -1
    }


    MODULE
    {
        name = ModuleScienceContainer
        reviewActionName = Review Stored Data
        storeActionName = Store Experiments
        evaOnlyStorage = True
        storageRange = 3.0
    }

 

 

 

Edited by Manul
added screenshot
Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
On 9/29/2018 at 9:09 AM, GabeTeuton said:

I seem to have issues with many cockpits not having a crew hatch, did i miss installed something or is it inteded?, i love the parts but if i can't exit to repack the chutes i can't use them u.u

 

Hatches are part of the model, so it's not your installation.

Of course it isn't intended. Wich cockpits don't have one?

Sorry for late response btw

Edited by Wolfair corp.
Link to comment
Share on other sites

4 minutes ago, Wolfair corp. said:

 

Hatches are part of the model, so it's not your installation.

Of course it isn't intended. Wich cockpits don't have one?

Sorry for late response btw

Please don't be sorry, what else can I ask for other than a reply whenever you happen to be able to reply, it's not that you took a year and a half haha, thanks anyway :)!!!!

 

The cockpits that are missing a hatch are:

Cobra MkII Cockpit
valentina Can't Exit
89bbb4df98.jpg


Combat Dragon II
Kerzer Can't Exit
a3f6dc52a9.jpg


Super Tucano
Wehrgar Can't Exit
eb37631731.jpg

 

 

Also the following can't make a Crew Report:
KU-57 Cockpit
459f4ddff2.jpg

Rafale
4241476608.jpg

Mk1 Cockpit
no photo as i fixed this one by going into the files

Link to comment
Share on other sites

@GabeTeuton

Thanks, that helped a lot.

I added crew experiments to the said cockpits, and added RasterPropMonitor computers where they were missing along the way, so there should not be any Initialization errors anymore.

You can grab it on GitHub if you want.

However, the hatch stuff is unity configuration, so I need Martinez to share me the unity project. I already messaged him about it.

Link to comment
Share on other sites

6 minutes ago, Wolfair corp. said:

@GabeTeuton

Thanks, that helped a lot.

I added crew experiments to the said cockpits, and added RasterPropMonitor computers where they were missing along the way, so there should not be any Initialization errors anymore.

You can grab it on GitHub if you want.

However, the hatch stuff is unity configuration, so I need Martinez to share me the unity project. I already messaged him about it.

Much appreciated i wasn't aware of the RPM error, i mean the first time it showed was when i was taking the puushes for you haha, so i thought it could've been because of something else!! Good to know i also helped you with that!!!

On second thoughts I may have skipped that error due to not (as of yet) used all the cockpits with the same "intensity".

 

Thanks anyway!!!

Link to comment
Share on other sites

5 hours ago, BGM Marcsen said:

Somehow cant find it on CKAN.

It's there.  AoA Technologies v1.4 for KSP 1.3.1.  You need to have "Settings > Compatible KSP Versions" set to include KSP 1.3.1, say by checking the "1.3" box.

Link to comment
Share on other sites

  • 4 weeks later...
1 hour ago, Catatau_27 said:

This mod don't work on 1.5.1, and broken 50% of my crafts on SPH DD:

Maybe one update solves. =)

Maybe a screenshot of the broken parts? (when you try to open a spacecraft)

To be fair I wan't even aware that there was an update, but I checked the changelog and nothing should be broken.

Edited by Wolfair corp.
Link to comment
Share on other sites

23 minutes ago, Wolfair corp. said:

Maybe a screenshot of the broken parts? (when you try to open a spacecraft)

To be fair I wan't even aware that there was an update, but I checked the changelog and nothing should be broken.

Ok i will take a Screenshot, i have one suggestion: Maybe the EVA of the Raffale cockpit can be usefull like a ASET standard or something like that on the future.

Link to comment
Share on other sites

  • 2 months later...
54 minutes ago, Wolfair corp. said:

Already a new update?

Well, I'm pretty busy right now. If you get to try AoA in 1.6, could you please tell me about any bug you encounter? Thanks!

Sure. And sorry about the inquiry....i was just notified that even asking is against the rules now.

I only said something because at load, KSP says it is unsupported by 1.6. I'll let you know if anything is legitimately broken.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...