linuxgurugamer

[1.4.1] Take Command Continued- Launch Kerbals in External Command Seats

Recommended Posts

80 for me...+ Factorio addiction i am starting slowly but surely to lose my mind, oh well... :D

Share this post


Link to post
Share on other sites
7 minutes ago, TheKurgan said:

WHAT!!?? ... how?

Ckan makes it easy

Share this post


Link to post
Share on other sites
50 minutes ago, linuxgurugamer said:

Ok, I have it, but I'm not going to do another release right now, working on something else.  Besides, I think you should take that config out of the file so there won't be conflicts

For now, just put the following in a file:


@PART[O_seat]:HAS[@MODULE[KerbalSeat]]:FOR[TakeCommand]
{
	CrewCapacity = 1
	MODULE
	{
		name = TakeCommand
		minimumCrew = 1
	}
}

and when i do the next release, delete it.

Thanks, looks good.  will be in the next release, in a day or so

Great.no rush, i just release an update too.

Share this post


Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

Ckan makes it easy

I use JSGME and running between 100 and 200 mods (still checking a lot out).

Share this post


Link to post
Share on other sites

@linuxgurugamer - just a heads up that Take Command and Vessel Movers' Spawn Vessel function aren't playing nicely with each other

REPLICATION STEPS

Launch vessel with command seat and Kerbal appears in seat ... Spawn vessel with command seat using VM and no kerbal is in the seat ... place spawned craft on ground (still no kerbal) ... press escape and exit to space center ... click on craft missing kerbal and choose to fly it ... kerbal is in seat now

If you instead select the original launched craft and choose to fly it, the craft that was spawned with vessel mover will still not have a kerbal in the command chair ... you must choose to fly the vessel missing the kerbal in order for the kerbal to be placed in the command chair

It appears that there is a kerbal assigned to a spawned vessels' command chair, however the KSP craft loading system is currently the only way to get the kerbal to appear in the chair (VM uses a different means to load craft than KSP does) ... switching to a vessel in scene doesn't materialize a kerbal either

Amazing job by the way ... Take Command is an invaluable mod

Edited by DoctorDavinci

Share this post


Link to post
Share on other sites
3 hours ago, DoctorDavinci said:

@linuxgurugamer - just a heads up that Take Command and Vessel Movers' Spawn Vessel function aren't playing nicely with each other

REPLICATION STEPS

Launch vessel with command seat and Kerbal appears in seat ... Spawn vessel with command seat using VM and no kerbal is in the seat ... place spawned craft on ground (still no kerbal) ... press escape and exit to space center ... click on craft missing kerbal and choose to fly it ... kerbal is in seat now

If you instead select the original launched craft and choose to fly it, the craft that was spawned with vessel mover will still not have a kerbal in the command chair ... you must choose to fly the vessel missing the kerbal in order for the kerbal to be placed in the command chair

It appears that there is a kerbal assigned to a spawned vessels' command chair, however the KSP craft loading system is currently the only way to get the kerbal to appear in the chair (VM uses a different means to load craft than KSP does) ... switching to a vessel in scene doesn't materialize a kerbal either

Amazing job by the way ... Take Command is an invaluable mod

That is really strange, especially since the spawned kerbal in the VM vessel wasn't even selected.

actually, if you place a probe, then use VM to spawn a vessel with a command seat, place spawned craft on ground (still no kerbal) ... press escape and exit to space center ... click on craft missing kerbal and choose to fly it ... kerbal is in seat now

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
3 hours ago, DoctorDavinci said:

 

@linuxgurugamer - just a heads up that Take Command and Vessel Movers' Spawn Vessel function aren't playing nicely with each other

REPLICATION STEPS

Launch vessel with command seat and Kerbal appears in seat ... Spawn vessel with command seat using VM and no kerbal is in the seat ... place spawned craft on ground (still no kerbal) ... press escape and exit to space center ... click on craft missing kerbal and choose to fly it ... kerbal is in seat now

If you instead select the original launched craft and choose to fly it, the craft that was spawned with vessel mover will still not have a kerbal in the command chair ... you must choose to fly the vessel missing the kerbal in order for the kerbal to be placed in the command chair

 

I'm going to call this a VM bug, since spawning a craft should not have any crew there already.

Will post in the VM thread

Share this post


Link to post
Share on other sites
13 hours ago, TheKurgan said:

67... you guys are feeding the addiction :)

Only 67? Surely you're forgetting something...

Share this post


Link to post
Share on other sites
Just now, linuxgurugamer said:

I'm going to call this a VM bug, since spawning a craft should not have any crew there already.

Will post in the VM thread

The way it used to work in 1.0.5 was when you spawned a craft with a command seat that Take Command would spawn a kerbal in the seat ... This was relied upon for the BAD T2 competition as @tetryds and I would have had a difficult time loading each kerbal into the planes for each of the battles

I have brought it up with the rest of the BDAc team to see if we can find a fix

 

Share this post


Link to post
Share on other sites

1.4.5 released:

  • - Added patch for Omicron
  • - Added patch form Kerbonov-KN2

Share this post


Link to post
Share on other sites

@linuxgurugamer You Sir, are an unsung hero of the KSP community! How many mods now bare your signature in one way or another? I just wanted to show my appreciation and say thank you for all you have contributed! o7

Share this post


Link to post
Share on other sites
39 minutes ago, RocketPCGaming said:

@linuxgurugamer You Sir, are an unsung hero of the KSP community! How many mods now bare your signature in one way or another? I just wanted to show my appreciation and say thank you for all you have contributed! o7

Officially, 44, plus 4 contract packs, plus assistance provided to 10 other mods.

You can see the complete list here: https://goo.gl/KxlgIC

Share this post


Link to post
Share on other sites
On 12/26/2016 at 0:09 PM, Beetlecat said:

Only 67? Surely you're forgetting something...

Up to 96... new CPU and ram... addons increasing exponentially... a high percentage of these are from @linuxgurugamer

Share this post


Link to post
Share on other sites

I believe the kerbal is internal, therefore not visible.

I'll have to see if I can disable internal transfers like that.

To get the kerbal back, dock with it and do another transfer back

What other mods do you have installed?  Specifically for the internal crew transfers

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

The next release of Take Command will be disabling the internal transfers to external seats.

It will also have patches for the EVA Parachutes for all known external command seats.

 

Share this post


Link to post
Share on other sites

New release: 1.4.6

  • - Updated all patches to add EVA Parachute if that mod is installed
  • - removed BetterCrewAssignment (can't do internal transfer to external seat)
  • - Moved cfg for stock external command seat to ModuleManager directory
  • - Fixed code so that KSP won't try to transfer a kerbal into/outof an external seat
  • - Added AssemblyVersion code

Share this post


Link to post
Share on other sites

Patch for Akita rover seat from USI Konstruction/MKS:

Spoiler

@PART[Akita_Seat]:HAS[@MODULE[KerbalSeat]]:NEEDS[Konstruction]
{
	CrewCapacity = 1
	MODULE
	{
		name = TakeCommand
		minimumCrew = 1
	}
	
	%MODULE[ModuleKrEjectPilot]:NEEDS[VanguardTechnologies]
	{
		%name = ModuleKrEjectPilot
		%ejectionForce = 100
		%baseCost = 666
		%baseMass = 0.1
		%maxUses = #$../CrewCapacity$
		%deployedDrag = 30
		%minAirPressureToOpen = 0.04
		%semiDeployedFraction = 0.25
		%semiDeployedHeight = 1.25
		%deployTime = 0.33
		%Soundfile = VanguardTechnologies/Sounds/ejectionSound
		%Volume = 1
	}
}

 

 

Share this post


Link to post
Share on other sites
35 minutes ago, Aelfhe1m said:

Patch for Akita rover seat from USI Konstruction/MKS:

  Hide contents


@PART[Akita_Seat]:HAS[@MODULE[KerbalSeat]]:NEEDS[Konstruction]
{
	CrewCapacity = 1
	MODULE
	{
		name = TakeCommand
		minimumCrew = 1
	}
	
	%MODULE[ModuleKrEjectPilot]:NEEDS[VanguardTechnologies]
	{
		%name = ModuleKrEjectPilot
		%ejectionForce = 100
		%baseCost = 666
		%baseMass = 0.1
		%maxUses = #$../CrewCapacity$
		%deployedDrag = 30
		%minAirPressureToOpen = 0.04
		%semiDeployedFraction = 0.25
		%semiDeployedHeight = 1.25
		%deployTime = 0.33
		%Soundfile = VanguardTechnologies/Sounds/ejectionSound
		%Volume = 1
	}
}

 

 

Thanks,  I've added it, will get new release out this evening

Share this post


Link to post
Share on other sites

Hey @linuxgurugamer. I still having a minor problem with the status on seats with my Omicron Seats. I put the right code on the parts, like Stock seat is, the Kerbals start right on the seat but even if i leave seat and seat again, the status for that seat still keep on "Not enough Crew 0/1".

Screen Shot 2017-01-14 at 9.57.10 PM

 

Screen Shot 2017-01-14 at 9.57.28 PM

 

Is there a way that you fix that? Thank you any way for your attention!

:D

cheers!

Edited by Climberfx

Share this post


Link to post
Share on other sites
On 1/12/2017 at 11:49 PM, fourfa said:

Bundled Module Manager is out of date (2.7.4)

So get the correct one.  I don't rebuild and re-release just because MM is updated.

20 minutes ago, Climberfx said:

Hey @linuxgurugamer. I still having a minor problem with the status on seats with my Omicron Seats. I put the right code on the parts, like Stock seat is, the Kerbals start right on the seat but even if i leave seat and seat again, the status for that seat still keep on "Not enough Crew 0/1".

Screen Shot 2017-01-14 at 9.57.10 PM

 

Screen Shot 2017-01-14 at 9.57.28 PM

 

Is there a way that you fix that? Thank you any way for your attention!

:D

cheers!

Send me a link for the version you are testing, I'll take a look

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.