linuxgurugamer

[1.4.1] Take Command Continued- Launch Kerbals in External Command Seats

Recommended Posts

Just now, Citizen247 said:

No doubt, but the real problem is that the Kerbal ends up weighing several tons ;).

???

Can you elaborate on this?

Share this post


Link to post
Share on other sites
Just now, GDJ said:

???

Can you elaborate on this?

When the Kerbal is ejected, it takes on the weight of the craft it was supposed to be controlling. In the case I noticed this the plane weighed ~1300kg when the kerbal was thrown out of the seat. If you check the weight of just the Kerbal it'll be 1300kg. If you then get the kerbal to board the aircraft the total weight of the craft is 2600kg. So 1300 of the original craft, and 1300 again because the kerbal has been eating too much special-k 0.o.

Share this post


Link to post
Share on other sites

Weird. Haven't run into this before.

Share this post


Link to post
Share on other sites
9 hours ago, Citizen247 said:

Hi, I've just come across something strange which I think is related to this. Sometimes the Kerbal appears, but isn't in the seat, that's not a great problem except in those times the kerbal takes on the entire vessels weight... What information do you need from me related to this?

Log file, list of mods, save file please.  And a video would help.

Share this post


Link to post
Share on other sites

Hi

I've done some more checking myself, and it looks like the extra weight is actually coming from a ton of resources that are being erroneously added to the Kerbal (a really obvious thing I just didn't think of). Stuff like Water, Food, Hydrazine etc. I'm not sure what's chucking those in, but I'd guess it's Kerbalism? Could be an interaction between this and that? I'll try over in the Kerbalism thread.

Thanks

Edited by Citizen247

Share this post


Link to post
Share on other sites

If I would thank you in every thread of every mod that you adopted and I use - I wouldn't have time to play the actual game with all your little orphants enhancing my experience. You should get a medal for your work!

thanks @linuxgurugamer

Share this post


Link to post
Share on other sites

hi,

here is a small issue with this mod:

there is 2 files considered as empty by the partools script for Unity and it brakes it:

BetterCrewAssignment.cfg

TakeCommand.cfg

it could be great to add the extension .txt to them or change something. :wink:

Share this post


Link to post
Share on other sites
7 minutes ago, Skalou said:

hi,

here is a small issue with this mod:

there is 2 files considered as empty by the partools script for Unity and it brakes it:

BetterCrewAssignment.cfg

TakeCommand.cfg

it could be great to add the extension .txt to them or change something. :wink:

What are you talking about?  If you are forking the mod, just delete them.

The parttools is not run when playing the game

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

What are you talking about?  If you are forking the mod, just delete them.

The parttools is not run when playing the game

on my side i don't care, i found the problem, it's for other modders...

Share this post


Link to post
Share on other sites

Oh, and, BetterCrewAssignment, isn't mine

Share this post


Link to post
Share on other sites

they are here:

GameData\TakeCommand\TakeCommand.cfg

GameData\TakeCommand\ModuleManager\BetterCrewAssignment.cfg

and i don't fork the mod, i just have it in my gamedata when using Unity for modeling.

Edited by Skalou

Share this post


Link to post
Share on other sites

Really appreciate using Take Command to give full function to the External Command Seat.

I have a suggestion for a MM script addition to add mod AutoAction function to External Command Seat-like parts.  It's tested as working as intended.

@PART[*]:HAS[@MODULE[KerbalSeat]]:FOR[TakeCommand]:NEEDS[AutoAction]
{
	MODULE
	{
		name = ModuleAutoAction
	}
}

 

Share this post


Link to post
Share on other sites

I really like this Mod, but I often have the issue that KER doesn't properly calculate TWR and Delta-v because it assumes the mass of empty command seats, and the kerbals increase that. Especially annoying on tiny airplanes because the center of mass in stock also uses the empty seat mass. (I lost a duna lander with Jeb and Bob because of this.) Would it be possible to have a "manned" option for the seat in the VAB which changes the mass to that of a seat with kerbal (just in the VAB, not in actual flight) so that KER and the center of mass use the correct mass?

Share this post


Link to post
Share on other sites
17 hours ago, 15Redstones said:

I really like this Mod, but I often have the issue that KER doesn't properly calculate TWR and Delta-v because it assumes the mass of empty command seats, and the kerbals increase that. Especially annoying on tiny airplanes because the center of mass in stock also uses the empty seat mass. (I lost a duna lander with Jeb and Bob because of this.) Would it be possible to have a "manned" option for the seat in the VAB which changes the mass to that of a seat with kerbal (just in the VAB, not in actual flight) so that KER and the center of mass use the correct mass?

you can check my WIP mod for this: :cool:

 

Share this post


Link to post
Share on other sites
20 hours ago, 15Redstones said:

I really like this Mod, but I often have the issue that KER doesn't properly calculate TWR and Delta-v because it assumes the mass of empty command seats, and the kerbals increase that. Especially annoying on tiny airplanes because the center of mass in stock also uses the empty seat mass. (I lost a duna lander with Jeb and Bob because of this.) Would it be possible to have a "manned" option for the seat in the VAB which changes the mass to that of a seat with kerbal (just in the VAB, not in actual flight) so that KER and the center of mass use the correct mass?

You already use KER, so you'll probably like the more accurate mod version by Skalou (see above), but for those that want something in pure stock, try my stock parts approximation of a kerbal dummy:

Spoiler

nAf5jF6.png

qgX9Wdk.png

IOcsc0I.png

 

 

 

Craft file for the dummy: https://kerbalx.com/swjr-swis/Kerbal-Stunt-Dummy-2

 

Share this post


Link to post
Share on other sites

Hey, I'm having a strange issue:

I can place kerbals in the seat in the editor but they don't appear in game. It's as though they're inside the seat like a regular command pod, I can transfer them to other seats but they still remain 'inside'. They also don't count as a source of control for the vessel. Further testing showed that a kerbal spawned in a seat can be transferred to a pod and walk to the seat and get in like normal, even if there is a kerbal 'inside' the seat. Not sure how to insert images but it pretty much just confirms what I wrote out.

edit: nothing obstructing the seats, simply a structural piece with a command pod and an external seat with lots of space around each part.


Cheers.

Edited by Ricksdetrix
Extra info

Share this post


Link to post
Share on other sites
7 hours ago, Ricksdetrix said:

Hey, I'm having a strange issue:

I can place kerbals in the seat in the editor but they don't appear in game. It's as though they're inside the seat like a regular command pod, I can transfer them to other seats but they still remain 'inside'. They also don't count as a source of control for the vessel. Further testing showed that a kerbal spawned in a seat can be transferred to a pod and walk to the seat and get in like normal, even if there is a kerbal 'inside' the seat.Hey, I'm having a strange issue:

I can place kerbals in the seat in the editor but they don't appear in game. It's as though they're inside the seat like a regular command pod, I can transfer them to other seats but they still remain 'inside'. They also don't count as a source of control for the vessel. Further testing showed that a kerbal spawned in a seat can be transferred to a pod and walk to the seat and get in like normal, even if there is a kerbal 'inside' the seat. Not sure how to insert images but it pretty much just confirms what I wrote out.

edit: nothing obstructing the seats, simply a structural piece with a command pod and an external seat with lots of space around each part.


Cheers.

Log file, this matches no previously reported bug.

Share this post


Link to post
Share on other sites
8 hours ago, Ricksdetrix said:

I can place kerbals in the seat in the editor but they don't appear in game. It's as though they're inside the seat like a regular command pod, I can transfer them to other seats but they still remain 'inside'. They also don't count as a source of control for the vessel. Further testing showed that a kerbal spawned in a seat can be transferred to a pod and walk to the seat and get in like normal, even if there is a kerbal 'inside' the seat. Not sure how to insert images but it pretty much just confirms what I wrote out.

edit: nothing obstructing the seats, simply a structural piece with a command pod and an external seat with lots of space around each part.


Cheers.

Hi

I have seen this before ... IIRC it was during the transition between KSP v1.0.5 and v1.1 where Take Command would do this when using the 1.0.5 compatible version with KSP v1.1 (could have been the 1.1.3 to 1.2 transition also ... don't really remember which)

I suspect that this is what is happening in your case however, as LGG said above, you need to post your logs in order for anyone to be of any real help to solving your problem

You can find out how to help us help you by reading the following thread post :)

 

Share this post


Link to post
Share on other sites

Hey I read the support thread but I have no idea how to upload a zip/config file, I tried copy pasting it into the message board but it just crashes my browser it's so large, what am I supposed to do?

Share this post


Link to post
Share on other sites
3 hours ago, Ricksdetrix said:

Hey I read the support thread but I have no idea how to upload a zip/config file, I tried copy pasting it into the message board but it just crashes my browser it's so large, what am I supposed to do?

Dropbox, Google Drive, etc.  Put the file there, then right-click and get the link, paste that link here.

 

Share this post


Link to post
Share on other sites

Thanks for the patience guys. Here's the log:

https://drive.google.com/open?id=0B5Ew9eLhmhcodDBWLUxWZ1ZDajg

 

I did notice these crop up in the config file, if it saves you guys any searching. Going to try reinstalling the mod again now

Cannot create config from file 'F:\Steam\steamapps\common\Kerbal Space Program\GameData\TakeCommand\ModuleManager\BetterCrewAssignment.cfg'.

Config(@PART[*]:HAS[@MODULE[KerbalSeat]]:FOR[TakeCommand]:NEEDS[AutoAction]) TakeCommand/TakeCommand/@PART[*]:HAS[@MODULE[KerbalSeat]]:FOR[TakeCommand]:NEEDS[AutoAction]

[ModuleManager] Deleting Node in file TakeCommand/TakeCommand subnode: @PART[*]:HAS[@MODULE[KerbalSeat]]:FOR[TakeCommand]:NEEDS[AutoAction] as it can't satisfy its NEEDS

Cannot find a PartModule of typename 'TakeCommand'

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.