linuxgurugamer

[1.4.1] Take Command Continued- Launch Kerbals in External Command Seats

Recommended Posts

54 minutes ago, linuxgurugamer said:

Flag?  Meaning, to plant a flag?

Yes. The command seat allows one flag planting, whereas a pod boarding resets this feature. I looked through the pod cfg and nothibg jumped out as resetting the plant flag. Looking to make a small hopper to tag anomolies.

Share this post


Link to post
Share on other sites
45 minutes ago, Red Shirt said:

Yes. The command seat allows one flag planting, whereas a pod boarding resets this feature. I looked through the pod cfg and nothibg jumped out as resetting the plant flag. Looking to make a small hopper to tag anomolies.

I'll take a look

Share this post


Link to post
Share on other sites

Hi, this is a dumb question, but how do I install the mod? I just downloaded it from spaceport and merged the GameData folder with my folder, and it did not work at all.

Share this post


Link to post
Share on other sites
1 hour ago, xlm said:

Hi, this is a dumb question, but how do I install the mod? I just downloaded it from spaceport and merged the GameData folder with my folder, and it did not work at all.

You need to have ModuleManager installed as well.

Share this post


Link to post
Share on other sites

New release, 1.4.11.1:

  • Added line for the Stockalike Mk1 Open Cockpit in the patch to add a vesselType line

This was preventing experiments from being run when launching in the NSED Open Cockpit when no other command module was on the vessel.

Share this post


Link to post
Share on other sites
16 minutes ago, inigma said:

@linuxgurugamer for us airplane fanatics, can you add this to your priority update list? :)

 

Share this post


Link to post
Share on other sites
On 11/27/2017 at 7:45 AM, swjr-swis said:

I don't claim to understand why they made that change to the game, especially since it used to work fine before - I built and used a heap of craft with closed fairings over the years. But Kerbals (and parts) exploding inside a closed faring is a very new thing. That's why this particular interaction with Take Command has only become evident now - the (game) problem simply did not exist before.

I have this problem on 1.2.2, if I have kerbals on external seats inside a fairing, as soon as the vessel spawns, they will spaghetify and eventually explode :-(.
If there's no way to fix it I guess I'll have to give up the idea of sending tourists into orbit in an X-37B... 

Share this post


Link to post
Share on other sites
2 hours ago, mbound said:

I have this problem on 1.2.2, if I have kerbals on external seats inside a fairing, as soon as the vessel spawns, they will spaghetify and eventually explode :-(.
If there's no way to fix it I guess I'll have to give up the idea of sending tourists into orbit in an X-37B... 

Stock bug, sorry

Share this post


Link to post
Share on other sites

Running into issue where after first spawn successful into command seat (or nearby) from SPH, and recovery, subsequent spawns are not taking place (no kerbal appears). Appears to be consistent.

I tried spawning these guys in this craft: https://www.dropbox.com/s/5wxp6v4sos9fll8/KerbAir.craft?dl=0

jq2ajqO.jpg

but get this:

V6k9jyh.jpg

maybe something wrong here in the log?

A3gCgZI.jpg

on reload of KSP 1.4.1 and try again only one Kerbal loads (Lupont Kerman):

gKjVDS0.jpg

 

Edited by inigma

Share this post


Link to post
Share on other sites

@linuxgurugamer a low-priority feature request?  The new inflatable airlock can make an interesting lightweight capsule:

Is it possible for TakeCommand to add crew while inflated in the VAB/SPH?

Share this post


Link to post
Share on other sites
8 minutes ago, inigma said:

Running into issue where after first spawn successful into command seat (or nearby) from SPH, and recovery, subsequent spawns are not taking place (no kerbal appears). Appears to be consistent.

I tried spawning these guys:

 

but get this:

 

maybe something wrong here in the log?

 

 

I have no idea, that log is unreadable, please post a link to the output_log.txt

is this 1.4.1 or 1.3.1?

A copy of the craft file would also be useful

Share this post


Link to post
Share on other sites

I updated my post above with link to craft file.  Where do I get output_log txt?  Is it in KSP_x64_Data\output_log.txt? If so, no such log exists, even with KSP 1.4.1 debug logging options set to flush output to disk.

Share this post


Link to post
Share on other sites

Ive been able to reproduce  it, but for future reference, read the post in my sig.

FYI, it happens  with a single  seat

Share this post


Link to post
Share on other sites
10 minutes ago, linuxgurugamer said:

Ive been able to reproduce  it, but for future reference, read the post in my sig.

FYI, it happens  with a single  seat

Ya I was noticing it happening with a single seat as well.

Thanks for the info. I also updated 

 

Share this post


Link to post
Share on other sites
1 hour ago, Oracle255 said:

Does it works for ksp 1.3.1 ?

Yes, there is a problem with 1.4.1, something changed inside KSP and I haven't yet figured it out

Share this post


Link to post
Share on other sites

I am, and this will have to wait until I get some more time .

Something changed in the game, and while it's possible to spawn a single kerbel the kerbel is not in the seat when he gets out there.

Share this post


Link to post
Share on other sites
On 3/17/2018 at 10:51 PM, linuxgurugamer said:

Stock bug, sorry

Yeah sure, and it's not a big deal, managed to get around it by just using non-stock fairings :-).
Thanks for the amazing work in maintaining this and many other mods!!  

Share this post


Link to post
Share on other sites
On 3/27/2018 at 12:04 AM, The Dunatian said:

I'm not sure if @linuxgurugamer realizes this, but this mod seems to be malfunctioning completely broken in 1.4.1. I couldn't spawn kerbals in chairs at all.

Read a few posts above yours - LGG knows.

Share this post


Link to post
Share on other sites
2 hours ago, i like pizza said:

This doesn't work for 1.4.3.

Its amazing the total lack of reading that goes on.  In the posts right above yours, it specifically says there are problems.

I dont consider this a critical mod, so the bugs will wait until I finish with some other work

Share this post


Link to post
Share on other sites

Oddly enough, it has been sporadically *working* for me in 1.4.3, along with Kerbal Construction Time, which it wasn't supposed to be compatible with. ;) Some other combination of updates or shenanigans has caused kerbals to spawn missing (but do get recovered).

I'll make a point of grabbing a log right after launching a craft with control seat only and linking it if it's helpful.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.