Esquire42

[1.2.2] Active Ablation v1.0.2 - Electric Powered Lifting Surface Ablation

Recommended Posts

Just now, Esquire42 said:

From the testing @captinjoehenry has done, it looks like the second point isn't the case. But thanks for the heads up about airflow occlusion. As for AHM, I was mainly thinking about adding it to my modded career. I might take a look at how you handle it and incorporate some parts, with your permission of course.

 

Hm. Well it's not a major modification so that seems acceptable. But I'm still not going to push it out until I get the darn thing to toggle :P 

Honestly I am not sure if my testing shows it is fully working.  What I can confirm though is that with this module internal bits no longer explode from overheating before the plane bits themselves bite the bullet.  What I am unsure of is if an ablator should render the plane bits wholly immune to over heating and exploding because you can get going sufficiently fast that your plane will still over heat and explode with the module.  So if the ablator should render the piece wholly immune it is not fully functional but it is sufficiently functional to protect internal components and components inside of cargo bays.

Share this post


Link to post
Share on other sites

Housekeeping: I realize that CC is best used for media works. When I release heat tile models, those will be licensed under CC. The next release of code, however, will be released under GNU GPLv3. But for now, CC remains in effect.

 

Also, next release will be on GitHub as well!

Edited by Esquire42
whoops

Share this post


Link to post
Share on other sites

Hey guys,

I'm planning on pushing the next release within a week or two. Very emotionally drained and really need some time to read and clean.

 

Share this post


Link to post
Share on other sites
1 hour ago, Esquire42 said:

Hey guys,

I'm planning on pushing the next release within a week or two. Very emotionally drained and really need some time to read and clean.

 

Take all the time you need no need to rush and feel better soon!

Share this post


Link to post
Share on other sites

Necro-thread!

Sorry this has fallen by the wayside. I've been really busy. Planning on getting to work on this again soon, within the next few weeks.

In addition, if anyone would like to join @captinjoehenry and myself with development/QA of this mod please PM me.

Share this post


Link to post
Share on other sites
On 3/30/2017 at 2:11 PM, Esquire42 said:

Necro-thread!

Sorry this has fallen by the wayside. I've been really busy. Planning on getting to work on this again soon, within the next few weeks.

In addition, if anyone would like to join @captinjoehenry and myself with development/QA of this mod please PM me.

Hey there Esquire I'm back playing KSP so if you need any help feel free to let me know!

Share this post


Link to post
Share on other sites

Hey @Esquire42,

Sorry for bothering you,

but I found this in my logs and wanted to know, if this is a known bug or if this can be resolved:

[WRN 01:04:09.534] Config in file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ActiveAblation\ActiveAblation.cfg' contains an unnamed node. Skipping.

 

If you need more Information, so just write me.

Edited by N3N

Share this post


Link to post
Share on other sites
6 hours ago, N3N said:

Hey @Esquire42,

Sorry for bothering you,

but I found this in my logs and wanted to know, if this is a known bug or if this can be resolved:


[WRN 01:04:09.534] Config in file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ActiveAblation\ActiveAblation.cfg' contains an unnamed node. Skipping.

 

If you need more Information, so just write me.

Does the active ablation module work though?  I'm not sure what that bug is but if it is working then it isn't too bad I think.

If it isn't working use this instead: https://www.dropbox.com/s/4a52598x5v1jcu7/ActiveAblation.zip?dl=0  it is just the same file but it is cleaner so it should work.

Edited by captinjoehenry

Share this post


Link to post
Share on other sites
1 hour ago, captinjoehenry said:

Does the active ablation module work though?  I'm not sure what that bug is but if it is working then it isn't too bad I think.

If it isn't working use this instead: https://www.dropbox.com/s/4a52598x5v1jcu7/ActiveAblation.zip?dl=0  it is just the same file but it is cleaner so it should work.

Thank you, I will try it. :wink:

Share this post


Link to post
Share on other sites

@Esquire42 @N3N I just made a big update for this!  I implemented an ISRU module for wings to make Electric charge into ablator fluid which is then used.  The energy cost of the converter needs balancing but as it is it is capable of keeping a space plane cool at over 7,000 m/s.  Control surfaces and airbrakes are not effected right now but that is coming.  So is the energy use balance.  But it is fully functional now!

latest version

Updated!  Now supports Airbrakes and control surfaces.  It should apply to all control surfaces but I am not 100% sure.

Updated Version Now With Control Surfaces and Airbrakes

Be advised you will need to turn on the converter to add ablatorfluid to the parts.  They should all start empty but due to the way the patch works every single part will gain 100 kg of weight when you use the active ablation system.  So if you are using a bunch of small wing parts this will cause issues.  Also I would advise assigning a control group to toggling the converter for producing ablatorfluid.

Also balance is still not really there.  The EC use is very small right now and I will want feed back on how much we should increase EC use to balance it out.

Another thing this active cooling only applies to aero surfaces so if you have landing gear sticking out they will still get over heated and explode.

Edit 2: Files are now on the Github awaiting an official release.

Edited by captinjoehenry

Share this post


Link to post
Share on other sites
16 hours ago, N3N said:

Hey @Esquire42,

Sorry for bothering you,

but I found this in my logs and wanted to know, if this is a known bug or if this can be resolved:


[WRN 01:04:09.534] Config in file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ActiveAblation\ActiveAblation.cfg' contains an unnamed node. Skipping.

 

If you need more Information, so just write me.

Probably something with tech tree stuff. Do you have any tech tree mods installed?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.