Phineas Freak

[1.2.2] Real Solar System Visual Enhancements v1.2.2-RC4 [2017-09-03]

Recommended Posts

Nevermind i finally got them to work, apparently i had KSP Reneissance installed at the same time, although Northern lights do not work for me, it would be a plus if they did but it's ok. Thanks for this amazing mod!
XJyUIU8.jpg

Share this post


Link to post
Share on other sites
On 29.03.2017 at 7:13 AM, QiJian said:

The dark side of the rocket does not have any light, in the daylight on Earth.

Anyone knows how to fix it?

Thanks!

I created Sun.cfg file somewhere in GameData folder with such text:

@Kopernicus:AFTER[RealSolarSystem]
{
    @Body[Sun]
    {
        @ScaledVersion
        {
            Light
            {
                sunlightColor = 1, 1, 1, 1
                sunlightIntensity = 0.95
                sunlightShadowStrength = 0.75
                scaledSunlightColor = 1, 0.98, 0.95, 1
                scaledSunlightIntensity = 0.90
                IVASunColor = 1, 0.98, 0.95, 1
                IVASunIntensity = 0.75
                sunLensFlareColor = 0, 0, 0, 0  //for better scatterer lensflare
                ambientLightColor = 0.06,0.06,0.06,1 //it's shadow color
                sunAU = 13984359719
                luminosity = 1360
            }
            Material
            {
                rimColor = 1,1,1,1
                emitColor0 = 1,0.97,0.83,1
                emitColor1 = 1,0.887,0.72,1
                sunspotColor = 0.56,0.55,0.53,1
            }
        }
    }    
}

 

About this mod:

Clouds just exterminate fps for big craft (>1000 parts), scatterer can cause epilepsy from 30-40 km to 140 km.

Share this post


Link to post
Share on other sites

@Phineas FreakWhen I installed this mod all the effects were working except clouds(Except on Titan, For some reason . . .) I cant seem to figure out why, I installed all the mods correctly and there's no BoulderCo in gamedata so I just have no idea how to get them to work, Please help.

 

https://www.dropbox.com/s/6tqwpw3rb1xx1yg/output_log.txt?dl=0

^Log

 

Share this post


Link to post
Share on other sites

Same for me - Installed Scatter, Installed EVE, Installed RSSVE - No clouds.   I've tried both solutions posted in the forum here, neither one work.

Running 64 on Win 10, with 1.2.2 and RC3.  Latest installs on all the dependencies.

 

Share this post


Link to post
Share on other sites

I have noticed some reflections from the Moon and Earth's deserts are really birght, and whites out the surface.

Share this post


Link to post
Share on other sites

 

As suggested in the support forum, I'm asking the same question here.

I just installed RSS and the visual enhancements per the instructions in the realism overhaul (updated thread) here:

And here:

Works like a champ except that I have no clouds at all on Earth.   Not sure why that is.


The same happens on either computers I use both with different video cards (one's a laptop with a quadro card, the other's an GTX 780 TI), all with current patches and drivers.  Both my boxes run a core I7, Windows 10 x64 and the 64 bit of Kerbal.  Both have 16gb memory and plenty of SSD disk space.  This happens with the Anniversary Edition of Windows 10 or the Creator Edition just released Tuesday April 11.  On the 780 TI, happens with Nvidia drivers 379.x or 381.x (current release).

Just to be sure I did a clean install of KSP (delete via Steam, wipe folder, re-install, re-apply CKAN).

Using CKAN to manage that and download the dependencies (kopernicus, scaterrer, etc...).  RSSVE is of course a manual install (drop in GameData).

I have no idea where to start fixing the clouds.  I've tried various permutations of texture resolutions and other items, removing other mods, etc... and - same result.

I saw a reference to half clouds with RSSVE, but that's not what's happening to me, I have no clouds at all, in the first menu or in game.  Perfect blue skies.  Looks great but I'd really have to have clouds :)

Any help is appreciated.

Cheers,

Share this post


Link to post
Share on other sites
42 minutes ago, ziporama said:

 

As suggested in the support forum, I'm asking the same question here.

I just installed RSS and the visual enhancements per the instructions in the realism overhaul (updated thread) here:

And here:

Works like a champ except that I have no clouds at all on Earth.   Not sure why that is.


The same happens on either computers I use both with different video cards (one's a laptop with a quadro card, the other's an GTX 780 TI), all with current patches and drivers.  Both my boxes run a core I7, Windows 10 x64 and the 64 bit of Kerbal.  Both have 16gb memory and plenty of SSD disk space.  This happens with the Anniversary Edition of Windows 10 or the Creator Edition just released Tuesday April 11.  On the 780 TI, happens with Nvidia drivers 379.x or 381.x (current release).

Just to be sure I did a clean install of KSP (delete via Steam, wipe folder, re-install, re-apply CKAN).

Using CKAN to manage that and download the dependencies (kopernicus, scaterrer, etc...).  RSSVE is of course a manual install (drop in GameData).

I have no idea where to start fixing the clouds.  I've tried various permutations of texture resolutions and other items, removing other mods, etc... and - same result.

I saw a reference to half clouds with RSSVE, but that's not what's happening to me, I have no clouds at all, in the first menu or in game.  Perfect blue skies.  Looks great but I'd really have to have clouds :)

Any help is appreciated.

Cheers,

Do you have by any chance the latest EVE release from 4 days ago? I am pretty sure RSSVE was built on the one before that, might be a first starter. 

Share this post


Link to post
Share on other sites
15 minutes ago, Theysen said:

Do you have by any chance the latest EVE release from 4 days ago? I am pretty sure RSSVE was built on the one before that, might be a first starter. 

Doesn't matter. Changes in the latest update were minimal. Both versions will work.

Share this post


Link to post
Share on other sites
6 minutes ago, Galileo said:

Doesn't matter. Changes in the latest update were minimal. Both versions will work.

@ziporama Agreed. I just installed RSS and RSSVE from stock with all updated mods, it works out of the box for me. 

 

@Ct9ars Indeed. Very bright especially from orbit. Now as I see everything working without further hassle And without changing any files I try to pick up helping PhineasFreak again, finally have time again. 

Edited by Theysen

Share this post


Link to post
Share on other sites

@theysen I've tried both and not getting anywhere with clouds - most likely user error.

I have a fresh install of KSP, - I've installed the following related mods (CKAN export - open with notepad++ or any text editor).  

https://drive.google.com/open?id=0B9oiN3kHkP-qYjU3b3NfTDF6OFk

Hopefully the error of my ways will be immediately apparent.  I feel like such a noob.

I also have downloaded and setup the RSSVE folder in gamedata of course.

Thanks guys,

 

z

 

Share this post


Link to post
Share on other sites
32 minutes ago, ziporama said:

@theysen I've tried both and not getting anywhere with clouds - most likely user error.

I have a fresh install of KSP, - I've installed the following related mods (CKAN export - open with notepad++ or any text editor).  

https://drive.google.com/open?id=0B9oiN3kHkP-qYjU3b3NfTDF6OFk

Hopefully the error of my ways will be immediately apparent.  I feel like such a noob.

I also have downloaded and setup the RSSVE folder in gamedata of course.

Thanks guys,

 

z

 

I can't look at it right now but hearing ckan Installation I am pretty sure it made you install a config pack for EVE after clicking on download. Make sure you don't have boulder co or SVE in your game data. 

 

"name": "EnvironmentalVisualEnhancements-HR" please delete that. Manually, it can't be deleted via CKAN. Or better: follow the OP instructions for installing RSSVE and do not use CKAN

So for the easiest way:  Deselect Environmental Visual Enhancements in CKAN, grab the manual download of EVE as instructed (Just the mod itself, 1.53MB - https://github.com/WazWaz/EnvironmentalVisualEnhancements/releases/download/EVE-1.2.2-1/EnvironmentalVisualEnhancements-1.2.2.1.zip)

 

The rest is taken care of by RSSVE. 

Edited by Theysen

Share this post


Link to post
Share on other sites
32 minutes ago, Theysen said:

I can't look at it right now but hearing ckan Installation I am pretty sure it made you install a config pack for EVE after clicking on download. Make sure you don't have boulder co or SVE in your game data. 

 

"name": "EnvironmentalVisualEnhancements-HR" please delete that. Manually, it can't be deleted via CKAN. Or better: follow the OP instructions for installing RSSVE and do not use CKAN

So for the easiest way:  Deselect Environmental Visual Enhancements in CKAN, grab the manual download of EVE as instructed (Just the mod itself, 1.53MB - https://github.com/WazWaz/EnvironmentalVisualEnhancements/releases/download/EVE-1.2.2-1/EnvironmentalVisualEnhancements-1.2.2.1.zip)

 

The rest is taken care of by RSSVE. 

I've removed BoulderCo.  Didn't have SVE.  Deleted EVE folder and did a manual install from the zip link.

Sorry to day but no change.

Here's my current GameData in case there are obvious shenanigans there.

 

Spoiler

04/14/2017  05:26 PM    <DIR>          .
04/14/2017  05:26 PM    <DIR>          ..
04/12/2017  10:03 PM    <DIR>          000_FilterExtensions
04/12/2017  10:03 PM    <DIR>          000_FilterExtensions Configs
04/12/2017  10:03 PM    <DIR>          B9PartSwitch
04/12/2017  10:03 PM    <DIR>          CommunityResourcePack
04/12/2017  10:03 PM    <DIR>          CommunityTechTree
04/12/2017  10:03 PM    <DIR>          CryoTanks
04/12/2017  10:03 PM    <DIR>          DeployableEngines
04/14/2017  05:26 PM                 0 dir.txt
04/12/2017  10:03 PM    <DIR>          EasyVesselSwitch
04/12/2017  10:03 PM    <DIR>          EditorExtensionsRedux
04/14/2017  05:21 PM    <DIR>          EnvironmentalVisualEnhancements
04/12/2017  10:03 PM    <DIR>          Firespitter
04/13/2017  05:15 PM    <DIR>          FMRS
04/12/2017  10:03 PM    <DIR>          FShangarExtender
04/12/2017  10:03 PM    <DIR>          HideEmptyTechTreeNodes
04/12/2017  10:03 PM    <DIR>          IndicatorLights
04/12/2017  10:03 PM    <DIR>          InterstellarFuelSwitch
04/12/2017  10:03 PM    <DIR>          JanitorsCloset
04/12/2017  10:03 PM    <DIR>          JSI
04/12/2017  10:03 PM    <DIR>          KAS
04/12/2017  10:03 PM    <DIR>          KerbalAtomics
04/14/2017  05:21 PM    <DIR>          KerbalEngineer
04/12/2017  10:03 PM    <DIR>          KerbalJointReinforcement
04/12/2017  10:03 PM    <DIR>          KerbalReusabilityExpansion
04/12/2017  10:03 PM    <DIR>          KIS
04/12/2017  10:03 PM    <DIR>          Kopernicus
04/12/2017  10:03 PM    <DIR>          KSCSwitcher
04/14/2017  05:21 PM    <DIR>          KSP-AVC
04/12/2017  10:04 PM    <DIR>          KWRocketry
04/12/2017  10:04 PM    <DIR>          MagicSmokeIndustries
04/12/2017  10:04 PM    <DIR>          MechJeb2
04/12/2017  10:04 PM    <DIR>          ModularFlightIntegrator
04/02/2017  09:28 AM            74,752 ModuleManager.2.7.5.dll
04/14/2017  05:17 PM         4,972,804 ModuleManager.ConfigCache
04/14/2017  05:17 PM           309,087 ModuleManager.ConfigSHA
04/14/2017  05:17 PM             8,899 ModuleManager.Physics
04/14/2017  05:17 PM            63,848 ModuleManager.TechTree
04/12/2017  10:04 PM    <DIR>          NavyFish
04/12/2017  10:04 PM    <DIR>          NearFutureConstruction
04/12/2017  10:04 PM    <DIR>          NearFutureElectrical
04/12/2017  10:04 PM    <DIR>          NearFutureProps
04/12/2017  10:04 PM    <DIR>          NearFuturePropulsion
04/12/2017  10:04 PM    <DIR>          NearFutureSolar
04/12/2017  10:04 PM    <DIR>          NearFutureSpacecraft
04/12/2017  10:04 PM    <DIR>          PersistentRotation
04/12/2017  10:04 PM    <DIR>          PlanetShine
04/12/2017  10:04 PM    <DIR>          PreciseManeuver
04/12/2017  10:04 PM    <DIR>          RealSolarSystem
04/12/2017  10:04 PM    <DIR>          RecoveryController
04/12/2017  10:04 PM    <DIR>          RSS-Textures
04/13/2017  05:16 PM    <DIR>          scatterer
04/12/2017  10:04 PM    <DIR>          SpaceY-Expanded
04/12/2017  10:04 PM    <DIR>          SpaceY-Lifters
04/12/2017  10:05 PM    <DIR>          Squad
04/12/2017  10:05 PM    <DIR>          StationPartsExpansion
04/12/2017  10:05 PM    <DIR>          SurfaceLights
04/12/2017  10:05 PM    <DIR>          TextureReplacer
04/12/2017  10:05 PM    <DIR>          TweakScale
04/12/2017  10:05 PM    <DIR>          UniversalStorage
04/12/2017  10:05 PM    <DIR>          WarpPlugin

 

Share this post


Link to post
Share on other sites
13 minutes ago, ziporama said:

I've removed BoulderCo.  Didn't have SVE.  Deleted EVE folder and did a manual install from the zip link.

Sorry to day but no change.

Here's my current GameData in case there are obvious shenanigans there.

 

  Reveal hidden contents

04/14/2017  05:26 PM    <DIR>          .
04/14/2017  05:26 PM    <DIR>          ..
04/12/2017  10:03 PM    <DIR>          000_FilterExtensions
04/12/2017  10:03 PM    <DIR>          000_FilterExtensions Configs
04/12/2017  10:03 PM    <DIR>          B9PartSwitch
04/12/2017  10:03 PM    <DIR>          CommunityResourcePack
04/12/2017  10:03 PM    <DIR>          CommunityTechTree
04/12/2017  10:03 PM    <DIR>          CryoTanks
04/12/2017  10:03 PM    <DIR>          DeployableEngines
04/14/2017  05:26 PM                 0 dir.txt
04/12/2017  10:03 PM    <DIR>          EasyVesselSwitch
04/12/2017  10:03 PM    <DIR>          EditorExtensionsRedux
04/14/2017  05:21 PM    <DIR>          EnvironmentalVisualEnhancements
04/12/2017  10:03 PM    <DIR>          Firespitter
04/13/2017  05:15 PM    <DIR>          FMRS
04/12/2017  10:03 PM    <DIR>          FShangarExtender
04/12/2017  10:03 PM    <DIR>          HideEmptyTechTreeNodes
04/12/2017  10:03 PM    <DIR>          IndicatorLights
04/12/2017  10:03 PM    <DIR>          InterstellarFuelSwitch
04/12/2017  10:03 PM    <DIR>          JanitorsCloset
04/12/2017  10:03 PM    <DIR>          JSI
04/12/2017  10:03 PM    <DIR>          KAS
04/12/2017  10:03 PM    <DIR>          KerbalAtomics
04/14/2017  05:21 PM    <DIR>          KerbalEngineer
04/12/2017  10:03 PM    <DIR>          KerbalJointReinforcement
04/12/2017  10:03 PM    <DIR>          KerbalReusabilityExpansion
04/12/2017  10:03 PM    <DIR>          KIS
04/12/2017  10:03 PM    <DIR>          Kopernicus
04/12/2017  10:03 PM    <DIR>          KSCSwitcher
04/14/2017  05:21 PM    <DIR>          KSP-AVC
04/12/2017  10:04 PM    <DIR>          KWRocketry
04/12/2017  10:04 PM    <DIR>          MagicSmokeIndustries
04/12/2017  10:04 PM    <DIR>          MechJeb2
04/12/2017  10:04 PM    <DIR>          ModularFlightIntegrator
04/02/2017  09:28 AM            74,752 ModuleManager.2.7.5.dll
04/14/2017  05:17 PM         4,972,804 ModuleManager.ConfigCache
04/14/2017  05:17 PM           309,087 ModuleManager.ConfigSHA
04/14/2017  05:17 PM             8,899 ModuleManager.Physics
04/14/2017  05:17 PM            63,848 ModuleManager.TechTree
04/12/2017  10:04 PM    <DIR>          NavyFish
04/12/2017  10:04 PM    <DIR>          NearFutureConstruction
04/12/2017  10:04 PM    <DIR>          NearFutureElectrical
04/12/2017  10:04 PM    <DIR>          NearFutureProps
04/12/2017  10:04 PM    <DIR>          NearFuturePropulsion
04/12/2017  10:04 PM    <DIR>          NearFutureSolar
04/12/2017  10:04 PM    <DIR>          NearFutureSpacecraft
04/12/2017  10:04 PM    <DIR>          PersistentRotation
04/12/2017  10:04 PM    <DIR>          PlanetShine
04/12/2017  10:04 PM    <DIR>          PreciseManeuver
04/12/2017  10:04 PM    <DIR>          RealSolarSystem
04/12/2017  10:04 PM    <DIR>          RecoveryController
04/12/2017  10:04 PM    <DIR>          RSS-Textures
04/13/2017  05:16 PM    <DIR>          scatterer
04/12/2017  10:04 PM    <DIR>          SpaceY-Expanded
04/12/2017  10:04 PM    <DIR>          SpaceY-Lifters
04/12/2017  10:05 PM    <DIR>          Squad
04/12/2017  10:05 PM    <DIR>          StationPartsExpansion
04/12/2017  10:05 PM    <DIR>          SurfaceLights
04/12/2017  10:05 PM    <DIR>          TextureReplacer
04/12/2017  10:05 PM    <DIR>          TweakScale
04/12/2017  10:05 PM    <DIR>          UniversalStorage
04/12/2017  10:05 PM    <DIR>          WarpPlugin

 

There is no RSSVE folder to begin with. 

 

Download the latest stable version of Real Solar System Visual Enhancements and uncompress it's contents. Then, copy or move the "RSSVE" folder inside your GameData folder. The final installation tree should look like this:

  • GameData/
    • ModuleManager.X.Y.Z.dll
    • EnvironmentalVisualEnhancements
    • RSSVE
    • scatterer

Share this post


Link to post
Share on other sites

Well duh me. thanks.

Ok, that's fixed.  So the good news is I have clouds now.  The bad news is I have some sort of blue shading on top of the planet - I can only see the clouds at certain camera angles.
Something else is afoot.  Working on that next.

Here's what it looks like.  If I zoom the camera out and change the view angle, in some cases I can get to clip the blue texture and I see clouds/earth below it.  If I zoom completely out, I get a box around my ship and the rest of the planet shows correctly. 

Screenshots below.

 

 

Edited by ziporama

Share this post


Link to post
Share on other sites

I got the same problem as @ziporama has, no clouds. I've already read the pages on this thread. I've also read those on the EVE, scatter and RSS threads but can't find specifics.
I've done exactly as is told on each addon page. I got the basic anycpu-Eve-release environmental visual enhancements mod as is recommended for RSS installs.
I run V1.2.2 of KsP. All mod versions I download were verified to work under ksp 1.2.2
I run windows 10(x64) and Ksp is also run in 64bit.
Videocard drivers are up to date..

I've also added the scatterer config settings in the planetconfig.cfg concerning Earth and Mars.

City lights etc etc work fine. No errors are reported in any logs. In fact everything works "perfect"
Even the terrain scaling looks nice with the cities and city lights. Just no clouds.

My gamedata folder tree:

10xKerbol
DistantObject
EnvironmentalVisualEnhancements
KerbalEngineer
Kopernicus
ModularFlightIntegrator
PlanetShine
RealSolarSystem
RSS-Textures
RSSVE
scatterer
Squad
TextureReplacer
ModuleManager 2.7.5

I've also been mixing with different versions of EVE and scatterer to see if there is a magic combo.
Somebody said it works out of the box by installing all the newest versions of all the required mods. Some users end up with no clouds, some end up with clouds.
So I was wondering if it is caused by specific videocards or missing operating software. I got  geforce GTX 650 TI.

Edited by Razorforce7

Share this post


Link to post
Share on other sites

@Razorforce7, I might be wrong, but your cause is your 10x kerbal mod. I see you have that mod installed but also Real Solar System.. which is a bit weird.
This mod is for real solar system, which gives the bodies names like earth, moon, mars, jupiter etc. 
RSSVE set it's cloud layers also to those body names, not to kerbal, duna etc.

Share this post


Link to post
Share on other sites

@DrLicor Then I guess I have always misinterpreted the real solar system installation procedure and thought that 10xKerbol was a dependency besides RSS itself. It is only now that I am made aware of it :P

And it did indeed solve the cloud issue :) rep+
Although there is now a city merging itself with the KSC itself instead of a grassland.
Glad the solution was this obvious.

Edit: complete reinstallation solved the issue with the city merging. Now it's time to play :)

Edited by Razorforce7

Share this post


Link to post
Share on other sites

@Theysen

Prior to my vacation, I did a little tweaking of my Scatterer config, which helped make the brightness balance better, so the deserts are less bright without negatively affecting the prettiness of the rest of the planet. IIRC, I adjusted the Gamma or Alpha settings. I'll share when I get a chance, so we can refine things.

I also find the Moon to be a bit bright in certain circumstances, but I had chalked that up to me using EngineLight or AmbientLightAdjust. I might do some fiddling, since I doubt I'll have time to get back into my RP-0 series this week, but I could probably do some testing and fiddling to help make the worlds prettier for all. @KillAshley did some great beautification work on the planets a while back, that might be making the Moon a dash too reflective now? Not sure.

Share this post


Link to post
Share on other sites
On 2017-03-29 at 0:13 AM, QiJian said:

The dark side of the rocket does not have any light, in the daylight on Earth.

http://i.imgur.com/MLcGjS4.png?2

http://i.imgur.com/2k8c3Ns.png

It seems to happen to me if I'm using EVE 1.2.2-1 instead of 1.2-2.

Try using the second to last EVE version (1.2-2, only AnyCPU-EVE-Release is required) and see if it fixes your issues.

E1- Scratch that, it wasn't the source of the problem.

Edited by TwistedMinds

Share this post


Link to post
Share on other sites

Checking back in here for my status update with my no clouds issue.
I reinstalled Windows on a new build and everything is now working correctly with clouds.  I also ran into an issue that KSP crashes with RivaTuner Statistics Server bundled with MSI Afterburner 4.30 - which forced me to run DX11 from the command line which had texture issues for me.  I installed RivaTuner beta 7.x and that solved the issue by allowing me to run KSP without any command line, and when I do that, RSSVE works like a champ.   Cheers and thanks for the assist last week.

Share this post


Link to post
Share on other sites

Does anyone know which settings control the brightness of the ground? It can get a bit extreme in places :) (this is on the moon with the sun overhead)

guJv7En.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.