Jump to content

[1.2.2] Real Solar System Visual Enhancements v1.2.2-RC4 [2017-09-03]


Phineas Freak
 Share

Recommended Posts

@Raptor831 Yes, the "bounding box" view of Scatterer is another known issue. It happens in both stock and RSS but usually only if:

  • You pan the camera around by a large angle
  • You distance the camera from the vessel (does not affect the zoom-in/out function though)

As you correctly guessed, the RSS scale makes them a bit more prevalent. I can replicate both of these very easily and with consistency. Changing the far/near camera values of the PQS/SS does improve the appearance a bit.

Link to comment
Share on other sites

  • 3 weeks later...

@Observe Fair note: make sure to disable the Scatterer ocean shaders to avoid the "floating tile" issue.

On another note: i have been working on the next update for KSP 1.3 but, judging from the fact that the complete RSS/RO/RP-0 suite of mods was just recently updated to support KSP 1.2 and i have made some bug fixes (major and minor), i am thinking about releasing another RC. What do you think?

Link to comment
Share on other sites

18 hours ago, Phineas Freak said:

@Observe Fair note: make sure to disable the Scatterer ocean shaders to avoid the "floating tile" issue.

Sir, how can we disable Scatterer ocean shaders?

Link to comment
Share on other sites

12 minutes ago, oguz said:

Sir, how can we disable Scatterer ocean shaders?

In the main menu, there is a scatterer window, disable ocean shaders and restart the game. 

Or you could download the newly released version for 1.3 that doesn't have his issue.

Edited by Galileo
Link to comment
Share on other sites

1 minute ago, Observe said:

New version of RSSVE for 1.3? Where is it may I ask?

Of scatterer. Not RSSVE. There was a new release for 1.2.2 as well that should fix the floating tiles. I don't know if the cfgs will need to be rewritten.

Edited by Galileo
Link to comment
Share on other sites

The next Release Candidate of RSSVE will be delayed by a bit. @blackrack did an absolutely amazing work with the per planet EVE integration (and the rest of the goodies) and i'd like to have it available for the next version (nothing difficult but i will have to do some tests before making it available in the mainline).

For now, the previous (v0.0300) version of Scatterer will suffice.

Link to comment
Share on other sites

8 hours ago, Phineas Freak said:

For now, the previous (v0.0300) version of Scatterer will suffice.

I find Scatterer v0.0300 unusable. Turning off the ocean shader removes the ocean altogether for me. Turning if back on, results in the floating tiles problem and makes it virtually impossible for atmospheric flying which I do a lot of.

Thank you very much for maintaining this mod! However, I guess I'll have to put the game on the shelf until RSSVE is 1.3 compatible with Scatterer. Thanks.

 

Link to comment
Share on other sites

1 minute ago, Observe said:

I find Scatterer v0.0300 unusable. Turning off the ocean shader removes the ocean altogether for me. Turning if back on, results in the floating tiles problem and makes it virtually impossible for atmospheric flying which I do a lot of.

Thank you very much for maintaining this mod! However, I guess I'll have to put the game on the shelf until RSSVE is 1.3 compatible with Scatterer. Thanks.

 

Technically speaking RSS isn't even compatible to 1.3 :)

Link to comment
Share on other sites

3 minutes ago, Observe said:

Turning off the ocean shader removes the ocean altogether for me.

That is what the toggle does. This is by design.

3 minutes ago, Observe said:

However, I guess I'll have to put the game on the shelf until RSSVE is 1.3 compatible with Scatterer.

As @Theysen mentioned, since one of the major dependencies (RSS) is not yet updated for KSP 1.3 there is absolutely no reason to update it for KSP 1.3. Do not expect any compatibility updates anytime soon. However, bug fixes and general improvements are in the works (as i noted a couple of posts above). Be patient.

Technically, it is possible to get the whole RSS suite up and running for KSP 1.3 but it is not something straigtforward.

Link to comment
Share on other sites

I hesitate to mention this, because it makes no sense (to me). Using KSP 1.3 with Scatterer 0.0300 I had the floating terrain tiles issue unless I turned ocean shader off - resulting in no ocean at all.

I edited RSSVE_Scatterer_Global_Config.cfg and commented out the last line !Scatterer_ocean,*{}:FOR[RSSVE]:NEEDS[Scatterer]. After doing that, I no longer have floating tiles and I have the nice Scatterer ocean!

Game now playable for me. Nice ocean, KSP 1.3, clouds etc. :)

EDIT: Atmosphere effects viewing from space are too bright (compared to using KSP 1.2), but I presume these will be tweaked in due time as mentioned.

Thanks.

Edited by Observe
Link to comment
Share on other sites

Apologies if I have incorrectly followed the instructions, but I am having the same problem KSPlenny:D and RocketBlam reported a while back, shown here: https://ibb.co/hBp6L -- the dark blue sky.  I have RSS, RO, and RP-0 installed, as well as scatterer, EVE, and RSSVE installed, all via CKAN, and I cannot, for the life of me, figure out what is going wrong.  The patch provided on page 12 of this thread did not work for me, though I was confused as to where it should be put, in the GameData folder?  In the RSSVE folder?  

I have tried to manually change the .cfg's from Earth to Kerbin in the files mentioned, to no effect.

Any help would be appreciated, and thank you for the wonderful work you do.

 

Edited by Jack95970002
Link to comment
Share on other sites

@Jack95970002 Without even a basic log file i cannot say what the problem is. One guess, judging from the sky appearance and since you said that you are using CKAN, is that the EVE BoulderCo folder is present in the GameData folder, breaking the RSSVE cloud configs.

BTW, CKAN installations are not currently supported by RSSVE.

Link to comment
Share on other sites

@Phineas Freak absolutely love this mod. Great work in keeping it going. I just have a few questions:

1. Will you be adding hi Res terrain files for earth? The grass around the space centre is pretty much a plain green (maybe my install isn't working right?). If not, how would one go about adding this?

2. The water level seems to be too high...and it is difficult to see shores (especially around cape Canaveral).

3. How can I increase the draw distance of the cloud layers? At a certain altitude (I can't remember which, sorry) I can see the cloud layer being drawn in with just a plain blue beyond it.

Thanks so much, and apologies for any typos etc as I'm typing on the phone!

Link to comment
Share on other sites

11 hours ago, Jack95970002 said:

shown here: https://ibb.co/hBp6L -- the dark blue sky.

 

That is because scatterer 1.3. use Scatterer version 0.0300 (thanks to Observe for sharing link) and problem will be fixed. At least that is how i fixed.

 

edit: Click on "changelog" in the website, then scrool down and download the correct version.

Edited by oguz
Link to comment
Share on other sites

@Toontoonizer thank you, i appreciate your kind words!

  • I had an implementation for detail textures (since the EVE terrain manager does not work anymore) early on but users complained about low frame rates. I recently tried to revive it but i also got the same issue (the lag was unbearable). That's especially annoying considering that i implemented the exact same system to add detail textures to Triton and it worked like a charm.
  • The water level is managed by RSS itself, i do not touch it. A new normal map texture would be required and that is not something that this mod does (maybe in the future). There was such an alternate texture though posted by @Observe in the first couple of pages of this thread.
  • This is (was) a bug with the camera far clip values. I have fixed it for the next Release Candidate.
Link to comment
Share on other sites

3 hours ago, Phineas Freak said:

@Toontoonizer thank you, i appreciate your kind words!

  • I had an implementation for detail textures (since the EVE terrain manager does not work anymore) early on but users complained about low frame rates. I recently tried to revive it but i also got the same issue (the lag was unbearable). That's especially annoying considering that i implemented the exact same system to add detail textures to Triton and it worked like a charm.
  • The water level is managed by RSS itself, i do not touch it. A new normal map texture would be required and that is not something that this mod does (maybe in the future). There was such an alternate texture though posted by @Observe in the first couple of pages of this thread.
  • This is (was) a bug with the camera far clip values. I have fixed it for the next Release Candidate.

Thank you for taking the time to answer my questions! Much appreciated. I will check out the alternate heightmap texture posted by @Observe and await the next release candidate :D

 

Link to comment
Share on other sites

I finally have beeen able to get RSSVE working with KSP 1.3 by replacing "Earth" with "Kerbin" in the RSSVE configs.

Scatterer - latest version
Kopernicus - latest version
RSS - latest version
EVE - latest version

RSSVE - latest version. Modify the following files:
city_lights.cfg, clouds.cfg, Earth_Atmosphere.cfg, Earth_Ocean.cfg, RSSVE_Scatterer_Planetlist_Config.cfg

Now I have Scatterer ocean effects, clouds, no floating tiles, and everything looks good as it did with previous KSP version 1.2.

Thanks.

EDIT: Cancel above. Galileo already solved the problem and has provided a patch file. My goof.

Edited by Observe
Link to comment
Share on other sites

53 minutes ago, Observe said:

I finally have beeen able to get RSSVE working with KSP 1.3 by replacing "Earth" with "Kerbin" in the RSSVE configs.

Scatterer - latest version
Kopernicus - latest version
RSS - latest version
EVE - latest version

RSSVE - latest version. Modify the following files:
city_lights.cfg, clouds.cfg, Earth_Atmosphere.cfg, Earth_Ocean.cfg, RSSVE_Scatterer_Planetlist_Config.cfg

Now I have Scatterer ocean effects, clouds, no floating tiles, and everything looks good as it did with previous KSP version 1.2.

Thanks.

EDIT: While we wait for an official update, here are the changes I made for those interested.

If you read back in the thread 2 pages, I have already posted a fix 

This one has been verified to work with the patch I made for RSS which is on the RSS thread as well.

Edited by Galileo
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...