lextacy

[1.1.3/1.2*] MARS SCIENCE LABORATORY (MSL) PHASE 1

Recommended Posts

The stock game does not have parts to fully enclose a rover and encapsulate a rover during descent. Most people will use the fairings, but the issue is the fairing base will be stuck under your rover and your landings to Mars will not be authentic. There is an outdated mod that did this, but the author has ceased to kerbal. I now will maintain this concept and bring even more parts to the game.

In this release I have issued 3 parts to your VAB. This is phase 1 which means I will roll out more parts during which will follow a time-line of events. I think these 3 parts are a good starting compromise. Here is a breakdown of the 4 phases. HIghlighted in red is what phase we are currently on. 

 

PHASE 1 = Aeroshell, Cruise stage, Heatshield . All basic parts. Player will need to mount their own chutes and radial engines if need be.

PHASE 2 (1970's) = Viking lander is a possibility. Vintige version of the aeroshell design. More texture choices. Radial monoprop engines for the cruise stage. (RO version will use REAL FUELS by NathanKell)

PHASE 3 (Late 90's early 2000's) = MER rovers (Spirit, Opportunity) . EDL system such as the terahedron and airbags.

PHASE 4 (Present) = Curiousity Rover. EDL system such as the skyscrane

 

You get 3 parts in phase 1 of this pack. There are configs included for realscaled parts to use for RO

Aeroshell "backshell" Includes RSC attitude control thrusters and texture changing so you can use the JPL logo. Parachute not included!

screenshot6.png

Heatshield....you know , to protect from atmosphere devils

screenshot5.png

Cruise stage which includes texture changing for JPL logo, solar panels that will recharge your EC, and has built it fuel tank. You provide the engines of choice*.

screenshot8.png

SPECIAL FEATURES!

Aeroshell can thrust jet in flight as seen here:

 

aeroshell.jpg

Mars Science Laboratory only requires:

1. Firespitter and Texture Changer - To change the logos

2. Tweakscale if you want more freedom of payload sizes


 

CHANGELOG:
1.0.4
[12-27-2016] 
*Changed RCS module to the newer stock supported ModuleRSCfx -MeCripp 
*Collision boxes re-done -MeCripp Cruise stage is in a more appropriate menu category and now acts as a pod -MeCripp 
*Heathshield is moved to Thermal category -MeCripp 
*Small rebalancing of some parts

1.0.3
[12-18-16]
-Inline-patched to clean up cloned configs and to recognize when player has RO installed
-Stock now has attitude jets for backshell
-Fixed decoupling when going through strong aero forces, however player must angle craft a bit before ejection to prevent "back splash" of heatshield and/or backshell. The real Curiosity mission had to do this same manuever.
-Fixed stock cruise stage to now have resource monoprop. 

1.0.2

[12-16-2016]
-Fixed issue where VAB crashes when placing cruise stage which was the fault of the RO configs overridding the stock ones when player did not have RF or RO installed.

 

Licence: 

Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International Public License

 

I WANT I WANT !!!  SPACEDOCK LINK 

http://spacedock.info/mod/1119/Mars Science Labratory

*This is my first parts mod, there might be bugs. If you report a bug please be patient as it takes a few days for me to have time to tackle the issue.*

Credits:

MeCripp - Collision work, Fixed Unity pass, Module Improvements

JPL - reasons

NASA  - reasons

Yogui87 -Textures from old mod

 

 

Edited by lextacy
new update

Share this post


Link to post
Share on other sites
4 hours ago, TheRagingIrishman said:

Would it be possible to get a version that works without RF/RO?

The initial install is for stock :)  The RO configs are in another folder, OH CRAP!  I just realized the RO config are overridding the stoick ones in game. The default ends up being RO and crashes peoples stock game. 

5 hours ago, Li0n said:

I have an issue with MSL 1.0.1 on KSP 1.2.2, all stock, as soon as I attach the cruise stage I got a CTD, here is a log + crash dump.

Hope you can fix it.

Ive looked through the log , did not find any entry related to the parts. The parts were made with 1.2 in mind. I had no clue they just rolled out 1.2.2. Could this be an issue with the new version? I guess we will find out if only people with 1.2.2 have this issue. I will play around more this weekned and test it on the new 1.2.2 and see if I can duplicate the issue. Thank you!

The issue is now more likely the fact I messed up the the RO folder and should have renamed them .old 

 

Re-released

 

Share this post


Link to post
Share on other sites

Thanks for the support :) 

Will you update the aeroshell ´s thrusters to work whitout RF ? 

Share this post


Link to post
Share on other sites
14 minutes ago, lextacy said:

The initial install is for stock :)  The RO configs are in another folder, OH CRAP!  I just realized the RO config are overridding the stoick ones in game. The default ends up being RO and crashes peoples stock game. 

Ive looked through the log , did not find any entry related to the parts. The parts were made with 1.2 in mind. I had no clue they just rolled out 1.2.2. Could this be an issue with the new version? I guess we will find out if only people with 1.2.2 have this issue. I will play around more this weekned and test it on the new 1.2.2 and see if I can duplicate the issue. Thank you!

The issue is now more likely the fact I messed up the the RO folder and should have renamed them .old 

 

Re-released

 

 
 
 
 

I would suggest using Module Manager to auto-patch the part cfgs (you can set MM to only patch if RealFuels and/or RealismOverhaul are installed). If you want, I'll write the cfgs myself (I've written LOTS of MM patches). Also it's laboratory, not labratory :wink: 

Edited by TheRagingIrishman

Share this post


Link to post
Share on other sites
On 12/16/2016 at 3:15 PM, TheRagingIrishman said:

I would suggest using Module Manager to auto-patch the part cfgs (you can set MM to only patch if RealFuels and/or RealismOverhaul are installed). If you want, I'll write the cfgs myself (I've written LOTS of MM patches). Also it's laboratory, not labratory :wink: 

hey could you please? im having trouble writing the code. Im always a sucker for spelling :P

Share this post


Link to post
Share on other sites

Hey, I am a big fan of this mod, as I used a similar one a couple years ago and loved it, but it was discontinued in .26. 

I've downloaded 1.0.2 for ksp 1.2.2

I still have the problem where attaching the cruise stage to any part immediately crashes the game. I confirmed that it crashes when attaching to any part in the VAB. I tried deleting the real configs folder in the mod and it results in the same behavior. I looked at the config files and I didn't see any red flags, so I don't know what's going on. I don't have real fuels installed btw. 

Share this post


Link to post
Share on other sites
7 minutes ago, Kevin Vandy said:

Hey, I am a big fan of this mod, as I used a similar one a couple years ago and loved it, but it was discontinued in .26. 

I've downloaded 1.0.2 for ksp 1.2.2

I still have the problem where attaching the cruise stage to any part immediately crashes the game. I confirmed that it crashes when attaching to any part in the VAB. I tried deleting the real configs folder in the mod and it results in the same behavior. I looked at the config files and I didn't see any red flags, so I don't know what's going on. I don't have real fuels installed btw. 

2 important things needed to help you.

1: What other mods do you have installed? (post a screenshot of GameData or a list)

2: Upload KSP.log to dropbox or Google Drive or some sharing site and post the link here. 

Share this post


Link to post
Share on other sites
7 minutes ago, TheRagingIrishman said:

2 important things needed to help you.

1: What other mods do you have installed? (post a screenshot of GameData or a list)

2: Upload KSP.log to dropbox or Google Drive or some sharing site and post the link here. 

https://www.dropbox.com/sh/7tteybedepzhch0/AADyWdt9dOVQJYbSc5Zl4NxVa?dl=0

Unfortunately I have a ton of mods installed in the version I tested. probably pushing 100. I'll test it in a vanilla game here in a couple minutes. Some relevant mods that I can think of that could be interfering are TAC Life support, tweakscale, tweakable everything, or Interstellar Fuel Switch.

Share this post


Link to post
Share on other sites

Alright, just tested in Stock Vanilla with the exception of Model Manager 2.7.5 and the same thing happened. Attaching the cruise stage part to another part crashes the game instantly.

Here is the crash folder: https://www.dropbox.com/sh/1m0diiif0wh8t6d/AAD_Mj5_Yv7DhIPnwnHqcchta?dl=0

Additional info:

MSL mod version: 1.0.2

KSP version: 1.2.2 (64 bit)

Share this post


Link to post
Share on other sites

@lextacy couple of things I noticed while looking at the cfgs. 

  1. Might want to tell people that they need to have Firespitter installed to do texture switch
  2. In backshell.cfg you misspelled MonoPropellant (you said Monopropellant)
  3. Any reason why cruise_stage.cfg uses mesh=cruise.mu while backshell.cfg and shield.cfg use MODEL {model=MSL/xxxxx}
  4. In the OP you say that the cruise stage has built in fuel tanks but cruise_stage.cfg only has storage for EC (no fuel)
  5. Again with cruise_stage.cfg, you gave it category = Propulsion. That's not a stock category.

 

@Kevin Vandy nothing bad in the log about the cruise stage. Trying to pin down what's causing the crash.

EDIT: Sorry to say this, but I'm unable to replicate a crash (see below). Can you try deleting the GameData/MSL folder completely and reinstalling?

Spoiler

b76082ec1d3c54b5874617e05ec49e14.png

 
 

 

Edited by TheRagingIrishman

Share this post


Link to post
Share on other sites
48 minutes ago, TheRagingIrishman said:

@lextacy couple of things I noticed while looking at the cfgs. 

  1. Might want to tell people that they need to have Firespitter installed to do texture switch
  2. In backshell.cfg you misspelled MonoPropellant (you said Monopropellant)
  3. Any reason why cruise_stage.cfg uses mesh=cruise.mu while backshell.cfg and shield.cfg use MODEL {model=MSL/xxxxx}
  4. In the OP you say that the cruise stage has built in fuel tanks but cruise_stage.cfg only has storage for EC (no fuel)
  5. Again with cruise_stage.cfg, you gave it category = Propulsion. That's not a stock category.

 

@Kevin Vandy nothing bad in the log about the cruise stage. Trying to pin down what's causing the crash.

EDIT: Sorry to say this, but I'm unable to replicate a crash (see below). Can you try deleting the GameData/MSL folder completely and reinstalling?

  Hide contents

b76082ec1d3c54b5874617e05ec49e14.png

 
 

 

good catch , thank you!  Wow this is alot of mistakes I made. So I think the firespitter dependancy was causing the crashes?  Ill do an update here soon.

Share this post


Link to post
Share on other sites
1 hour ago, lextacy said:

good catch , thank you!  Wow this is alot of mistakes I made. So I think the firespitter dependancy was causing the crashes?  Ill do an update here soon.

Nope, lack of firespitter wasn't making it crash. When KSP sees a module it can't load, then it ignores it. Also, I didn't have firespitter and nothing crashed. I'm not sure why Kevin was having crashes when I wasn't.

Share this post


Link to post
Share on other sites
1 hour ago, lextacy said:

good catch , thank you!  Wow this is alot of mistakes I made. So I think the firespitter dependancy was causing the crashes?  Ill do an update here soon.

Well, I had firespitter installed on my modded install, but not on my vanilla install, and it crashed both times, so maybe not in my case. Though it appears my crashing might be only for me.

Share this post


Link to post
Share on other sites
3 minutes ago, Kevin Vandy said:

Well, I had firespitter installed on my modded install, but not on my vanilla install, and it crashed both times, so maybe not in my case. Though it appears my crashing might be only for me.

Are you running linux os ? 

Share this post


Link to post
Share on other sites
1 minute ago, Kevin Vandy said:

Windows 10 64 bit most updated version of the mod and ksp 1.2.2

Getting same crash on cruise stage right after picking it  it will crash but don't see anything in the log

Share this post


Link to post
Share on other sites

Well, I'm kind of stumped. I downloaded the new update 1.0.3 and installed in both heavily modded and vanilla versions of KSP 1.2.2. I got crashes in both when trying to attach the cruise stage to any other part. It is only this part in the entire game that is crashing the game for me. I usually don't have crashes. I tried attatching the part from the top node, bottom node, or just radially, and it instantly crashed each time.

Here is the crash report from the vanilla stock install with the exceptions of Model manager 2.7.5 and Firespitter: https://www.dropbox.com/sh/9z79r3wrul9o5sr/AADFXvUBBr1Cn0rpSOCPuXvCa?dl=0

I'll try a few more things with the config files, but I might have to happily play with just the other two parts for a while.

Suggestion for the current parts:

1. Move the heatshield to the 'Thermal' section and maybe the cruise stage to 'command and control' or 'electrical'. I did it myself and it makes sense to me anyways (for the heatshield only, didn't effect the crash of cruise stage).

2. Either add support for tweakscale for the parts, add a variant size option, or just have each part come in two sizes. I've been trying the default options with the rescale factor of .66 in the config file, which is fine, but I can only fit  the smallest, most compressed rovers in, a little unlike the well known Curiosity, which is almost the size of a car. Maybe you could make the viking or spirit and opportunity parts this size, but the curiosity parts a bit bigger when you go to the next phase of the mod. 

Edited by Kevin Vandy

Share this post


Link to post
Share on other sites

Hi, ksp crash when adding the cruise part (with a heavily moded ksp and a light (Module Manager and Firespitter dll) ) also the total price is reduced (-3000) when putting the cruise part.

Here error log : http://textup.fr/184187du and output log if you need : http://textup.fr/184188D2

@Kevin Vandy +1 We need TweakScale (or bigger part) support for bigger rover :)

Share this post


Link to post
Share on other sites
7 hours ago, Kevin Vandy said:

Well, I'm kind of stumped. I downloaded the new update 1.0.3 and installed in both heavily modded and vanilla versions of KSP 1.2.2. I got crashes in both when trying to attach the cruise stage to any other part. It is only this part in the entire game that is crashing the game for me. I usually don't have crashes. I tried attatching the part from the top node, bottom node, or just radially, and it instantly crashed each time.

Here is the crash report from the vanilla stock install with the exceptions of Model manager 2.7.5 and Firespitter: https://www.dropbox.com/sh/9z79r3wrul9o5sr/AADFXvUBBr1Cn0rpSOCPuXvCa?dl=0

I'll try a few more things with the config files, but I might have to happily play with just the other two parts for a while.

Suggestion for the current parts:

1. Move the heatshield to the 'Thermal' section and maybe the cruise stage to 'command and control' or 'electrical'. I did it myself and it makes sense to me anyways (for the heatshield only, didn't effect the crash of cruise stage).

2. Either add support for tweakscale for the parts, add a variant size option, or just have each part come in two sizes. I've been trying the default options with the rescale factor of .66 in the config file, which is fine, but I can only fit  the smallest, most compressed rovers in, a little unlike the well known Curiosity, which is almost the size of a car. Maybe you could make the viking or spirit and opportunity parts this size, but the curiosity parts a bit bigger when you go to the next phase of the mod. 

The log unfortunately just says "CRASH!"  Are you on a desktop? Try doing the reverse and place a random part in VAB to where the cruise stage is suppose to go. May be the backshell node is causing problem.

My hunch on this crashing issue is people might be on low-end machines. Some people are getting it to work no matter the mod count and/or version of KSP. This really is frying my brain nevertheless :/

1. YES! I can do this for next update. I forgot 1.2 used new categories. My bad

2. I will certainly add tweakscale support very soon! :D I do believe that is a "dependancy" anyways. If you need the aeroshell stuff bigger for big rovers you can just change the rescale factor for now in .cfg

7 hours ago, MeCripp said:

@lextacy are these Lionhead models ?

 

Ill take that as a compliment as all these models are developed by me in 3dsMAX. I can really do some good modeling that looks authentic to the real world parts. In 3dsMAX if you take a simple cone and run the "shell" modifier onit you immedietly get the backshell shape to the letter. I was shocked.

5 hours ago, kiki37250 said:

Hi, ksp crash when adding the cruise part (with a heavily moded ksp and a light (Module Manager and Firespitter dll) ) also the total price is reduced (-3000) when putting the cruise part.

Here error log : http://textup.fr/184187du and output log if you need : http://textup.fr/184188D2

@Kevin Vandy +1 We need TweakScale (or bigger part) support for bigger rover :)

Not sure if 3000 funds is alot. But I dont play career mode to know lol. The logs you gave did not give me information on the crash sadly. What version of KSP you have?

 

RageingIrish..........What version of KSP did you get the parts to work in? 

Edited by lextacy

Share this post


Link to post
Share on other sites

I have ran your part back through unity and don't have the crash but I didn't setup the solar panel part on it do you just add a transformer and a pivot transformer ? Or can you point me to a good tutorial on how ?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.