allista

[1.4.3] Ground Construction 2

Recommended Posts

I designed a base in the SPH then loaded it onto a DIY kit on rocket in the VAB, but when I constructed the kit nad it came time to 'launch' I got a notification that there was a problem and not all parts were successfully constructed.

I tried re-building that kit several times(loading up a game before it was deployed), then tried building it on the launch-pad, and got the same error each time.

Finally I tried re-saving the base in the VAB and then loading the VAB version into the kit and it deployed just fine both on the launchpad and on Minmus.

I have not yet done due diligence to make sure that this is a problem with GC and not caused by another mod, but I thought I would mention it in case anyone else encountered the same problem(or wanted to verify it on a clean install).

I know that I have built and deployed bases from the SPH so I think it is just an issue with loading a vessel designed in one construction building into a kit in the other construction building.

---

Edit: not reproducible on a clean USI MKS/LS install, probably a problem from using KR&D on the DIY Kit.

Edited by Terwin
  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, RoverDude said:

@allista - no reason why not, since a DIY Kit is like Ikea :D

 

but don't you need a Doctorate in Kit Construction to make Ikea furniture :cool:

  • Like 2

Share this post


Link to post
Share on other sites
4 minutes ago, Tabris said:

but don't you need a Doctorate in Kit Construction to make Ikea furniture :cool:

I've been paid upwards of $40 an hour to assemble Ikea furniture for people...  Apparently some think it does.  :wink:

  • Like 4

Share this post


Link to post
Share on other sites
19 hours ago, Terwin said:

I designed a base in the SPH then loaded it onto a DIY kit on rocket in the VAB, but when I constructed the kit nad it came time to 'launch' I got a notification that there was a problem and not all parts were successfully constructed.

I tried re-building that kit several times(loading up a game before it was deployed), then tried building it on the launch-pad, and got the same error each time.

Finally I tried re-saving the base in the VAB and then loading the VAB version into the kit and it deployed just fine both on the launchpad and on Minmus.

I have not yet done due diligence to make sure that this is a problem with GC and not caused by another mod, but I thought I would mention it in case anyone else encountered the same problem(or wanted to verify it on a clean install).

I know that I have built and deployed bases from the SPH so I think it is just an issue with loading a vessel designed in one construction building into a kit in the other construction building.

This is very interesting. I hope you still have a save with this problem, mabe a _before_launch autosave that GC makes? If so, I would like to look into it to see where the problem is.

Share this post


Link to post
Share on other sites
2 hours ago, allista said:

This is very interesting. I hope you still have a save with this problem, mabe a _before_launch autosave that GC makes? If so, I would like to look into it to see where the problem is.

I was able to successfully deploy a vessel with the same name later on, so I am afraid that that save is lost.

When I tried to reproduce the issue in a clean install it would not replicate.

I think the actual issue could be with KR&D, I did weight research on the DIY base kit because I was curious if it would affect the loaded weight, then I launched and failed to deploy, so I reverted to a save before the research, loaded up the same vessel and it still failed to deploy.

It seems likely that the KR&D results were saved in the vessel save file and were kept until I refreshed the kit(after re-saving the base design in the VAB).

If there is a mass check prior to launch, then the 0.2 weight reduction of the kit(possibly more if it affected the loaded weight) then I could have still been running afoul of that even after reverting to a save before I did the KR&D research.

Sorry I do not have the save, but at the very least I have verified that I could not reproduce the issue in a clean (USI) install.

  • Like 1

Share this post


Link to post
Share on other sites

Just curious, is there a different before the GC standalone vs the one that is part of MKS?  I ask, because the ISRU used to allow you to convert ore to material kits and I don't see that anymore.

thanks

Share this post


Link to post
Share on other sites

So, uh, I have community resource pack installed, in the resource definitions there is an entry for "metals" but since it's not in the resourceconfig folder, it doesn't show up in any planet. Do I just copy and paste the file from other resource, changing the ResourceName to "metals" as well as the configuration for the surface scanner? I also don't have any container for it. Is there a mod that activates the "metals" resources? After all, the changes I'd make manually will be erased once I update CRP

Share this post


Link to post
Share on other sites
1 minute ago, juanml82 said:

So, uh, I have community resource pack installed, in the resource definitions there is an entry for "metals" but since it's not in the resourceconfig folder, it doesn't show up in any planet. Do I just copy and paste the file from other resource, changing the ResourceName to "metals" as well as the configuration for the surface scanner? I also don't have any container for it. Is there a mod that activates the "metals" resources? After all, the changes I'd make manually will be erased once I update CRP

Metals is what you need for RocketParts in the mod Exaplanetary Launchpads (as far I remember)

Edited by LatiMacciato

Share this post


Link to post
Share on other sites

@allista I've been having the same error a lot of people have reported ([ERR] Coroutine couldn't be started because the the game object 'Tundra.Workshop250' is inactive!"). I play with KSP set to show errors on screen when they happen and they cropped up during a launch (my first in a new save in a new install) many of them less than a hundredth of a second apart.

Here's my KSP.log. I will warn you that it's a modded save so there's a bunch of stuff in the log from other mods but the only GC errors were from 20:22:27.366 to 20:23:12.246. If there's anything else I can do, let me know.

Edited by TheRagingIrishman
  • Like 1

Share this post


Link to post
Share on other sites

Hi everybody,

Just want to ask if it's advisable to use EPL to build/construct the DIY containers on-site then use GC to build the actual "ship/vessel/base/rover/contraption"? =D

 

Regards and thanks in advance =)

Share this post


Link to post
Share on other sites
13 hours ago, LatiMacciato said:

Metals is what you need for RocketParts in the mod Exaplanetary Launchpads (as far I remember)

Mmm... So while I can download EPL and delete everything that isn't resources from that mod, I think this mod should include the MM patches and whatever else is needed to make metals "appear", so it works as a standalone mod

Share this post


Link to post
Share on other sites
10 minutes ago, juanml82 said:

Mmm... So while I can download EPL and delete everything that isn't resources from that mod, I think this mod should include the MM patches and whatever else is needed to make metals "appear", so it works as a standalone mod

But this does work as a stand-alone mod...  There's a patch that makes the stock ISRU module take Ore and output MaterialKits.

(For MKS Users, GC-Core does not include this patch because MKS handles the MK production chain already).

This has nothing to do with EL's presence or lack therof.  If you are using EL, you would just use the EL parts as normal so they do their thing.

 

  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, juanml82 said:

Mmm... So while I can download EPL and delete everything that isn't resources from that mod, I think this mod should include the MM patches and whatever else is needed to make metals "appear", so it works as a standalone mod

The OP hasn't been updated yet but the production chain changed when allista and Rover Dude started collaborating. It now uses Materialkits instead of metals as RD mentions above. 

Share this post


Link to post
Share on other sites
50 minutes ago, juanml82 said:

Mmm... So while I can download EPL and delete everything that isn't resources from that mod, I think this mod should include the MM patches and whatever else is needed to make metals "appear", so it works as a standalone mod

You get Metals from a converter, not from a surface. MetalOre is what you scan for. Launchpads' production chain is MetalOre -> Metals -> RocketParts.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
12 hours ago, RoverDude said:

But this does work as a stand-alone mod...  There's a patch that makes the stock ISRU module take Ore and output MaterialKits.

(For MKS Users, GC-Core does not include this patch because MKS handles the MK production chain already).

This has nothing to do with EL's presence or lack therof.  If you are using EL, you would just use the EL parts as normal so they do their thing.

 

 

11 hours ago, JadeOfMaar said:

You get Metals from a converter, not from a surface. MetalOre is what you scan for. Launchpads' production chain is MetalOre -> Metals -> RocketParts.

Wait, but this uses "ore" to "material kits", right? Also, is there a container where I can store material kits besides the workshop included in the mod? Can't really convert it if there isn't anything to store it in.

Share this post


Link to post
Share on other sites

@juanml82 Good question. If you're using Configurable Containers, also made by @allista and I believe is bundled with GC, maybe there's an option for MaterialKits already in it? In that case there's no need to code a tank.

Otherwise install USI Core and you'll get kontainers to hold MaterialKits. USI Core only has kontainers and reactors. There's no truckload of unneeded parts there.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
8 hours ago, FirroSeranel said:

Hey @allista and @RoverDude,

I'm also getting tons and tons of "Coroutine could not be started because the game object [Sequence of parts] is inactive."

Any luck tracking this down?

Ya like I said a few posts ago, I've been getting swamped with these. The strange thing is that they happen during a bunch of different game events but the game events they occur in change each time I play KSP.

Edited by TheRagingIrishman

Share this post


Link to post
Share on other sites
1 hour ago, TheRagingIrishman said:

Ya like I said a few posts ago, I've been getting swamped with these. The strange thing is that they happen during a bunch of different game events but the game events they occur in change each time I play KSP.

They seem to happen everytime the vessel is loaded or updated, e.g., staging. I don't know if they are debug spam or true error spam. It looks like allista is just looping through all parts that could have the GC module attached to it. The error throws when that part is not on the vessel.   I'm not sure why the loop isn't just looking for parts with the GC module on the vessel but I'm also not a programmer so what do I know. Regardless, it doesn't appear to be having a performance impact. I disabled showing errors on screen (but left null refs) so it wouldn't be a constant source of irritation. 

Edited by Tarheel1999

Share this post


Link to post
Share on other sites

When packing stuff into kits I usually end up with several oddly sized boxes that are hard to fit onto a rocket. They are also about the only big parts in the game which are not round.

Would it be possible to add a kit in the form of a cylinder, where the diameter is tweakable and the content determines the height? If I was told to pack things for launching them with a rocket, that would be the most natural form factor.

  • Like 3

Share this post


Link to post
Share on other sites
19 hours ago, JadeOfMaar said:

@juanml82 Good question. If you're using Configurable Containers, also made by @allista and I believe is bundled with GC, maybe there's an option for MaterialKits already in it? In that case there's no need to code a tank.

Otherwise install USI Core and you'll get kontainers to hold MaterialKits. USI Core only has kontainers and reactors. There's no truckload of unneeded parts there.

Will try USI Core. I don't see any configurable containers in the fuel tanks. Does it conflict with interstellar fuel switch?

Share this post


Link to post
Share on other sites
19 minutes ago, juanml82 said:

configurable containers -snip- Does it conflict with interstellar fuel switch?

I believe so.

Share this post


Link to post
Share on other sites
22 minutes ago, juanml82 said:

Will try USI Core. I don't see any configurable containers in the fuel tanks. Does it conflict with interstellar fuel switch?

Yes and no - If they are both applied to the same fuel tank, then weird things will happen.  But there's nothing in particular bad that happens if they are in the same game.

Share this post


Link to post
Share on other sites
On 3/6/2017 at 6:11 PM, gamerscircle said:

Just curious, is there a different before the GC standalone vs the one that is part of MKS?  I ask, because the ISRU used to allow you to convert ore to material kits and I don't see that anymore.

thanks

There certainly is, otherwise why would there be two versions?

MKS's version is stripped down: it does not include any patches (so no workshops in stock parts, no ISRU) and parts, except for the DIY Kit itself. Instead, MKS adds its own dedicated workshops and MaterialKits production pathway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now