allista

[1.7] Global Construction

Recommended Posts

Upgraded to ksp 1.7.2 and GC 2.4.1. Just built my first assembly line on the Mun but every kit explodes on spawn. Even an empty container. Looks like ksp sees the kit as crashing into Mun. I build the assembly line from a kit that was flown to the Mun. Not sure if that has anything to do with it.

[LOG 21:20:59.229] [DIY Kit: Flex]: Ready to Launch - waiting to start physics...
[LOG 21:20:59.229] 6/26/2019 9:20:59 PM,AmpYear,OnVesselCreate
[LOG 21:20:59.235] [000_AT_Utils: 21:20:59.235] Vessel assembled for launch: DIY Kit: Flex
[LOG 21:20:59.319] [Dynamic Battery Storage]: Summary: 
 vessel DIYKit (loaded state True)
- 0 stock power handlers
[LOG 21:20:59.537] [FlightIntegrator]: Reloaded drag cube for zeroed cube root part DIYKit on vessel DIY Kit: Flex
[LOG 21:20:59.538] [FlightIntegrator]: Vessel DIY Kit: Flex has been unloaded 1.79769313486232E+308, applying analytic temperature 176.292893558036
[LOG 21:20:59.735] [USI-LS] Vessel situation changed, refreshing life support
[LOG 21:20:59.736] [USI-LS] Vessel situation changed, refreshing life support
[WRN 21:21:00.632] [F: 80515]: Vessel DIY Kit: Flex crashed through terrain on Mun.
[LOG 21:21:00.634] DIYKit Exploded!! - blast awesomeness: 0.2
[LOG 21:21:00.636] [DIYKit]: Deactivated
 

Any suggestions on where to start troubleshooting? Anyone else seen this issue?

Share this post


Link to post
Share on other sites
7 hours ago, beeble42 said:

Upgraded to ksp 1.7.2 and GC 2.4.1. Just built my first assembly line on the Mun but every kit explodes on spawn. Even an empty container. Looks like ksp sees the kit as crashing into Mun. I build the assembly line from a kit that was flown to the Mun. Not sure if that has anything to do with it.

[LOG 21:20:59.229] [DIY Kit: Flex]: Ready to Launch - waiting to start physics...
[LOG 21:20:59.229] 6/26/2019 9:20:59 PM,AmpYear,OnVesselCreate
[LOG 21:20:59.235] [000_AT_Utils: 21:20:59.235] Vessel assembled for launch: DIY Kit: Flex
[LOG 21:20:59.319] [Dynamic Battery Storage]: Summary: 
 vessel DIYKit (loaded state True)
- 0 stock power handlers
[LOG 21:20:59.537] [FlightIntegrator]: Reloaded drag cube for zeroed cube root part DIYKit on vessel DIY Kit: Flex
[LOG 21:20:59.538] [FlightIntegrator]: Vessel DIY Kit: Flex has been unloaded 1.79769313486232E+308, applying analytic temperature 176.292893558036
[LOG 21:20:59.735] [USI-LS] Vessel situation changed, refreshing life support
[LOG 21:20:59.736] [USI-LS] Vessel situation changed, refreshing life support
[WRN 21:21:00.632] [F: 80515]: Vessel DIY Kit: Flex crashed through terrain on Mun.
[LOG 21:21:00.634] DIYKit Exploded!! - blast awesomeness: 0.2
[LOG 21:21:00.636] [DIYKit]: Deactivated
 

Any suggestions on where to start troubleshooting? Anyone else seen this issue?

Thanks for the report, I'll look into it.

Could you provide the KSP_Data/output_log.txt for more information?

*on mac/linux it's called Player.log and is located elsewhere

Share this post


Link to post
Share on other sites
7 hours ago, allista said:

Thanks for the report, I'll look into it.

Could you provide the KSP_Data/output_log.txt for more information?

*on mac/linux it's called Player.log and is located elsewhere

I'm on a Mac. For the refrence of others, the path is ~/Library/Logs/Unity/Player.log

https://www.dropbox.com/s/upjmkhlzkrj9h32/Player.log?dl=0

I had a quick read and there's no extra messages other than what's seen in the ksp log. At least in the part I'm looking at. Hopefully you can find something useful. I've tried removing FAR and dependencies with no change. It could be another plugin causing a conflict but I'm hoping we could find something useful to narrow down that search a little.

Share this post


Link to post
Share on other sites

Slowly making recycling of parts and vessels for GC...

 

Share this post


Link to post
Share on other sites
42 minutes ago, Tacombel said:

@allista There is no connection between the workshop and the parts being recycled? That's great.

For ground workshop there isn't: it can recycle anything within 300m radius, same as with construction.

For orbital workshop the recycled vessel should be docked. Hm... this poses a problem, as docking may re-root the vessel, making it inaccessible for recycler. Have to think about it...

Share this post


Link to post
Share on other sites

Have you thought of combining recycling with Hangar? I.e. docking a vessel in a hangar (maybe a special one), close hangar and recycle vessel.

Since Hangar already removes the vessel from the world, this might avoid some of the issues from implementing it physically, and imo., is more believable.

Though the satisfaction from imploding things is always nice ;-)...and you can explain it with swarms of nanites or some similar science fiction term. 

 

Just a thought.

 

Share this post


Link to post
Share on other sites
Posted (edited)

https://imgur.com/a/1WOJFqG

 

Don't know what is going on here. The construction finished, received a message and the queue is empty, but nothing happened. It seems that it is lacking some resources. I have added enough of them to the station, but still nothing happening.

 

Never mind. I realized that I need the orbital workshop :-)

Edited by Tacombel

Share this post


Link to post
Share on other sites
10 hours ago, KiefferDK said:

Have you thought of combining recycling with Hangar? I.e. docking a vessel in a hangar (maybe a special one), close hangar and recycle vessel.

Since Hangar already removes the vessel from the world, this might avoid some of the issues from implementing it physically, and imo., is more believable.

Though the satisfaction from imploding things is always nice ;-)...and you can explain it with swarms of nanites or some similar science fiction term. 

 

Just a thought.

I thought indeed, but there are some strong (IMHO) arguments against it:

  • The idea of recycling is that if engineers can assemble something in a workshop, they can do the reverse. Hangars have no workshops, no engineers; it's unclear why and how a hangar should be able to chew a ship inside into something useful.
  • Consequently, the recycling shown above is the construction reversed: it uses the same framework to calculate energy cost and output resources as is used to create kits. This framework is of course GC-specific, so to use it in Hangar I either need to lift it up to AT_Utils or link Hangar against GC (noooo way), or do some unpleasant magic with conditionally loaded sub-dlls.
  • Also, all calculations are based on actual living parts; I would have to reimplement them for ProtoVessels AND ShipConstructs to use for disembodied ships stored in a hangar.
  • Considerable advantage of the shown method is that it allows partial disassembly; you can chop up any sub-tree of parts, starting from single terminal ones, and leave the rest of the ship be. I'm still not sure if I could solve the re-rooting in flight painlessly to be able to work with practically un-rooted part tree and recycle any physically terminal part, but even how it is now it's already much better then a whole-vessel recycling in one go.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

I'm getting similar exploding container issue now. Have not had that before. I've removed other mods (including KJR) except SCANsat (18.10), because none of my vessels would load without it. Getting the same result with no other mods. Same thing happens when deploying an empty container.

Here is the relevant part of the Player.log 

Spoiler

Game State Saved to saves/default/Tug-25-before_spawn
 [DIY Kit: Tug-25]: Ready to Launch - waiting to start physics...
[000_AT_Utils: 23:58:09.605] Vessel assembled for launch: DIY Kit: Tug-25
DragCubeSystem: Rendering procedural drag for MobileSmelter
[FlightIntegrator]: Reloaded drag cube for zeroed cube root part OrbitalKitContainer2 on vessel DIY Kit: Tug-25
[FlightIntegrator]: Vessel DIY Kit: Tug-25 has been unloaded 1.79769313486232E+308, applying analytic temperature 178.304219999827
Unpacking DIY Kit: Tug-25
[FLIGHT GLOBALS]: Switching To Vessel DIY Kit: Tug-25 ---------------------- 
[PlanetariumCamera]: Focus: DIY Kit: Tug-25
[F: 11598]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 90.58724 - momentum: 226.5
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

https://www.dropbox.com/s/qf1efhy153zfk4j/Player.log?dl=0

Mod's awesomeness is off the charts, b.t.w.

Thank you for all the great work you do

Edited by DeW
Posted as a quote by accident

Share this post


Link to post
Share on other sites
8 hours ago, allista said:

I thought indeed, but there are some strong (IMHO) arguments against it:

  • The idea of recycling is that if engineers can assemble something in a workshop, they can do the reverse. Hangars have no workshops, no engineers; it's unclear why and how a hangar should be able to chew a ship inside into something useful.
  • Consequently, the recycling shown above is the construction reversed: it uses the same framework to calculate energy cost and output resources as is used to create kits. This framework is of course GC-specific, so to use it in Hangar I either need to lift it up to AT_Utils or link Hangar against GC (noooo way), or do some unpleasant magic with conditionally loaded sub-dlls.
  • Also, all calculations are based on actual living parts; I would have to reimplement them for ProtoVessels AND ShipConstructs to use for disembodied ships stored in a hangar.
  • Considerable advantage of the shown method is that it allows partial disassembly; you can chop up any sub-tree of parts, starting from single terminal ones, and leave the rest of the ship be. I'm still not sure if I could solve the re-rooting in flight painlessly to be able to work with practically un-rooted part tree and recycle any physically terminal part, but even how it is now it's already much better then a whole-vessel recycling in one go.

 

Thanks for replying. You're right about the advantages of course ;-)

As an IRL-developer who has never delved into Unity or KSP coding, it's really interesting to hear about the challenges and peculiarities that modders encounter.

I for one  will be happy to have recycling available directly in GC and am going to use it heavily. Can't wait to upgrade my older bases through a more sensible process  ;-)

And btw: GC, Hangar and TCA are (IMO) among the most useful mods around, delivering more flexible and practical gameplay within their subject areas, still working within (or maybe right at) the limits of the framework.

So thank you for them and keep up the good work! 

Share this post


Link to post
Share on other sites
Posted (edited)

It would be great to use GC for ground bases, but I suppose that it would call the kraken too frequently. Nonetheless, with the actual configuration of the containers it doesn't seem practical :-)

 

8WQKff3.jpg

Edited by Tacombel

Share this post


Link to post
Share on other sites
3 hours ago, DeW said:

Hi,

I'm getting similar exploding container issue now. Have not had that before. I've removed other mods (including KJR) except SCANsat (18.10), because none of my vessels would load without it. Getting the same result with no other mods. Same thing happens when deploying an empty container.

Here is the relevant part of the Player.log 

  Reveal hidden contents
Spoiler
  Reveal hidden contents

Game State Saved to saves/default/Tug-25-before_spawn
 [DIY Kit: Tug-25]: Ready to Launch - waiting to start physics...
[000_AT_Utils: 23:58:09.605] Vessel assembled for launch: DIY Kit: Tug-25
DragCubeSystem: Rendering procedural drag for MobileSmelter
[FlightIntegrator]: Reloaded drag cube for zeroed cube root part OrbitalKitContainer2 on vessel DIY Kit: Tug-25
[FlightIntegrator]: Vessel DIY Kit: Tug-25 has been unloaded 1.79769313486232E+308, applying analytic temperature 178.304219999827
Unpacking DIY Kit: Tug-25
[FLIGHT GLOBALS]: Switching To Vessel DIY Kit: Tug-25 ---------------------- 
[PlanetariumCamera]: Focus: DIY Kit: Tug-25
[F: 11598]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 90.58724 - momentum: 226.5
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

https://www.dropbox.com/s/qf1efhy153zfk4j/Player.log?dl=0

Mod's awesomeness is off the charts, b.t.w.

Thank you for all the great work you do

Thanks for the report. I don't see anything in the logs aside from some exceptions thrown on game saves by contact system.

The container is spawned and is immediately considered as "moving" and crashing into the nearest part.

There are no mods to conflict with either. So the only explanation left is some hidden incompatibility with KSP 1.7.2

Looking into it.

8 minutes ago, Tacombel said:

It would be great to use GC for ground bases, but I suppose that it would call the kraken too frequently. Nonetheless, with the actual configuration of the containers it doesn't seem practical :-)

Could you elaborate the point?

No krakens were encountered before 1.7.2, which I haven't tested extensively yet. And to tell the truth, the mechanics of spawning vessels on the ground is MUCH simpler than that of spawning in orbit.

After all, GC started as ground-only construction :cool:

And what's wrong with the configuration of the containers?

Share this post


Link to post
Share on other sites

That's part of the planetary base system, that are kind of flat parts, so when connected to the container it goes up in the air. Also, I have to test if it is possible to attach the container when the base is in place, because the node will be to low compared to the container node.

 

 

Share this post


Link to post
Share on other sites
16 minutes ago, Tacombel said:

That's part of the planetary base system, that are kind of flat parts, so when connected to the container it goes up in the air. Also, I have to test if it is possible to attach the container when the base is in place, because the node will be to low compared to the container node.

 

 

Ah, I see: you mean incremental construction, like with space stations.

I thought about it when I was making the framework. The blocker is the way a container is resized; to make it useful for on-the-ground docked construction I need to move the attach node on container's surface and simultaneously move the container away while it scales. Even worse, the growth point and the attach node position could not be the same, yet the local position of the attach node with respect to the growth point should be constant... :science:

Now that I think about it, it seems there is a way to do it; but not easy at all... :confused:

Share this post


Link to post
Share on other sites
Posted (edited)
Quote
On 7/3/2019 at 4:44 AM, allista said:

Thanks for the report. I don't see anything in the logs aside from some exceptions thrown on game saves by contact system.

The container is spawned and is immediately considered as "moving" and crashing into the nearest part.

There are no mods to conflict with either. So the only explanation left is some hidden incompatibility with KSP 1.7.2

Looking into it.

 

I've rolled back to 1.7.1, changed version numbers in persistent.sfs and one quicksave to 1.7.1. Container still explodes the same way as in 1.7.2. With and without KJR Next

Spoiler

[DIY Kit: Tug-25]: Ready to Launch - waiting to start physics...
[000_AT_Utils: 14:56:55.070] Vessel assembled for launch: DIY Kit: Tug-25
[FlightIntegrator]: Reloaded drag cube for zeroed cube root part OrbitalKitContainer2 on vessel DIY Kit: Tug-25
[FlightIntegrator]: Vessel DIY Kit: Tug-25 has been unloaded 1.79769313486232E+308, applying analytic temperature 178.887259262095
DragCubeSystem: Rendering procedural drag for MobileSmelter
Unpacking DIY Kit: Tug-25
[FLIGHT GLOBALS]: Switching To Vessel DIY Kit: Tug-25 ---------------------- 
[F: 12033]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 90.55715 - momentum: 226.4
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5
[OrbitalKitContainer2]: Deactivated

Almost the same as in 1.7.2 (relative velocity: 90.58724 - momentum: 226.5). It seems that spawned object travels radially away from the body it suppose to orbit. In this case it's Minimus

Spoiler

ORBIT
{
    SMA = 70946.965740495798
    ECC = 0.0050050379886157148
    INC = 0.81957809053460839
    LPE = 99.676033476498759
    LAN = 319.36593860383209
    MNA = -2.8534231129578731
    EPH = 21837080.014958277
    REF = 3
}

Nope. Just checked my theory. It is not traveling radially away from the body it's orbiting. I've tried various ship orientations and was able to successfully deploy ("Finalize") the container while assembly space was pointing towards retrograde.

Edited by DeW

Share this post


Link to post
Share on other sites

After further tests I've found that even though there is some correlation between assembly space gates alignment to retrograde, it's not the main cause of half-awesome blasts.

Impact speed to retrograde angle:

Spoiler

15º to retrograde:
[F: 43796]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 79.63257 - momentum: 199.1
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

10º to retrograde:
[F: 16672]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 79.51658 - momentum: 198.8
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

5º to retrograde:
[F: 5980]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 79.40538 - momentum: 198.5
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

0º to retrograde:
[F: 6111]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 79.36948 - momentum: 198.4
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

0º to retrograde:
[F: 6213]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 79.36814 - momentum: 198.4
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

0º to retrograde:
[F: 6415]: OrbitalKitContainer2 collided into OrbitalAssemblySpace - relative velocity: 79.36545 - momentum: 198.4
OrbitalKitContainer2 Exploded!! - blast awesomeness: 0.5

My successful container deployment was somewhat accidental. But then I've managed to stop physics by going into 5x warp right after hitting "Finalize" button. Here is what happened:

screenshot.png

I've also noticed that clicking "control from here", on either side of the container, prograde orientation does not change 180º.

Share this post


Link to post
Share on other sites
18 minutes ago, DeW said:

But then I've managed to stop physics by going into 5x warp right after hitting "Finalize" button. Here is what happened:

So it actually spawned intersected with the assembly space? :o

Share this post


Link to post
Share on other sites
1 hour ago, allista said:

So it actually spawned intersected with the assembly space? :o

Indeed. I'm going to keep trying to see if it consistently doing that.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi folks,

I recently started using this awesome mod and I find it quite enjoyable :)

One thing that puzzles me is how does Machinery affect anything? I did a search of the forums plus Google and also tried a few scenarios, I couldn't find any reason to have more than the minimum required 95 (default 100)

It doesn't get consumed at any point and it doesn't seem to affect any speed or efficiency of any process, I tried with 100 and 10000, I'm quite puzzled, is this part of a future development idea or am I missing something?

Thanks :)

Edited by NightmanX
grammar

Share this post


Link to post
Share on other sites
7 hours ago, NightmanX said:

Hi folks,

I recently started using this awesome mod and I find it quite enjoyable :)

One thing that puzzles me is how does Machinery affect anything? I did a search of the forums plus Google and also tried a few scenarios, I couldn't find any reason to have more than the minimum required 95 (default 100)

It doesn't get consumed at any point and it doesn't seem to affect any speed or efficiency of any process, I tried with 100 and 10000, I'm quite puzzled, is this part of a future development idea or am I missing somethin:)

Nah, it's as simple as you see it: Machinery is required for the converters in assembly lines to work. Nothing more. The extra space is just meant for the output of the converter that produces Machinery for other parts that require it, if any.

Previously, to make another assembly line or a workshop you would need to make the part itself separately from the kit, then to fill it with Machinery produced by the converter. Now the Machinery is produced as part of the kit during assembly.

Share this post


Link to post
Share on other sites

Incremental station attached with incorrect alignment. The only extrange think I saw was that there was two smoke clouds when launching. One in the junction of the new piece and another one several pieces away.

 

W0aKzi1.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry for my ineptitude :lol:

Now I am trying to add an orbital assembly space using the container in the image above. I launch the assembly line GUI, select the container and Add part, chose the orbital assembly space, select dock, and when I press Add I get a message saying there are no workers in the workshop, while I have four of them in the orbital assembly line and another one in the orbital workshop.

 

Then I go to KSC and create a vessel with a crew conduit and an assembly space, repeat the procedure but this time with add Vessel and everything works as expected, it starts assembling.

later...

Now I tried to assembly a spacecrane with add part inside the assembly space and i get the no workers message when I try to start construction.

Edited by Tacombel

Share this post


Link to post
Share on other sites
10 hours ago, allista said:

Nah, it's as simple as you see it: Machinery is required for the converters in assembly lines to work. Nothing more. The extra space is just meant for the output of the converter that produces Machinery for other parts that require it, if any.

IMHO this should either be removed or given a purpose like for example consider Machinery like some sort of tooling requirement based on the size of the part being assembled. Like have 100 Machinery requirement for a 1m3 volume part and 1000 Machinery for a 10m3 volume part. If you'll consider this idea it will probably need a better formula for scaling up as there are huge parts out there like the B9 HX ships and having millions of Machinery needed for that will probably be quite restrictive :)

@allista Thank you for all the great work!

Share this post


Link to post
Share on other sites
4 hours ago, Tacombel said:

Incremental station attached with incorrect alignment. The only extrange think I saw was that there was two smoke clouds when launching. One in the junction of the new piece and another one several pieces away.

 

W0aKzi1.jpg

What part and what mod is this central hub from? I'll have to test it myself.

4 hours ago, Tacombel said:

Sorry for my ineptitude :lol:

Now I am trying to add an orbital assembly space using the container in the image above. I launch the assembly line GUI, select the container and Add part, chose the orbital assembly space, select dock, and when I press Add I get a message saying there are no workers in the workshop, while I have four of them in the orbital assembly line and another one in the orbital workshop.

 

Then I go to KSC and create a vessel with a crew conduit and an assembly space, repeat the procedure but this time with add Vessel and everything works as expected, it starts assembling.

later...

Now I tried to assembly a spacecrane with add part inside the assembly space and i get the no workers message when I try to start construction.

Thanks for the report. I'll check it out.

Though I've assembled and constructed many single parts while testing, so the thing I'd check first is that you really have workers inside; if true, try to transfer one of them out and in again (simple EVA should suffice),

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.