Jump to content

[1.9-1.10] Global Construction


allista
 Share

Recommended Posts

  • 2 weeks later...

Following a couple of other comments (...okay, one of them was mine) - I did think there was some problem with some specific parts causing DIY kits to bug out, as today I again had the 'DIY kit on the ground but invisible to the workshop' thing.

...Then, while I was doing some experiments to work out what to say in here, I discovered that if the (ground) DIY kit is actually docked to the (also ground) workshop, it can be built.  So that was odd.

I'm also thankful that all those years ago I built that first General Purpose Lander with *two* winches on it, as they eventually became KAS fuel hoses and could be used to chain the container onto the base... :)

 

Link to comment
Share on other sites

  • 4 weeks later...

Hopefully this isn't too silly, but I am adding a vessel to the orbital assembly space. It has the (D) to indicate the vessel can be docked when created, but when I click on the vessel in the assembly space, the options to choose where the vessel will be docked upon construction do not appear. Any ideas? 

 

 

Link to comment
Share on other sites

  • 4 weeks later...
On 5/2/2020 at 5:59 AM, allista said:

Thanks for the report.

It does look like a bug in calculation of container deployment dimensions, but I need to be able to reproduce and test it on my side.

Could you, please, provide the .craft file of this station addon?

The hard limit is the size of the assembly space.

The kit in the container has constant density, so the heavier the kit, the bigger the container. And once the kit is assembled in the assembly space, it have to be spawned inside the assembly space. And if it's bigger, you've got yourself big fat explosion.

So before a kit is accepted to the assembly queue, the present assembly spaces are checked for the ability to spawn the resulting container.

However, there's a way to work around this: an empty Kit Container is itself an assembly space without any limit, because it is itself resized before assembly begins.

So all you have to do is to spawn empty container (orbital if you're building in space, ground otherwise), and, if in orbit, to dock this container with arrows pointing to the docking port.

Then the Assembly Workshop will recognize the empty container as yet another assembly space which is always big enough for any kit.

Oh, so many thanks for that tidbit!! I've been looking for info on this for a long time.  I sent multiple ships over years to Val to build an orbital construction platform to support my activities around Jool but couldn't build any of the vehicles I'd created in the VAB.  I was so excited to have my own shipyard in orbit and was disappointed when it didn't work (but without a good explanation why).  Thanks for the comment; I'm back in business and building my next deep space mornership to go hit Sarnus and the rest of the Outer Planets Mod using Laythe as my colony home base. 

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...

Hello

 

Anyone using this mod on RSS/ROI have tried and I can make DIY kits and deploy them, but I can´t add resources (no option available) so I can´t launch the ships and I end with some big useless boxes...

FIXED!

It seems to work flawlessly on ksp 1.10.1  RSS/RO (science sandbox)

Edited by Makrom
I figured out what I was doing wrong...
Link to comment
Share on other sites

  • 2 weeks later...

It's been too long :maneuver:

This is the release of work I've been doing before I had to pause.

But later is better than never, I guess.

The KSP-1.12 compatibility update is on its way after this, but I won't give you any estimates on time.

 

Version 2.7.0 for Kerbal Space Program 1.11.1

Released on 2022-02-19

  • KSP: 1.11.1
  • Added support of attach nodes in Part Variants for construct docking
  • The construct from Docked Container is wielded to the base ship excluding the docking port
  • When construction is started, the required crew is automatically transferred into the workshop if not present
  • UI
    • Added Get Crew and Dismiss Crew buttons to the Workshop Window
    • Added Warp to Deployed button to the Workshop Window
    • Updating Editor UI on ship naming change
    • Corrected ETA display
  • The deployment of a container does not decrease container size
  • Fixed
    • task synchronization of tasks between workshops in Workshop Manger
    • recycling report on failed resource trasfers
    • kit mass calculation
    • NRE in Docked Kit Container UI
    • AOR exception in Jobs+stage derived methods/properties

 Download (16.04 MiB) 

Link to comment
Share on other sites

Hey there,

Love the mod, so much so that I've been looking to write my first Patch about it. I'm using the Spacedock Reloaded mod (the one inspired by the Warp-5 complex from Star Trek). I'm trying to add the Assembly Space to them. The mesh isn't set up to animate or anything, and from what I can gather the SpawnManager.SpawnSpace is looking for a mesh within the .mu file? (not sure how that works). What I'm wondering is what fields in the Assembly Space module are required? For example: Do I *have* to have the DamperID, AnimatorID, and SpawnManager.SpawnSpace?

Link to comment
Share on other sites

  • 1 month later...

Quick question from a noob guys. Can you expand the workshop space to build things on planets/moons that are to big for the workshop that makes the kit boxes? I tried chaining 2 together and that didn't work.  

Link to comment
Share on other sites

12 hours ago, Choc113 said:

Quick question from a noob guys. Can you expand the workshop space to build things on planets/moons that are to big for the workshop that makes the kit boxes? I tried chaining 2 together and that didn't work.  

On surface you don't need to build inside the workshop space. You can create an empty container, place near the assembly line, then build a kit of any size in this container, then transport the container to the construction workshop, deploy it and build the final construct.

You just need the ground assembly line for that to work. Orbital one only works with containers docked to its ship.

Link to comment
Share on other sites

  • 2 weeks later...

When I launch a dockable kit in docked mode, it eats the docking port. Not a big deal, but I lost three docking ports before I figured out what was going on and just started launching new craft in undocked mode. Am I doing something wrong?

Unrelated question, how hard would it be to make your Hangers into construction areas? I'd love to build in the big ground hangers.

Love this and all your mods Allista!

Link to comment
Share on other sites

12 hours ago, loverevolutionary said:

When I launch a dockable kit in docked mode, it eats the docking port. Not a big deal, but I lost three docking ports before I figured out what was going on and just started launching new craft in undocked mode. Am I doing something wrong?

Unrelated question, how hard would it be to make your Hangers into construction areas? I'd love to build in the big ground hangers.

Love this and all your mods Allista!

Thanks, glad to hear :)

Adding MM patches for Hangars to use them as Assembly Spaces seems doable. I'll consider it.

The "eating" of docking ports is optional and configurable from the construction window of a Construction Workshop. Click on the kit being constructed and switch the "After construction: Launch/Dock" to Dock, then, below, in the "Dock via:" part toggle the switch "Wield" so that it is not active (not green if you use the default color scheme).

U7hd5lj.png

Link to comment
Share on other sites

  • 3 weeks later...

Hello, I did a new install (ksp 1.12.2) and used the 2.7.0 version, because  Ckan doesn´t show the last version as available so I did it manually, but then in Ckan GC appears as AD but the version it shows is 2.7.1 for ksp 1.12.3 (!), besides that, I got the strange thing of not being able to close the assembly door, it loads the assembly line unit with the door open and I can´t close it so I can´t build anything.

Any clue?

Fixed: I reinstall At_utils

 

thx

Edited by Makrom
found my level 8 error
Link to comment
Share on other sites

10 hours ago, Makrom said:

Hello, I did a new install (ksp 1.12.2) and used the 2.7.0 version, because  Ckan doesn´t show the last version as available so I did it manually, but then in Ckan GC appears as AD but the version it shows is 2.7.1 for ksp 1.12.3 (!), besides that, I got the strange thing of not being able to close the assembly door, it loads the assembly line unit with the door open and I can´t close it so I can´t build anything.

Oh :o thanks for the report!

Indeed, the .version file has 1.12.3 KSP version instead of 1.12.2 :confused:

This should be the reason why CKAN prevents you from installing; but you may configure accepted KSP versions in CKAN client itself.

As for the assembly line door (I presume you're talking about the ground variant), I need to check that; and it would also help to see the contents of your Player.log.

Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

Hello!

I'm struglling terribly trying to produce entire ships in space. I can create kits, and they'll show a green deployment area, but when I hit deploy, nothing happens. Also, the UI says that my test ship (a simple 2-person scooter just a cockpit with fuel tanks, engine and some RCS thruster, battery and a solar panel) will need some stuff - like electrical units, snacks, and fuel. There is plenty of all of those available - and no obvious way to make the kit use them. I've even tried seeing if I can transfer resources , but it just doesnt work.  I have watched the videos, I have read the instructions at the beginning of this thread - and I can still get no further than creating the kit.  Is there a good write-up of how things are supposed to work? (I do much better reading instructions than I do watching videos). Everything is so easy up to the point of creating the kit, but I seem to have hit a brick wall at that point, which makes it all the more frustrating.  Latest version of KSP being used, GC installed via CKAN

 

Oh and I have one further, but much more minor question - when the UI says "wield the port" does it mean use or was it a typo for weld? - it has occurred to me that maybe it needs me to be using the "welding ports" from the USI Konstruction mod, but that doesnt seem likely as Allista would surely have made that clear.

 

Anyway, many many thanks for your hard work in making your mods Allista, I bet the problem is me overlooking something somewhere! :-}

 

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...