linuxgurugamer

[1.9.x] Part Wizard Continued

Recommended Posts

While making a complex, very small probe yesterday, I realized that this mod could benefit from a feature where, when you click a part in the list, it becomes the "active" part in the editor.

Why? I think it would be really great to be able to select a part that is behind/under another one. Currently, I use WASD Camera to do this: I move slowly very close to the overlapping part until it "clip" through the camera, giving access to the part behind/under it...

That is, yet, another request... :rolleyes:

As always, thanks for everything you do for the KSP community.

Share this post


Link to post
Share on other sites

Define "active".  Normally that means that you've clicked it, which picks it up

Not a great idea, sorry.

Share this post


Link to post
Share on other sites

You are right: Picking it up is not a good idea. I was more thinking about Translation, Rotation and Reroot tools...

Share this post


Link to post
Share on other sites
16 hours ago, Galenmacil said:

You are right: Picking it up is not a good idea. I was more thinking about Translation, Rotation and Reroot tools...

Please add this as an issue/enhancement request to github, for those tools, it's not a bad idea

Share this post


Link to post
Share on other sites
7 hours ago, Gordon Dry said:

Has anybody tested this with KSP 1.4.0 yet?

Please wait until I get this updated

Share this post


Link to post
Share on other sites
On 25/10/2017 at 3:57 AM, Galenmacil said:

While making a complex, very small probe yesterday, I realized that this mod could benefit from a feature where, when you click a part in the list, it becomes the "active" part in the editor.

Why? I think it would be really great to be able to select a part that is behind/under another one. Currently, I use WASD Camera to do this: I move slowly very close to the overlapping part until it "clip" through the camera, giving access to the part behind/under it...

That is, yet, another request... :rolleyes:

As always, thanks for everything you do for the KSP community.

 

10000000% this

 

Had the same thought ages ago.

When in editor some times its hard to select a part but if we could some how have this awesome tool show all parts on the ship while in the editor and allow us to lets say left shift plus click a part in the list of parts it then selects it as the active part we can then move,rotate the part as we see fit.

 

This mod would be even more amazeing if it allowed this function as 1000`s of times I have struggled to select s small part on a craft.

Share this post


Link to post
Share on other sites

Hi. I tried the latest PartWizard on 1.4.3, and got this exception on KSP.LOG:

[LOG 10:16:01.772] [AddonLoader]: Instantiating addon 'PartWizardPlugin' from assembly 'PartWizard'
[EXC 10:16:01.778] MissingManifestResourceException: Could not find any resources appropriate for the specified culture or the neutral culture.  Make sure "PartWizard.Resources.Strings.resour
ces" was correctly embedded or linked into assembly "PartWizard" at compile time, or that all the satellite assemblies required are loadable and fully signed.
        System.Resources.ResourceManager.AssemblyResourceMissing (System.String fileName)
        System.Resources.ResourceManager.InternalGetResourceSet (System.Globalization.CultureInfo culture, Boolean createIfNotExists, Boolean tryParents)
        System.Resources.ResourceManager.GetString (System.String name, System.Globalization.CultureInfo culture)
        PartWizard.Resources.Strings.get_ViewTypeAll ()
        PartWizard.PartWizardWindow..ctor (System.String name, System.String version)
        PartWizard.PartWizardPlugin.Awake ()
        UnityEngine.GameObject:AddComponent(Type)
        AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
        AddonLoader:StartAddons(Startup)
        AddonLoader:OnLevelLoaded(GameScenes)
        AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
        UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

Link to full KSP.log.

Share this post


Link to post
Share on other sites

Very strange, I don't know what happened.

But, I've fixed it with a new release:

1.3.7.1:

  • Updated code for Toolbarcontroller
  • Added ToolbarRegistration
  • removed blizzy/stock options from setting

There is something wrong with the build, please wait

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
  • Rerelease of 1.3.7.1:
  •     Updated code for Toolbarcontroller
  •     Added ToolbarRegistration
  •     removed blizzy/stock options from settings
  • Compiled by hand to fix resource error

Share this post


Link to post
Share on other sites

New release, 1.3.7.3

  • Version bump to fix CKAN and compile issues

Sorry for the bad releases, I think I have it solved.

Share this post


Link to post
Share on other sites

New minor release, 1.3.7.4

  • Added dependency checks for clickthroughblocker and toolbarcontroller
  • Verified build before releasing, to avoid previous issues

Share this post


Link to post
Share on other sites

New release, 1.3.8

  • Added InstallChecker
  • Updated AssemblyVersion
  • Updated for KSP 1.8

Share this post


Link to post
Share on other sites

Hey @linuxgurugamer, just installed the mod and was curious how it would report on some vessels I've built earlier. As soon as I select stage asc. or desc. mode, some lines are displayed on to op each other, flickering like crazy (I'd say 10 or 15 Hertz). This seems only to affect part groups having symmetry (e.g. a radial decoupler plus drop tank in 2x symmetry, the lines for the decouplers and tanks are flickering as if fast changing position with each other), and only happens with vessels built before I installed this mod, not while building new vessels or loading a vessel built with this mod active. 

Is that a known issue?

KSP 1.8.1, PW 1.3.8, I also use EEX 3.4.1, KER 1.1.7.1 and Basic dv 1.8.8, thinking of any mods active in VAB

Thanks and I'm curious for your reply :) 

Share this post


Link to post
Share on other sites

First I've heard of this

Could you send me those craft files?

Share this post


Link to post
Share on other sites
Posted (edited)

Sent you a PM with a link, example craft, stock.

Here all the parts of "2" are affected.

And hovering the mouse over any of lines in "2" makes a wonderful green and yellow stroboscopic light of that stage :D 

In the stage overview on the bottom right I can see the focus fast switching between the decoupler and the Terrier.

Edited by VoidSquid

Share this post


Link to post
Share on other sites

I'm curious, could you reproduce the issue? Or is it just my installation here going bonkers?

Share this post


Link to post
Share on other sites
33 minutes ago, VoidSquid said:

I'm curious, could you reproduce the issue? Or is it just my installation here going bonkers?

I wont have time until tomorrow.

In the meantime, if you want you can make a new install and try it in there

Share this post


Link to post
Share on other sites

It's not that important, but thanks anyway, looking forward for your reply :) 

Share this post


Link to post
Share on other sites
16 hours ago, VoidSquid said:

Hey @linuxgurugamer, just installed the mod and was curious how it would report on some vessels I've built earlier. As soon as I select stage asc. or desc. mode, some lines are displayed on to op each other, flickering like crazy (I'd say 10 or 15 Hertz). This seems only to affect part groups having symmetry (e.g. a radial decoupler plus drop tank in 2x symmetry, the lines for the decouplers and tanks are flickering as if fast changing position with each other), and only happens with vessels built before I installed this mod, not while building new vessels or loading a vessel built with this mod active. 

Is that a known issue?

KSP 1.8.1, PW 1.3.8, I also use EEX 3.4.1, KER 1.1.7.1 and Basic dv 1.8.8, thinking of any mods active in VAB

Thanks and I'm curious for your reply :) 

I see the problem when I select Stage Ascending, but not descending.  Very strange, I'll have to dig into it on Monday night

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

I see the problem when I select Stage Ascending

So I'm not imaging things? Thanks :) 

3 minutes ago, linuxgurugamer said:

I'll have to dig into it on Monday night

As I said, low importance, no worries :) 

Share this post


Link to post
Share on other sites
7 minutes ago, VoidSquid said:

So I'm not imaging things? Thanks :) 

As I said, low importance, no worries :) 

Insomnia, so I took a look.

Low, yes, but very strange.  I'll know more Monday evening when I look at it during my modding stream

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

Insomnia

Be my guest ;) 

3 minutes ago, linuxgurugamer said:

so I took a look

Ty :) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.