Jump to content

[1.11.x] - Modular Kolonization System (MKS)


Recommended Posts

14 hours ago, Planefan 08 said:

Hmm...I really hope that some day they'd make USI compatible with 1.6.1. None of the other mods have it either, but man the stock parts revamp and built-in dV indicators are very very tempting

umm... it's compatible today :)

Link to post
Share on other sites
On 1/14/2019 at 8:37 PM, infinite_monkey said:

I seem to have a (understanding?) problem with the Scout Landing Module. It has a workshop, I can open the workshop window, but when I want to start manufacturing, it says "No workers in the workshop". Where does my engineer have to be in order to make it work? Is there a minimum star-rating the engineer needs?

I noticed that also - no where to put a kerbal in it and it doesn't stack when you place a command can or workshop on it.

16 hours ago, Planefan 08 said:

Hmm...I really hope that some day they'd make USI compatible with 1.6.1. None of the other mods have it either, but man the stock parts revamp and built-in dV indicators are very very tempting

As others have noted - it does work - I am using 1.6.1 right now with USI/MKS.

 

Link to post
Share on other sites
On 1/18/2019 at 10:02 PM, Planefan 08 said:

Hmm...I really hope that some day they'd make USI compatible with 1.6.1. None of the other mods have it either, but man the stock parts revamp and built-in dV indicators are very very tempting

As others have mentioned it already is compatible. You might get some messages about incompatibility but it still works.

I know there's at least one bug I'm waiting for a fix for (or hoping that it's related rather, it's not a confirmed bug) - recyclers resetting themselves when returning focus to a vessel.
Not sure if there are any other issues currently, but I'd say as for 1.6.1 compatibility, it's very playable already today. Just do it™ - download and play!

Link to post
Share on other sites
On 6/22/2017 at 11:11 PM, Aelfhe1m said:

Can confirm this also happens with KSP 1.3, MKS 0.52.1 (latest constellation download with updated USI Tools 0.9.2) and JSIAdvTransparentPods 0.1.14

  Reveal hidden contents

 

Also some of the MKS parts are showing transparency cutaways by default where they shouldn't (e.g. the Tundra agriculture modules). I'm working my way through the parts to compile a complete list. Done - see below

The ag module can be patched to disable transparent pods by adding:

  Reveal hidden contents

@PART[Tundra_Agriculture*]:NEEDS[MKS,JSIAdvTransparentPods]       
{         
	MODULE         
	{         
		name = JSIAdvTransparentPod
		transparentPodSetting = OFF
	}         
}  

 

Edit: so far most Tundra parts seem to have the unwanted transparency issue - probably because of the placeholder interiors being autodetected by jsi?

Edit2: Finished checking all the USI parts.

  • Duna and Ranger parts are OK (non-transparent).
  • Otter cab has same issue as Karibou.
  • Malemute, Honeybadger. AES, HERP and all passenger cabs have no issues (no transparencies).

Hello, just a small catch-up, was this ever adressed ? i can see the glitch as well with 1.5.1 and JSIATP

Link to post
Share on other sites
6 hours ago, Jasseji said:

Hello, just a small catch-up, was this ever adressed ? i can see the glitch as well with 1.5.1 and JSIATP

I use generic IVAs for a lot of that stuff... so until pretty IVAs are made, it's going to be a thing (unless you get rid of the IVA in the config... then no portraits).

Link to post
Share on other sites
18 minutes ago, Infleto said:

Editing the MKS LS config file

Hey, I am trying to edit the MKS config file to double hab time.  I edited both the Life support config file and the MKS config file.  But in game the GUI shows the same hab time for all parts.

The config is only a default.  To change it you need to do it in the GUI in the space center scene

Link to post
Share on other sites
6 hours ago, RoverDude said:

I use generic IVAs for a lot of that stuff... so until pretty IVAs are made, it's going to be a thing (unless you get rid of the IVA in the config... then no portraits).

oh, sorry, i was already falling asleep when writing this - i am actually referring to the Karibou Cockpit which is showing the complete IVA (completely without the outer Hull as the other person posted)  when TransparentPods is installed.

 

In VAB/SPH though, the view is correct (so you see the hull and the IVA through the transparent windows)

Link to post
Share on other sites

Weird thing happening to me;

  • Fresh install of KSP 1.6.1
  • No other mods
  • Latest USI Constellation mod

On the VAB, can't configure the bays of any of the MKS modules:

vHqeWBd.png

While on my other installation (same USI Constellation, KSP 1.4.5) everything looks perfectly:

IROuX6T.png

KSP throws some warnings and errors into the log:

[WRN 16:37:30.908] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\UmbraSpaceIndustries\LifeSupport\Resources.cfg'.

Any idea of what is missing?

 

Link to post
Share on other sites

 

2 hours ago, elijahlorden said:

You are not missing anything.  The other options you see in the previous version are provided by additional mods.  If you only installed USI you will be missing mods like KIS, which provides the 'Seat # inventory' options.

Not all of them: Auto-strut, Fuel Flow, and Rigid attachment are 'Advanced tweakables' and part of the core game, they can be turned on in settings.

Edited by Terwin
clarify Advanced Twekables are stock
Link to post
Share on other sites
17 hours ago, elijahlorden said:

You are not missing anything.  The other options you see in the previous version are provided by additional mods.  If you only installed USI you will be missing mods like KIS, which provides the 'Seat # inventory' options.

Yes, you are right; dumb from my side not noticing.

But then the question shifts to: shouldn't I be able to configure the bays of the Tundra Assembly Plant while in the VAB? I'm also not getting any information about the ratios for resources conversion...

Link to post
Share on other sites
9 hours ago, Kermanzooming said:

Yes, you are right; dumb from my side not noticing.

But then the question shifts to: shouldn't I be able to configure the bays of the Tundra Assembly Plant while in the VAB? I'm also not getting any information about the ratios for resources conversion...

It maybe caused by firesplitter not being installed correctly - can you share a screen shot of your gamedata directory?  (could also be USI tools install)

Edited by RookFett
Link to post
Share on other sites
2 hours ago, RookFett said:

can you share a screen shot of your gamedata directory?

Solved! In the GameData/UmbraSpaceIndustries/MKS/Parts folder there was a folder called 'New Folder', with what looked to be additional copies of the parts. Once deleted, everything works like a charm.

So be careful; if you download the USI Constellation package, be sure  to delete that rogue extra folder.

 

Thanks to @RookFett, @terwin and @elijahlorden for the support!

Link to post
Share on other sites

What am I missing in attempting to configure the industrial and assembly plants?

I'm looking at the chart in the documentation that shows the resource flow.  For example, the putting it together page shows the industrial plant converting metallic ore into metals.  However, I can't find any setting on the industrial bays that takes an input of metallic ore and most of the conversions I can find don't make sense.

(The drill also lists conversions rather than just what it's harvesting but in that case it still seems to harvest what was on the left, the conversion doesn't seem to mean anything.)

KSP 1.4.5

Link to post
Share on other sites
13 hours ago, Loren Pechtel said:

What am I missing in attempting to configure the industrial and assembly plants?

I'm looking at the chart in the documentation that shows the resource flow.  For example, the putting it together page shows the industrial plant converting metallic ore into metals.  However, I can't find any setting on the industrial bays that takes an input of metallic ore and most of the conversions I can find don't make sense.

(The drill also lists conversions rather than just what it's harvesting but in that case it still seems to harvest what was on the left, the conversion doesn't seem to mean anything.)

KSP 1.4.5

The drills don't do 'conversions' the bit with the two resources with an arrow between them is for switching the harvest/production type.  The same interface is used to change the production type of other parts as well.  

The one on the left is current, and the one on the right is what you get if you change it(it costs resources to swap, so you want to make sure you only need to do it once)

The Smelt-O-Matic, Industrial Refinery, and Material Processing Units are what you can use to turn metal ore into metals(depending on which resource each bay is set to refine).

The Assembly Plant and Workshop are used to turn those refined resources into useful materials(like material kits or Machinery).

 

So, to produce metals, you would want your Drill set to metallic ore, and your smelter/refinery/mpu set to Metals to consume metallic ore and produce metals.

For example, to produce material kits, you would need Minerals, Metallic Ore, and Substrate produced from your drills, which in turn would be fed to a refinery to produce Chemicals, Metal, and Polymers, which you could then feed into your assembly plant to make material kits.

Sifters can also produce all of the raw materials at the same time(from Dirt) but at a greatly reduced rate.

 

 

Link to post
Share on other sites
42 minutes ago, Terwin said:

The drills don't do 'conversions' the bit with the two resources with an arrow between them is for switching the harvest/production type.  The same interface is used to change the production type of other parts as well.  

The one on the left is current, and the one on the right is what you get if you change it(it costs resources to swap, so you want to make sure you only need to do it once)

The Smelt-O-Matic, Industrial Refinery, and Material Processing Units are what you can use to turn metal ore into metals(depending on which resource each bay is set to refine).

The Assembly Plant and Workshop are used to turn those refined resources into useful materials(like material kits or Machinery).

 

So, to produce metals, you would want your Drill set to metallic ore, and your smelter/refinery/mpu set to Metals to consume metallic ore and produce metals.

For example, to produce material kits, you would need Minerals, Metallic Ore, and Substrate produced from your drills, which in turn would be fed to a refinery to produce Chemicals, Metal, and Polymers, which you could then feed into your assembly plant to make material kits.

Sifters can also produce all of the raw materials at the same time(from Dirt) but at a greatly reduced rate.

 

 

Ok, that makes a **lot** more sense.  It's a very confusing interface, though!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...