Jump to content

[1.11.x] - Modular Kolonization System (MKS)


Recommended Posts

1 hour ago, Craze said:

It still doesn't work. Waiting for the official release for 1.10.x

There may be a conflict with some mod.

I wouldn't hold your breath.  RoverDude has already implied that an "official" release will be unlikely since MKS already works in 1.10.x with the exception of the light globe issue, for which there is a workaround.  And KSP 1.11 is around the corner.

Post your log file and a better description of what "...doesn't work."  If there's a conflict, there may be a clue in there.

Link to post
Share on other sites
23 hours ago, Feye said:

While I'm at it tho, can someone please explain to me why I should use a Tundra MedBay over a Kolonization Module?

The MedBay is heavier, seems to chug way too much EC and CSupplies for only affecting "Tourist" Kerbals seated in the module itself while the KModule does not have those restrictions and eats less EC and CSup and you don't need a Medic Kerbal either? :huh:

If I understand it correctly, the MedBay can cure Kerbals; the KModule cannot. This matters if a detached expedition's planning is incorrect and it manages to return or be rescued anyway. Otherwise, yes, prevention is better than cure.

Link to post
Share on other sites
17 hours ago, damerell said:

If I understand it correctly, the MedBay can cure Kerbals; the KModule cannot. [..] prevention is better than cure.

Alright that makes sense to me since Kerbals become "Tourists" if their timers expire - something I had not thought of while digging through the *.cfgs, thanks!

Link to post
Share on other sites
19 hours ago, Brigadier said:

I wouldn't hold your breath.  RoverDude has already implied that an "official" release will be unlikely since MKS already works in 1.10.x with the exception of the light globe issue, for which there is a workaround.  And KSP 1.11 is around the corner.

Post your log file and a better description of what "...doesn't work."  If there's a conflict, there may be a clue in there.

I have already deleted the mod and the log file is overwritten. I solved the problem with light globe. But the breaking Ground Expansion add-ons didn't load.

Link to post
Share on other sites

@RoverDude I got an error while starting up the game. All mods (except the WildBlueIndustries) were installed via CKAN:


PartLoader: Part 'UmbraSpaceIndustries/MKS/Parts/LightGlobe/MKS_LightGlobe' has no database record. Creating.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

DragCubeSystem: Creating drag cubes for part 'MKS.LightGlobe'
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at ModuleDeployablePart.AssumeDragCubePosition (System.String name) [0x00088] in <c1858a3f77504bd1aaa946fdccf84670>:0 
  at DragCubeSystem+<RenderDragCubes>d__34.MoveNext () [0x001de] in <c1858a3f77504bd1aaa946fdccf84670>:0 
  at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object

It's not critical for me, I'm just setting up an install to duplicate someone else's setup to do some debugging.

The complete logs are here:  https://www.dropbox.com/s/nays7ar3b608eys/mks-PlayerLog.zip?dl=0

I did a reinstall of all the MKS mods, but got the same error.  

Link to post
Share on other sites
39 minutes ago, linuxgurugamer said:

@RoverDude I got an error while starting up the game. All mods (except the WildBlueIndustries) were installed via CKAN:


PartLoader: Part 'UmbraSpaceIndustries/MKS/Parts/LightGlobe/MKS_LightGlobe' has no database record. Creating.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

DragCubeSystem: Creating drag cubes for part 'MKS.LightGlobe'
 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at ModuleDeployablePart.AssumeDragCubePosition (System.String name) [0x00088] in <c1858a3f77504bd1aaa946fdccf84670>:0 
  at DragCubeSystem+<RenderDragCubes>d__34.MoveNext () [0x001de] in <c1858a3f77504bd1aaa946fdccf84670>:0 
  at UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) [0x00027] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object

It's not critical for me, I'm just setting up an install to duplicate someone else's setup to do some debugging.

The complete logs are here:  https://www.dropbox.com/s/nays7ar3b608eys/mks-PlayerLog.zip?dl=0

I did a reinstall of all the MKS mods, but got the same error.  

Yea it's a known issue.  I haven't looked personally but a page or so back  it was mentioned that this is fixed in the latest code ready to be compiled.

Link to post
Share on other sites

Hi,

1st of all, english is not my native language, so excuse me in advance.

I have several questions, i try to make a space station for several years with mks + living support. Every recipes are "on".

  • Supply. I have 12 kerbals in my station, so i need 129.6 supply / day. I have a tundra kerbitat, so with the 86.5% bonus i only need 17.496 a day right ? i have a tundra agriculture module, with 2 recipe of agroponics. So i need mulch, produced by kerbonaut (i put some small tanks), fertilizer (i have plenty), machinery (i have plenty too) and electricity (i have also plenty with nuclear reactor). But agroponic is only "charged 5%" So of course my small supplies tank is quickly empty ! What i need to do for 100% ? My machinery and fertilizer empty very slowly (as expected), mulch is full quickly and my kerbonaut are starving. By the way "kerbitat"module  need people inside to have the 86.5% bonus ? if yes, it is only for people inside or for the whole station ? Same question for agriculture module, do i need 4 people inside (right now i have 4 farmers lvl 5 inside but still only 5%).
  • Supplies colony.  I have 2 tundra colonization module (to help with very long travel). So i need 18x2 supplies colony/day. I suppose the 86.5% bonus from kerbitat do not apply to supplies colony ? But well after ~3 years, i should need 18x2 x 400 days x 3 = 45 000 supplies colony. But in my game, after 3 years i have burned 421908 supplies colony ! My living module is showing "charged at 886 %". It explain the difference (~45000x8.86), but what the hell is that ? Why not just 100% ? Like agroponic it is just on/off so i really dont understand why 5% and 886% (governor at 0.1 or 1, still 886%). And again same question, do i need the kerbonaut inside to have the bonus ? it only affect kerbonaut inside ? And what is the button "kolony growth" ?

I have read carfully the wiki but i didnt find anything about all these questions.

So thank you in advance for all your answers. (btw i speak badly english but i understand it pretty well so dont be afraid to make complete explanations :o)

 

 

 

Link to post
Share on other sites

MKS manufacturing parts require kerbals to work at full efficiency, the more stars on your highest ranked kerbal of each type the better.

Scientists aid agriponics and other organic related processes

Engineers aid inorganic processes(refining raw materials like metal ore or minerals for example)

Pilots aid with logistics(if you put one in a rover, then your local logistics extends from 100m to > 1km I believe)

Only the highest ranked kerbal of each type counts(scientist or engineer, the rank of the pilot does not matter I don't think)

Also, Colony supplies are less life-support and more luxury supplies to keep your kerbals happy(Kolony modules stop/reverse the habitation and home timers), and no longer matter if your habitation is high enough(pilots stop home/habitation counters if there is 1 year of habitation in the current vessel, Engineers and scientists require 5 years of habitation)

Once you have a station with enough habitation, the only utility of colonization modules(and colony supplies) is for growing your colony(not sure of the details, but you do need at least one male and one female on board for this to work, and it is not quick).

Personally, I just go with a large hab-space for most of my colonies and do not mess with colony supplies

5% sounds like you do not have a scientists on board to boost your agriponics.

You get the same efficiency on the ISRU with no engineer on board.

 

note: the nom-o-matics from USI-LS are not affected by kerbal rank, and I find that they are usually an easier way to turn mulch back into supplies because they only need fertilizer and power.  Also, they always produce at the same rate, making them easier to plan for. 

Link to post
Share on other sites

Can someone please enlighten me in several matters about Ground (Global) Construction containers?
I'm on KSP 1.9.1.

1. How to choose vessel to build from container in flight? I saw it in (old) videos about GC. But I can select vessel for kit in editor only. So if I need to build something off-Kerbin, I have to transport customized container/kit to colony every time?
2. What are the rules for vessels put into dockable kit containers? Simple part with two nodes builds fine, but if I put container with it upside down, workshop just doesn't show this kit in the GUI.
3. Are Tundra-type parts the only ones which can build vessels from kits? Because only this two ground workshops have SKH_Max > 0.0.
 

Link to post
Share on other sites

Question: do the FelxOtubes link up the vessel or leave both shps sperate? i've been looking for a mod to link up vessels without docking ports or claws so i dont have to attach wheels to everything

Link to post
Share on other sites
56 minutes ago, pss88 said:

Can someone please enlighten me in several matters about Ground (Global) Construction containers?
I'm on KSP 1.9.1.

1. How to choose vessel to build from container in flight? I saw it in (old) videos about GC. But I can select vessel for kit in editor only. So if I need to build something off-Kerbin, I have to transport customized container/kit to colony every time?
2. What are the rules for vessels put into dockable kit containers? Simple part with two nodes builds fine, but if I put container with it upside down, workshop just doesn't show this kit in the GUI.
3. Are Tundra-type parts the only ones which can build vessels from kits? Because only this two ground workshops have SKH_Max > 0.0.
 

1) You need a version of GC that allows manufacturing a kit off kerbin, I do not think that this version is currently included in MKS, so you probably want to install GC separately.  You cannot select a different vessel for an already constructed kit, the vessel is set when the kit is created.

2) no clue, I never tried, this, I would build the bits then use KIS/KAS to add them to my base

3) GC has multiple components that can build kits, including a mobile construction unit(you still need to add wheels). I do not remember which MKS parts can build kits, but I think it should be any of the parts that let an engineer assemble specialized parts from refined materials.

Link to post
Share on other sites

I've been using the search function and different combinations of keywords for an hour straight, and I can't find an answer, so I do really apologize if this has been answered before.

I'm playing on 1.8.1 with USI Core, USI Kolonization Systems, USI Life Support, and USI Tools installed. I also have Event Horizon installed (Interstellar Black Hole Planetary System added) and Extraplanetary Launchpads along with some QOL mods. I can't play on a newer version of KSP due to EventHorizon's dependency on Kopernicus.

I love SSTOs optimized to fly into the airstream so fast that going straight towards the horizon is how they reach 70-80k to circularize. So I've spent a while learning how to make a USI compatible SSTO (learning the mod core concepts and applications)

I used two Ranger Habitation modules and one Ranger Agriculture module. These modules are uninflated because for some reason this mod allows the full functionality of converters to work when uninflated, rendering Tundra Kerbitats and Duna Habitation modules woefully out-classed in portability, weight, etc., and being an SSTO, I need to save on space and weight. Any time I left the scene, whether it be loading a quicksave, returning from KSC or Tracking Station, or reopening the game, all of my kerbals decided to (T) pose and become #grumpy. This is a problem. After an hour of narrowing it down, it turns out it's because all of my converters except for my Recyclers all turn off whenever the scene is loaded again. Turning my converters back on brings them back to work, which also confuses me because I thought that whenever a kerbal (T) posed they MUST have a medbay treat them before they return to work. I guess that's broken too?

This cannot be intended functionality since having any more than 3 converters makes re-toggling them all a pain, which is exactly what a real base would have--not to mention the kerbals constantly dying and all work being brought to a halt every single scene load.

What's going on here? Maybe it's a mod conflict? Here are my mods from CKAN and my Game Data folder in case any other mods are here, and not in CKAN, besides EventHorizon.

 

UhqPyp3.png

 

wiPUwLm.png

Link to post
Share on other sites
7 hours ago, rudemario said:

I've been using the search function and different combinations of keywords for an hour straight, and I can't find an answer, so I do really apologize if this has been answered before.

I'm playing on 1.8.1 with USI Core, USI Kolonization Systems, USI Life Support, and USI Tools installed. I also have Event Horizon installed (Interstellar Black Hole Planetary System added) and Extraplanetary Launchpads along with some QOL mods. I can't play on a newer version of KSP due to EventHorizon's dependency on Kopernicus.

I love SSTOs optimized to fly into the airstream so fast that going straight towards the horizon is how they reach 70-80k to circularize. So I've spent a while learning how to make a USI compatible SSTO (learning the mod core concepts and applications)

I used two Ranger Habitation modules and one Ranger Agriculture module. These modules are uninflated because for some reason this mod allows the full functionality of converters to work when uninflated, rendering Tundra Kerbitats and Duna Habitation modules woefully out-classed in portability, weight, etc., and being an SSTO, I need to save on space and weight. Any time I left the scene, whether it be loading a quicksave, returning from KSC or Tracking Station, or reopening the game, all of my kerbals decided to (T) pose and become #grumpy. This is a problem. After an hour of narrowing it down, it turns out it's because all of my converters except for my Recyclers all turn off whenever the scene is loaded again. Turning my converters back on brings them back to work, which also confuses me because I thought that whenever a kerbal (T) posed they MUST have a medbay treat them before they return to work. I guess that's broken too?

This cannot be intended functionality since having any more than 3 converters makes re-toggling them all a pain, which is exactly what a real base would have--not to mention the kerbals constantly dying and all work being brought to a halt every single scene load.

What's going on here? Maybe it's a mod conflict? Here are my mods from CKAN and my Game Data folder in case any other mods are here, and not in CKAN, besides EventHorizon.

Being able to use uninflated ranger modules certainly sounds like a bug, and the auto-turn-off is likely related to that bug.

Kerbals can go Tourist for multiple reasons.

If they go tourist due to lack of EC or supplies, they can be brought back with EC or supplies, if they go tourist due to lack of habitation, they can be brought back by either improving habitation or a med-bay, if they go tourist due to an expired home timer, they can only be brought back by a med-bay.

A med-bay uses colony supplies to reverse hab and home timers, but unlike a colonization module, it can reverse expired timers as well as unexpired timers(but it takes more colony supplies and the kerbal must be inside the medbay).

I do not think the timers stop when a kerbal becomes a tourist, so if a kerbal has been a tourist for a long time, it is probable that only a med-bay can revive them.

 

The mods made by Roverdude should be fine, and the GC, IR and Extraplanetary launch pads mods should also be fine(GC and IR are currently supported and EPL is formerly supported), that seems to leave the visual mods(which may or may not do more then just graphic enhancements), Better time-warp(anything that messes with offline processes is suspect and this mod may or may not do that), Instantiator and ModularFlightIntegrator

First, try reinstalling all the USI mods manually as CKAN is notorious for messing up mod installations.

If that does not work, it is time to start uninstalling mods one at a tie to determine the culprit.

Instantiator says it is only compatible up throutgh 1.3.1, so I would try dropping that one first , followed by modularFlightIntegrator, then better time warp.

I am pretty sure I have heard people mention using MKS with Kopernicus systems, so if the above steps do not work, your options are trying a fresh install or removing the visual mods to see if one of those is the culprit.

 

 

 

Link to post
Share on other sites
4 hours ago, Terwin said:

Being able to use uninflated ranger modules certainly sounds like a bug, and the auto-turn-off is likely related to that bug.

Kerbals can go Tourist for multiple reasons.

If they go tourist due to lack of EC or supplies, they can be brought back with EC or supplies, if they go tourist due to lack of habitation, they can be brought back by either improving habitation or a med-bay, if they go tourist due to an expired home timer, they can only be brought back by a med-bay.

A med-bay uses colony supplies to reverse hab and home timers, but unlike a colonization module, it can reverse expired timers as well as unexpired timers(but it takes more colony supplies and the kerbal must be inside the medbay).

I do not think the timers stop when a kerbal becomes a tourist, so if a kerbal has been a tourist for a long time, it is probable that only a med-bay can revive them.

 

The mods made by Roverdude should be fine, and the GC, IR and Extraplanetary launch pads mods should also be fine(GC and IR are currently supported and EPL is formerly supported), that seems to leave the visual mods(which may or may not do more then just graphic enhancements), Better time-warp(anything that messes with offline processes is suspect and this mod may or may not do that), Instantiator and ModularFlightIntegrator

First, try reinstalling all the USI mods manually as CKAN is notorious for messing up mod installations.

If that does not work, it is time to start uninstalling mods one at a tie to determine the culprit.

Instantiator says it is only compatible up throutgh 1.3.1, so I would try dropping that one first , followed by modularFlightIntegrator, then better time warp.

I am pretty sure I have heard people mention using MKS with Kopernicus systems, so if the above steps do not work, your options are trying a fresh install or removing the visual mods to see if one of those is the culprit.

 

 

 

Thank you for the explanation on hab timers and medbays; it seems I simply didn't notice that the only thing that puts kerbals into a permanent catatonic state is the home timer, and the other timers just need to be brought up from whatever their negative value is at the time of resupply (because the timers still tick) Now I think I fully understand the system.

In regards to the mods, I tried slowly over the course of 2 hours to try various combinations of files. First I tried removing a few mods (bettertimewarp, etc) one by one, no change. Then I tried manually reinstalling the USI mods from their github pages. No luck. Then I tried stripping everything away until I just got down to MKS and USI-LS one by one, and still no luck, I'm still able to use the uninflated converters. So then, I tried getting rid of all mods, no avail. Then, I tried a full fresh clean install of 1.8.1 and ONLY installed MKS and USI-LS.

y6xN9Zd.png

Still able to activate the converters. At this point I was stumped and concluded it was a bug, and by extension this would extend to my other base on the Mun (but which was unmanned), but moving onto damerell's comment

38 minutes ago, damerell said:

Surely the obvious answer is to stop exploiting the bug where the converters work when uninflated. Inflate them when you get to space and see if there is any unexpected behaviour after that.

I inflated the modules shown and the ones on my SSTO pre-launch and tried to leave the scene, and things function as intended. Converters stay on upon scene reload. So either converters being toggleable is intended behaviour because the nature of the game and modding it prevents them from being disabled when uninflated or something, or this is a bug. They work perfectly fine minus a few days/months of hab for habitation modules when uninflated. This seems to me like unintended functionality. If I were to conduct a flight without resetting the scene I could exploit this to make it to Jool without the punishment of a larger craft.

Thank you guys so much for the help. I thought I wouldn't be able to continue building bases but it just turns out I was fooled by unintended functionality. This means I can still play and build a base to explore the new planetary system added by EventHorizon and keep the accretion disk provided by INSTANTIATOR.

Much appreciated guys. I'm excited that I can still use all my mods and continue.

Link to post
Share on other sites
2 minutes ago, The Robot Soldier said:

Does anyone know what this module at the front of this craft is and where to find it. I have MKS and Global Construction installed and I still can't find it in my parts list.  

 

That looks sort of like the orbital construction yard for EPL(?) that I think is still included, but is hidden/disabled.

You may need to move the config file out of a discontinued directory or something to get it back

Link to post
Share on other sites

I’m new to this mod... I’m in a career save with KSPIE and ground construction, and now I’m seeking to build a colony on Minmus. How to expand a base? Putting everything on wheels and dock them  significantly increases part count, and thus inconvenient.

Link to post
Share on other sites
1 hour ago, SynX said:

How to expand a base?

You can use the MKS logistics feature to create bases out of vessels in close proximity to each other but not physically attached. 

For a more detailed explanation see: https://github.com/UmbraSpaceIndustries/MKS/wiki/Functions-(Logistics)

Or it you do want them attached you can use the MKS Kerbitrail(tm) FlexOTube (see https://github.com/UmbraSpaceIndustries/MKS/wiki/Parts-(MKS-General-Components)#construction-bits )

Link to post
Share on other sites
2 hours ago, SynX said:

I’m new to this mod... I’m in a career save with KSPIE and ground construction, and now I’m seeking to build a colony on Minmus. How to expand a base? Putting everything on wheels and dock them  significantly increases part count, and thus inconvenient.

I like using KIS/KAS, as that adds a few tools(wrench and power screw-driver) that allow engineers to attach and detach modules.  There are range limits and a weight limit based on the number of kerbals in-range, but those can be changed in a config file if they get too bothersome, or, you can install RoverDude's Konstruction mod which has parts that add to the amount of mass an engineer can move around using KAS(fork-lift parts, crane parts, etc)

This also allows me to remove things that are no longer needed like engines, wheels, and reaction wheels, and reduces/eliminates the need for lots of docking ports(if I remember correctly, the number of available docking ports in physics range has an exponential impact on frame rates due to each one checking if each of the others are in-range)

Link to post
Share on other sites
5 hours ago, SynX said:

I’m new to this mod... I’m in a career save with KSPIE and ground construction, and now I’m seeking to build a colony on Minmus. How to expand a base? Putting everything on wheels and dock them  significantly increases part count, and thus inconvenient.

 

4 hours ago, Caerfinon said:

You can use the MKS logistics feature to create bases out of vessels in close proximity to each other but not physically attached. 

For a more detailed explanation see: https://github.com/UmbraSpaceIndustries/MKS/wiki/Functions-(Logistics)

This.

 MKS was built on the premise that certain things dont have to be attached to allow for transfers and sharing.

But, if you need, I use EVA transfer from @DMagic. It's much simpler if you don't want the overhead of KAS/KIS

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...