Jump to content

[1.11.x] - Modular Kolonization System (MKS)


Recommended Posts

5 hours ago, Valerik2231 said:

Hi. You can help me? Miner drills ressource switching not working in fly.  I can see in VAB next button:

Bay1 Dirt=>gipsum; gipsum => minerals; minerals=> substate etc.

 

Also, some drills were not loaded into the game.

Game ver. 1.10.1

Sorry for my English.

You need an engineer outside your vessel, and I think some resources(materials kits and possibly specialized parts) to switch modules(Some parts need kits, other need kits+spec parts, others can swap with just an engineer, I forget which of those drills are)

Generally if you have the 'X -> Y' with a button to change y, then a button to move Y into X, you require some resource that gets consumed, so I am pretty sure drills need more than just an engineer on hand to switch what a drill is harvesting.

(for example: cargo containers just cycle through all options with one button, as they do not require any parts to change, so nothing is lost if you must cycle through several to get to what you want)

1 hour ago, been said:

 

rover dude I was wondering when we were going to get these new 50 meter parts 

The 50m parts('Atlas') are planed to be added along with W.O.L.F and they are slated to be added in the 'Next' version of MKS.

(Originally 'next' was 1.8, I think, but then RoverDude got busy, and he has had less time to tweak the game balance/add finishing touches/etc.  This delay *may* be related to RD contributing to KSP 2, or perhaps his real life just got busy).

In any case, it is generally considered impolite to pester the modders about next/planed releases.

(not that RD has ~180 followers[receiving email alerts] on this thread, ready to jump on W.O.L.F. as soon as it comes available, concerned about no more beta releases available from his twitch or anything)

Link to post
Share on other sites

Hello! I tried downloading and installing this last night. I'm on 1.10, and I applied the patch for the GlobeLamp file so it would run, and it installed and ran just fine. But when I got into the game, I noticed that the only parts were a few couplers/nodes and some mining drills, which were missing their textures. The rest of the models were missing. I looked in the file and confirmed that most of the parts were not there. I downloaded the mod from GitHub, so I checked the git directories to see if maybe my download was incomplete, and I noticed those files were missing from GitHub as well. I also checked the file on SpaceDock, and when I downloaded that, they were also missing. Is this a known problem? Is there any place that is hosting the complete MKS file?

Link to post
Share on other sites
15 hours ago, been said:

20m MKS base parts :) : KerbalSpaceProgram

rover dude I was wondering when we were going to get these new 50 meter parts 

Soon(tm)

9 hours ago, PathologicalGeometry said:

Hello! I tried downloading and installing this last night. I'm on 1.10, and I applied the patch for the GlobeLamp file so it would run, and it installed and ran just fine. But when I got into the game, I noticed that the only parts were a few couplers/nodes and some mining drills, which were missing their textures. The rest of the models were missing. I looked in the file and confirmed that most of the parts were not there. I downloaded the mod from GitHub, so I checked the git directories to see if maybe my download was incomplete, and I noticed those files were missing from GitHub as well. I also checked the file on SpaceDock, and when I downloaded that, they were also missing. Is this a known problem? Is there any place that is hosting the complete MKS file?

Are you on career or science?  And you have CCK correct? (Bundled with it)

Link to post
Share on other sites
11 minutes ago, Shialac said:

Hey, i am unable to find this mod on CKAN. Any Advice? Or should I just go for a manual installation?

You will need to adjust compatibility so that you can see 1.7.x compatible mods.

It is generally better to manually install, but you should see it in ckan if you check compatibility.

Link to post
Share on other sites
18 hours ago, Shialac said:

Hey, i am unable to find this mod on CKAN. Any Advice? Or should I just go for a manual installation?

Manual installation is a last resort; CKAN metadata gets dependencies and conflicts right for you (if it's right, but if it's not, at least it only has to be fixed once to help everyone). You'll need in any event to go back up the thread to find the fix for the light globe part.

Link to post
Share on other sites

For some odd reason, folks in this thread are declining to answer the simple question "How do I make this work in 1.10.1?" with an actual answer, instead opting to tell people to look a vague number of pages back.

LightGlobe.cfg must be deleted from the the MKS parts folder/

Link to post
Share on other sites
6 hours ago, dlrk said:

For some odd reason, folks in this thread are declining to answer the simple question "How do I make this work in 1.10.1?" with an actual answer, instead opting to tell people to look a vague number of pages back.

If I had known the answer, I would have posted it. Since I didn't, I posted how to find it. Given a choice between me rummaging through the thread and the person who actually needs to know doing it, I declined to do it myself. What's odd about that?

Link to post
Share on other sites
7 hours ago, dlrk said:

For some odd reason, folks in this thread are declining to answer the simple question "How do I make this work in 1.10.1?" with an actual answer, instead opting to tell people to look a vague number of pages back.

Not odd.  There is nothing wrong with pointing people to find the answer.  If more people did that, this thread would probably be half the size.  Going back 2 pages the "fix" is mentioned at least once for each page.  In fact 2-3 pages back you have someone posting that it doesn't work in 1.10 literally one post after someone re-posted the fix.

I'd change that to, for some odd reason people just post that it is broken without taking a small amount of time to search the thread for a fix first.

 

7 hours ago, dlrk said:

LightGlobe.cfg must be deleted from the the MKS parts folder/

Actually there are 2 options.  Delete the file or grabbed the fixed file from the github repo.  It has been fixed but just not published yet in a new release.

 

Link to post
Share on other sites
30 minutes ago, dlrk said:

The version warning is just a warning that can be ignored, right?

There is one part(light globe) that does not work with KSP 1.10, you can either delete that part config(it stops on that part showing the path where to find it during game loading) or you can download an updated version fro github.

Other than that, the latest version of USI-MKS works fine on KSP 1.10.1

Link to post
Share on other sites

Hello! So i'm a noob so I do apologize for my ignorance but I have been searching for answers for a while and just cant seem to find them. I deleted the light globe out to get this mod to work but there's something that's confusing me. I spent some time reading about the mod and there are some nodes in the expanded tech tree I feel should have assets in that are empty. the nodes are "Recycling", "Storage Technology", "Colonization", and "Advanced Colonization". Am I right in assuming there should be items in these nodes with this mod installed or are they nodes for other mods? If so which mods?

Link to post
Share on other sites
45 minutes ago, Sky High said:

Hello! So i'm a noob so I do apologize for my ignorance but I have been searching for answers for a while and just cant seem to find them. I deleted the light globe out to get this mod to work but there's something that's confusing me. I spent some time reading about the mod and there are some nodes in the expanded tech tree I feel should have assets in that are empty. the nodes are "Recycling", "Storage Technology", "Colonization", and "Advanced Colonization". Am I right in assuming there should be items in these nodes with this mod installed or are they nodes for other mods? If so which mods?

The community tech tree has a large number of nodes that may or may not be used by other mods.  I strongly suspect that to fill all of the nodes, you would need to install enough mods that the conflicts would break your game.

The alternative is to install the mod that hides empty nodes.

Link to post
Share on other sites
7 hours ago, Terwin said:

The community tech tree has a large number of nodes that may or may not be used by other mods.  I strongly suspect that to fill all of the nodes, you would need to install enough mods that the conflicts would break your game.

The alternative is to install the mod that hides empty nodes.

Yes, and I am very specifically asking about certain nodes to figure out if those nodes should have parts in them for this specific mod. I feel after reading about this mod and the recycling systems and colonization systems, the nodes I mentioned would have parts in them. I have scoured the internet and cant figure it out. So if you know if the specific nodes I mentioned should have parts in them for this specific mod that would be really helpful. Other than that, empty nodes don't bother me.

Link to post
Share on other sites
13 minutes ago, Sky High said:

Yes, and I am very specifically asking about certain nodes to figure out if those nodes should have parts in them for this specific mod. I feel after reading about this mod and the recycling systems and colonization systems, the nodes I mentioned would have parts in them. I have scoured the internet and cant figure it out. So if you know if the specific nodes I mentioned should have parts in them for this specific mod that would be really helpful. Other than that, empty nodes don't bother me.

Look at the CTT config in patches and your answer will be there.

Link to post
Share on other sites
2 hours ago, Sky High said:

Can you point me in the correct direction for that? I don't know where to look for that and as I stated, I'm ignorant. I'm trying to learn. Please help

RoverDude was saying KSP\GameData\UmbraSpaceIndustries\MKS\Patches\MKS_CTT.cfg is the file to check for any references to that node.

For example,

@PART[Tundra_Kerbitat375]:NEEDS[CommunityTechTree]
{
    @TechRequired = longTermHabitation
}

indicates that the Tundra 3.75m Kerbitat should be in the longTermHabitation module.

Link to post
Share on other sites
53 minutes ago, Terwin said:

RoverDude was saying KSP\GameData\UmbraSpaceIndustries\MKS\Patches\MKS_CTT.cfg is the file to check for any references to that node.

For example,

@PART[Tundra_Kerbitat375]:NEEDS[CommunityTechTree]
{
    @TechRequired = longTermHabitation
}

indicates that the Tundra 3.75m Kerbitat should be in the longTermHabitation module.

This is extremely helpful. Thank you so much!

Link to post
Share on other sites

So, I can't seem to get the kontainers to work. The parts themselves exist, but they don't actually hold anything, and there's no way to switch types in the menu that I'm aware of.

I seem to recall from my last playthrough that you'd just put the kontainer on your ship, then right click it and cycle through options there, much as one would change the colour of a fuel tank. But there's no option there for anything to do with changing the type, or filling it up. It basically acts like a giant structural piece.

Am I mistaken, and that's not how they work, or am I experiencing a bug? Every other part works fine, afaik, including the kolonization modules like the habitats, which can store a small amount of the same materials. It's just the shipping kontainers that don't work. 

Link to post
Share on other sites
5 minutes ago, strigon said:

So, I can't seem to get the kontainers to work. The parts themselves exist, but they don't actually hold anything, and there's no way to switch types in the menu that I'm aware of.

I seem to recall from my last playthrough that you'd just put the kontainer on your ship, then right click it and cycle through options there, much as one would change the colour of a fuel tank. But there's no option there for anything to do with changing the type, or filling it up. It basically acts like a giant structural piece.

It sounds like you might be missing a file or a supporting mod.

If you installed MKS with ckan, try removing it and putting it back, or removing it and installing the mod manually.(the zips on github include all required dependencies)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...