Jump to content

[1.12.x] - Modular Kolonization System (MKS)


RoverDude
 Share

Recommended Posts

1 minute ago, watain895 said:

Awesome, I was hoping that would be it, makes it ideal for pioneer testing. Thanks for the quick reply!

As a general point, if you're on Laythe, water can be obtained for agriculture (if you're doing it that way) very easily thanks to its high concentration in the ground and oceans (use the Ventral Ocean Extractor from Karbonite to extract it and ship it off via PL) - I don't know of any part than can extract it from the atmosphere; maybe KSPIE has one?

Link to comment
Share on other sites

50 minutes ago, RoverDude said:

for harvesting, I'd recommend Karbonite vs KSPIE as the latter comes with a huge amount of other stuff that may or may not mesh well.

Does Karbonite provide a means of extracting atmospheric water? I thought it only did Ka/Ka+.

Link to comment
Share on other sites

Just now, voicey99 said:

Does Karbonite provide a means of extracting atmospheric water? I thought it only did Ka/Ka+.

Extract atmospheric karbonite and convert it to water if you're so inclined.   Or just toss an MM patch on the atmospheric scoops that come with it (or even a PR if someone wants to get punchy).

Link to comment
Share on other sites

13 minutes ago, RoverDude said:

Extract atmospheric karbonite and convert it to water if you're so inclined.   Or just toss an MM patch on the atmospheric scoops that come with it (or even a PR if someone wants to get punchy).

Instead of spamming extractors for all the gas resources (which I would be happy to write configs for), would it be possible for the scoop to extract a full gas mix (Karbonite would still be its own filter) as a new resource (like dirt) and run it through a new fractioning part that would separate them out in the same manner as the sifter does - or is that too much work for what it's worth/beyond the scope of Karbonite?

Edited by voicey99
Link to comment
Share on other sites

I tried to balance the crew of my various bases to make the kolonization stats grow somewhat equally, but manually counting heads and checking how many crew present increases which stats go tedious very quickly.

So I decided to change the kolonization monitor to display how many crew are present that increase each of the three kolonization stats. The coding wasn't too hard so I committed and pushed to a branch on my fork. So far so good.

However when I tried to make a pull request from there, it included a dozen other commits and listed some changes to CustomAstronautComplexUI.cs that I didn't make... see here.

Is this normal or did I make a mistake? I'm not very good with git, it seems to be completely orthogonal to my way of thinking.

So please let me know if I should go ahead with this PR as is or if I need to fix something first, thanks.

[edit] If I make a PR against MKS/master instead of MKS/DEVELOP the unexpected CustomAstronautComplexUI.cs changes don't show up. But I believe all PR's should be against DEVELOP?

Edited by jd284
Link to comment
Share on other sites

2 hours ago, jd284 said:

However when I tried to make a pull request from there, it included a dozen other commits and listed some changes to CustomAstronautComplexUI.cs that I didn't make... see here.

Is this normal or did I make a mistake?

Your change is based on the master branch, but your PR is asking to merge it to DEVELOP.  That means it has the side effect of also merging any other changes that are on master but not DEVELOP.  Generally there shouldn't be any, but it looks like someone else made some changes directly on master at some point in the past.

As far as your own PR is concerned, it'd be best to rebase it to DEVELOP so that it can be merged to DEVELOP cleanly.  Basically you'd use the rebase command to replace your current commit (that's based on master) with a new one that's based on DEVELOP, then force-push it to GitHub to update your PR.

However, that change in CustomAstronautComplexUI.cs really ought to be merged to DEVELOP at some point.  I think the MKS releases are typically actually compiled from DEVELOP, not master, and this discrepancy is the reason why #1324 is still a bug, because the fix is in the repository but not on the branch that actually gets released.  Fortunately, someone just recently made the exact same fix on DEVELOP.  If PR #1351 gets merged, that'll resolve the discrepancy (and it shouldn't cause a conflict when merged to master later, because the change is identical.)

(Edit: PR #1351 has been merged, so the problem described in the preceding paragraph has been resolved.)

Edited by Wyzard
Link to comment
Share on other sites

On 10/31/2017 at 1:49 PM, RoverDude said:

Your best bet for getting anything sorted is to provide better detail, current versions (i.e. I still have people reporting issues that are running on 1.3.0 - which does me no good), and logging github issues.  Tossing out issues with no info in the thread makes for more work for people searching later, and makes my job of support a lot more difficult as well.

I can't really log an issue based on voicey99's PR (https://github.com/UmbraSpaceIndustries/MKS/pull/1340). But i assure you, any further comments will be posted at github.

On another note, i know that i can refuel reactors with an engineer & maintenance. But how on earth do you transfer the actual fuel on site, to a rover for instance, so it can reach the remote site? Hook the rover to the nuclear refinery and wait for it to fill? 

Link to comment
Share on other sites

1 hour ago, k=mc2 said:

Is this mod compatible with OSX?

No reason why it woudn't be, since it's a KSP mod and KSP runs on OSX

16 minutes ago, Esendis said:

On another note, i know that i can refuel reactors with an engineer & maintenance. But how on earth do you transfer the actual fuel on site, to a rover for instance, so it can reach the remote site? Hook the rover to the nuclear refinery and wait for it to fill? 

That's one choice, sure.  Claw or docking port, fill, then rover/fly away.

Link to comment
Share on other sites

How do efficiency parts work? 

Current scenario, I've got a Minmus base with two ranger ago modules, I have currently have one set to Dirt and the other to greenhouse.  What does the eMultiplier of 3.47 actually mean for the math of Dirt cultivation?  Is it actually providing an output of 3.47x for same input resources?

 

 

---edit---

@voicey99 thank you for your help,

 

The mission is only on the Mun so I think for now I'll just tag the crew of that mission as vets and make mental note to rotate them off instead of resupplying them. 

Edited by mike5brown
Forgot to thank voicey99
Link to comment
Share on other sites

6 minutes ago, mike5brown said:

How do efficiency parts work? 

Current scenario, I've got a Minmus base with two ranger ago modules, I have currently have one set to Dirt and the other to greenhouse.  What does the eMultiplier of 3.47 actually mean for the math of Dirt cultivation?  Is it actually providing an output of 3.47x for same input resources?

It increases the *rate*, not the *output*.  So you'll get 3.47x the output for 3.47x the input - in the same time.  (I'm not 100% sure the multiplier is quite that simple, but I am sure the input and the output will go up at the same ratio.)

Link to comment
Share on other sites

2 hours ago, Artem Belov said:

Am I doing something Wrong Ive installed the mod and i can see Exactly 0 of the parts of the mod here

Gotta give a lot more information.  KSP version?  MKS version?  Where did you download it from?  Do you have the latest USI Tools? (KSP AVC will prompt for this), etc.

Link to comment
Share on other sites

3 minutes ago, Terra1 said:

I have the latest version of MKS and KSP 1.3.1, I downloaded it from spacedock, some of the parts aren't showing up unless I go into the "Advanced Mode" tab in the VAB (Top left)

Help?

(I have the latest USI tools)

It should have created several new categories in Simple Mode for the parts. Check for them.

Link to comment
Share on other sites

14 minutes ago, Aelfhe1m said:

Make sure you have the most up to date version of  USI Tools installed. If that still doesn't work then post a link to your log files ("How to get support") and we'll try to figure out what's wrong.

I downloaded the latest version of MKS from spacedock. So I have USI Tools, also, I looked for the log yesterday but it wasn't where the page said it was (I found a unity shader cache, that's it.)

 

Edited by Terra1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...