Jump to content

[1.12.x] - Modular Kolonization System (MKS)


RoverDude
 Share

Recommended Posts

4 hours ago, ZAJC3W said:

Just a heads up.

MKS/OKS depends on Global Construction Core which is still not updated to 1.8.0 and is spamming in VAB:

[EXC 21:09:25.687] MissingFieldException: Field 'KSPWheelController.wheelCollider' not found.
	AT_Utils.Metric..ctor (IShipconstruct vessel, System.Boolean compute_hull, System.Boolean world_space) (at <884dc0722e2f44d080ac1ddc449a08e3>:0)
	GroundConstruction.VesselKit..ctor (PartModule host, ShipConstruct ship, System.Boolean assembled, System.Boolean simulate) (at <ee2790a7aadc42028b18e84465689e22>:0)
	GroundConstruction.GCEditorGUI.Update () (at <ee2790a7aadc42028b18e84465689e22>:0)

 and causing quite a lag.

 

As @DoktorKrogg noted, I've pulled GC from the bundle.  If CKAN nabbed it, delete GroundConstruction and you will be fine.

Link to comment
Share on other sites

2 hours ago, ZAJC3W said:

Awesome, Thanks!!

Laziness of using ckan has it's downfalls.

Also be aware that someone set some versions of USI mods to 1.x on ckan, so in addition to making it look like they are working before they actually are, this may lead to additional wonkiness down the road.

19 hours ago, [email protected] said:

Now just one more mod... but I may try a duped save anyway.

I know what you mean, the last WOLF stream was before the release of 1.8(and the download has been removed), so if I switch over now, I expect I would lose the nodes I set up on Kerbin and the Mun.

Link to comment
Share on other sites

8 hours ago, t6jesse said:

@ZAJC3W It's up to date, I've been using it

 

https://github.com/UmbraSpaceIndustries/MKS/wiki

First line on that link:

This page reflects changes implemented in 0.50, but prior to 0.50.9. Some of the ratios may be off unless noted otherwise

from git hub:

USI Kolonization Systems v0.50.9.0
@BobPalmer BobPalmer released this on 5 Jan 2017 · 448 commits to master since this release

well over 2 years, nearly 3 behind, is not up to date in my books ;)

But if it's close enough then fine, i'll work out exact ratios as i go.

Edited by ZAJC3W
Link to comment
Share on other sites

21 minutes ago, ZAJC3W said:

First line on that link:

This page reflects changes implemented in 0.50, but prior to 0.50.9. Some of the ratios may be off unless noted otherwise

from git hub:

USI Kolonization Systems v0.50.9.0
@BobPalmer BobPalmer released this on 5 Jan 2017 · 448 commits to master since this release

well over 2 years, nearly 3 behind, is not up to date in my books ;)

But if it's close enough then fine, i'll work out exact ratios as i go.

Time is less important than changes.  Most of the ratios etc have been pretty well set for years.

The Wiki is a community project.  Please feel free to update as you play through.

Link to comment
Share on other sites

1 hour ago, ZAJC3W said:

well over 2 years, nearly 3 behind, is not up to date in my books ;)

But if it's close enough then fine, i'll work out exact ratios as i go.

A lot of the more recent stuff has been a focus on WOLF(currently in Beta), and the Atlas class MKS components(the domes).  Before that was integration with Global Construction, then local resource sharing and logistics if I remember correctly(or possibly the unmanned drills and processing units).

But the major components have not changed markedly in a while, as they do a good job of working as intended.

(I was planning to say I made updates much more recently than 2017, but most of those installs seem to be from 2016 or early 2017, so probably not)

That said, does anyone know if the 2.5m and 3.75m MPUs were fixed so that the Fertilizer(G) settings produce fertilizer and not chemicals?  I don't generally use those sizes for fertilizer so I never checked and updated the Functions page on the Wiki...

 

Link to comment
Share on other sites

On 10/31/2019 at 6:10 PM, Terwin said:

That said, does anyone know if the 2.5m and 3.75m MPUs were fixed so that the Fertilizer(G) settings produce fertilizer and not chemicals?

Looking at the part configs, it seems that all of the MPU recipes are configured to make what what they claim to make.

Link to comment
Share on other sites

12 hours ago, DoktorKrogg said:

Looking at the part configs, it seems that all of the MPU recipes are configured to make what what they claim to make.

Ok, I vaguely remember it being fixed way back when, but apparently never got around to updating the wiki.

Edit: Fixed now.

Edited by Terwin
Link to comment
Share on other sites

22 hours ago, RoverDude said:

Less broken and more visually odd.  I'll have to take a look.

If you're going to take a look, can you please check these 2 possible cases for visual oddness?

  • MKS Tundra 2.5m Hub.
  • Construction docking ports.

 

foMXc0J.jpg
MKH part with shading issues. Also, the center part of the Space Station is a Tundra hub that renders in black (not highlighted).

nwF5jmO.jpg
Construction docking ports with shading issues?

Although they might look odd, functionality is at 100% (no gameplay issue whatsoever).

Link to comment
Share on other sites

On 5/2/2019 at 9:00 PM, DoktorKrogg said:

I just submitted PR#136 to hopefully address both of these issues. I added a new MM patch that looks for any part that holds MatKits and then adds the USI_ModuleRecycleBin if it doesn't already have it. I also noticed that the patch for USI_ModuleFieldRepair didn't have an @ in front of the RESOURCE filter. So hopefully adding that will fix that patch as well. If any of you who have been experiencing either of these issues would like to try out these fixes before we merge them into the next release, that would be helpful. 

I found, that this patch still isn't working and module USI_ModuleFieldRepair isn't added to parts. I brought this to the MM thread and the reason for the nonfunctionality is, that you can't have OR syntax in HAS block. I submitted PR# 142 to fix it.

In the MKS repository is related issue for this: Issue# 1449

Edited by maja
Link to comment
Share on other sites

Hi!

I want to start playing with this mod for the first time! Before that, I decided to try the mod in the "sandbox" mode, not in the career. There were 2 questions

1. If not used "Filter Extention" mod, than Orbital Shipyard and Mobile Launch Platform  modules are not in the parts lists anywhere.

2. I'm trying to build my first shipyard station. Used the following parts:

In VAB, before start, I fill them full of all resources and engeners. After launch of the mission in window "Workshops" i see string "No operation workshops" (screenshot https://imgur.com/cOmT9mJ). What am I doing wrong?

My mods https://imgur.com/nB7DGMR All this mods installs auto, then i install MKS (except Filter Extention).

KSP 1.8.1

Edited by nickicool
Link to comment
Share on other sites

18 minutes ago, nickicool said:

 

1. If not used "Filter Extention" mod, than Orbital Shipyard and Mobile Launch Platform  modules are not in the parts lists anywhere.

2. I'm trying to build my first shipyard station. Used the following parts:

In VAB, before start, I fill them full of all resources and engeners. After launch of the mission in window "Workshops" i see string "No operation workshops" (screenshot https://imgur.com/cOmT9mJ). What am I doing wrong?

There's a reason the Orbital Shipyard and Mobile Launch Platform aren't visible unless you dig for them, and that's because they were stripped of their functionality (which was with ExtraPlanetary Launchpads) and depreciated years ago. The shells of the parts are only around for compatibility.

Edited by voicey99
Link to comment
Share on other sites

6 minutes ago, voicey99 said:

There's a reason the Orbital Shipyard and Mobile Launch Platform aren't visible unless you dig for them, and that's because they were stripped of their functionality (which was with ExtraPlanetary Launchpads) and depreciated years ago. The shells of the parts are only around for compatibility.

This means now for build ships on orbit need use only parts and all the mechanics from Ground Construction?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...