RoverDude

[1.3] - Modular Kolonization System (MKS)

Recommended Posts

Well, at least its not my reading comprehension.  I've stacked it with both Geologists and Engineers (two-star new hires) and still nothing.  Bug report on this then?

Share this post


Link to post
Share on other sites
1 minute ago, Cmdrdogsworth said:

Well, at least its not my reading comprehension.  I've stacked it with both Geologists and Engineers (two-star new hires) and still nothing.  Bug report on this then?

You only get the crew bonus once, as per the highest skill level of the relevant crew.

Share this post


Link to post
Share on other sites

What is the intended use case for the yellow ground pylon?  Its not listed in the wiki anywhere.

Share this post


Link to post
Share on other sites
Just now, eberkain said:

What is the intended use case for the yellow ground pylon?  Its not listed in the wiki anywhere.

Anchoring bases to the ground with uneven terrain when using Ground Construction and DIYKits to deploy base components.

Share this post


Link to post
Share on other sites
Just now, RoverDude said:

Anchoring bases to the ground with uneven terrain when using Ground Construction and DIYKits to deploy base components.

I gotcha

Share this post


Link to post
Share on other sites
On 12/27/2017 at 8:07 PM, williamhall531@gmail.com said:

i am missing the orca command pod thingy. im pretty sure i have the latest versions of MKS. help me please

I am pretty sure the orca command pod is in a different Rover Dude mod, perhaps Malemute Rover or USI Exploration pack?

Share this post


Link to post
Share on other sites
4 minutes ago, Terwin said:

I am pretty sure the orca command pod is in a different Rover Dude mod, perhaps Malemute Rover or USI Exploration pack?

It's in Freight Transport Technologies (FTT). The shot with it in would be better off changed out, since it confused people.

Share this post


Link to post
Share on other sites

So.. any news on some larger parts?  I read a few posts ago that planetary warehousing "isn't for ongoing use" and this compounds the overall problem that I have with MKS, which is that you need a LOT of parts to build a base, which kills framerates, esp. when you have to land a 80-100 part starship near it to resupply/crew transfer.

I often find that my SSTOs that deliver personnel and cargo to a base are actually bigger than the actual base, and that due to hab/home timers, I can only put about 10-15 kerbals into a base that seats 100, and this 10-15-kerbal-supporting-base has close to 80 parts itself because they're all so small... I know RoverDude has said he doesn't like tweakscale, and that larger parts are "coming" but I haven't heard anything on this in a while since the last pre-renders of the 3D models a few months ago.

As for planetary logistics, one solution I came up with to the lots-of-small-parts-cause-performance-issues was to put several bases all over the mun (or wherever), and an equatorial supply base where I can drop supplies and other materials so that it can inject into planetary logistics and feed the other bases farther away without me having to bring a supply craft within physics range.  This seems to work, but if planetary logistics aren't intended for long-term, not sure how long it'll last :)

In my last save, I tried putting all the components within physics range of each other to use local logistics with.. after 2 or 3 components my frame rate was unusably slow due to the 200+ parts within physics range, so that wasn't a good way to go.

Share this post


Link to post
Share on other sites

I love the mod, but I just want to build and have fun, without all that planning with resources and management, I was wondering if there was a way to disable all that with needed resources to deploy a habitat, so I just press deploy, and it just deploys, no extra stuff needed.

Thanks beforehand.

Share this post


Link to post
Share on other sites
5 hours ago, buih@live.dk said:

I love the mod, but I just want to build and have fun, without all that planning with resources and management, I was wondering if there was a way to disable all that with needed resources to deploy a habitat, so I just press deploy, and it just deploys, no extra stuff needed.

Thanks beforehand.

Don't use Life support and you don't need to worry about habitat and food and all of that production.  Honestly the easiest way to get around the rest is to use Hyperedit.  It allows you to fill up various "supplies" so you could use it to for example, add the proper material kits necessary to deploy the various structures.

Share this post


Link to post
Share on other sites

Hi. Love the Mods. Only been using it them for a few days and still getting a feel for how everything works. Have some issues and suggestions.

1. Is it possible to add your own solid (crew style) connection tubes with lights on. I knownyou have the expandable auto tubes, but they always look grey, cant change the colour and just dont have the same feel as the rest of your components. Have some solid units of different lengths to connect parts would be nice. As it is i have to install other mods just to get better looking connecting tubes.

2. Would it be possible to add ground tether all your parts, or maybe even just the stabilsers of the konstruction. I installed a logistics module in wrong place, undocked it with my little konstruction rover to move it and found it remained tethered, and my poor little rover had very hard time moving it as no part had the disable tether option and the container appeared to keep the tether active.

3. Some but not all of your modules have the turn on lights option but no lights fitted. Be nice to have the modules with the own self illumination rather than have to install lights externally which add more part count.

4. Any chance of a fuel refinery module with the same look and feel as you other units, rather than just the grey looking stock ones?

5. Larger weldable docking ports, to fit some of the larger style stock  parts and on othe mods.

6. Have the same issue as some others where not all usi parts appear in menus. All the mods are up to date, and have the usi style icons for konstructiin, konlization etc. But have to type umbra in search to see all parts. No big deal as i got used to it now, but be nice to why items such as your landing legs dont appear in any menu. Also i dont have an icon under manfacturing for umbra or usi, am i supoosed  have one?

Ps. Icons dont appear even if just the your mods only are installed, so def not a conflict with another mod.

7. My kerbitat modules say they have the ability t be configured fr different options in the description. They have the buttons in the menu for changing options, but they do nothing are they supposed to work?

Anyway, great mod, not installed the life support yet, waiting until i get to know all the parts first before i jump in and start killing my litle kerbals

Share this post


Link to post
Share on other sites
1 hour ago, Bionic bulldog said:

4. Any chance of a fuel refinery module with the same look and feel as you other units, rather than just the grey looking stock ones?

there used to be one until ISRU was rolled into stock, RoverDude's reasoning for removing it was "not re-inventing the wheel"

 

Quote

7. My kerbitat modules say they have the ability t be configured fr different options in the description.

You need MaterialKits, SpecializedParts & Electric Charge. also a kerbal on EVA needs to change it.

MKS Wiki good source for information.

Edited by Tabris
additional info

Share this post


Link to post
Share on other sites
2 minutes ago, Tabris said:

there used to be one until ISRU was rolled into stock, RoverDude's reasoning for removing it was "not re-inventing the wheel"

I see. Good reasoning, just would have been nice is all.

Share this post


Link to post
Share on other sites
2 hours ago, Bionic bulldog said:

6. Have the same issue as some others where not all usi parts appear in menus. All the mods are up to date, and have the usi style icons for konstructiin, konlization etc. But have to type umbra in search to see all parts. No big deal as i got used to it now, but be nice to why items such as your landing legs dont appear in any menu. Also i dont have an icon under manfacturing for umbra or usi, am i supoosed  have one?

Ps. Icons dont appear even if just the your mods only are installed, so def not a conflict with another mod.

What version of USITools do you have? 0.10.0.0 - the one bundled with the latest* version of MKS has a glitch that breaks custom categories. 0.10.1.0 is a hotfix for this. Some USI parts can also be found in the standard categories, like the Karbonite landing legs (which I assume are what you mean by "landing legs"?) are in Utility.

2 hours ago, Bionic bulldog said:

7. My kerbitat modules say they have the ability t be configured fr different options in the description. They have the buttons in the menu for changing options, but they do nothing are they supposed to work?

Anyway, great mod, not installed the life support yet, waiting until i get to know all the parts first before i jump in and start killing my litle kerbals

Kerbitats have only life-support applications, so if you don't use an LS mod they are just functionless eyecandy. USI-LS doesn't kill your kerbals by default either, just turns them into tourists until you resupply them.

Edited by voicey99

Share this post


Link to post
Share on other sites
4 hours ago, voicey99 said:

What version of USITools do you have? 0.10.0.0 - the one bundled with the latest* version of MKS has a glitch that breaks custom categories. 0.10.1.0 is a hotfix for this. Some USI parts can also be found in the standard categories, like the Karbonite landing legs (which I assume are what you mean by "landing legs"?) are in Utility.

Kerbitats have only life-support applications, so if you don't use an LS mod they are just functionless eyecandy. USI-LS doesn't kill your kerbals by default either, just turns them into tourists until you resupply them.

Hi. Yes i did update all usi software from the website yesterday, even if ckan was saying it was correct. I had checked all folders prior to updating, bjt when i updated think i only looked for items like landing legs in the ground folder where other legs would be. Ill double check later all the other folders.

 

Share this post


Link to post
Share on other sites

So a quick update :)  Textures are done on the new Atlas harvester - switched from yellow to a more neutral gray.

Wdqd5jP.png

Also - ran the config numbers.  The large harvester, at 133 tons, has a dirt harvesting efficiency of over 4,000 (about equivalent to 25 industrial strip miners, or over 130 of the normal MKS drills).  The large refineries (20m and 10m varieties will be provided) will be able to take dirt directly to refined products (Metals, Chemicals, Polymers, etc.) which will help further reduce part count.  

 

 

Share this post


Link to post
Share on other sites
15 hours ago, RoverDude said:

Also - ran the config numbers.  The large harvester, at 133 tons, has a dirt harvesting efficiency of over 4,000 (about equivalent to 25 industrial strip miners, or over 130 of the normal MKS drills).  The large refineries (20m and 10m varieties will be provided) will be able to take dirt directly to refined products (Metals, Chemicals, Polymers, etc.) which will help further reduce part count.  

Ran some of my own numbers, and if it has an eff of 4k, it will need 8kEC/s. That's nearly double the output of the 3.75m reactor, so I assume we are going to get a new, huge one?

Share this post


Link to post
Share on other sites

A thought about the hab/home timer.  The current "instantly get maximum home time" feels a bit silly.  It's the "instant" bit that bothers me.  Put huge station in orbit around Kerbin, have kerbals pass within 150m on their way to Eeloo.  I think homesickness should increase slowly instead of instantly from the current value to the maximum possible (in the current situation).  

My thinking is the maximum increase per 6h period should be 100d of home time.  So if you dock a freshly launched keerbal with a 30 year station, it would take about 128 days to build up a full 30y home timer.

 

Share this post


Link to post
Share on other sites
4 hours ago, voicey99 said:

Ran some of my own numbers, and if it has an eff of 4k, it will need 8kEC/s. That's nearly double the output of the 3.75m reactor, so I assume we are going to get a new, huge one?

If so, then it'd probably a sign of MKS expending into larger bases- since larger reactors would need more cooling, we'd probably need more storage, etc.

Share this post


Link to post
Share on other sites
6 hours ago, voicey99 said:

Ran some of my own numbers, and if it has an eff of 4k, it will need 8kEC/s. That's nearly double the output of the 3.75m reactor, so I assume we are going to get a new, huge one?

Yep :wink:

2 hours ago, sstabeler said:

If so, then it'd probably a sign of MKS expending into larger bases- since larger reactors would need more cooling, we'd probably need more storage, etc.

Yep :wink:

3 hours ago, WuphonsReach said:

A thought about the hab/home timer.  The current "instantly get maximum home time" feels a bit silly.  It's the "instant" bit that bothers me.  Put huge station in orbit around Kerbin, have kerbals pass within 150m on their way to Eeloo.  I think homesickness should increase slowly instead of instantly from the current value to the maximum possible (in the current situation).  

My thinking is the maximum increase per 6h period should be 100d of home time.  So if you dock a freshly launched keerbal with a 30 year station, it would take about 128 days to build up a full 30y home timer.

 

Not sure what gameplay benefit that provides other than folks just clicking the warp button.  Though it would be easy enough to restrict hab sharing between disconnected vessels to landed only.

Share this post


Link to post
Share on other sites
7 hours ago, WuphonsReach said:

A thought about the hab/home timer.  The current "instantly get maximum home time" feels a bit silly.  It's the "instant" bit that bothers me.  Put huge station in orbit around Kerbin, have kerbals pass within 150m on their way to Eeloo.  I think homesickness should increase slowly instead of instantly from the current value to the maximum possible (in the current situation).  

My thinking is the maximum increase per 6h period should be 100d of home time.  So if you dock a freshly launched keerbal with a 30 year station, it would take about 128 days to build up a full 30y home timer.

I can see some disadvantages.  First off, it's fiddly.  Players will have trouble understanding why different Kerbals have different timers on the same station, or how long they need to 'stage' a Kerbal on a station to get the home time from it.  Secondly, it's awkward: If you're adding to a station to prevent your Kerbals from running out of time, how much time ahead do you need to add it?  Right now, if you add it one second before they run out, you're fine.  With yours...  When does the increase come into effect?  Does it matter how much there was to start with?  How much you're adding?  etc.  I see the realism argument - but I don't think the small addition to realism is worth the complexity overhead.

I do think disconnected home/hab should be limited to surface bases however.  It makes sense there, but it really doesn't in space.

Share this post


Link to post
Share on other sites
1 hour ago, DStaal said:

I do think disconnected home/hab should be limited to surface bases however.  It makes sense there, but it really doesn't in space.

Yeah.  I had an experience with this that felt totally wrong.  I had messed up, I had a grumpy Kerbal around Minmus(?).  The tourist bus came along to pick him up (his booster was one-way, the plan from the start was to bring him home on the bus, I just didn't launch it at the right time.)  Set up the rendezvous, the bus comes zipping by at a good clip.  (MechJeb, why do you start the matching burn at closest approach?  It should start earlier so you match velocities at closest approach!)  Before the rocket lit (and while he couldn't see the rocket, either, although I don't expect the mod to track that) he got ungrumpy.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm having issues with mining.

Latest USI from CKAN USI Kolonization Systems v0.53.0.0

KSP 1.3.1 (64bit)

I have built a rover with a MEU-100-A Pulse drill.  It has cooling fins attached to the unit it's mounted on, it has sufficient power.

1)  If I start the drill without deploying it, it mines ore.  It never overheats, runs at operational temperature fine.

2) If I deploy the drill it mines ore whilst drill started.

3) If I stop the drill/retract it, it stops mining ore.  BUT I cannot get it to start again, (Start drill command is missing from GUI).  I can deploy it,/retract it but it just sits there, no option to restart it.

I've messed around with it heaps but this has me stymied.  Any ideas?

Edited by SSSPutnik
USI version added.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now