RoverDude

[1.3] - Modular Kolonization System (MKS)

Recommended Posts

@alien_wind I actually do not know because I have not been using drills with multiple separators since that time.  The drills in the current release can way outperform any of my MPUs, so I am using the small automated drill with a single separator.

Incidentally, the Governor slider on the drills and MPUs does not appear to be working.  I like to be able to balance the drill's output with what the MPU is capable of processing.

Share this post


Link to post
Share on other sites

@RoverDude, a quick heads-up: the copy of GC bundled in MKS is missing the 000_AT_Utils/Plugins/001_AnisotropicPartResizer.dll file, which makes 002_MultiAnimators.dll fail to load.  That interferes with GC working correctly.

Share this post


Link to post
Share on other sites
On 3/12/2019 at 6:58 PM, Skystorm said:

@alien_wind I actually do not know because I have not been using drills with multiple separators since that time.  The drills in the current release can way outperform any of my MPUs, so I am using the small automated drill with a single separator.

Incidentally, the Governor slider on the drills and MPUs does not appear to be working.  I like to be able to balance the drill's output with what the MPU is capable of processing.

well I seems like a bug to me when the required xfer not match the drills slots count

On 3/12/2019 at 2:54 PM, Esendis said:

I never understood if that is a bug or by design. Either way, the fix is quite easy. Just edit the MaxCoolant of each drill in question by its separators. For instance:


@PART[MKS_Drill_02]
{
	@MODULE[ModuleCoreHeat]
	{
		@MaxCoolant = 300
	}
}

3 separators X 100KW 

Credit goes to @Skystorm

In my case however, once the drills were patched, the reactors became impossible to cool.

thnks yeah well I don't useally like moving things around in configs but it really feels like  a bug to me so I did it worked like a charm

Share this post


Link to post
Share on other sites
8 hours ago, alien_wind said:

well I seems like a bug to me when the required xfer not match the drills slots count

thnks yeah well I don't useally like moving things around in configs but it really feels like  a bug to me so I did it worked like a charm

Can you keep a reactor at 1000K temp after the drill patch or is it just me?

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/14/2019 at 8:55 AM, Esendis said:

Can you keep a reactor at 1000K temp after the drill patch or is it just me?

yes,I checked specifically.the reactor works fine

it sounds like you just don't have enough radiators also make sure you're using the extendable ones the panels only work on close parts

Edited by alien_wind

Share this post


Link to post
Share on other sites

Hi,

mod dependencies in ckan for this mod are bit strange.  It lists "global construction core" mod as required dependency but manual install guide does not mention this mod at all. Is this mod really needed or not as its out of date and does not supports 1.6. Do I have to install this "global construction core" or should I skip  ? (few people on forums reported that its bugged for 1.6)

 

Thanks

Share this post


Link to post
Share on other sites

You can safely skip Global Construction.  it's recommended by MKS as a partner mod for providing offworld construction.  Extraplanetary Launchpads works also.

Share this post


Link to post
Share on other sites
38 minutes ago, Friznit said:

You can safely skip Global Construction.  it's recommended by MKS as a partner mod for providing offworld construction.  Extraplanetary Launchpads works also.

thanks for tip. Thing is "global construction core" this is not listed as recommandeed but as dependency. It is  sub mod or library  for to mod called "global construction" global construction mod itself is not listed in dependencies at all.  There is another mod listed in dependency called Konstruction with "K" that one is fine and compatible with 1.6. So this is quite confusing I would suggest maybe changing this mod from dependency to suggested category in CKAN and list possible replacement mods in here. Possible that  this dependency core mod  is listed completely by mistake in ckan

Share this post


Link to post
Share on other sites
33 minutes ago, Kozzy said:

thanks for tip. Thing is "global construction core" this is not listed as recommandeed but as dependency. It is  sub mod or library  for to mod called "global construction" global construction mod itself is not listed in dependencies at all.  There is another mod listed in dependency called Konstruction with "K" that one is fine and compatible with 1.6. So this is quite confusing I would suggest maybe changing this mod from dependency to suggested category in CKAN and list possible replacement mods in here. Possible that  this dependency core mod  is listed completely by mistake in ckan

@RoverDude has embedded GC functionality into MKS.  While technically it won't break if you don't include it.  It is part of the zip file if you install manually which is why it isn't included in any special instructions.  Konstruction is another of Roverdude's mods and is very handy to have with MKS

Share this post


Link to post
Share on other sites
Posted (edited)

Seems as I got all working so far with few other mods.

Found only one annoyance I don get why so many mods do  this as its completely ridiculous . I would really love to have option to disable  cluttering GUI buttons that are serving no  purpose other than cheat or debug/change options of the mod.

Feels like playing in debug mode.  It would be totally fine to see options during new game creation only  or  have it in text file only.

I do not need to see 10 buttons in GUI  for various mods during game play that allows me cheat or reconfigure advanced mod options. 

Its too easy to break settings during game play. Or its  Like having shooter game with left click = shoot gun,  right mouse  click =  enable god mode. 

Edited by Kozzy
.

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, Kozzy said:

I would really love to have option to disable  cluttering GUI buttons that are serving no  purpose other than cheat or debug/change options of the mod. 

Also, consider the very useful Blizzy's Toolbar mod.

Edited by Brigadier

Share this post


Link to post
Share on other sites

wow I did not imagined there are so many mods for this. Thanks for tips. :) for far I have manual added big red X on each button I dont want but this will be better

Share this post


Link to post
Share on other sites

Quick question, do Scientist Kerbals passively generate science? It looks like Science, Funds, and Science are passively generated by some Kerbals, is this correct?

Share this post


Link to post
Share on other sites
38 minutes ago, dlrk said:

Quick question, do Scientist Kerbals passively generate science? It looks like Science, Funds, and Science are passively generated by some Kerbals, is this correct?

Not precisely...  Colonization can generate science (and funds, and boosts to mining/ISRU).  Colonization is generated by having Kerbals living on or in orbit around the planet.  The better your Colonization bonus, the faster the rewards are generated - even if the Kerbals are called home.

So having Scientist Kerbals in place will get you more science passively, yes.  But there's a couple of steps along the way, and some tweaks to it.  (There's some part-based info, as well as differences between orbit and surface.)

Share this post


Link to post
Share on other sites

How do you get the FlexOTubes to connect?  I can't seam to get it to drag the tube to the next node.

Share this post


Link to post
Share on other sites
22 minutes ago, Nuggzy said:

How do you get the FlexOTubes to connect?  I can't seam to get it to drag the tube to the next node.

Do you have KIS?  The tubes are basically big KAS pipes that you connect via KIS.

Share this post


Link to post
Share on other sites
1 minute ago, goldenpsp said:

Do you have KIS?  The tubes are basically big KAS pipes that you connect via KIS.

yes, I have the tubes attached to the module but I am not getting a link option to drag the tube when I right click them.

Share this post


Link to post
Share on other sites
4 minutes ago, Nuggzy said:

yes, I have the tubes attached to the module but I am not getting a link option to drag the tube when I right click them.

oh well i should have also asked if you have KAS as well.  I mentioned above but I wasn't clear.  The tubes are essentially a larger skinned version of KAS pipes.  So you need that mod as well.

Share this post


Link to post
Share on other sites
Posted (edited)

did anyone else encountered this behavior :

after a while(I'm not sure when it started or what caused it)

some materials in the "kolony inventory" tab

just stopped showing up info(like there's no amount of it and and no input/output of it) even though I can see that there is that material onboard.

when I change other containers to be of that material that stopped working it shows up again but which containers stopped responding is just random.

I tried to compare part data in the vessel in the save between a container that is working and one that isn't and I see no difference in amounts/modules

-edit-

after completely replacing my kontainers the inventory functionality returned but some materials didn't

only after I destroyed all the kontainers of that kind that we're before mks update then it showed again the actual amount of material

so it seems somethings in kontaier data got corrupted in mks update

also: disabled kontainers caused this problem it seems it doesn't scan the kontainers aboard for true amount and multiple kontainers of same material get it confused

(I should make emphasize that not all old kontainers got corrupted,I think only the active ones got corrupted in the update)

 

Edited by alien_wind
more info about problem

Share this post


Link to post
Share on other sites
7 hours ago, goldenpsp said:

oh well i should have also asked if you have KAS as well.  I mentioned above but I wasn't clear.  The tubes are essentially a larger skinned version of KAS pipes.  So you need that mod as well.

That was it, got it working, thanks.

Share this post


Link to post
Share on other sites
On 3/18/2019 at 5:09 PM, DStaal said:

Not precisely...  Colonization can generate science (and funds, and boosts to mining/ISRU).  Colonization is generated by having Kerbals living on or in orbit around the planet.  The better your Colonization bonus, the faster the rewards are generated - even if the Kerbals are called home.

So having Scientist Kerbals in place will get you more science passively, yes.  But there's a couple of steps along the way, and some tweaks to it.  (There's some part-based info, as well as differences between orbit and surface.)

Are more details available anywhere? This doesn't seem to be in the Wiki

Share this post


Link to post
Share on other sites
On 3/12/2019 at 8:54 AM, Esendis said:

I never understood if that is a bug or by design. Either way, the fix is quite easy. Just edit the MaxCoolant of each drill in question by its separators. For instance:


@PART[MKS_Drill_02]
{
	@MODULE[ModuleCoreHeat]
	{
		@MaxCoolant = 300
	}
}

3 separators X 100KW 

Credit goes to @Skystorm

In my case however, once the drills were patched, the reactors became impossible to cool.

Thank you for this fix!  I had been struggling to cool these drills, but didn't understand enough about the heating system to know what to change.  Was the original intent to not be able to run all 3 at once?  Maybe it was a design choice to have to choose between different drill 'recipes'?  But having all of them working at once is way cooler!

Share this post


Link to post
Share on other sites
Posted (edited)

By design MKS drills work at 100% at all times.  So with one resource selected, you get 100%.  With two, you get 50% each.  With three resources configured, you get 33.3% each.  Heat is used as a mechanic to limit the efficiency of the drill, which can be a little counterintuitive.  It looks like the drill running hot and can't be cooled, but the higher than expected temp will max out so that each resource is getting 33% efficiency

Edited by Friznit

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.