RoverDude

[1.7.x] - Modular Kolonization System (MKS)

Recommended Posts

2 hours ago, ss8913 said:

My second point - I've maintained for years that there's no practical reason in KSP to ever use a rover.  However I came up with one that could be worked into MKS - give some kind of "entertainment bonus" to hab/home time if there's a rover parked <= 150m from your base (within kolonization range) ... the idea being if the kerbals can go do donuts offworld in the rover, they won't miss their K-150/Korvette back home as much .. or something like that. :)  Pretty sure Elon Musk's actual RL goal is to do donuts in a Tesla on Mars, so.. kind of a similar concept :)

With autopilots I think there is a good use for rovers--you can reach every biome of a world with a rover (although power could be problematic on the outer worlds) and at a lot less weight than the fuel for all those landings.  A rover is similar to what you would get with ISRU--but on harder difficulty levels you need plenty of extra fuel as you might find zero when you drill.

There's also all that science laying around in the space center itself and a rover is the only way to get some of it.  (Not every building has a surface suitable for landing on.)

Share this post


Link to post
Share on other sites

Shot from last night, just thought it looked pretty.

Minmus early research base, three launches so far (base, crew, lab).

Base was delivered remotely and KAS-constructed in-situ. Crew vehicle has a tiny orbiting hab module for the return trip. Lab was delivered as a DIY kit, and has a PDU and local warehousing.

No actual scientists yet, that's the next trip.

sq3aQUl.png

Share this post


Link to post
Share on other sites

Hey there,

I am seeing a bug on the Kerbonaut hiring screen - I believe this is the TRP-Hire screen included inside MKS.

If I go to hire a new kerbal it subtracts the funds, sets the level of all current kerbals to zero and no kerbal is added.

It is not possible to exit the hire screen once inside - clicking leave will make other mods show up (e.g. the alarmclock) over the hire screen.

It used to work, this is a new thing that has shown up recently - first manifested itself as I went to do bulk hiring of kerbal (2+).

Have done some searching but have not been able to find any mention of anything similar.

Share this post


Link to post
Share on other sites

Where's the PDU? Also, does the main base have any radiators?

Share this post


Link to post
Share on other sites
6 minutes ago, voicey99 said:

Where's the PDU? Also, does the main base have any radiators?

The PDU is near the ball hub in the front. It has antenna on top of it.

Share this post


Link to post
Share on other sites
2 minutes ago, maja said:

The PDU is near the ball hub in the front. It has antenna on top of it.

That's an MPU

Share this post


Link to post
Share on other sites

I'm still trying to wrap my head around the whole Logistics process...

 

There's a few questions that have come up:

  • It seems I need to include a "dummy" logistics part on an unmanned miner in order to make it interact with PL. So far I've seen the MPU (expensive, light) and the Duna and Tundra logistics parts (heavy, Duna's cheaper) work for this. Are there any other parts to tie in a remote miner to the PL system?
  • Do Quartermasters have the same range extension feature as pilots, or do they fulfil only other logistics duties?
  • "Remote" power: The microwave transceiver only lists a range on the sending side. Do I need a microwave transceiver on the power rig and a normal PDU on the receivers or do I need microwave on both ends?

I'm definitely having a blast planning out my first outpost and trying to make it fully self-sustaining. Bases actually having a purpose is so much more fun. :D

 

Also, something of a bug/inconveniece that has been mentioned before, but nothing came of it: If I try to use one of the switchable miners there are several large pauses involved. Once when picking the part from the list, once when attaching it to a ship (pause increases for more symmetry parts) and once when clicking deploy in the field (not on start drilling, though). KSP just freezes for about 20 seconds and one CPU core gets pegged at 100%. The pause seems to be a bit shorter on the MEU-100 vs the MEU-500 and strip miners.

I can reproduce the problem with only the USI suite and CRP present on a test install. My best guess by observation is hat "something" gets thrown into a serious loop when trying to enumerate all those drills. There is absolutely nothing at that point in either the KSP.log or Player.log.

Share this post


Link to post
Share on other sites

Sorry, both base parts have a Ranger Power Pack to transmit EC (they can transmit and receive power, even with no Plutonium. Power comes from the NF reactor.). There's also a ground radiator behind the horizontal strut. The power pack, drill and geothermal radiator are all attached to the side of these - you can just see the tops of these behind the MPU.

Edited by Domfluff

Share this post


Link to post
Share on other sites
Just now, jinks said:
  • It seems I need to include a "dummy" logistics part on an unmanned miner in order to make it interact with PL. So far I've seen the MPU (expensive, light) and the Duna and Tundra logistics parts (heavy, Duna's cheaper) work for this. Are there any other parts to tie in a remote miner to the PL system?

Nope, unless you feel like some config editing.

1 minute ago, jinks said:
  • Do Quartermasters have the same range extension feature as pilots, or do they fulfil only other logistics duties?

Quartermasters can only enable pulling resources from PL, to use rover range extensions you need a proper pilot.

6 minutes ago, jinks said:
  • "Remote" power: The microwave transceiver only lists a range on the sending side. Do I need a microwave transceiver on the power rig and a normal PDU on the receivers or do I need microwave on both ends?

I'm actually not sure. I think (I may be wrong) that they can interface with each other, but they use the shorter of the two ranges as the range. The PDU is not required to receive/transmit power, it simply has the functions inbuilt - it doesn't appear to have a range defined for either sending or receiving (the junction box and transmitter both have defined receive ranges equal to their transmit ranges), so I assume it defaults to 2km.

14 minutes ago, jinks said:

Also, something of a bug/inconvenience that has been mentioned before, but nothing came of it: If I try to use one of the switchable miners there are several large pauses involved. Once when picking the part from the list, once when attaching it to a ship (pause increases for more symmetry parts) and once when clicking deploy in the field (not on start drilling, though). KSP just freezes for about 20 seconds and one CPU core gets pegged at 100%. The pause seems to be a bit shorter on the MEU-100 vs the MEU-500 and strip miners.

I can reproduce the problem with only the USI suite and CRP present on a test install. My best guess by observation is hat "something" gets thrown into a serious loop when trying to enumerate all those drills. There is absolutely nothing at that point in either the KSP.log or Player.log.

Seems this is more than a one-off bug - could you open a GitHub issue?

Share this post


Link to post
Share on other sites
36 minutes ago, MSC said:

Hey there,

I am seeing a bug on the Kerbonaut hiring screen - I believe this is the TRP-Hire screen included inside MKS.

If I go to hire a new kerbal it subtracts the funds, sets the level of all current kerbals to zero and no kerbal is added.

It is not possible to exit the hire screen once inside - clicking leave will make other mods show up (e.g. the alarmclock) over the hire screen.

It used to work, this is a new thing that has shown up recently - first manifested itself as I went to do bulk hiring of kerbal (2+).

Have done some searching but have not been able to find any mention of anything similar.

Need more info.  Starting with KSP version, MKS version, and a screenshot of your GameData and USI folders, because I have never seen this issue.

Edited by RoverDude

Share this post


Link to post
Share on other sites
7 hours ago, RoverDude said:

Actually, I was just talking to @allista about the models for orbital construction and in-situ DIY kit creation :)

 

RE rovers - the only rub is whenever I have had a rover mechanic like that, people just abuse it and spam the required part on their vessel :wink:

can you make it require more than one part?  like a rover cockpit, some wheels, maybe an antenna..?  One other thing occurs to me as well.. the construction cranes are.. kind of small, esp. considering the size of 5m kontainers.. any way to add some tweakscale functionality to them so I can make a really big crane to move really big stuff?   As you know, having lots of little kontainers around isn't ideal due to part count/framerate issues...

Share this post


Link to post
Share on other sites
Just now, ss8913 said:

can you make it require more than one part?  like a rover cockpit, some wheels, maybe an antenna..?  One other thing occurs to me as well.. the construction cranes are.. kind of small, esp. considering the size of 5m kontainers.. any way to add some tweakscale functionality to them so I can make a really big crane to move really big stuff?   As you know, having lots of little kontainers around isn't ideal due to part count/framerate issues...

Not a fan of tweakscale - the Osprey is the big brother to the Akita and is a WIP.

And trust me... even if I require more than one part, people game the system - they are incredibly creative :D

Share this post


Link to post
Share on other sites
4 minutes ago, RoverDude said:

Need more info.  Starting with KSP version, MKS version, and a screenshot of your GameData and USI folders, because I have never seen this issue.

I have just gone through my save games - appears not to be related to the mod. Some weird corruption of my savegame from a particular point forward.

Share this post


Link to post
Share on other sites
18 minutes ago, voicey99 said:

Nope, unless you feel like some config editing.

Nah, I'm good. Just making sure I'm not mission something obvious.

18 minutes ago, voicey99 said:

Quartermasters can only enable pulling resources from PL, to use rover range extensions you need a proper pilot.

I'll inform HR to act accordingly. :wink:

18 minutes ago, voicey99 said:

I'm actually not sure. I think (I may be wrong) that they can interface with each other, but they use the shorter of the two ranges as the range. The PDU is not required to receive/transmit power, it simply has the functions inbuilt - it doesn't appear to have a range defined for either sending or receiving (the junction box and transmitter both have defined receive ranges equal to their transmit ranges), so I assume it defaults to 2km.

Time to do some field testing...

18 minutes ago, voicey99 said:

Seems this is more than a one-off bug - could you open a GitHub issue?

I's a bit vague, but sure.

Edit: #1362

Edited by jinks

Share this post


Link to post
Share on other sites
7 hours ago, RoverDude said:

Actually, I was just talking to @allista about the models for orbital construction and in-situ DIY kit creation :)

As soon as this happens, I'll be ditching EL for GC.  Right now I still use EL because 99% of what I use it for is building giant weird ungainly ships in orbit.

Can't wait to see what you have in store!

Edited by tsaven

Share this post


Link to post
Share on other sites

This is probably the wrong topic, but since MKS contains the PDUs it's the only good place I can come up with.

 

@RoverDude, several years ago (2014) in the Alcubierre Drive thread you alluded to *maybe* doing something with beamed power, has there ever come something of that?

 

Right now the only option for beamed power in KSP is KSPi, which comes with a lot of baggage. I'm looking for something simpler and "more Kerbal". All I want is a reason to dump some solar satellites in a low orbit and have them them be useful.

 

So, just as an open-ended question, how hard would it be to slap together the PDU code with the CommNet relay/LOS features of stock and have a *simple* beamed power system that can move EC from near Kerbol to my drones near Eeloo? Is this something that fits with USI suite, or should I rather pose that question towards @Nertea and his Near Future line of mods?

 

(I kinda feel guilty throwing just another mod idea your way, so don't feel obligated to even think about it. :wink:)

Share this post


Link to post
Share on other sites
2 hours ago, voicey99 said:

That's an MPU

Yes, of course. I need rest :)

Share this post


Link to post
Share on other sites
2 hours ago, RoverDude said:

And trust me... even if I require more than one part, people game the system - they are incredibly creative :D

Well ... yes :cool:

Share this post


Link to post
Share on other sites
2 hours ago, Daveroski said:

Any idea why the Kerbal portraits are so dark in the Salamander pod?

 

Something to do with IVA camera position

Share this post


Link to post
Share on other sites
18 hours ago, sh1pman said:

Something to do with IVA camera position

It just feels wrong somehow, the kerbals sitting for days or weeks at a time (let alone months or even years) in the dark like that. OK.. it's silly.. but it makes me choose a different pod with added life support modules. Heavier and more expensive but at least then it feels like the kerbals can do their jigsaw puzzles. After all, adding life support to the game is about keeping your kerbals happy and comfortable. As this would otherwise be the pod of choice, I look forward to a speedy fix.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.