RoverDude

[1.7.x] - Modular Kolonization System (MKS)

Recommended Posts

5 hours ago, Kwarazi said:

@mrstoned Will that work I thought DIY kits were hardcoded to only allow construction in the VAB ? and as EL is no longer officially supported by @RoverDude I can see how it would actually work.

And just because EL is no longer officially supported it doesn't mean it doesn't work.  It just means you'll get no help from RoverDude and there will be no MKS parts for it.  He's happy for users to contribute PRs keeping support.  (Speaking of, if I have some time today I should update that...)

Share this post


Link to post
Share on other sites
2 hours ago, DStaal said:

Speaking of, if I have some time today I should update that...

I submitted Kaa253's fixes for EPL 1.4 two weeks ago, currently waiting on RD to merge them.

Share this post


Link to post
Share on other sites
3 hours ago, voicey99 said:

I submitted Kaa253's fixes for EPL 1.4 two weeks ago, currently waiting on RD to merge them.

Good to hear.  I expect he's waiting for the next release.

I should also update the PatchManager configs slightly - I left some 'optional' fields empty, but that's meant things are blank in the UI.

Share this post


Link to post
Share on other sites

Hi, new to using the Modular Kolonization System and I am loving it so far, the mod adds incredible depth to the game. However, I am having trouble with nuclear fuel transfers to and from Nertea's reactor and reprocessor since installing. A search on the issue seems to indicate this mod changes the way fuel and waste transfers happen. I have tried sending an engineer on EVA but no options are available to transfer fuel. On Roverdude's parts there is a "repair reactor" function that was mentioned in other posts I've read. However, when I try to use that option to transfer waste to Nertea's reprocessor, it simply says my core is too damaged.It's at 100% health. I'd really like to be able to mine and refine fuel and use it with MKS, is there some way to do that?

Share this post


Link to post
Share on other sites
On 19/04/2018 at 11:46 PM, DStaal said:

Note that 'controlling the craft' is a specialist function.  :wink:  But that's basically what the 'tourist' setting gets you - they'll stop working until you take care of their timer, at which point they'll revert back to their original class/level.

Also, if you look at the USI-LS configuration panel you'll notice that homesickness and habitation are already separate - they have separate timers, and can have separate effects.

Well, guess that's dependant on your point of view. ANY Kerbal can control a vessel, but pilots can use the SAS modes. What I wanted was for them to not stop working completely (usually rendering them stuck in orbit indefinately for no reason other than stubbornness), but for them to just lose the ability to perform the role for which they were likely there to perform. Think of it like a bus driver, who doesn't just stop controlling the bus while doing 100kph down the freeway, but no longer stops to pick up passengers.

Been waiting for updates and mods to settle down before I start a new play through, but I didn't realise home and hab were separate options. That's good news for me! :D

On 20/04/2018 at 1:24 AM, voicey99 said:

This is for USI-LS rather than MKS, but for the first one you can get around it by sending up a station with over 50yrs of habtime per kerbal and sending them to it to make home time infinite (hab time will become temporarily infinite as well), and then sending them all over.

Wasn't sure which thread would be more appropriate sorry. That's a good solution for later in the game. Thank you for the tip! :D

These quotes gives me workable solutions, so since this turned out to be OT, I'll call it job done.

Share this post


Link to post
Share on other sites

Completely lost!  Documentation is all out of date!  Need help. 

I just want to create a simple space station to use as a training academy supporting 15 kerbals plus three instructors.

Right from the start I am totally confused and frustrated!  I have at least three modules named "Habitat" and every stinking one when I open it is configured as "Greenhouse" and the configuration buttons for every stinking one say [Greenhouse]=>[Greenhouse]!!!!

I am ready to take a brick to my computer because I have spent hours and I cant even get a single habitat working!!!!

Edited by ctbram

Share this post


Link to post
Share on other sites
On 4/20/2018 at 9:23 AM, mrstoned said:

I'm using EL to build the DIY-kits offworld

This is an excellent idea. If at some point EL will get deprecated and DIY can be built off world via Ground Construction, one can just blow up that small EL station with survey sticks.

Share this post


Link to post
Share on other sites
43 minutes ago, ctbram said:

Completely lost!  Documentation is all out of date!  Need help. 

I just want to create a simple space station to use as a training academy supporting 15 kerbals plus three instructors.

Right from the start I am totally confused and frustrated!  I have at least three modules named "Habitat" and every stinking one when I open it is configured as "Greenhouse" and the configuration buttons for every stinking one say [Greenhouse]=>[Greenhouse]!!!!

I am ready to take a brick to my computer because I have spent hours and I cant even get a single habitat working!!!!

Before you launch a module from this mod, check it in the VAB and set it to the to whatever you want it to be when it arrives.

If you don't do this, you will need an engineer and materials to change it one it is in location.

When it comes to habitats, have one or more hitch-hikers and turn the 'habitat' on. This will multiply the habitable time of the base.

Check stuff out as much as you can on field by the runway before launching it into space.

An academy would give much better results on the surface of Mimnus than in orbit of Kerbin, Mun or Mimnus.

Landed Modules within a Kerbals Leap (on Mimnus) of each other share habitation. They can also share resources provided both modules have storage containers (which must be able to be switchable to 'local/planetary')

 

Share this post


Link to post
Share on other sites

I'm trying to get a simple base up and going, but am having some serious troubles find any info in the relevant wiki and text files:

Running KSP 1.3.1 and MKS 0.53.2.0


1.) What is the difference between the regular and the -A drills besides the description saying it is automated ?

2.) How do I get power distribution going between vessels when I have a PDU with engineer and pilot on board and a transport lander with the microwave power thingy, or just between two MKS ships in general?

 

Also I have a bug, not sure if this is know or needs my logs:

When I press "Start dirt drill" on the 100-A the drill starts extracting dirt without the drill being deployed. When I press deploy if will go down, but the "start dirt drill" option will forever disappear from the GUI and the drill will no longer extract any resources. I can use the drills normaly by only using the "start/stop dirt drill button" as long as I never press the deploy button.


Yeah, nevermind. I've been at it for two days and can't get power to distribute, can't get anything out of planetary storage no matter how many pilots and egineers I have in every craft... then considering you have about a 20% chance of the parts on the ground being shot into the air and exploding when you focus in on them...  It's just not worth this much hassle to figure out how it all should work, with bugs and all.

Edited by Jimbodiah

Share this post


Link to post
Share on other sites
15 hours ago, Jimbodiah said:

1.) What is the difference between the regular and the -A drills besides the description saying it is automated ?

Normally, drills use a production multiplier of 0.05 + [stars of highest level engineer/miner on board + 1] * 0.2, e.g. a 3-star kerbal would give a multiplier of 0.85. The automated drills and MPUs do not use this multiplier and lock it at 1, making them slightly slower than if they had a 4-star kerbal on board.

15 hours ago, Jimbodiah said:

2.) How do I get power distribution going between vessels when I have a PDU with engineer and pilot on board and a transport lander with the microwave power thingy, or just between two MKS ships in general?

You need a PDU (big range) *or* a microwave transmitter (2km range) *or* a cable box (500m range) at either end of the transfer, one as the transmitter and one as the receiver (and it will use the shorter of the two ranges). it will then transmit power between them automatically, and since it can only do it in chunks more storage on both ends will mean it can transfer it faster

15 hours ago, Jimbodiah said:

Yeah, nevermind. I've been at it for two days and can't get power to distribute, can't get anything out of planetary storage no matter how many pilots and egineers I have in every craft... then considering you have about a 20% chance of the parts on the ground being shot into the air and exploding when you focus in on them...  It's just not worth this much hassle to figure out how it all should work, with bugs and all.

Pulling out of PL is simple, all you need is a pilot or quartermaster on the vessel, a logistics module and a container with planetary logistics enabled (plus resources to actually pull). I don't know about the drills, but parts being shot out is a stock bug, and you can install WorldStabiliser to fix it.

Share this post


Link to post
Share on other sites

I am trying to change a module on the Tundra Refinery from one resource to another (via a Kerbal on EVA), but I keep getting the message Missing Resource: 22 SpecializedParts . Is this a bug or am I doing something wrong? I have about 2000 Specialized Parts on this vessel.

Share this post


Link to post
Share on other sites
2 hours ago, VasimrVasimrovich said:

I am trying to change a module on the Tundra Refinery from one resource to another (via a Kerbal on EVA), but I keep getting the message Missing Resource: 22 SpecializedParts . Is this a bug or am I doing something wrong? I have about 2000 Specialized Parts on this vessel.

Is warehouse enabled for the spec parts container?

(Also the general reminder that support is not provided for 1.3.x versions)

 

Share this post


Link to post
Share on other sites
4 hours ago, RoverDude said:

Is warehouse enabled for the spec parts container?

(Also the general reminder that support is not provided for 1.3.x versions)

 

It was disabled, enabling it solved the issue. Thank you for the quick support :D

Share this post


Link to post
Share on other sites

Does anyone know how to transfer nuclear waste or fuel? With an engineer on EVA the only option I have is to repair the reactor. The game then says the reactor is too damaged, despite it being in perfect health. From inside, I can click transfer waste or fuel buttons, the game then says to click on a part. Clicking on any nuclear fuel or waste container does nothing, clicking anything else exits. I also can't get fuel out of my fuel processor. Do I just need to scrap nuclear reactors that run out of fuel? 

Share this post


Link to post
Share on other sites
On 4/21/2018 at 2:44 AM, ctbram said:

Completely lost!  Documentation is all out of date!  Need help. 

I just want to create a simple space station to use as a training academy supporting 15 kerbals plus three instructors.

Right from the start I am totally confused and frustrated!  I have at least three modules named "Habitat" and every stinking one when I open it is configured as "Greenhouse" and the configuration buttons for every stinking one say [Greenhouse]=>[Greenhouse]!!!!

I am ready to take a brick to my computer because I have spent hours and I cant even get a single habitat working!!!!

Do you have USI-LS installed?

I think that habitation, as a life support related function, may be part of USI-LS.  That is usually the reason that habitats can do nothing other than whatever efficiency-boost mode they may have.

 

 

7 hours ago, loverevolutionary said:

Does anyone know how to transfer nuclear waste or fuel? With an engineer on EVA the only option I have is to repair the reactor. The game then says the reactor is too damaged, despite it being in perfect health. From inside, I can click transfer waste or fuel buttons, the game then says to click on a part. Clicking on any nuclear fuel or waste container does nothing, clicking anything else exits. I also can't get fuel out of my fuel processor. Do I just need to scrap nuclear reactors that run out of fuel? 

For MKS reactors, you should have a 'Perform Maintenance' action that will top off both nuclear fuel and machinery as applicable.

For NF reactors, you may need a module manager patch to allow this action.  (I also find NF reactors to be much hotter, hungrier and more fragile than MKS reactors, so I remove the NF MKS reactor patch and stick with MKS reactors myself) 

Also, a nuclear fuel refinery will automatically deposit any refined fuel in any attached storage(including a reactor), so explicit refueling may not be needed if you have a refinery on your base.(not 100% sure as I always have a manned workshop by the time I am producing nuclear fuel, and a workshop with an engineer in it will automatically perform maintenance every day)

Share this post


Link to post
Share on other sites

Need a bit of assistance. I've got a basic base on Minmus, with a Duna Pioneer, and Duna Agriculture modules, a few Ranger hab and agricultural module, and a BUNCH of storage. All the storage is set to Planetary Warehouse, but nothing is pushing to PL. Three two-star Engineers, one three-star Scientist, and one two-star Pilot are on the base. What am I missing to be able to push product out to PL? I know to pull I need a logistics module, but I thought pushing was universally accessible.

 

As a secondary concern, on saving and reloading any resource lodes blow up, regardless of how much they had left on saving. I can attach one on to the base, and save immediately, then exit, reload in, and the lode will just explode as if it had all been used up. It won't have processed the materials, unless I'm in physics range. I'm still testing but it is possible that the effect also occurs if I leave physics range and let time run. It's exploding and not processing the catch-up first.
 

Spoiler

KSP: 1.4.2 (Win64) - Unity: 2017.1.3p1 - OS: Windows 7 Service Pack 1 (6.1.7601) 64bit
000_AT_Utils - 1.5.1
USI Tools - 0.12
Community Category Kit - 3.0
Community Resource Pack - 0.10
ConfigurableContainers - 2.4.2
Firespitter - 7.9
GroundConstruction - 1.2.1.1
Kerbal Attachment System - 0.6.4
Kerbal Engineer Redux - 1.1.3
Kerbal Inventory System - 1.10.6640.40620
KSP-AVCE - 1.2
SCANsat - 1.1.8.4
StageRecovery - 1.7.2
Tracking Station Evolved - 1.0.1
Kerbal Alarm Clock - 3.9.1
USI Core - 0.7
Karbonite - 0.12
Konstruction - 0.5
USI-LS - 0.9
MKS - 0.55
Waypoint Manager - 2.7
OSE Workshop - 1.2.3
[x] Science! - 5.14

 

Edited by Onigato
Wrong planetary body

Share this post


Link to post
Share on other sites
On 4/23/2018 at 10:34 PM, Onigato said:

Need a bit of assistance. I've got a basic base on Minmus, with a Duna Pioneer, and Duna Agriculture modules, a few Ranger hab and agricultural module, and a BUNCH of storage. All the storage is set to Planetary Warehouse, but nothing is pushing to PL. Three two-star Engineers, one three-star Scientist, and one two-star Pilot are on the base. What am I missing to be able to push product out to PL? I know to pull I need a logistics module, but I thought pushing was universally accessible.

 

As a secondary concern, on saving and reloading any resource lodes blow up, regardless of how much they had left on saving. I can attach one on to the base, and save immediately, then exit, reload in, and the lode will just explode as if it had all been used up. It won't have processed the materials, unless I'm in physics range. I'm still testing but it is possible that the effect also occurs if I leave physics range and let time run. It's exploding and not processing the catch-up first.
 

  Reveal hidden contents

KSP: 1.4.2 (Win64) - Unity: 2017.1.3p1 - OS: Windows 7 Service Pack 1 (6.1.7601) 64bit
000_AT_Utils - 1.5.1
USI Tools - 0.12
Community Category Kit - 3.0
Community Resource Pack - 0.10
ConfigurableContainers - 2.4.2
Firespitter - 7.9
GroundConstruction - 1.2.1.1
Kerbal Attachment System - 0.6.4
Kerbal Engineer Redux - 1.1.3
Kerbal Inventory System - 1.10.6640.40620
KSP-AVCE - 1.2
SCANsat - 1.1.8.4
StageRecovery - 1.7.2
Tracking Station Evolved - 1.0.1
Kerbal Alarm Clock - 3.9.1
USI Core - 0.7
Karbonite - 0.12
Konstruction - 0.5
USI-LS - 0.9
MKS - 0.55
Waypoint Manager - 2.7
OSE Workshop - 1.2.3
[x] Science! - 5.14

 

You need a logistics enable module on your vessel to access the planetary warehouse.

Logistics modules provide both push and pull(with pilot) capability

MPUs also provide logistics(Push only) capability.

The only pioneer module that provides logistics is the tundra 2.5m pioneer/logistics module. 

Share this post


Link to post
Share on other sites

I was looking into the Making History Mission Builder today and I noticed that I don't seem to be able to prescribe most of the MKS and USI-LS parts as required in a create vessel description. :(

Share this post


Link to post
Share on other sites
11 hours ago, Terwin said:

You need a logistics enable module on your vessel to access the planetary warehouse.

Logistics modules provide both push and pull(with pilot) capability

MPUs also provide logistics(Push only) capability.

The only pioneer module that provides logistics is the tundra 2.5m pioneer/logistics module. 

And that would be my derp. Thanks, I've got a Duna Logistics en-route now, 5 Kerdays to intercept with Minmus, and about 2500 dV on the transfer stage, and another 1500 in the "landing" stage. I *may* have over-engineered it just a little bit. Maybe. But that transfer craft can move a 2.5m cargo Kontainer full of Machinery or MatKits with a few hundred spare dV on landing and a direct from ground to Minmus launch. *shrug*

Share this post


Link to post
Share on other sites

I've been seeing the various MKS parts that normally appear in the TL 5 node for Advanced Construction of the Stock Tech Tree are not getting cleared out of that node after applying Community Tech Tree. They are appearing in TL 9, Long Term Habitation, as expected, and can't actually be utilized in the VAB until that node is researched. I don't know if this is anything other than a cosmetic problem, but it would likely be confusing to new players.

I'm running KSP x64 1.4.3 with MH 1.2, MKS 0.55.0.0, USI-LS 0.9.0.0, Module Manager 3.0.6, and CTT 3.3.1. I saw this earlier when running KSP 1.4.2, so this is a totally clean install, with just the mods above. I've only noticed this for the MKS and LS parts on that node (so far), so I'm assuming it's not a CTT bug.  I've submitted an Issue on the MKS GitHub.

UPDATE: I'm seeing this on the Fertilizer Tanks as well.  They're showing in TL 3 Survivability, as well as TL 6 Hydroponics.

Edited by KSPrynk

Share this post


Link to post
Share on other sites

I can not figure out how to do nuclear fuel and waste transfers, and what people are telling me to do not only doesn't work, it doesn't make sense in terms of the controls and user interface I am seeing. I suspectperhaps people are not using the very latest version of MKS with the latest version of the game, and things have changed, or that there is some undocumented interaction between MKS and Nertea's Near Future Power mods.

For example, people say I need to send an engineer on EVA or have routine maintenance performed to transfer fuel and waste. However, I have specific "transfer fuel" and "transfer waste" buttons, and the game informs me that reactors need to be off and cool in order to transfer waste and/or fuel. The buttons do nothing, however. Clicking on any fuel or waste capable part does nothing, clicking anything else exits from the fuel transfer routine. Routine maintenance that I can see being performed on other parts does not fill my reactors, nor does it empty my waste. I have absolutely no way of getting nuclear fuel out of my processor into my reactors. Maintenance performed on EVA results in nothing more than the message "Reactor is too  damaged to repair" which is not the case.

Is it possible that these mods are preventing each other from allowing fuel transfers? If the "cool reactor" mechanic is part of Nertea's mods rather than a new feature in MKS, this might be happening: Near Future requires a cool reactor and use of the "tranfer fuel" button, but MKS makes fuel transfer impossible, they have to happen through maintenance. However, Near Future prevents this because the reactor isn't cool. This is just a guess as to the cause, the symptom remains the same: I can not transfer nuclear fuel through the mechanisms the game presents for doing so. Any ideas? I can't get rid of either mod at this point without losing a whole bunch of base building.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.