RoverDude

[1.7.x] - Modular Kolonization System (MKS)

Recommended Posts

Just now, gamerscircle said:

That is a thing in KSP?  I that with the new MKS skills, as I haven't really used them...  Just trying to get the basics of MKS and getting a foot hold understanding of what I need.. then, trying to branch out to a little to refine what I have in place.. is a challenge.
 

ie, I have an 'okay' infrastructure on the Mun, but it got to where I had to do supply drops to my drill sites almost every 30 days.. [I have to Agi mods making supplies] , then someone suggested that I include the small recycler at the drill sites. and "wham" I get over a year vs ...  Then a suggestion to start converting the mulch to supplies... [this I thought I understood, but one step at a time.. as I need to swap out the current drill sites]

It's a thing in MKS. Open the Kolonization tab, and you should see kolonization bonuses for different planetary bodies.

https://github.com/BobPalmer/MKS/wiki/The-Kolonization-Dashboard

Share this post


Link to post
Share on other sites
41 minutes ago, gamerscircle said:

okay, I have that same issue with the stock deployable as well.  About the only time I see them really attract heat, is when I land a craft anywhere near the structure. 

The radiator is the stock large TCS, and the base is manned. Here it is, Minmus MO "Bergenite":

vVMI1J0.jpg

It's from a few versions ago and now consists of 8 ME-100s running at 283% capacity and a refinery at 38% (since I forgot to put much machinery in it) powered by a 1.25m with a 1-star engineer on board. Even with the massive buff, a large TCS should be able to handle that-the reactor is slightly overloaded, bit the TCS should still cool it-the TCS is well below capacity (12%) and when the engineer is removed from the base (which still has a pilot on board) it stops cooling the drills at all. I've had this problem before where stock TCSs don't cool USI parts properly, but radiators do. Looks like I'm going to be screwing some radiators on-I might be decommissioning the Berg soon anyway, given how manned drilling bases have somewhat lost importance.

And yes, the three kolonisation ratings are a thing, and increase over time depending on how many kerbals of the various specialisations you have on board. Kolonisation buffs converters, Botany buffs supplies production (I think) and geology buffs drills (but not the automated versions). For drills, it seems to be base efficiency+geology rating, as my geology rating is 183% and the drills are running at 283%.

Share this post


Link to post
Share on other sites
1 minute ago, gamerscircle said:

I will read the above, my Mun is over 250% , 

Which means you'll need 250% as much EC and cooling to run the drills. On the other hand, you are getting 250% as many resources :wink:

Share this post


Link to post
Share on other sites
6 minutes ago, RoverDude said:

huh... that extra 100% is a bug, need to sort that :)  Should have been just 183% in your case

Logged as Issue #1179.

Share this post


Link to post
Share on other sites
3 minutes ago, sh1pman said:

Which means you'll need 250% as much EC and cooling to run the drills. On the other hand, you are getting 250% as many resources :wink:

Good with the bad... [wonders if his Hello Kitty account is still active]

Share this post


Link to post
Share on other sites
Just now, gamerscircle said:

Good with the bad... [wonders if his Hello Kitty account is still active]

Your drills will be running at 359% efficiency. Have fun watching your reactor melt.

Share this post


Link to post
Share on other sites
Just now, voicey99 said:

Your drills will be running at 359% efficiency. Have fun watching your reactor melt.

Thank God reactors don't melt in MKS!

Share this post


Link to post
Share on other sites
Just now, sh1pman said:

Thank God reactors don't melt in MKS!

Sssssssh. I can imagine RD rubbing his fingers together at the idea.

Share this post


Link to post
Share on other sites
4 minutes ago, voicey99 said:

Sssssssh. I can imagine RD rubbing his fingers together at the idea.

Well, since there is MKS-Lite, there can probably be MKS-Xtreme, with radiation, melting reactors and kerbals dying of age and diseases. 

Share this post


Link to post
Share on other sites
1 minute ago, sh1pman said:

Well, since there is MKS-Lite, there can probably be MKS-Xtreme, with radiation, melting reactors and kerbals dying of age and diseases. 

[reaches for a sickness bag.. only to find 3 different user manuals & an addendum]

Share this post


Link to post
Share on other sites
3 hours ago, RoverDude said:

Right.  As I explained.... Kerbalism does a wholesale update of one of the core stock mechanics - converters.  Which is about 90% of what MKS does.  So when you override all of this behavior and cut bits out, it is going to break stuff that depends on those stock functions existing.

True, but I do like your modeling of ur modules, in MKS, and I like how u can change the textures colors. :( The modules are like deep space travel eye candy <3 <3 <3

Share this post


Link to post
Share on other sites

I seem to have an issue with pulling Machinery, and only Machinery, from the Planetary Logistics. I have a good deal of it in the PL system, I have a Pioneer module with pilots, "Ranger" Inflatable storage things, see screenshot.

Is this a bug, or am I doing something wrong?

As always, thanks in advance!

A60E41147915910DF3BE8D60BECD44BF0FFC579A

Edited by Shawarmakriger

Share this post


Link to post
Share on other sites

@RoverDude I also manually added in an LFO configuration (keeping the OX mode) for the MPUs, if you're going to give them one next release would you like me to PR that in too since I've already made it?

Share this post


Link to post
Share on other sites

@voicey99 - please do!

34 minutes ago, Shawarmakriger said:

I seem to have an issue with pulling Machinery, and only Machinery, from the Planetary Logistics. I have a good deal of it in the PL system, I have a Pioneer module with pilots, "Ranger" Inflatable storage things, see screenshot.

Is this a bug, or am I doing something wrong?

As always, thanks in advance!

Can you confirm which MKS version you are on?

Share this post


Link to post
Share on other sites

Before I submit the PR, I've also noticed they also don't generate any heat. Given a little more time, I could have a go at incorporating that as well, or I could add just the LFO mode.

Share this post


Link to post
Share on other sites
3 minutes ago, Laythe Dweller said:

Hey, anyone know why this disappeared from CKAN? All the other USI mods are there, but MKS is missing...

CKAN just hasn't updated yet, give it a day or two, as has been said multiple times.

And @RoverDude should the heat production values be low to reflect the MPUs' low processing rates or higher for balance?

Share this post


Link to post
Share on other sites

So does 50kW for the 1.25m, 100kW for the 2.5m and 200kW for the 3.75 sound about good to you? They might also need a serious buff to compete with the stock ISRU since, when the stock 2.5m is up to temperature, it is faster than even the 3.75m automated one by at least a factor of 10-even when unmanned.

Edited by voicey99

Share this post


Link to post
Share on other sites

That sounds right, but no need for a buff as MKS production is already balanced against USI.... stock was made cartoony-fast since it had to appeal to a much broader audience.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.