RoverDude

[1.7.x] - Modular Kolonization System (MKS)

Recommended Posts

1 hour ago, wendel said:

Did you ever find a fix for this? I'm running into the same problem right now.

Like the first time this was mentioned, are you using USI-LS? Some of the modules you're trying to switch to might be dependent on USI-LS. Try running it with LS installed and see if it persists.

Share this post


Link to post
Share on other sites
11 minutes ago, Caithloki said:

Hello, I am currently have issues with food production on my base, I have and engineer and scientist on the base but with Cultivate S on both the duna model and the pop up green house but I only get 5% efficiency. Does it only work well when I have a botinist or farmer or is there more to it? both modules have full machinery and resources available to produce stuff.

A scientist or other agroponics kerbal is needed to boost production if you use anything more advanced than a nom-o-matic.

Share this post


Link to post
Share on other sites
31 minutes ago, voicey99 said:

Like the first time this was mentioned, are you using USI-LS? Some of the modules you're trying to switch to might be dependent on USI-LS. Try running it with LS installed and see if it persists.

Even without USI-LS it shouldn't cause a stack overflow though. Seems like this is a bug in USITools where a configurable bay with only one valid configuration causes infinite recursion.

Share this post


Link to post
Share on other sites
50 minutes ago, Caithloki said:

Hello, I am currently have issues with food production on my base, I have and engineer and scientist on the base but with Cultivate S on both the duna model and the pop up green house but I only get 5% efficiency. Does it only work well when I have a botinist or farmer or is there more to it? both modules have full machinery and resources available to produce stuff.

You should change ht greenhouse to the "greenhouse" setting.  This increases the efficiency of the Duna module.

Star ratings of engineer and scientist?

Post up a screenshot of your setup with the efficiency and your available resources and supplies storage.

Share this post


Link to post
Share on other sites

Don't know if this has been answered before, but I have a question regarding logistics and containers.

So I have a dirt drill set up near my base, but it does not seem to be outputting to planetary storage correctly. I can pull from it into my main base and it will be sent there that way, but it does not send dirt to planetary storage by default.

Share this post


Link to post
Share on other sites
11 minutes ago, Lord_Potato said:

Don't know if this has been answered before, but I have a question regarding logistics and containers.

So I have a dirt drill set up near my base, but it does not seem to be outputting to planetary storage correctly. I can pull from it into my main base and it will be sent there that way, but it does not send dirt to planetary storage by default.

You must have a planetary logistics unit attached directly to the storage unit that you want pushed into PL.

Duna Logistics unit, Tundra pioneer unit, or the new unmanned processing units.

 

more info here:

https://github.com/BobPalmer/MKS/wiki/Functions-(Logistics)

 

Share this post


Link to post
Share on other sites

So, i'm having a weird problem.

I just updated to the newest constellation.

None of the Agriculture units will switch functionality in the VAB. The notification that it has changed appears, but the contents of the part(s) do not change from the initial agroponics configuration.

the Kerbitats and other containers change the way they ought to.

I've installed everything properly, to the best of my knowledge, so i don't think its a problem on my end.

before I go declaring bugs, has anyone else noticed this?

Share this post


Link to post
Share on other sites

Hi everybody,

I'm a bit wary of using GC since when I tried to use it on my current career save I get tons of "Coroutine couldn't be started because the the game object '<insert part name here>' is inactive!" messages every couple of minutes. I get these messages while focused on ships and in the VAB. =(

Is there a way to use the latest MKS version along with EL? =">

 

Regards and thanks in advance =)

Edited by ErevanGaming
typo =D

Share this post


Link to post
Share on other sites

If you are getting log spam, the best thing to do is ping @allista:wink:

And there's nothing stopping you from using EL.

1 hour ago, CaribouGone said:

So, i'm having a weird problem.

I just updated to the newest constellation.

None of the Agriculture units will switch functionality in the VAB. The notification that it has changed appears, but the contents of the part(s) do not change from the initial agroponics configuration.

the Kerbitats and other containers change the way they ought to.

I've installed everything properly, to the best of my knowledge, so i don't think its a problem on my end.

before I go declaring bugs, has anyone else noticed this?

If you're not using USI-LS then there's no point to the agriculture modules.  That's usually the only time I hear of these not working.

Share this post


Link to post
Share on other sites
31 minutes ago, RoverDude said:

If you are getting log spam, the best thing to do is ping @allista:wink:

And there's nothing stopping you from using EL.

Hi RoverDude,

Will do =)

I initially got the impression that GC has become a dependency for MKS ="> am I safe to assume that I could use the latest version and remove the GC related directories for the time being while the "Coroutine" related error spam gets sorted out by allista? =">

 

Regards and thanks for the quick reply! =)

Share this post


Link to post
Share on other sites
3 hours ago, RoverDude said:

If you're not using USI-LS then there's no point to the agriculture modules.  That's usually the only time I hear of these not working.

Nevermind, i think figured out the issue.

I thought the configuration also changed the type of storage (Cultivator(D) would store dirt; (S), Substrate; as apposed to Agroponics' mulch storage). (I was looking at the inflatable Ag unit.) It would seem this is not the case.

Edited by CaribouGone

Share this post


Link to post
Share on other sites

Hi RoverDude =)

Just an update on the GC related error, I ran KSP with the latest version of MKS with GC and RemoteTech (since someone on the GC thread said it may be conflicting with GC) and the rest of the mods I use, but this time without Configurable Containers and the "Coroutine" error (3 lines total) now only appears once when I load a vessel in the VAB and once when switching between vessels. =)

The 3 lines of error are:
Coroutine couldn't be started because the the game object 'Tundra.Workshop250' is inactive!" 
Coroutine couldn't be started because the the game object 'Tundra.AssemblyPlant' is inactive!" 
Coroutine couldn't be started because the the game object 'Ranger.Workshop' is inactive!" 

Hope this helps unless you need anything else. Will be glad to send/reference my log file =)

 

Regards and thanks again. =)

 

Share this post


Link to post
Share on other sites

I wonder if someone could check to see if their PDU power distribution is working?

I have a Tundra PDU with both Microwave Power Tranceiver and Power Coupler attached, and with an engineer onboard.

I have a Karibou parked about 10m next to the PDU with a Fuel Cell Array, but "No PDUs in range" appears when I right click the fuel cell.

(No nullrefs, etc appearing in log)

Edited by Fury1SOG
Added extra information

Share this post


Link to post
Share on other sites

So how do get my resources back out of the Planetary Warehouses?

Screenshot:

Spoiler

Q6yTVch.png

I have:

  • A logistics Module
  • A pilot
  • An ISM with Planetare Warehousing enabled
  • Plenty of Exotic Minerals, MetallicOre amd Metals in the Planetary Storage that I now would like to withdraw from my account

What am I missing?

 

-----------------

 

 

42 minutes ago, Fury1SOG said:

I wonder if someone could check to see if their PDU power distribution is working?

Working for me.

Quote

I have a Tundra PDU with both Microwave Power Tranceiver and Power Coupler attached, and with an engineer onboard.

I have a Karibou parked about 10m next to the PDU with a Fuel Cell Array, but "No PDUs in range" appears when I right click the fuel cell.

I believe that's a bug with the Fuel Cell. Have you tried other modules for receiving electricity, such as the Duna modules or the Dedicated Microwave Power Tranceiver part?

My fuel cells also don't see any PDU's, although all other parts that are nearby are perfectly happy with the one I have running.

 

Edited by Kobymaru

Share this post


Link to post
Share on other sites
18 hours ago, voicey99 said:

Like the first time this was mentioned, are you using USI-LS? Some of the modules you're trying to switch to might be dependent on USI-LS. Try running it with LS installed and see if it persists.

The first time it was mentioned, RD asked the poster about USI-LS, but didn't mention if it was the cause or the cure. No real solution was offered, and so I asked. Sorry.

 

But, yeah, USI-LS seems to cure the problem. I was using TAC LS before, and assumed it was supported, but I suppose now it is not.

 

Thanks!

 

17 hours ago, jd284 said:

Even without USI-LS it shouldn't cause a stack overflow though. Seems like this is a bug in USITools where a configurable bay with only one valid configuration causes infinite recursion.

 

I think jd284 touched on the real problem.

Edited by wendel
I forgot to say "Thank you".

Share this post


Link to post
Share on other sites
1 hour ago, Kobymaru said:

So how do get my resources back out of the Planetary Warehouses?

Screenshot:

  Hide contents

Q6yTVch.png

I have:

  • A logistics Module
  • A pilot
  • An ISM with Planetare Warehousing enabled
  • Plenty of Exotic Minerals, MetallicOre amd Metals in the Planetary Storage that I now would like to withdraw from my account

What am I missing?

Is the Pilot IN the Logistics Module? I believe that is one of the "required crew here" functions. :P

It should pull automatically as it is drained. It will not arbitrarily fill storage to full as I think it only pulls in 10% chunks if it gets too low. Also you might want to try switching to another vessel outside physics range & then switching back after everything has been set up. I've noticed that if you try assembling things on site the various functions don't always activate properly until the vessel is reloaded fully.

Share this post


Link to post
Share on other sites
2 hours ago, Kobymaru said:

So how do get my resources back out of the Planetary Warehouses?

I have:

  • A logistics Module
  • A pilot
  • An ISM with Planetare Warehousing enabled
  • Plenty of Exotic Minerals, MetallicOre amd Metals in the Planetary Storage that I now would like to withdraw from my account

What am I missing?

 

If you have a Warehouse enabled storage unit(such as ISM) with the correct resource type and it has less than 25% of that resource, it should refill to 50% of that resource.

Assuming your Pilot and storage unit are in the same vessel as the logistics module, and you have enough of that resource in PL to get the container up to 50%.(and the storage unit has PL enabled of course)

Share this post


Link to post
Share on other sites
13 minutes ago, ExavierMacbeth said:

Is the Pilot IN the Logistics Module? I believe that is one of the "required crew here" functions. :P

Yes, she is (see screenshot: there is a "Traedith's inventory" option in the Logistics Center, and if you look in her portrait, you see that she's a pilot)

13 minutes ago, ExavierMacbeth said:

It should pull automatically as it is drained. It will not arbitrarily fill storage to full as I think it only pulls in 10% chunks if it gets too low.

It is almost completely drained.

13 minutes ago, ExavierMacbeth said:

Also you might want to try switching to another vessel outside physics range & then switching back after everything has been set up.

Thanks, that helped me. Apparently I needed to restart my game - now it works as expected. 

7 minutes ago, Terwin said:

If you have a Warehouse enabled storage unit(such as ISM) with the correct resource type and it has less than 25% of that resource, it should refill to 50% of that resource.

Thanks, that was the case.

Share this post


Link to post
Share on other sites

Seems like the pricing still has a few gremlins in it, the 2.5m and 3.75m MPUs both cost negative funds dry and hiring an MKS-spec kerbal from the AC with 0 courage and 100 stupidity costs you -14K (-28K and -42K when 1 and 2-star). Logged as issue #1188.

Edited by voicey99

Share this post


Link to post
Share on other sites

So, I've looked around the tutorial documentation but I've still got a couple questions before I start trying to design a self sufficient colony on Vall.

When it comes to crew, does the number of kerbals matter? If I have an engineer on my mining base (and a pilot for logistics to xfer raw materials to a processing facility) would I get better results with 2 engineers? Do engineers also increase the rate at which converters such as the workshop work, and would multiple engineers do better?

I seem to recall that pilots reduce overall efficiency, scientists increase it, and engineers increase it a lot.. with skill levels mattering too. Is that still true? Where do all these new types fit in?

Share this post


Link to post
Share on other sites
16 minutes ago, Enorats said:

So, I've looked around the tutorial documentation but I've still got a couple questions before I start trying to design a self sufficient colony on Vall.

When it comes to crew, does the number of kerbals matter? If I have an engineer on my mining base (and a pilot for logistics to xfer raw materials to a processing facility) would I get better results with 2 engineers? Do engineers also increase the rate at which converters such as the workshop work, and would multiple engineers do better?

I seem to recall that pilots reduce overall efficiency, scientists increase it, and engineers increase it a lot.. with skill levels mattering too. Is that still true? Where do all these new types fit in?

Number of kerbals have no effect, only the best one for each skill counts;

Engineers increase some converters efficiency, but some other converters are boosted by scientists (or more specific new MKS classes). Again no need to have several same type Kerbals.

The "pilots reduce overall efficiency" etc thing, does not look like it ever was the case in MKS. I think it's the mechanism for Extraplanetary Launchpads "productivity" (and might depend on *where* you put the kerbals too).

Share this post


Link to post
Share on other sites

Ah, right. Now I remember. That -1 productivity, 1.5 for sci, and 2.5 for engi's thing was EL's workshop productivity. Crossing some wires in the old brain there. Thanks for clearing that up.

Now I know I can make more minimalistic mining outposts rather than massive sprawling complexes home to armies of engineers.

Share this post


Link to post
Share on other sites
23 minutes ago, Enorats said:

Ah, right. Now I remember. That -1 productivity, 1.5 for sci, and 2.5 for engi's thing was EL's workshop productivity. Crossing some wires in the old brain there. Thanks for clearing that up.

Now I know I can make more minimalistic mining outposts rather than massive sprawling complexes home to armies of engineers.

Actually, with the new MPUs (which have inbuilt automated PL push capacity) and automated drills, you can make reasonable unmanned outposts now (I made a PR for MPUs to get heat mechanics and an LF-OX mode next patch as well as a 900% ore processing productivity buff).

Edited by voicey99

Share this post


Link to post
Share on other sites
On 1/3/2017 at 4:55 PM, voicey99 said:

The scanner says 0.0040% avg. That *might* be the average for the biome, not accounting for local variations.

...Oh.

Right. Then it's just me not paying attention, thanks for the help :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.