RoverDude

[1.8.x] - Modular Kolonization System (MKS)

Recommended Posts

Just now, voicey99 said:

If that's the case, then how did I dock two ports, one of which is a root (and then had to use the KIS rerooting trick to compress)?

What is the KIS rerooting trick? :)

Share this post


Link to post
Share on other sites
52 minutes ago, Jebs_SY said:

What is the KIS rerooting trick? :)

 

Share this post


Link to post
Share on other sites

The main problem I have with this mod is the lack of scientists so there's few kerbals I can get to staff my science laboratories.

 

Am I missing something?

Share this post


Link to post
Share on other sites
1 minute ago, Noel32 said:

The main problem I have with this mod is the lack of scientists so there's few kerbals I can get to staff my science laboratories.

 

Am I missing something?

Yep, you now need to use the Kolony Dashboard to do all you're hires. Don't use the astronaut center anymore because as you've noticed it doesn't work with so many new professions. 

Share this post


Link to post
Share on other sites
5 minutes ago, dboi88 said:

Yep, you now need to use the Kolony Dashboard to do all you're hires. Don't use the astronaut center anymore because as you've noticed it doesn't work with so many new professions. 

Sorry but.. where could I find the Kolony Dashboard? 

Share this post


Link to post
Share on other sites
1 minute ago, Noel32 said:

Sorry but.. where could I find the Kolony Dashboard? 

It's on the bottom bar in space centre/vab/sph and it's on the right hand side during flight. It's the button with the globe with a little flag on it. From there you can hire new recruits, view planetary logistics, local logistics and kolony statistics.

Share this post


Link to post
Share on other sites

If you have Blizzy's toolbar, then it will be one of the magenta buttons with no image.

Share this post


Link to post
Share on other sites
25 minutes ago, Noel32 said:

Ok, clearly I must have done something wrong as this is not showing up for me..

Yeah i'd recommend reinstalling if you're missing this button.

4apskn0.png

Share this post


Link to post
Share on other sites

For future reference, it might be that either USITools or MKS got ahead of the other and broke something i.e. I recently updated USITools from v0.8.9 to 0.8.11 without updating MKS, and subsequently broke the button until I updated MKS to the parity version, which fixed it.

Share this post


Link to post
Share on other sites

If I'm using EPL and MKS, is it OK to remove all the EPL parts? If not, which parts are unnecessary?

Share this post


Link to post
Share on other sites

The only EL parts you need to keep are the hammer and stakes if you want to use the survey station function. For orbital construction with MKS you don't need any EL parts.

Share this post


Link to post
Share on other sites
1 hour ago, dlrk said:

If I'm using EPL and MKS, is it OK to remove all the EPL parts? If not, which parts are unnecessary?

I wrote a module manager config that removes most EPL parts. It gets rid of the parts related to the making of rocket parts but keeps the EL launchpads (which switch over to use Material Kits and Specialized Parts instead of Rocketparts. Just plop in anywhere within /GameData 

https://www.dropbox.com/s/5bunl2llw2dx2q8/hideMOST_ELMKS.cfg?dl=1

Edited by TheRagingIrishman

Share this post


Link to post
Share on other sites

Hi guys! So finally, I got my Duna Base up and running :) Took me quite a while, because it's not just the MKS parts - it's also the supporting infrastructure for refueling and transport.

The location was carefully chosen to lie on a 3-Biome boundary that lets me mine EVERYTHING!!  The downside is, it's on a sloped location which is slightly annoying for landing purposes.

It's at Stage 2, by which I mean it can produce Fertilizer and MaterialKits, and it's fairly self-sufficient.

Next step: SpecializedParts production!

Check it out here:

http://imgur.com/a/N0fhY

 

8qgngjk.png

Share this post


Link to post
Share on other sites

I'm playing again after some time and just tried that new Local Logistics. Man.. thank you, Roverdude, it solved SO MANY problems of my bad designs, it is awesome.

Share this post


Link to post
Share on other sites

Request for clarification:

Assuming a smelt-o-matic produces X amount of metal

When converted to an efficiency part on a vessel with a three bay refinery, does the smelter add 1/3X to each bay, or does it add X to each bay?

 

Share this post


Link to post
Share on other sites

I'm trying to alter my BaseHabTime but the game doesn't seem to be picking it up.  I'm now thinking another mod may be overwriting the values i'm setting in the config.  I'm playing with Stock Scale Real Solar System so it wouldn't surprise me if some numbers are off but I'm seeing 7days of hab time/crew spot.  I edited both the USI-LS.cfg (in the MKS folder) and the Settings.cfg (in the LifeSupport folder), changing BaseHabTime from .25 to 1.  I expected that to give me 28 days of Hab time but I'm still seeing 7 days.   I did a scan of my gamedata folder for .cfg files with BaseHabTime in them and found that WildBlueTools had an MM_USILS.cfg but that had the value set to 1.  I tried bumping that up to 4 just to see what would happen.  And it didn't do anything...

Where should I be making that change?  Any idea what I'm doing wrong?  

I'm hoping to do an apollo style moon landing but 7 days isn't long enough and I don't want to turn off the penalties of not having life support.

Thanks in advance.

Share this post


Link to post
Share on other sites
8 minutes ago, AndreZero said:

I'm trying to alter my BaseHabTime but the game doesn't seem to be picking it up.  I'm now thinking another mod may be overwriting the values i'm setting in the config.  I'm playing with Stock Scale Real Solar System so it wouldn't surprise me if some numbers are off but I'm seeing 7days of hab time/crew spot.  I edited both the USI-LS.cfg (in the MKS folder) and the Settings.cfg (in the LifeSupport folder), changing BaseHabTime from .25 to 1.  I expected that to give me 28 days of Hab time but I'm still seeing 7 days.   I did a scan of my gamedata folder for .cfg files with BaseHabTime in them and found that WildBlueTools had an MM_USILS.cfg but that had the value set to 1.  I tried bumping that up to 4 just to see what would happen.  And it didn't do anything...

Where should I be making that change?  Any idea what I'm doing wrong?  

I'm hoping to do an apollo style moon landing but 7 days isn't long enough and I don't want to turn off the penalties of not having life support.

Thanks in advance.

The settings files are only used as defaults for a new savefile - if you've got a save you're already using, you want to edit them via the in-game dialog box.

Share this post


Link to post
Share on other sites
1 minute ago, DStaal said:

The settings files are only used as defaults for a new savefile - if you've got a save you're already using, you want to edit them via the in-game dialog box.

Ah, that makes sense.  

Stupid question: Where would I find this in-game dialog box?  When I click on the green cube, it gives me the current stats but no option to edit anything.

Share this post


Link to post
Share on other sites
1 minute ago, AndreZero said:

Ah, that makes sense.  

Stupid question: Where would I find this in-game dialog box?  When I click on the green cube, it gives me the current stats but no option to edit anything.

It should be that green cube - from the KSC view, not while looking at any specific ship or in any of the buildings.

Share this post


Link to post
Share on other sites
3 minutes ago, DStaal said:

It should be that green cube - from the KSC view, not while looking at any specific ship or in any of the buildings.

Ok, I was looking at it in mission.  Now I've got it set.

Thanks!

Share this post


Link to post
Share on other sites

I've recently started playing with MKS, and have run into a problem.  I have several kerbals that got turned into tourists due to Habitation/Homesickness.  I figured sending them back to Kerbin would reset them, but they seem to be stuck as Tourists.  Is the medbay the only way to cure them?

Thanks.

  --Rehpic

Share this post


Link to post
Share on other sites
1 hour ago, Rehpic said:

I've recently started playing with MKS, and have run into a problem.  I have several kerbals that got turned into tourists due to Habitation/Homesickness.  I figured sending them back to Kerbin would reset them, but they seem to be stuck as Tourists.  Is the medbay the only way to cure them?

Try launching them in a vessel with supplies

Share this post


Link to post
Share on other sites
11 hours ago, Baladain said:

Request for clarification:

Assuming a smelt-o-matic produces X amount of metal

When converted to an efficiency part on a vessel with a three bay refinery, does the smelter add 1/3X to each bay, or does it add X to each bay?

 

I believe it adds X to each bay., if I understand your question correctly.  If you have only one bay active and turn on your smelter, the bay will be at, for example, 150%.  If you enable a second, it will also be at 150%, and the third will be the same.  If they are all set to produce the same thing, they will be at 450% total.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.