RoverDude

[1.8.x] - Modular Kolonization System (MKS)

Recommended Posts

2 hours ago, Baladain said:

To follow up on the idea that the meu-500 drill can only run one separator without overheating,

is this a re-balance so the 500 isn't essentially the equivalent of 9 100s?

Now the three separators are only there in case you want to switch back and forth?

Well, overheating doesn't actually shut it down, so you can still run three different resources off one drill, just not as fast as with three drills.

Still seems weird though since the other multi-separator parts actually use all the separators.

Share this post


Link to post
Share on other sites
On 8/29/2018 at 9:58 PM, Requia said:

just not as fast as with three drills.

 

Letting multiple separators overheat is only like 25% faster than one separator at optimum temperature.

Share this post


Link to post
Share on other sites

Heat seems to be a popular topic these days,

I have a 2.5M nuclear reactor with 2 stock radiator (small) attached.

The nuclear reactor overheats, even though the radiators level out at 11%.

Can anyone make sense of this for me?  Unfortunately this is for a station so the ranger thermal control units aren't an option.

Share this post


Link to post
Share on other sites

I've been having a problem with the modules where they are only have 5% load, whatever I do. This happens with greenhouses too, so it makes self sustaining bases impossible. If anybody knows why this is happening, I would like to know the solution. Thanks!  :)

Share this post


Link to post
Share on other sites
3 minutes ago, Vinhero100 said:

I've been having a problem with the modules where they are only have 5% load, whatever I do. This happens with greenhouses too, so it makes self sustaining bases impossible. If anybody knows why this is happening, I would like to know the solution. Thanks!  :)

Which modules specifically?

For your greenhouses, can you send a screenshot showing how they're configured and the resources available?

Share this post


Link to post
Share on other sites

I just realized, it was because there was no crew. I was trying to set up supplies plants on the moon, but i didn't put crew in so i could make my other bases require less life support. But I also have another question: can you put resources into the planetary warehouse without a quartermaster/logistics center? (sorry about the pointless question)

Edited by Vinhero100

Share this post


Link to post
Share on other sites
18 hours ago, Vinhero100 said:

I just realized, it was because there was no crew. I was trying to set up supplies plants on the moon, but i didn't put crew in so i could make my other bases require less life support. But I also have another question: can you put resources into the planetary warehouse without a quartermaster/logistics center? (sorry about the pointless question)

Good Morning Vinhero to use planetary resources you must have a pilot or a quartermaster at each location you want to push resources  from.

 

Share this post


Link to post
Share on other sites
3 hours ago, tman70506 said:

Good Morning Vinhero to use planetary resources you must have a pilot or a quartermaster at each location you want to push resources  from.

 

Thanks, I read somewhere that I didn't need a quartermaster to push resources, only to pull from planetary logistics. Must have been outdated. 

Share this post


Link to post
Share on other sites
3 hours ago, tman70506 said:

Good Morning Vinhero to use planetary resources you must have a pilot or a quartermaster at each location you want to push resources  from.

12 minutes ago, Vinhero100 said:

Thanks, I read somewhere that I didn't need a quartermaster to push resources, only to pull from planetary logistics. Must have been outdated. 

The Duna and Tundra logistics centers need a pilot or quartermaster, both for push and pull.

The Material Processing Units don't need a pilot, but are only capable of pushing.  (They're intended for use in unmanned mining rigs, which push to PL so that your base with a logistics center can pull.)

Share this post


Link to post
Share on other sites
4 minutes ago, Wyzard said:

The Duna and Tundra logistics centers need a pilot or quartermaster, both for push and pull.

The Material Processing Units don't need a pilot, but are only capable of pushing.  (They're intended for use in unmanned mining rigs, which push to PL so that your base with a logistics center can pull.)

Oh, That makes so much more sense now! Thanks.

Share this post


Link to post
Share on other sites

 

Hi, I have problem with this mod.
When i run my previously saved game with USI LifeSupport everything works. Now I want to build glorious colonies co i install (with ckan) MKS and when I start my save it crash. Can you help me please?

error.log

output.log

crash.dmp

Share this post


Link to post
Share on other sites
7 hours ago, Wyzard said:

The Duna and Tundra logistics centers need a pilot or quartermaster, both for push and pull.

The Material Processing Units don't need a pilot, but are only capable of pushing.  (They're intended for use in unmanned mining rigs, which push to PL so that your base with a logistics center can pull.)

I think a better way to think about it (and a slight correction to your statement) is this:

A part with logistics capabilities can push any connected resource in suitable containers to Planetary Storage.  A part with logistics capabilities staffed with a quartermaster/pilot can pull from Planetary Storage into suitable containers if requested.  The parts with logistics capabilities are the logistics centers and the MPUs.  (Note that the MPU's don't have a seat - so they can't be staffed, and therefore can only push.)

3 hours ago, infinite_monkey said:

If I want a fuel depot near the base, is there a way to automatically push fuel from the mining rig? For now it's just tanks, no command pod.

Push to where?  To Planetary Storage - see above.  If from the fuel depot to the base - no.  You can only *pull* using any logistics other than Planetary Storage.  So if you have something on the base which uses fuel (or open the local logistics interface and start a pull manually).

Note that the automatic pulls require a logistics-enabled tank at both ends - the Kontainers are, but most other fuel tanks are not.

Share this post


Link to post
Share on other sites
9 hours ago, Ahry said:

Hi, I have problem with this mod.
When i run my previously saved game with USI LifeSupport everything works. Now I want to build glorious colonies co i install (with ckan) MKS and when I start my save it crash. Can you help me please?

Welcome to the forums.

You could be running out of memory.  You're also running KSP 1.3.1 so you should consider updating to 1.4.x.  Since I don't see it in your output_log file, which version of MKS are you trying to install?

Edited by Brigadier

Share this post


Link to post
Share on other sites
14 hours ago, DStaal said:

A part with logistics capabilities can push any connected resource in suitable containers to Planetary Storage.  A part with logistics capabilities staffed with a quartermaster/pilot can pull from Planetary Storage into suitable containers if requested.  The parts with logistics capabilities are the logistics centers and the MPUs.  (Note that the MPU's don't have a seat - so they can't be staffed, and therefore can only push.)

The difference between this and what I'd written is that this description says a Duna/Tundra logistics center can push (just not pull) when unmanned.  Is that true?  I'd thought not, but I could be mistaken.

Share this post


Link to post
Share on other sites
47 minutes ago, Wyzard said:

The difference between this and what I'd written is that this description says a Duna/Tundra logistics center can push (just not pull) when unmanned.  Is that true?  I'd thought not, but I could be mistaken.

I believe it's true.  I also could be mistaken.  ;) 

Share this post


Link to post
Share on other sites
17 hours ago, Brigadier said:

Welcome to the forums.

You could be running out of memory.  You're also running KSP 1.3.1 so you should consider updating to 1.4.x.  Since I don't see it in your output_log file, which version of MKS are you trying to install?

I running on 1.4.1 KSP scan say same 1.4.1.2089

And MKS version 0.55.0.0

But i install some new mods (ground construction) and suggested mods with this mod and they say, that i have invalid version of tracking station evolved, so i uninstall it and create new world and there it works. But in my previous world doesnt :-(.

It is possible to install this mod in game witch is in progress and was created without it?

Share this post


Link to post
Share on other sites
6 hours ago, Ahry said:

I running on 1.4.1 KSP scan say same 1.4.1.2089

And MKS version 0.55.0.0

But i install some new mods (ground construction) and suggested mods with this mod and they say, that i have invalid version of tracking station evolved, so i uninstall it and create new world and there it works. But in my previous world doesnt :-(.

There is a current version of Tracking Station Evolved that works with KSP 1.4.x.  I have no idea if it's backwards compatible with 1.4.1 but, if not, there's probably a version that is.

You already have mini-AVC installed through one of your mods so you should see it working during your game start.  Pay attention to it when it informs you that there are mods to update.  Have you considered using AVC or CKAN to help with your mod installation?

 

6 hours ago, Ahry said:

It is possible to install this mod in game witch is in progress and was created without it? 

MKS - yes.

Share this post


Link to post
Share on other sites
3 hours ago, Brigadier said:

There is a current version of Tracking Station Evolved that works with KSP 1.4.x.  I have no idea if it's backwards compatible with 1.4.1 but, if not, there's probably a version that is.

You already have mini-AVC installed through one of your mods so you should see it working during your game start.  Pay attention to it when it informs you that there are mods to update.  Have you considered using AVC or CKAN to help with your mod installation?

I install all my mods with ckan. But ckan says it is ok and KSP AVC says it is not compatible...

I do not undestand what happen but now I can play my previous game with MKS without crash (yesterday it crash).

Share this post


Link to post
Share on other sites
8 hours ago, Ahry said:

I install all my mods with ckan. But ckan says it is ok and KSP AVC says it is not compatible...

I do not undestand what happen but now I can play my previous game with MKS without crash (yesterday it crash).

Does AVC actually say it's not compatible?  AVC will tell you that the mod is built for a version of KSP you're not running, despite the mod being completely functional, depending on the information in the .version file.

Either way, I'm glad it has worked out.  Enjoy MKS.

Share this post


Link to post
Share on other sites
11 hours ago, alexus said:

Does it work in 1.4.5 version?

 

9 hours ago, RoverDude said:

Yes

I am having an issue but, first, I want to say I love this mod. I have used a whole bunch of life support and game mechanic changing mods and this one has the best balance of fun, low part count, and complexity.

I am running KSP 1.4.5 and MKS 0.55 with USI-LS 0.9 and a bunch of other mods. I have checked, to the best of my ability, to ensure I don't have a known compatibility issue. MKS was installed with CKAN as were all but 3 other mods. I have used this mod for 3 or 4 weeks now and only had one problem but the second problem cropped up today and it bothers me enough to ask about it.

The big problem is orbital transfer. I can create T-credits. I can pull up the transfer window and start a transfer that it says I can afford. The specific instance is a transfer of fuel and oxidizer from a Mun surface supply depot to an orbiting station that has no fuel or oxidizer in the tanks. I set up the transfer and hit go. The window gave me a timer of 1 hour. I warped ahead at 50x while at the supply depot. After the timer ran down, I switched to the station. The station had no fuel but the supply depot had lost the fuel when the transfer started.

As a side note, I would like to see a transfer in from another station option as opposed to just a transfer out.

The smaller problem is the battery time counter. It counts down from last known battery level when the ship/station/base is not the current active vessel. No solar panel, reactor, or fuel cell seems to be run in the background. Drills and unmanned bases seem to be unaffected. I assume unmanned bases are unaffected because they keep putting resources into the planetary stock even after warping ahead many days. I have just selected the vessel with the lowest amount of days of power and warped the number of days it takes to nearly deplete the second lowest. Then, I go around and select each vessel to 'reset' the batteries. This is becoming more of a problem as the number of bases and stations I have grows. But, I have started building things with hundreds of days of power.

So, are either of these known issues? To try and fix this myself, I am downloading MKS from github and will uninstall from CKAN and drop MKS in manually. I have no idea if that will do anything but on the github page I saw that CKAN is not recommended. I am not even sure if that is still relevant.

I'd like to be sure my gamedata folder is correct. I have a folder called 000_USITools and an UmbraSpaceIndustries. In the Umbra folder I have Akita, FX, Karibou, Konstruction, Kontainers, LifeSupport, MKS, ReactorPack. Is this correct?

EDIT - Github is being ridiculously slow tonight (~3kb/s) so it will be after work tomorrow before I can try my first attempt at fixing this.

Edited by AngrybobH

Share this post


Link to post
Share on other sites
11 hours ago, AngrybobH said:

The smaller problem is the battery time counter. It counts down from last known battery level when the ship/station/base is not the current active vessel. No solar panel, reactor, or fuel cell seems to be run in the background. Drills and unmanned bases seem to be unaffected. I assume unmanned bases are unaffected because they keep putting resources into the planetary stock even after warping ahead many days. I have just selected the vessel with the lowest amount of days of power and warped the number of days it takes to nearly deplete the second lowest. Then, I go around and select each vessel to 'reset' the batteries. This is becoming more of a problem as the number of bases and stations I have grows. But, I have started building things with hundreds of days of power.

In USI-LS/MKS as in stock KSP nothing is run in the background, everything does catch-up in 6 hour increments when you get in range.

I believe that nothing in the timers acolovely persons for processeses that consume resources or recieve inputs, so both supplies and electricity will go down, even though the vessel itself never gets below full.

This is a conservative approach so that what you see is the minimum you can expect when you go back.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.