RoverDude

[1.8.x] - Modular Kolonization System (MKS)

Recommended Posts

Please consider changing either the tourists' or tehnicians abreviations in the life support pannel(the one in the toolbar). Both abreaviations are "T" and it's sometimes confusing as hell which is which.....

Share this post


Link to post
Share on other sites
7 hours ago, Terwin said:

When I click on the link in RoverDude's signature, I see ' KSP 1.7.x Compatibility ' for each of the latest releases.  Where are you getting a 1.8 version of MKS?

Mine showed up in CKAN.

Share this post


Link to post
Share on other sites
23 hours ago, Space Cowboy Bob said:

Is anyone else finding MKS incompatible with 1.8? USI Life Support works, but I just wanted to confirm if anyone else is having issues with MKS? It gets to the end of the loading screen, say's "Loading Breaking Ground", then goes to "Verifying Breaking Ground" and that's as far as it'll load. The max KSP version though says 1.8.9. 

I had this and this is not from MKS. I think its caused by Nertea Near Future mods, but this is fully understandable - 1.8 is very new.

Anyways, the clean 1.8 with just updated Module Manager and three base mods: KSP AVC and current MKS + LS do start to menu in 1.8; however once in Sandbox game, they extremely slow down fps in VAB and SPH, and that's not any of the graphics settings/shaders etc. I think its because of MKS+LF or GroundConstruction/Firesplitter,... the MKS+LS are not 1.8 ready in their current version.

Share this post


Link to post
Share on other sites
23 hours ago, Terwin said:

When I click on the link in RoverDude's signature, I see ' KSP 1.7.x Compatibility ' for each of the latest releases.  Where are you getting a 1.8 version of MKS?

CKAN shows the Max KSP version but I did check the github and it clearly says 1.7.x. 

Share this post


Link to post
Share on other sites
On 10/17/2019 at 7:13 PM, Space Cowboy Bob said:

It gets to the end of the loading screen, say's "Loading Breaking Ground", then goes to "Verifying Breaking Ground" and that's as far as it'll load. The max KSP version though says 1.8.9. 

On 10/18/2019 at 3:11 AM, Brigadier said:

Mine showed up in CKAN.

So the hang on "Verifying Breaking Ground..." is caused by Firespitter. Unfortunately this isn't a quick fix because some of the Firespitter code relies on the old Unity particle system which was deprecated in Unity 2017 and removed in Unity 2018 (KSP 1.8 includes a bump to Unity 2019). I have zero experience with the particle systems, so I'm not sure what all is involved in getting this fixed.

Despite what CKAN and KSP-AVC say, the USI mods will require updates before they're fully compatible with KSP 1.8. I have made pull requests for USITools, MKS, USI-LS and WOLF with the required updates. Unfortunately, we can't put out official releases until we get Firespitter sorted out. RD is on vacation the rest of the week and I'm busy on getting WOLF ready for release, so it may be a while unless someone who knows their way around the particle systems wants to figure out how to fix Firespitter. :)

Share this post


Link to post
Share on other sites

And which parts of MKS use Firespitter? What happens if I remove it from my pack of mods?

Share this post


Link to post
Share on other sites

MKS just uses Firespitter for resource switching in kontainer tanks, doesn't it?  It may be worth looking at B9PartSwitch as an alternative — that's what most mods use (when the stock switcher isn't enough), and its UI is nicer than FSFuelSwitch.

(Switching to B9 would have a backward-compatibility impact for spacecraft that've already been launched, though.  But a major update like 1.8 seems like a reasonable time for that to happen.)

Share this post


Link to post
Share on other sites

Give Rover and Doc a day or two, at least,  then realize that his fixing things in his stuff might actually break things for you in some other mod. 

 

if nothing else while you wait hit up Netflix or mug redbox for a movie or two, or binge read a webcomic. There’s Freefall, Grrl power or ...hmmm....

Share this post


Link to post
Share on other sites
6 hours ago, Wyzard said:

MKS just uses Firespitter for resource switching in kontainer tanks, doesn't it?  It may be worth looking at B9PartSwitch as an alternative — that's what most mods use (when the stock switcher isn't enough), and its UI is nicer than FSFuelSwitch.

(Switching to B9 would have a backward-compatibility impact for spacecraft that've already been launched, though.  But a major update like 1.8 seems like a reasonable time for that to happen.)

No point in switching given I maintain firespitter ;). But as noted before, I am halfway around the world.

Share this post


Link to post
Share on other sites
4 hours ago, RoverDude said:

 ;). But as noted before, I am halfway around the world.

Then the world needs to go on a diet!:D oh wait it’s holloween that uniquely Japanese time of year when parents take there kids to visit the local Yakuza for candy and the rest of Japan trashes,Well, Japan. Although after living there, honestly I think it’s partly so they can clean up the mess afterwords.

 

https://kotaku.com/shibuya-trashed-after-halloween-so-volunteers-clean-up-1820034368

 

in the states it’s also national half off miniture candy eve. 

 

 

Share this post


Link to post
Share on other sites

CKAN showing 1.8 compatibility for USI is a bit of a misnomer since the dependency of Firespitter is definitely broken with 1.8. So till that is fixed all USI mods are no go.

Edited by Atlas Gaming

Share this post


Link to post
Share on other sites
3 hours ago, Atlas Gaming said:

CKAN showing 1.8 compatibility for USI is a bit of a misnomer since the dependency of Firespitter is definitely broken with 1.8. So till that is fixed all USI mods are no go.

OMG thanks for the heads up!

Share this post


Link to post
Share on other sites

So I've discovered a Confusing Thing that I wonder if anyone else has seen - regarding Orbital Logistics.  This is KSP 1.7.3 and MKS 1.2.0.0.

I have a bunch of bases and stations around Mun, and I thought it would be a great idea to build a ship that was basically a Tundra Pioneer+Logistics module with a monoprop engine on it, so that I could dock it with things and transfer resources to it.  I built this thing in orbit with GlobalConstruction, launched, sent it somewhere, and made a transfer.

Presently it failed with "The target logistics module could not be found on the destination vessel.".

I observed that other transfers still worked, and after some poking around in the save file I observed that the new ship, in fact the new module, had a duplicate ModuleId in the ModuleOrbitalLogistics module of the... module.  It was in fact a duplicate of the P+L module on the station that built the ship.  Manually editing the quicksave file to give the new module a new GUID allowed transfers to work correctly.

Presumably keeping an eye out for this in the future will allow it to be corrected, but am I trying to do something weird here?  Is this a known phenomenon with multiple logistics modules on a single vessel?  I do recall that I launched it with the 'start docked after construction' feature that seems to have appeared recently (or at least since the last time I built something in orbit)...

 

Share this post


Link to post
Share on other sites
18 hours ago, ChrisF0001 said:

Orbital Logistics failed with "The target logistics module could not be found on the destination vessel."

This message is displayed when the part with ModuleOrbitalLogistics is no longer attached to the vessel it was attached to when the transfer was created. There are 2 things going on here that OrbLog was not really built for:

  • Having multiple ModuleOrbitalLogistics on the same vessel
  • Movable/Dockable OrbLog vessels

The assumption with OrbLog is that you'll be transferring resources between permanent bases/stations. Using OrbLog any more "creatively"  than that is a "do it at your own risk" sort of thing. OrbLog looks at both the vessel ID and the module ID for the origin and destination vessels. Vessel IDs have a tendency to get changed every time vessels are docked/undocked from one another though, so any docking/undocking operations that occur while an OrbLog transfer is in progress is likely going to result in a failed transfer.

As to how you ended up with 2 OrbLog modules with the same module ID is a bit of a mystery (since they're GUIDs which are supposed to be unique) except that again, OrbLog doesn't expect to find 2 OrbLog modules on the same vessel. So that may have something to do with it. More specifically, it uses KSP's Vessel.FindPartModuleImplementing method to locate the OrbLog module when setting up a transfer. When there are multiple modules, I expect that KSP probably just returns the first one it finds, which may not always be the same one.

TL;DR ...

19 hours ago, ChrisF0001 said:

am I trying to do something weird here?

Yeah, kinda. ^_^ Keep a look out for WOLF which is coming soon. We expect WOLF to be a more attractive way to do the sorts of things that players currently use Planetary Logistics and Orbital Logistics for.

Share this post


Link to post
Share on other sites

So the large domes (I don't remember the name) are not a part of WOLF, but of MKS? Will they be released together with WOLF or later?

Share this post


Link to post
Share on other sites

Atlas. I believe they're like the next level up from Tundra, so they should be part of MKS.

Share this post


Link to post
Share on other sites
5 minutes ago, infinite_monkey said:

So the large domes (I don't remember the name) are not a part of WOLF, but of MKS? Will they be released together with WOLF or later?

WOLF and the Atlas series parts (aka the domes) will be bundled with MKS when they're released. As for the timing, I don't have any info on that presently. I can say that the part configs are 95% done for the Atlas parts and I think the models are also done. So we just need to get the model-specific info added to the part configs and they should be ready for release. As for WOLF, I'm still working on the hopper models and there are still a few minor bugs/tweaks that need sorting out. We're also doing a reskin of the Tundra models for the WOLF parts.

Share this post


Link to post
Share on other sites
12 hours ago, RoverDude said:

1.8.x versions of all USI stuff as well as Firespitter are up.

Note that they still show on SpaceDock as being for 1.3.1.  ;)

Share this post


Link to post
Share on other sites

@RoverDude Thank you for express update.

 

edit...

It even seems to be working in 1.8.1 that just has been released on steam -> somebody(private division) should finally learn how to bug test before release ;)

Edited by ZAJC3W

Share this post


Link to post
Share on other sites

Just a heads up.

MKS/OKS depends on Global Construction Core which is still not updated to 1.8.0 and is spamming in VAB:

[EXC 21:09:25.687] MissingFieldException: Field 'KSPWheelController.wheelCollider' not found.
	AT_Utils.Metric..ctor (IShipconstruct vessel, System.Boolean compute_hull, System.Boolean world_space) (at <884dc0722e2f44d080ac1ddc449a08e3>:0)
	GroundConstruction.VesselKit..ctor (PartModule host, ShipConstruct ship, System.Boolean assembled, System.Boolean simulate) (at <ee2790a7aadc42028b18e84465689e22>:0)
	GroundConstruction.GCEditorGUI.Update () (at <ee2790a7aadc42028b18e84465689e22>:0)

 and causing quite a lag.

 

Share this post


Link to post
Share on other sites
48 minutes ago, ZAJC3W said:

MKS/OKS depends on Global Construction Core which is still not updated to 1.8.0 and is spamming in VAB

There are no hard dependencies between MKS and GC. It has been removed from the 'official' MKS bundle for now (i.e. on GitHub). CKAN may be a different story.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.