RoverDude

[1.8.x] - Modular Kolonization System (MKS)

Recommended Posts

On 12/18/2019 at 2:55 PM, Terwin said:

1) ckan can be wonky some times.  Usually it works ok, but if you are having problems with CKAN installed mods, the first step to try and fix it is to uninstall the CKAN mods and install them manually(for MKS this involved downloading from github{the 'latest release' link https://github.com/UmbraSpaceIndustries/MKS/releases  } then putting the contents of the zip file into your gameData folder)

2) the extraplanetary Launchpad models are no longer maintained and have been hidden/disabled so that they will not appear any more except on previously built vessels(to avoid breaking saves).  I believe there is a mod out there that will re-enable them, but General Construction(Previously Ground Construction) has replaced extra-planetary launchpads as the recommended on-site building mod for MKS

I tried installing it by hand but theses Drills don't appear to. any other ideas?

Share this post


Link to post
Share on other sites
1 hour ago, .Iszox said:

I tried installing it by hand but theses Drills don't appear to. any other ideas?

A picture of your mod folder, and a link to your log files would help a lot in diagnosing what's going on.

Share this post


Link to post
Share on other sites
On 12/18/2019 at 9:45 PM, DStaal said:

Actually, the solution is fairly simple:

Leave, the come back.  Or quicksave and then reload.

The nice looking attachment pieces (actually, they're fairings) will load upon scene load.  It's just when they're first attached via KIS (this is KIS, not KAS) that they don't load.

That did the trick, awesome! Thank you very much :D

Share this post


Link to post
Share on other sites
20 hours ago, DStaal said:

A picture of your mod folder, and a link to your log files would help a lot in diagnosing what's going on.

This is my modfolder. I had this Problem with only Roverdude Mods and their Dependencies installed so i think the Problem is somewhere there. The Logs:https://github.com/Iszox/Mod-Problems

 

TTvNhD8.png39PXfIy.png

Share this post


Link to post
Share on other sites

I can't hire anyone, i tried reinstalling the game and mod. I made new save and this problem still happens. In the console i get "Exception:NullReferenceException: Object reference not set to an instance of an object" everytime i hire. I'm using ksp 1.7.3 with MKS and USI-Life Support.

Here's my log

https://gofile.io/?c=mxRZ1z

Edited by idkwhattochooseausername
forgot to include log

Share this post


Link to post
Share on other sites

Greetings!

I was wondering if there is any news regarding Wolf or the Atlas parts. I'm getting back into KSP after about a year and catching up. I've seen in this thread that there were some Twitch streams demoing the new mod/parts but they don't seem to be available anymore. Is there a download link available for Beta testing?

Sorry if this information is already available. I did some searching around and was unable to find anything from the past 6 weeks. I'm sure with the holidays things have slowed down a bit.

Great thanks!

Share this post


Link to post
Share on other sites

Upon reflection, it occurs to me that it is rude for me to request an update on a mod. Its done when its done. Sorry about that. Didn't mean anything by it.

My question of if there is a Beta link still stands though :)

Share this post


Link to post
Share on other sites

I've actually been wondering the same thing, the discussion feels like WOLF is out, but I just can't find it, so I'm wondering if I'm just being dumb or if it's not released yet.

If it's not released yet, cool.

 

(I'm also thinking of getting back into KSP. I last played about a year ago. I actually have to play very sporadically because KSP sucks me in like no other game I've ever played. But I've got some time off over the holidays so figured I'd indulge.)

Share this post


Link to post
Share on other sites

Due to the lack of twitch streams or a release announcement(I have been watching closely for this, last MKS release was 10-28 according to Git-hub), I suspect development is on hold while RoverDude works on something covered by a comprehensive NDA.

My hope is that Star Theory looked at how highly-configurable USI-LS is and tapped him to update and clean-up the mod for inclusion as the stock life support system in KSP 2, but with just enough background processing/environment awareness to common points of confusion such as the remaining EC time dropping even though a base is staying fully charged.

With any luck, many of the elements of MKS will also be part of base-building.

 

Share this post


Link to post
Share on other sites
On 12/20/2019 at 10:00 AM, .Iszox said:

This is my modfolder. I had this Problem with only Roverdude Mods and their Dependencies installed so i think the Problem is somewhere there. The Logs:https://github.com/Iszox/Mod-Problems

 

TTTvNhD8.png39PXfIy.png

HI @ISzox. I had the same issue. The reason was the ReStock Mod. After I whitelisted Squad/Parts/Resources/RadialDrill/ the MKS big drills showed up. The link below detalis how to do it.

https://github.com/PorktoberRevolution/ReStocked/wiki/Asset-Blacklist-and-Whitelist

Btw, @RoverDude thank you a lot for this great mod!

Share this post


Link to post
Share on other sites

I know it's only been a couple weeks, but now that Global Construction is updated to 1.8.1 will it be re-added to the MKS package any time soon?

Share this post


Link to post
Share on other sites

@Rein I have been using latests releases of MKS and Global Construction together on KSP 1.8.1 and they work fine together, although not bundled. 

Share this post


Link to post
Share on other sites
7 hours ago, Rein said:

I know it's only been a couple weeks, but now that Global Construction is updated to 1.8.1 will it be re-added to the MKS package any time soon?

As @CateredCarrot said, you can just add it manually.  Other than ending up with more parts the result is the same.

Share this post


Link to post
Share on other sites
3 hours ago, goldenpsp said:

As @CateredCarrot said, you can just add it manually.  Other than ending up with more parts the result is the same.

Oh ok.  Glancing through the thread for GC it looked like MKS might have made some changes to GC configs so I wasn't sure if I should just wait until it was re-added.

Share this post


Link to post
Share on other sites
5 hours ago, Rein said:

Oh ok.  Glancing through the thread for GC it looked like MKS might have made some changes to GC configs so I wasn't sure if I should just wait until it was re-added.

MKS only has the 'GC core' piece, which is basically GC without some of the workshops(as MKS has its own), and may not have the recipe for making specialized parts out of ore.

Share this post


Link to post
Share on other sites
On 12/28/2019 at 1:59 AM, CateredCarrot said:

HI @ISzox. I had the same issue. The reason was the ReStock Mod. After I whitelisted Squad/Parts/Resources/RadialDrill/ the MKS big drills showed up. The link below detalis how to do it.

https://github.com/PorktoberRevolution/ReStocked/wiki/Asset-Blacklist-and-Whitelist

Btw, @RoverDude thank you a lot for this great mod!

Thanks for the solution

Share this post


Link to post
Share on other sites

I've got a station obriting the Mun with various components, incluing a piloted Pioneer module, and plenty of various kerbals, but I don't seem to be getting any kolony rewards. Also, nothing happens when I click on check kolony rewards on the pioneer module. Am I missing something about how the rewards work or is something going wrong? Cheers!

Thanks for the mod by the way, it's awesome!

Share this post


Link to post
Share on other sites
2 hours ago, Falesh said:

I've got a station obriting the Mun with various components, incluing a piloted Pioneer module, and plenty of various kerbals, but I don't seem to be getting any kolony rewards. Also, nothing happens when I click on check kolony rewards on the pioneer module. Am I missing something about how the rewards work or is something going wrong? Cheers!

Thanks for the mod by the way, it's awesome!

From the wiki

 

Quote

Kolony Bonuses are accrued by kerbonauts spending time on the relevant body and which stat they contribute to depends on their specialisation (FundsBoost contributes to Geology rating, ScienceBoost contributes to Botany rating and RepBoost contributes to Kolonisation rating). As these points are generated, in addition to providing production and habitation buffs, they will also generate their namesake resources over time, which can be collected from a Pioneer module on the vessel containing the points-generating crew.

So I'm pretty sure you have to be ON the Mun, not orbiting it to accrue kolony rewards.

Share this post


Link to post
Share on other sites

I read that but didn't really notice that distinction. You are probably right, thanks. :)

Share this post


Link to post
Share on other sites

Are the KIS/KAS Flex-o-Tubes deprecated for the 1.2.0 version of MKS (for use in 1.7.X versions of KSP)? I've been looking for them but can't find them. I suppose the alternative is to just use KAS pipes to link up my bases, but the Tubes looked so much nicer.

Share this post


Link to post
Share on other sites
41 minutes ago, terrendos said:

Are the KIS/KAS Flex-o-Tubes deprecated for the 1.2.0 version of MKS (for use in 1.7.X versions of KSP)? I've been looking for them but can't find them. I suppose the alternative is to just use KAS pipes to link up my bases, but the Tubes looked so much nicer.

The parts they were based on in KAS were deprecated, and it took a bit for a new solution to be found.  I think there's a changed patch in the version for KSP 1.8 that lets them work, which you could backport.  (Otherwise there's some discussion on the issue earlier in this thread.)

Share this post


Link to post
Share on other sites

Hey!  Sorry for the absence, had a few things to sort out followed by holiday and conference :)  Will be working on the next patch soonish as I have a holiday coming up.

Share this post


Link to post
Share on other sites
1 hour ago, RoverDude said:

Hey!  Sorry for the absence, had a few things to sort out followed by holiday and conference :)  Will be working on the next patch soonish as I have a holiday coming up.

Woo-whoo...he's back :)

Share this post


Link to post
Share on other sites
3 hours ago, RoverDude said:

Hey!  Sorry for the absence, had a few things to sort out followed by holiday and conference :)  Will be working on the next patch soonish as I have a holiday coming up.

Welcome back RoverDude!

Share this post


Link to post
Share on other sites
21 hours ago, RoverDude said:

Hey!  Sorry for the absence, had a few things to sort out followed by holiday and conference :)  Will be working on the next patch soonish as I have a holiday coming up.

Great to have you back - wholeheartedly reject any idea of you apologising, of course.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.