Jump to content

[1.8.x] - Modular Kolonization System (MKS)


Recommended Posts

58 minutes ago, Terwin said:

https://github.com/UmbraSpaceIndustries/MKS/wiki/Parts-(Tundra-Series)#mks-tundra-training-akademy

Nope, need to be landed to get 3 stars: " Up to one star when used on Kerbin, two stars while in orbit, and three stars if training takes place landed on another planet or moon. "

I wonder if that's modifiable with a MM config.  There's no direct reference to experienced gain in the Tundra_Akademy.cfg but it contains a Module definition for ModuleExperienceManagement.  How can I find any references to that module within the GameData\Umbra... folder?  I'm on a Windows 10 machine and no grep (not that I'd know how to use it without some study).

Edit 1: OK, found findstr in Windows and located three references to that module in the .cfg files.  None of which help.

Edited by Brigadier
Link to post
Share on other sites
6 minutes ago, Brigadier said:

I wonder if that's modifiable with a MM config.  There's no direct reference to experienced gain in the Tundra_Akademy.cfg but it contains a Module definition for ModuleExperienceManagement.  How can I find any references to that module within the GameData\Umbra... folder?  I'm on a Windows 10 machine and no grep (not that I'd know how to use it without some study).

Honestly if you are going to go to that much trouble, why not just hack them another star?

Link to post
Share on other sites
2 minutes ago, goldenpsp said:

Honestly if you are going to go to that much trouble, why not just hack them another star?

Fair enough, but what if I wanted to advance all of my Kerbals' education at a faster rate, by default, and not limit their experience points to 3 when landed on another body?

That said, pretty much an academic exercise for me because I've never written my own MM config.

Link to post
Share on other sites

I has assumed from the description that this was the number of stars that would be *added*. My kerbals are all at least lvl 2 already since MKS lets you hire them at up to lvl 2. If it doesn't work like this then is there some config file I could change to make it like this bc this seems to make more sense imo.

Link to post
Share on other sites
1 minute ago, ski23 said:

I has assumed from the description that this was the number of stars that would be *added*. My kerbals are all at least lvl 2 already since MKS lets you hire them at up to lvl 2. If it doesn't work like this then is there some config file I could change to make it like this bc this seems to make more sense imo.

I hadn't read it that way but I think you're correct.

Link to post
Share on other sites
59 minutes ago, Brigadier said:

Fair enough, but what if I wanted to advance all of my Kerbals' education at a faster rate, by default, and not limit their experience points to 3 when landed on another body?

That said, pretty much an academic exercise for me because I've never written my own MM config.

I mean there is no "wrong" way to play.  Personally I enjoy playing within the parameters the mod has setup.

 

And MM configs are easy to figure out.  Also quite fun once you get the hang of them.

Link to post
Share on other sites
2 hours ago, Dhruv said:

Any possibilities for updating it for ksp v 1.9.1??

@Dhruv, It is safe to use in 1.9.1. If you are adding it to an existing save, it is always good to make a backup of your save first.

Link to post
Share on other sites

I have a small feature request/suggestion, if that's not too presumptuous. I sometimes get in a bad situation by accidentally clicking the "disassemble part" button in the action menu, because it's often right next to the button I want, like "grab connector". Obviously a confirmation prompt or something like that would get really irritating for the user, but would there be any way to do something like put a bit of space between it and the other buttons? Just so you're less likely to move too quickly and derp and click it.

Maybe it's just me. If it is, then I guess there would be no point in the change.

Either way, again thanks for the cool mod package. You've given me endless hours of entertainment. :)

Link to post
Share on other sites
19 hours ago, TotallyNotAPilot said:

How compatible would this mod be with Kerbal Planatery Base Systems?

I'm personally more familiar with that mod, but now that I found this one I'm conflicted on which one I want to use.

PBS has support for MKS. I've been using them together. Most of the PBS parts aren't as good for MKS functions as MKS parts, but they do work. The greenhouses grow supplies, the habitats have habitation values, and so on.

Link to post
Share on other sites
3 hours ago, Tokamak said:

I have a small feature request/suggestion, if that's not too presumptuous. I sometimes get in a bad situation by accidentally clicking the "disassemble part" button in the action menu, because it's often right next to the button I want, like "grab connector". Obviously a confirmation prompt or something like that would get really irritating for the user, but would there be any way to do something like put a bit of space between it and the other buttons? Just so you're less likely to move too quickly and derp and click it.

Maybe it's just me. If it is, then I guess there would be no point in the change.

Either way, again thanks for the cool mod package. You've given me endless hours of entertainment. :)

Not just you lmao. I just "finished" a mission in which I disassembled my parachute trying to repack it. 

Link to post
Share on other sites
4 hours ago, Tokamak said:

I have a small feature request/suggestion, if that's not too presumptuous. I sometimes get in a bad situation by accidentally clicking the "disassemble part" button in the action menu, because it's often right next to the button I want, like "grab connector". Obviously a confirmation prompt or something like that would get really irritating for the user, but would there be any way to do something like put a bit of space between it and the other buttons? Just so you're less likely to move too quickly and derp and click it.

Maybe it's just me. If it is, then I guess there would be no point in the change.

Either way, again thanks for the cool mod package. You've given me endless hours of entertainment. :)

honestly id be totally irretated like you if quicksave wasen't a thing..

i've gotten in habbit of quicksaveing every time im about to do something that can end up in a massive series of explosions.

so if i make stupid mistake i just lose 5 minutes of work instead of a colony.

Link to post
Share on other sites
On 8/28/2020 at 4:06 PM, hemeac said:

@Dhruv, It is safe to use in 1.9.1. If you are adding it to an existing save, it is always good to make a backup of your save first.

well after testing it doesn't work for v1.9.1

Also can anyone update it for 1.9.1 I just can't live without this mod!!!!

Link to post
Share on other sites
On 6/17/2020 at 10:48 AM, RoverDude said:

Umm....  I am literally playing the same one you can download in 1.9.1 - this mod currently works in 1.9.1 - so no need to wait.

@Dhruv, what is not working?  RoverDude stated that this mod works in 1.9.1, so you may have installed the mod incorrectly or you have a mod conflict.  It would be helpful to get a copy of your log file as well as a screenshot of your GameData folder.

Link to post
Share on other sites
1 hour ago, hemeac said:

@Dhruv, what is not working?  RoverDude stated that this mod works in 1.9.1, so you may have installed the mod incorrectly or you have a mod conflict.  It would be helpful to get a copy of your log file as well as a screenshot of your GameData folder.

Really sorry for troubling you, the mod was not installed properly as I installed it from spacedock. After installing it from github it works perfectly!

Thanks for support

Link to post
Share on other sites
7 minutes ago, Dhruv said:

Really sorry for troubling you, the mod was not installed properly as I installed it from spacedock. After installing it from github it works perfectly!

Thanks for support

Glad you got it working in the end.

Link to post
Share on other sites

Hi!

I was trying out the MagPie mod, but ran into a bug with the the texture of the USI MKS modules:

https://imgur.com/CoVNTVl https://imgur.com/CoVNTVl

From my research, the textures for each mks tundra module are separated from the model, and MagPie only loads one of them, and disregards the pictogramms (labelled t22 etc.) when loading the _MainTexture, except for 2 modules, one for each size respectively. Is there a workaround to get Magpie to load these, or is it linked to the fact that there is more than one texturemap needed for each module and therefore it doesn't work?

Link to post
Share on other sites

Wondering if this is a bug or feature - the Ranger Agricultural Module can't be boosted with efficiency parts in version 1.3.0.0 of MKS. I'm running KSP 1.8 so that all my mods work, maybe that has something to do with it?

I took a peek in the configs and it looks like the Ranger module is missing the "EfficiencyTag" line in the Agroponics module. The Tundra 2.5m Agri module has the following in the .cfg:

MODULE
	{
		name = USI_ConverterSwapOption
		ConverterName = Agroponics
		StartActionName = Start Agroponics
		StopActionName = Stop Agroponics
		
		UseSpecialistBonus = true
		ExperienceEffect = BotanySkill
		EfficiencyTag = Greenhouse
		
		INPUT_RESOURCE
		{...

While the Ranger module has:

MODULE
	{
		name = USI_ConverterSwapOption
		ConverterName = Agroponics
		StartActionName = Start Agroponics
		StopActionName = Stop Agroponics
		
		UseSpecialistBonus = true
		ExperienceEffect = BotanySkill
		
		INPUT_RESOURCE
		{...

Is this intentional?

Link to post
Share on other sites

So I'm currently trying to put together a modpack and the moment I downloaded USI Kolonization and Life Support, extracted them into the Kerbal Space Program Folder, and when I try to start the game the loading screen get stuck on the MKS/Parts/LightGlobe part and does just not continue loading. I have waited about 20 minutes and have tried restarting steam and my PC, so can someone please help?

Link to post
Share on other sites
2 hours ago, Geryz said:

So I'm currently trying to put together a modpack and the moment I downloaded USI Kolonization and Life Support, extracted them into the Kerbal Space Program Folder, and when I try to start the game the loading screen get stuck on the MKS/Parts/LightGlobe part and does just not continue loading. I have waited about 20 minutes and have tried restarting steam and my PC, so can someone please help?

MKS has not yet been upgraded to KSP 1.10, so if you want to use it, you will need to remove the file(s) for the lightglobe part.

Link to post
Share on other sites
20 minutes ago, Geryz said:

Ok now Module Manager is giving me errors for Interstellar Fuel Switch, which I also have installed and had no problems with before I installed USI

I only know that others have the latest version of MKS running in 1.10 after they remove the light-globe piece.

Personally I am waiting to build a grand inter-planetary network once the new version comes out with W.O.L.F.(and presumably ATLAS will be nice too).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...