Jump to content

[1.8.x] - Modular Kolonization System (MKS)


Recommended Posts

4 hours ago, BadModder54 said:

Ok, so when placing it in a separate install, the "missing parts" are in the Manufacturing tab, but not in the main USI section. Does that make sense? I'm just wondering if that's true for my main install since I never looked in that particular tab. I'll check and let you know.

 

o k ,  its missing completely on my modded install. I have the community tech tree installed, and all the dependencies are the correct version. It is possible that I've simply not unlocked them yet, although I cannot see where they could be. Here's my KSP log file anyway, any errors or noticable conflicts? 

 

Log: https://www.dropbox.com/s/7kghylxc4c43cim/KSP.log?dl=0

If you have CTT that's very possible, they are a LOT more spread out in CTT.

 

(EDIT) - you can also start a sandbox game in your save.  That will prove that it's just that they are not unlocked yet in CTT.

Edited by RoverDude
Link to post
Share on other sites
On 9/27/2020 at 5:00 PM, RoverDude said:

If you have CTT that's very possible, they are a LOT more spread out in CTT.

 

(EDIT) - you can also start a sandbox game in your save.  That will prove that it's just that they are not unlocked yet in CTT.

Sorry for the late reply! I messed with some settings, and it does turn out they were in an "errant" node and that's why they appeared to not be loaded in. Thanks for your time!

Link to post
Share on other sites

Awesome mod, I found I can't play without this and it is awesome to see KSP2 implementing a lot of the features of this mod. However I unfortunately have been having issues with the WOLF dashboard. It appears as a blank grey tab with some jumbled text cramped in the upper left corner. Is there any thing I can do to fix this? Thanks for the help! :)

Link to post
Share on other sites
2 hours ago, Einstein_Cross_X1 said:

Awesome mod, I found I can't play without this and it is awesome to see KSP2 implementing a lot of the features of this mod. However I unfortunately have been having issues with the WOLF dashboard. It appears as a blank grey tab with some jumbled text cramped in the upper left corner. Is there any thing I can do to fix this? Thanks for the help! :)

It will be OK once you plant your first depot. BTW this thing seems to be unreleased, so there may be more bugs. And no tutorials.

Edited by Hohmannson
Link to post
Share on other sites
On 7/1/2020 at 4:11 PM, firda said:

Thanks a lot, renaming GameData\UmbraSpaceIndustries\MKS\Assets\LightGlobe.mu (to *.remove - changing/adding extension) helped :)

Looks like the above fix is all that is needed ... needs more testing.

To all of those who are looking for the fix to get it working on 1.10 - I found it after looking 14 pages back by others telling others looking for the fix "Oh it's just a page or two back and you'll find it". 

Hope this helps!

Link to post
Share on other sites
8 minutes ago, enewmen said:

I  notice MKS won't load in KSP 1.10

And luckily due to the nice efforts of @physius you don't have to go back 14 pages to find the fix.  You only have to spend a few seconds reading the post above yours.

22 hours ago, physius said:

I found it after looking 14 pages back by others telling others looking for the fix "Oh it's just a page or two back and you'll find it". 

 

And actually the light globe fix was mentioned 3 times one page back.  Sorry that you missed it.

Edited by goldenpsp
Link to post
Share on other sites

What is the difference between the pulse drills and the Automated pulse drills. I've never been able to tell the difference.

 

EDIT: found it in the wiki. Automated drills dont use the specialist bonus so are better for ships with no crew.

Edited by ski23
Link to post
Share on other sites
  • 2 weeks later...
53 minutes ago, Hypercore said:

The EL parts are going away, right? If it is, I wish it wasn't

I don't recall MKS having EL specific parts.  More that some of the MKS parts had EL functions added to them.  It's been awhile since I've dealt with MKS + EL.

 

AFAIK the integration is still being maintained by third party contributors.  So as long as people still keep those up to date and @RoverDude accepts the pull requests things will still work.

Link to post
Share on other sites
1 hour ago, Hypercore said:

The EL parts are going away, right? If it is, I wish it wasn't

No specific EL parts, if someone wants to do a third party integration that's fine - tbh I will probably be moving to the model where I encourage people to maintain these kinds of patches separately since it's tough maintaining something for a mod I do not use.

Link to post
Share on other sites

Can someone explain to me the use case for cultivating over agroponics? I feel like i'm missing something, the agroponics option in agriculture modules produces more supplies per day than the corresponding cultivate options, and doesn't require dirt, substrate or water. Agroponics just needs fertilizer and mulch, and seems simpler in terms of supply chains

Link to post
Share on other sites
2 minutes ago, bdole92 said:

Can someone explain to me the use case for cultivating over agroponics? I feel like i'm missing something, the agroponics option in agriculture modules produces more supplies per day than the corresponding cultivate options, and doesn't require dirt, substrate or water. Agroponics just needs fertilizer and mulch, and seems simpler in terms of supply chains

Agroponics isn't break-even with resource use. If you use cultivate, the supply chains will replenish themselves.

Link to post
Share on other sites
2 hours ago, Clamp-o-Tron said:

Agroponics isn't break-even with resource use. If you use cultivate, the supply chains will replenish themselves.

Can you elaborate? I was under the impression the kerbals produced enough mulch to keep agroponics fed, and thats the only input other than fertilizer right? And you need fertilizer for cultivate anyways

Link to post
Share on other sites
8 hours ago, bdole92 said:

Can you elaborate? I was under the impression the kerbals produced enough mulch to keep agroponics fed, and thats the only input other than fertilizer right? And you need fertilizer for cultivate anyways

You're not wrong. It doesn't help that the most up-to-date documentation is in KSPedia... except some bug makes it not appear in KSPedia. Some of this may be wrong, but it reflects my best understanding.

"Agronomics" makes Supplies from Mulch and Fertilizer.

"Cultivate" is used to produce Supplies from Fertilizer, Water, and Substrate/Dirt. The (to me, rather niche) use case is if you want to produce excess Supplies above and beyond the available Mulch - perhaps because you are sending an expedition from your base that will not carry Agroponics.

"Agriculture" makes Organics from the same ingredients, which are used in the production of Colony Supplies.

What makes it break even is "Fertilizer (M)" or "Fertilizer (G)" which produces additional Fertilizer from Minerals or Gypsum.

On top of this, "Greenhouse" is a mode which boosts the throughput of some "Cultivate" modules; "Crusher" is a mode (for material processors) which boosts the throughput of some "Fertilizer" modules.

Big Agriculture modules (like Tundra) offer Agroponics, Cultivate, and Agriculture. These aren't, then, competing ways to keep up with normal Supplies replenishment; they're different functions for different jobs.

"Fertilizer (M/G)" comes on material processors, the Ranger Crusher, and the Tundra Agricultural Support Module. The choice of ways to do things for a long mission is between bringing a huge amount of Fertilizer and bringing a way to dig up Gypsum or Minerals and one of these additional parts to make it into Fertilizer. For a long enough mission, the second option is the lighter one.

On top of that, then, the second option uses up Machinery (but at a slow rate). There's then a similar choice between just sending a box of the stuff, or sending the modules and SpecializedParts to turn Recyclables back into Machinery, or sending the full kit to dig stuff up and make the SpecializedParts too.

I _think_ the "boost" modules have no limit to the number of modules they can support, so a very large base can get more throughput from a tonne of boost module than a tonne of the boosted module.

This kind of thing is meant to drive the MKS gameplay. When your base is just 3 kerbals for a short visit, you just bring Supplies. The longer you stay, the more incentive there is to ship in the stuff that's more mass-efficient in the long run, so you naturally have something to do with your base as time goes by.

Link to post
Share on other sites
2 hours ago, damerell said:

I _think_ the "boost" modules have no limit to the number of modules they can support, so a very large base can get more throughput from a tonne of boost module than a tonne of the boosted module.

From my understanding, the 'boost' function is intended to allow lower tech/smaller modules to participate in more advanced processes.  The total boost is supposed to be equivalent to having the same tonnage of advanced components working as you have less advanced components boosting(ie output of 10 tons of refinery+10 tons of crusher boosting components = output of 20 tons of refinery).  Total output and total consumption of machinery should be identical for the same total mass of components regardless of the proportion that are boosting vs processing.

This is supposed to keep your early components from becoming useless once you have added your later components.

Link to post
Share on other sites
5 minutes ago, Terwin said:

From my understanding, the 'boost' function is intended to allow lower tech/smaller modules to participate in more advanced processes.

Ah! That makes sense of oddballs like the Ranger Agricultural Module. Thanks.

Link to post
Share on other sites
47 minutes ago, Syczek said:

USI to 1.10

Ordinarily I'm pretty heavily against such "when update" questions, but in this case MKS is now over a year and two major game releases behind the times...
I get that these things take time, especially if there's some major rework in progress, but this is getting pretty close to "dead mod" territory right now. That's a shame, because on the rare occasions it's compatible with the current state of the game, it's pure awesome.

Could we not have some kind of interim compatibility update, or even just an official word on said compatibility? It's literally been years since I could start an MKS playthrough with any confidence it's going to work properly.

Link to post
Share on other sites
2 hours ago, steve_v said:

Ordinarily I'm pretty heavily against such "when update" questions, but in this case MKS is now over a year and two major game releases behind the times...
I get that these things take time, especially if there's some major rework in progress, but this is getting pretty close to "dead mod" territory right now. That's a shame, because on the rare occasions it's compatible with the current state of the game, it's pure awesome.

Could we not have some kind of interim compatibility update, or even just an official word on said compatibility? It's literally been years since I could start an MKS playthrough with any confidence it's going to work properly.

Ordinary i would agree except that this mod worked fine in 1.9 and with the exception of the light globe it is also working in 1.10.

Link to post
Share on other sites
2 hours ago, steve_v said:

Ordinarily I'm pretty heavily against such "when update" questions, but in this case MKS is now over a year and two major game releases behind the times...
I get that these things take time, especially if there's some major rework in progress, but this is getting pretty close to "dead mod" territory right now. That's a shame, because on the rare occasions it's compatible with the current state of the game, it's pure awesome.

Could we not have some kind of interim compatibility update, or even just an official word on said compatibility? It's literally been years since I could start an MKS playthrough with any confidence it's going to work properly.

Worked perfectly fine in 1.9.x, works fine in 1.10.x with the exception of the light globe.  

59 minutes ago, ZAJC3W said:

Isn't RoverDude working on KSP2 now?

Yeah, still alive but KSP1 and KSP2 keep me busy too :)

10 minutes ago, goldenpsp said:

Ordinary i would agree except that this mod worked fine in 1.9 and with the exception of the light globe it is also working in 1.10.

(what this guy said) ;)

Link to post
Share on other sites
55 minutes ago, goldenpsp said:

Ordinary i would agree except that this mod worked fine in 1.9 and with the exception of the light globe it is also working in 1.10.

And if you go into the DEV Branch and grab the CFG for the light globe, it will work just fine in 1.10 again.  @RoverDudeMaybe you should push that change out to the release version. It is such a minor change but would fix the compatibility issue for KSP 1.10.

Link to post
Share on other sites
5 hours ago, RoverDude said:

Worked perfectly fine in 1.9.x, works fine in 1.10.x with the exception of the light globe. 

This plus if you installed it from the constellation zip you have to remove

Constellation_2018.11.22.01.zip\GameData\UmbraSpaceIndustries\MKS\Parts\New folder\

from your KSP GameData folder otherwise some Tundra Parts won't be useable.
You can unlock them in the tree and they will show unlocked (and bought), but it won't get saved and once you swap to VAB/SPH it'll tell you to go unlock it in R&D (the right click -> buy isn't available in VAB/SPH).

At least in my install I had to do so, might be an error on my side as it took several tries to get it all to load up in the first place. Grain of Salt and all ;)

While I'm at it tho, can someone please explain to me why I should use a Tundra MedBay over a Kolonization Module?
The MedBay is heavier, seems to chug way too much EC and CSupplies for only affecting "Tourist" Kerbals seated in the module itself while the KModule does not have those restrictions and eats less EC and CSup and you don't need a Medic Kerbal either? :huh:

Edited by Feye
Added mass as point against MedBay
Link to post
Share on other sites
6 hours ago, RoverDude said:

works fine in 1.10.x with the exception of the light globe.

Excellent, thanks. Think we could put this information somewhere visible, or better yet fix that one little niggle and officially mark it as compatible?

 

5 hours ago, pmoffitt said:

@RoverDudeMaybe you should push that change out to the release version.

Seconded.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...