• 0
rational_pi

[Mac] Current Version ID: 0, Play button greyed out?

Question

Hello,

I've just downloaded and installed the latest version of KSP, and I opened the launcher only to find that the play button is greyed out. It is listing "current version ID" as 0, which I'm assuming has something to do with it - something is corrupt? Any advice?

EDIT: I've partially found the solution, but still looking for a less hacky fix. If I open the terminal window and execute

$ /Applications/KSP_osx/Launcher.app/Contents/MacOS/Launcher

it does launch and allow me to play. So there appears to be a bad link in the Launcher package or something. Does anybody have a fix such that I don't have to launch it from the terminal, or is this a wait-until-KSP-fixes-it issue? (In which case I suppose this is resolved, and here is the solution for anybody else having the problem.)

Thanks!

Edited by rational_pi
Additional information

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
On 1/18/2017 at 0:53 PM, jenspr said:

Any news?
I just bought KSP and am experiencing the exact same problems.

So what to do?

Very disappointing and frustrating.. Spend a bit of money and cannot even use it

Here's the final workaround I've come up with. In Mission Control, open Automater (its icon is a little robot, and it is located in the Other folder by default). Create a New Document -> Application. On the right side (library) look for Run Shell Script and drag that into the workflow. Type /Applications/KSP_osx/Launcher.app/Contents/MacOS/Launcher into the text box and leave everything else as the default, and then save it to the Applications folder (I named it KSP_Hack but you can call it whatever). Finally, to get the icon, open up Finder and navigate to the Applications window, right click on KSP_Hack and click Get Info. Then, in the finder window, find the KSP launcher, and drag it to the icon next to where it says "KSP_Hack" at the very top. The icon should change to the Kerbal icon. Now KSP_Hack looks totally legit, and you'll never know the difference!

Share this post


Link to post
Share on other sites
  • 2

Hi @rational_pi, it sounds like you have the same issue a lot of other macOS users have reported, basically Apples Gatekeeper will interfere with unsigned applications, Squad are working on getting KSP signed for future releases.

Until then your workaround will do the job, as can copying KSP to the desktop and back, in most cases it causes Gatekeeper to treat the files as yours and permits KSP to run.

Share this post


Link to post
Share on other sites
  • 0

I know zero about Macs (which you will shortly understand), but I've done a little bit of forum poking for you, and I've found some information which could be helpful, at least to get you started.  The few solutions that I seem to have found involve either:

  • Re-install the game
  • If downloaded through Steam then Verify integrity of Cache and try again
  • Don't use the launcher (can you launch it through KSP exe on a mac?!)

Couple of (old) threads here and here, and half way down this thread.

Sorry I can't be more helpful!

SM

Share this post


Link to post
Share on other sites
  • 0
On 1/11/2017 at 0:12 AM, Speeding Mullet said:

I know zero about Macs (which you will shortly understand), but I've done a little bit of forum poking for you, and I've found some information which could be helpful, at least to get you started.  The few solutions that I seem to have found involve either:

  • Re-install the game
  • If downloaded through Steam then Verify integrity of Cache and try again
  • Don't use the launcher (can you launch it through KSP exe on a mac?!)

Couple of (old) threads here and here, and half way down this thread.

Sorry I can't be more helpful!

SM

I did try re-installing and it's not through Steam. If I just launch the KSP exe it doesn't load, it sits on the loading bar for an infinite amount of time and doesn't make any progress.

Thank you though!

Share this post


Link to post
Share on other sites
  • 0

Any news?
I just bought KSP and am experiencing the exact same problems.

So what to do?

Very disappointing and frustrating.. Spend a bit of money and cannot even use it

Share this post


Link to post
Share on other sites
  • 0

I'm sorry to hear you are having trouble jenspr, unfortunately Apples Gatekeeper will prevent unsigned apps from loading. You should be able to open the app and run the KSP.app file directly, or try the workaround above.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.