StarCrusher96

[1.5.1] Kerbal Star Systems [v0.8.2] August 18, 2018

Recommended Posts

2 hours ago, IggyHitokage said:

Yeah, that's why I'm assuming this is just a stupid false positive, apologies if I raised an alarm about it. :(

No problem :) I’ll double check my antivirusses this evening haha 

Share this post


Link to post
Share on other sites

I have a question about the atmospheres on a couple of the planets. I've tried some aerobraking on Jool and Tylo which didn't end well.

The KSS wiki for Jool says the atmospheric height is 400km but I don't seem to switch to atmospheric flight until about 320km (when I can only physics warp). Even then there appears to be no atmosphere (barometer reads IN VACUUM). As soon as I go below about  200km I hit what must be dense atmosphere resulting in insta-death in a short lived ball of fire. I've noticed a similar affect on Eve.

Attempting to aerobrake on Tylo I got to 9700m, just 30m into the atmosphere, before hitting the atmospheric brick wall (I was travelling pretty fast as it was a poor intercept). The atmospheric stats for Tylo seem a bit odd. An atmospheric height of only 10km but an atmospheric pressure of 6.9 atm. I'm definitely no physicist but is there any scientific reason this could happen? Is it by design or a bug?

Otherwise thoroughly enjoying the mod. Its rejuvinated my love of KSP :)

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Badlywrapdkebab said:

Attempting to aerobrake on Tylo I got to 9700m, just 30m into the atmosphere, before hitting the atmospheric brick wall (I was travelling pretty fast as it was a poor intercept). The atmospheric stats for Tylo seem a bit odd. An atmospheric height of only 10km but an atmospheric pressure of 6.9 atm. I'm definitely no physicist but is there any scientific reason this could happen? Is it by design or a bug?

Tylo should not have a dense atmosphere :/

Share this post


Link to post
Share on other sites
14 minutes ago, TheSpacePotato said:

Tylo should not have a dense atmosphere :/

 Thought it only had an exosphere. Going to investigate. 

  • Like 2

Share this post


Link to post
Share on other sites
3 hours ago, Badlywrapdkebab said:

I have a question about the atmospheres on a couple of the planets. I've tried some aerobraking on Jool and Tylo which didn't end well.

The KSS wiki for Jool says the atmospheric height is 400km but I don't seem to switch to atmospheric flight until about 320km (when I can only physics warp). Even then there appears to be no atmosphere (barometer reads IN VACUUM). As soon as I go below about  200km I hit what must be dense atmosphere resulting in insta-death in a short lived ball of fire. I've noticed a similar affect on Eve.

Attempting to aerobrake on Tylo I got to 9700m, just 30m into the atmosphere, before hitting the atmospheric brick wall (I was travelling pretty fast as it was a poor intercept). The atmospheric stats for Tylo seem a bit odd. An atmospheric height of only 10km but an atmospheric pressure of 6.9 atm. I'm definitely no physicist but is there any scientific reason this could happen? Is it by design or a bug?

Otherwise thoroughly enjoying the mod. Its rejuvinated my love of KSP :)

So I looked at the configs for Tylo and Jool

About Jool:

In KSS Jool got a new atmospheric model more similar to Jupiter. 

AACHCTI0.JPG

400 km (~ 250 km real Jupiter) - 0 atm

325 km - 9.86923267 × 10-8 atm

200 km - 0.001 atm

150 km - 0.1 atm --- This is the devision between flying Low or High

100 km - 1 atm

0 km (~ -150 km real Jupiter) - 20 atm

-> This means you need to dive much deeper in the atmo of Jool to start aerobreaking.

 

About Tylo:

Tylo only has an exosphere of 7,0000000030275E-011 kpa (6,90846287 × 10-13 atm) - almost vacuum. 

So it's not suitable for aerobreaking.

 

To fix Tylo, go to KSS/KopernicusFiles/VanillaPlanets/Jool/Tylo.cfg

Replace the Atmospheric part with this one.

Spoiler

Atmosphere                
    {                
        enabled = True            
        oxygen = False            
        altitude = 10000            
        adiabaticIndex = 1.54            
        atmosphereMolarMass = 0.016            
        temperatureSeaLevel = 87            
        staticPressureASL = 7.0000000030275E-011            
        temperatureCurve                
        {                
            key =    0    70    0.00000E+00    3.50000E-02
            key =    1000    105    3.50000E-02    5.00000E-03
            key =    2000    110    5.00000E-03    0.00000E+00
            key =    3000    110    0.00000E+00    0.00000E+00
            key =    4000    110    0.00000E+00    0.00000E+00
            key =    10000    110    0.00000E+00    0.00000E+00
        }                
        temperatureSunMultCurve                
        {                
            key =    0    1    0.00000E+00    -6.00000E-05
            key =    20000    -0.2    -6.00000E-05    1.33333E-05
            key =    50000    0.2    1.33333E-05    0.00000E+00
            key =    60000    0.2    0.00000E+00    0.00000E+00
        }                
        temperatureLatitudeBiasCurve                
        {                
            key =    0    0    0    -0
            key =    38    0    -0    -0
            key =    90    -0    -0    0
        }                
        temperatureLatitudeSunMultCurve                
        {                
            key =    0    40    0    -0
            key =    38    34.7    -0.2686    -0.2686
            key =    90    15    -0.4363    0
        }                
        temperatureAxialSunBiasCurve                
        {                
            key =    0    0.81    0.0088    0.0088
            key =    32.133    0.95    0    0
            key =    122.133    0    -0.0166    -0.0166
            key =    212.133    -0.95    -0    -0
            key =    302.133    -0    0.0166    0.0166
            key =    360    0.81    0.0088    0.0088
        }                
        temperatureAxialSunMultCurve                
        {                
            key =    0    0    0    0
            key =    38    0.5    0.02    0.02
            key =    90    1    0    0
        }                
        temperatureEccentricityBiasCurve                
        {                
            key =    0    2.56    0    -5.12
            key =    1    -2.56    -5.12    0
        }                
        pressureCurve                
        {                
            key =    0    7.00000E-11    0.00000E+00    -1.32289E-14
            key =    10000    0.00000E+00    0.00000E+00    0.00000E+00
        }                

            AtmosphereFromGround
            {
                
                waveLength = 0.97,0.95,0.90,1  
                scale = 0.01
                innerRadius = 0
                outerRadius = 0
                outerRadiusMult = 0
                innerRadiusMult = 0
            }
        }

 

I hope this provides more insight in the atmospheric models of Jool and Tylo.

Edited by StarCrusher96
  • Like 3

Share this post


Link to post
Share on other sites
15 hours ago, StarCrusher96 said:

@Thrandir

Only thing you can do is install ONLY KSS_BASIC on a clean install of KSP 1.3.1. Make sure you're using the most recent versions of kopernicus and ModuleManager. Run the game and send me the logs. I just can't understand why a clean install doesn't work. 

 

edit2 : KSP logs that you've been asked me for 

https://www.dropbox.com/s/41qjqdbgma1ntr5/KSP_log0.rar?dl=0

So, it doesn't work at all with fresh install KSP + KSS_BASIC and Kopernicus

 

Hello, there i have good news and bad news.

Firstofall, thanks for replies and trying to be helpful :)

Now, i've found what is caused the problem.

It is 

 

 

 

So, that one is good news but bad news is when i try to install kopernicus with ckan, it has dependency for modulerflightintegrator. So I don't know what to do. If i remove Modularflightintegrator from gamedata folder without Ckan, do i get a problem in the future base on lack of moduleflightintegrator ?

 

edit 1: I've just tried without modularflightintegrator. Your systems doesn't show up without it. So it has dependecny on modularflightintegrator as well.

From now on, there is nothing i can do for it or is there ?

Edited by Thrandir

Share this post


Link to post
Share on other sites

https://forum.kerbalspaceprogram.com/index.php?/topic/140580-131-kopernicus-release-3-nov-30/&page=110&tab=comments#comment-3233750

Is there some way I could have accidentally messed up the brightness curve for Kerbol unintentionally somehow? I'm finding bodies extremely dark  during daylight and my ships aren't really lit up by the sun either.

Below is a picture on the mun with Kerbol visible:

fsDmD5W.png

I tried running on a clean install but that didn't seem to fix it. Is there something I can reset or modify to fix this?

Thanks a lot for the work on this mod, the planets are fantastic, even if I cant really see them :P!

Edited by Lifeisgreasy

Share this post


Link to post
Share on other sites
5 hours ago, Thrandir said:

 

edit2 : KSP logs that you've been asked me for 

https://www.dropbox.com/s/41qjqdbgma1ntr5/KSP_log0.rar?dl=0

So, it doesn't work at all with fresh install KSP + KSS_BASIC and Kopernicus

 

Hello, there i have good news and bad news.

Firstofall, thanks for replies and trying to be helpful :)

Now, i've found what is caused the problem.

It is 

 

 

 

So, that one is good news but bad news is when i try to install kopernicus with ckan, it has dependency for modulerflightintegrator. So I don't know what to do. If i remove Modularflightintegrator from gamedata folder without Ckan, do i get a problem in the future base on lack of moduleflightintegrator ?

 

edit 1: I've just tried without modularflightintegrator. Your systems doesn't show up without it. So it has dependecny on modularflightintegrator as well.

From now on, there is nothing i can do for it or is there ?

Kopernicus comes along with moduleflightintegrator... one doesn’t work without the other :P

59 minutes ago, Lifeisgreasy said:

https://forum.kerbalspaceprogram.com/index.php?/topic/140580-131-kopernicus-release-3-nov-30/&page=110&tab=comments#comment-3233750

Is there some way I could have accidentally messed up the brightness curve for Kerbol unintentionally somehow? I'm finding bodies extremely dark  during daylight and my ships aren't really lit up by the sun either.

Below is a picture on the mun with Kerbol visible:

fsDmD5W.png

I tried running on a clean install but that didn't seem to fix it. Is there something I can reset or modify to fix this?

Thanks a lot for the work on this mod, the planets are fantastic, even if I cant really see them :P!

Oh now i see ... kopernicus updated. Use the previous version of kopernicus (release 2) and your brightnesscurves will be fixed. 

@Thrandir, try this too.

Edited by StarCrusher96
  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, StarCrusher96 said:

Kopernicus comes along with moduleflightintegrator... one doesn’t work without the other :P

Well, So your mod which you've created won't work properly then :(

I did try to install GPP, it works fine but yours is not. Problem is i really want to play with KSS :) 

Share this post


Link to post
Share on other sites
21 minutes ago, Thrandir said:

Well, So your mod which you've created won't work properly then :(

I did try to install GPP, it works fine but yours is not. Problem is i really want to play with KSS :) 

If you download kopernicus from Github you get Modulemanager and moduleflightintegrator with it. That's how it always goes ...

around 6000 others managed to make KSS work ... 

Edited by StarCrusher96

Share this post


Link to post
Share on other sites
2 minutes ago, StarCrusher96 said:

If you download kopernicus from Github you get Modulemanager and moduleflightintegrator with it. That's how it always goes ...

I dont want to be pain in the kerbin :D but i've tried that too. ( With Ckan and without ckan installation from github ) :P

 

Share this post


Link to post
Share on other sites
22 minutes ago, Thrandir said:

I dont want to be pain in the kerbin :D but i've tried that too. ( With Ckan and without ckan installation from github ) :P

 

So just install kopernicus release 2, modulemanager & ModuleFlightIntegrator just as others did?

Edited by StarCrusher96

Share this post


Link to post
Share on other sites
1 hour ago, StarCrusher96 said:

Oh now i see ... kopernicus updated. Use the previous version of kopernicus (release 2) and your brightnesscurves will be fixed. 

@Thrandir, try this too.

This fixed it, thanks!

  • Like 1

Share this post


Link to post
Share on other sites

DUE TO AN UPDATE OF KOPERNICUS (RELEASE 3), KSS BROKE SOMEHOW, AS USUAL. 

HOW TO PLAY KSS? -> USE KOPERNICUS RELEASE 2.

WORKING ON FIXING IT!

Edited by StarCrusher96
  • Like 4

Share this post


Link to post
Share on other sites
1 hour ago, StarCrusher96 said:

 

around 6000 others managed to make KSS work ... 

Well not 6000 others, as you can see me, @Lifeisgreasy has/had same problem. I don't want to be rude but i did what you have asked me. I did provide logs 2 times by now. I've Installed my KSP 2 times. ( i did not mention other installation before you did ask me)I've also tried install mod 1 by 1 because asked me to do it. I've spent my almost 10 hours for this to fix and i wanted play KSP with your KSS mod.  So, no sir i am not stupid. I did everything by book. I don't care what others did or why not they did not report.

 

1 hour ago, StarCrusher96 said:

So just install kopernicus release 2, modulemanager & ModuleFlightIntegrator just as others did?

I did install, 1.3.1-2 instead 1.3.1-3. It doesn't fix entirely. I am still having a texture problem on KSC view. If i am on day cycle it does stuck on day cycle on KSC view, even time is showing at night time. Also, it does fix Mun or other planet texture, day and night cycle problem. i haven't tried all planets but i will.

So, yes it is still buggy but less. Also i've been informed that it isn't MFI problem. So please, you may find useful to check logs and what is wrong with KSS.

Have a good day and i am really fan of your KSS that is why i did all tests and other stuff to work it out.

Edited by Thrandir

Share this post


Link to post
Share on other sites

@Thrandir, day and night cycle being broken is normal. This happens when Kerbin's orbit is moved around another star. @Lifeisgreasy's problem has been solved.

I need all the logs, screenshots and an exact description of the problem. 

Edited by StarCrusher96
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, StarCrusher96 said:

DUE TO AN UPDATE OF KOPERNICUS (RELEASE 3), KSS BROKE SOMEHOW, AS USUAL. 

HOW TO PLAY KSS? -> USE KOPERNICUS RELEASE 2.

WORKING ON FIXING IT!

 

  • Like 1

Share this post


Link to post
Share on other sites

Hey guys. I'm new to the forum and I have to say that this mod looks amazing. I've been reading through a lot of the previous posts and the wiki and I can't wait to start a new career with KSS. I just had one small question. If I start a new career with the current release of KSS will my save likely break when Part 2 is released? I gather its a huge update so if it does, cool. More practice. If this has an obvious answer, sorry. I'm dumb and don't know things :confused:.

  • Like 2

Share this post


Link to post
Share on other sites

@Charles Foxtrot You should be able to start a new career and update to Part 2 without breaking the save. However, with the new kopernicus update, I'm kind of unsure :P

  • Like 2

Share this post


Link to post
Share on other sites

@TheSpacePotato Yeah I was reading about the new kopernicus update. But thanks for letting me know. Either way, I just installed the current KSS and it is insane! A bit more of a challenge than the stock system I've been playing :). Thank you for such a cool mod

  • Like 3

Share this post


Link to post
Share on other sites
21 hours ago, Charles Foxtrot said:

Thank you for such a cool mod

Make sure to always thank @StarCrusher96 :P He deserves a vast majority of the credit.

Also TheSpacePotato for having to take over the sciencedefs when I started to slack off due to school work.

Hope I can contribute more in the near future after finals are over, though.

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Greatness101 said:

Also TheSpacePotato for having to take over the sciencedefs when I started to slack off due to school work.

Hope I can contribute more in the near future after finals are over, though.

Well with the new writers I no longer have to focus on writing everything :P

  • Like 2

Share this post


Link to post
Share on other sites

I guess I'm harsh, but I'm sort of doing it right: I put Kopernicus, then basic 7.0, then the rest of the systems are on top. As a result, there is an error +

everything is very slow.

 

"Kopernicus was not able to load the custom planetary system due to exception in the loading process. Loading your savegame is NOT recommended, because the missing planets could corrupt it and delete your progress. Please contact the planet pack author or the Kopernicus team about the issue and send them a valid bugreport, including your KSP.lpg, your <oduleManager.ConfigCache file and the folder Logs/Kopernicus/ from your KSP root directory."

 

Like I found some conflict with the mods.

Edited by Isildurd
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Isildurd said:

I guess I'm harsh, but I'm sort of doing it right: I put Kopernicus, then basic 7.0, then the rest of the systems are on top. As a result, there is an error +

everything is very slow.

 

"Kopernicus was not able to load the custom planetary system due to exception in the loading process. Loading your savegame is NOT recommended, because the missing planets could corrupt it and delete your progress. Please contact the planet pack author or the Kopernicus team about the issue and send them a valid bugreport, including your KSP.lpg, your <oduleManager.ConfigCache file and the folder Logs/Kopernicus/ from your KSP root directory."

 

Like I found some conflict with the mods.

Use kopernicus RELEASE 2 not 3 (NOT THE LATEST). The update broke KSS, general rule when kopernicus updates is that a lot of planetmods break and need to be updated.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.