Jump to content

[1.5.1] Kerbal Star Systems [v0.8.2] August 18, 2018


StarCrusher96
 Share

Recommended Posts

31 minutes ago, StarCrusher96 said:

For example The Mun that eats vessels ... Think i finally fixed it for 0.7.4

I have just noticed I am still getting Mun troubles, however now they take the form of orbits getting messed up to a greater or lesser extent rather than vessels outright disappearing. I am going to regress through some older saves and try and get something from the log file about SOI changes for ships I know are in stable Mun orbits.

Link to comment
Share on other sites

7 minutes ago, billw2011 said:

I have just noticed I am still getting Mun troubles, however now they take the form of orbits getting messed up to a greater or lesser extent rather than vessels outright disappearing. I am going to regress through some older saves and try and get something from the log file about SOI changes for ships I know are in stable Mun orbits.

It's caused by Karkua :P delete it and the orbits don't get messed up. 

Link to comment
Share on other sites

5 minutes ago, StarCrusher96 said:

It's caused by Karkua :P delete it and the orbits don't get messed up. 

I did, I posted about it in this same thread a few days ago! This is WITH Karkua deleted. When Karkua was there it entirely removed my Mun orbiting vessels due to collision with it. Now the vessels stay there but their orbits are getting perturbed to the point that some vessels have gone into escape trajectories from the Kerbin system. I looked back through log and I have noticed some vessels are transitioning to Kerbol SOI during load. I left these vessels in stable Mun orbits.

Quote


-INFO- Tac.LifeSupportController[FFEA4744][1247.97]: Vessel situation change
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FF: vessel Mun CommSat 1a (unloaded) has reached orbit around Kerbol
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.LifeSupportController[FFEA4744][1247.97]: Vessel situation change
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FF: vessel Mun CommSat 1 Probe Debris (unloaded) has reached orbit around Kerbol
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-INFO- Tac.LifeSupportController[FFEA4744][1247.97]: Vessel situation change
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FF: vessel FSat VCASS 7Yh (unloaded) has reached orbit around Kerbol

/edit Just to be clear to delete Kurkua I just removed the cfg file.

Edited by billw2011
Link to comment
Share on other sites

1 hour ago, billw2011 said:

I did, I posted about it in this same thread a few days ago! This is WITH Karkua deleted. When Karkua was there it entirely removed my Mun orbiting vessels due to collision with it. Now the vessels stay there but their orbits are getting perturbed to the point that some vessels have gone into escape trajectories from the Kerbin system. I looked back through log and I have noticed some vessels are transitioning to Kerbol SOI during load. I left these vessels in stable Mun orbits.

/edit Just to be clear to delete Kurkua I just removed the cfg file.

So I couldn't reproduce the problem, although I did find my older saves when the orbits were not messed up. I think perhaps it is some combination of the warp across SOI bug and something to do with Korpernicus, OR something to do with the order of initialization of mods where a mod is messing with craft orbits before Korpernicus has initialized and doing it incorrectly.

Link to comment
Share on other sites

I've never played with other star systems before, but I'm thinking I want to try. Problem is, I'm rather attached to the stock planets. Is it as simple as nixing some configs to have this mod leave the Kerbol system as-is?

Also, Is anyone able to post a screenshot of the tracking station showing the orbits of the new stars around the galactic center (the All?) for me? I'm just curious about the scale of this and want to visualize it a bit before I install it. Thanks!

Link to comment
Share on other sites

10 hours ago, Booots said:

I've never played with other star systems before, but I'm thinking I want to try. Problem is, I'm rather attached to the stock planets. Is it as simple as nixing some configs to have this mod leave the Kerbol system as-is?

Changing back to stock is almost impossible. One of the main features of kss, is to improve the rather simple and boring stock bodies. 

It’ll take some work to revert everything. You can try it yourself but I’m not giving support to undo all the work I did to make everything more interesting.

Hope you understand it.

Edited by StarCrusher96
Link to comment
Share on other sites

I found some weird interactions when flying a spacecraft between kelar III and IV. Because the SOI of Kelar IV is > 32Mkm, it is possible for a spacecraft to enter orbit of Kelar IV when trying to get to Lyrne. Also,  I think if KSP has the barycenter feature for mutiple object system, it will be much better and more realistic for KSS and other planet/star packs. (sorry for bad English)

 

Edited by Lil guy
Link to comment
Share on other sites

3 hours ago, Lil guy said:

I found some weird interactions when flying a spacecraft between kelar III and IV. Because the SOI of Kelar IV is > 32Mkm, it is possible for a spacecraft to enter orbit of Kelar IV when trying to get to Lyrne. Also,  I think if KSP has the barycenter feature for mutiple object system, it will be much better and more realistic for KSS and other planet/star packs. (sorry for bad English)

Seems like i forgot to define the SOI of Kelar IV! Thx for reporting.

Link to comment
Share on other sites

10 hours ago, Lil guy said:

I found some weird interactions when flying a spacecraft between kelar III and IV. Because the SOI of Kelar IV is > 32Mkm, it is possible for a spacecraft to enter orbit of Kelar IV when trying to get to Lyrne. Also,  I think if KSP has the barycenter feature for mutiple object system, it will be much better and more realistic for KSS and other planet/star packs. (sorry for bad English)

 

Barycenters require the Sigma Binary plugin. I'm pretty sure Kel/Char and Ceth/Klip are supported, but I don't think any of the star systems are.

Link to comment
Share on other sites

50 minutes ago, Greatness101 said:

Barycenters require the Sigma Binary plugin. I'm pretty sure Kel/Char and Ceth/Klip are supported, but I don't think any of the star systems are.

Sigma Binary doesn't work  ... for some reason it keeps giving errors. Would be caused by open nodes in the configs. I'm still working on finding those.

2 hours ago, Lifeisgreasy said:

It seems that the biome map for Narath is mirrored with respect to the planet itself. It isn't just the S.C.A.N. overlay either, confirmed that the biomes are mirrored when I landed.

TvbcrWD.jpg

SSeuvu4.jpg

thx for reporting!

Link to comment
Share on other sites

17 minutes ago, StarCrusher96 said:

Kerelus, the first Wolf Rayet star discovered by kerbals. 

screenshot67.png?dl=1

Someone asked for a WR star in the wiki a week ago :P

Which shows that we are listening to your requests and we will implement them if they are good ideas.

Link to comment
Share on other sites

Hello I need some help I can't get this mod to work I don't know what I did wrong  Kopernicus works fine but KSS just has a forever loading screen and on the site the images won't load so I can't see what it looks like in game data on this site I have everything I need it's just not in the right order

Edited by Zrty
Link to comment
Share on other sites

6 hours ago, StarCrusher96 said:

Kerelus, the first Wolf Rayet star discovered by kerbals. 

screenshot67.png?dl=1

If that explodes, won't it give cancer to everything within about 10,000 light years?

 

also i'd really like to see a sneek peek of the rogue precursor planet kthxbye

Link to comment
Share on other sites

8 hours ago, Zrty said:

Hello I need some help I can't get this mod to work I don't know what I did wrong  Kopernicus works fine but KSS just has a forever loading screen and on the site the images won't load so I can't see what it looks like in game data on this site I have everything I need it's just not in the right order

It works I found out what happening it's one of my mods but I don't know which one

 

everthing works you need to load it without mods 1st then with mods 

 

well now im haveing serious issues with frame rate I have 8GB ddr4 with a GTX1060 and a Intel quad core CPU 

it's just the title screen so nevermind on any help 

Edited by Zrty
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...