sarbian

[1.10.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.11.0] [20th August 2020]

Recommended Posts

FYI that at least on build 938, the auto rendezvous is broken. Matches planes and then just sits, at least when the active ship is inside the orbit of the target ship.

Cheers...

Edited by ksp_circles

Share this post


Link to post
Share on other sites
On 2/5/2020 at 4:38 AM, steve_v said:

Alright. The time has come, with some trepidation, to crosspost this one here:

FAR alone seems fine and there is little help to be had over there anyway, at least since ferram4 went AWOL. So I now I must humbly poke @sarbian with a pointy stick and ask why adding MechJeb to a happy little FAR install is bringing me such hurt.

Any ideas? It looks like an unfortunate interaction to me, rather than solely a FAR bug.

I think some RO players determined that this happens when a vessel has multiple command pods and during separation (or presumably RUD) the command pod on the inactive vessel starts spamming FAR debug stuff.  That smells more like a FAR bug associated with inactive vessels.  The workaround is to disable mechjeb manually via the tweakable on the part for command pods which should be active (this is more of an issue with RO and multiple command pods due to the need to include avionics on every significant stage, so boosters commonly drop command pods).

Share this post


Link to post
Share on other sites
9 hours ago, Jim DiGriz said:

some RO players determined that this happens when a vessel has multiple command pods

There's only one ModuleCommand here AFAIK, and so there should be only one MechJeb module.

9 hours ago, Jim DiGriz said:

That smells more like a FAR bug associated with inactive vessels.

Possibly, insofar as debris is inactive.

 

Edited by steve_v

Share this post


Link to post
Share on other sites
16 hours ago, steve_v said:

There's only one ModuleCommand here AFAIK, and so there should be only one MechJeb module.

That shouldn't be it then.  MechJeb doesn't run on debris, has to have the MechJebCore module attached to it, so the AR404 part or the MM patched CommandPods, unless something really weird has happened and you have managed to get the MJ module on debris.

Share this post


Link to post
Share on other sites

Just for anyone wondering, KSP 1.9 throws a incompatible mod warning on load, but Mechjeb seems to function anyway. I don't think it's broken, but don't trust it fully until you've played around with it for a while.

Share this post


Link to post
Share on other sites
12 hours ago, vardicd said:

Just for anyone wondering, KSP 1.9 throws a incompatible mod warning on load, but Mechjeb seems to function anyway. I don't think it's broken, but don't trust it fully until you've played around with it for a while.

Seems to be working for me, too!

 

Share this post


Link to post
Share on other sites
12 hours ago, vardicd said:

Just for anyone wondering, KSP 1.9 throws a incompatible mod warning on load, but Mechjeb seems to function anyway. I don't think it's broken, but don't trust it fully until you've played around with it for a while.

Well it could be as something as simple as a recompile to solve the issue. after all this is 1.9 you know.. not 1.8.1.

But if it works then it's just tht simple.

Space_Coyote

Edited by Space_Coyote

Share this post


Link to post
Share on other sites
On 2/12/2020 at 5:14 PM, vardicd said:

Just for anyone wondering, KSP 1.9 throws a incompatible mod warning on load, but Mechjeb seems to function anyway. I don't think it's broken, but don't trust it fully until you've played around with it for a while.

Mine says its incompatible, and then nothing shows up on load.

Share this post


Link to post
Share on other sites
Just now, charliesoap4 said:

Mine says its incompatible, and then nothing shows up on load.

I have no idea why, It's working just fine for me, and one or two others have posted that it's working for them. 

Share this post


Link to post
Share on other sites
14 hours ago, charliesoap4 said:

Mine says its incompatible, and then nothing shows up on load.

You need ModuleManager installed and/or you need to use the AR202 part probably (assuming you are starting over clean in KSP 1.9 and have only installed MJ).

With no apparent issues, and nothing in the release notes that should require issues, sarbian is just going to bump the compat checker and release 1.8/1.9 compatible MJ binaries -- which means that ignoring the compat checker warning is the correct thing to do.

EDIT:  Sarbian has done a release so once CKAN is done updating it should show up and stop complaining about the version checker.  There's also a PR into CKAN to add MM as an explicit dep of MJ, once that gets merged to CKAN then it should eliminate most of the complaints from users who forget to MM/AR202 (users who hand install MJ and forget MM may of course still hit that problem).

Edited by Jim DiGriz

Share this post


Link to post
Share on other sites

And here is the release.

2.9.2

  • Localization support with included Simplified Chinese Localization
  • Improved integrator and Brent's Method for maneuvers
  • Fix the ApR and SMA maneuvers
  • Support Multi-Node maneuvers
  • Various fixes and code improvements
  • Stuff I forgot

MechJeb2-2.9.2.0.zip

Share this post


Link to post
Share on other sites

A landing guidance issue that has bugged me for quite a while. Autowarp keeps trying to go, but then immediately resets to warp 1. I often manually "kick" the warp level up by clicking on one of the higher warp levels. It immediately starts going back down to warp 1, but I get at least a bit of time warp in the process, as that takes finite time. (And occasionally I do that too late, resulting in a rapid unplanned disassembly). I have little clue what triggers this. Happens on most, but not all, of my landings.It is not biome changes, as I see it even when I'm over the same biome for quite a while.

Below are links to KSP.log and Player.log from a session I did specially to highlight this. On KSP startup, I immediately used the tracking station to switch to my "base resupply" ship, which I had left in low orbit of Minmus. Picked a landing point (near my base) and told McJeb to land at that point. I did several times do the "manual kick" of the warp level, or I'd have been waiting 15 minutes of real time. :-) The only thing I see suspicious (and I do think it suspicious) in the logs is a lot of mentions of packing and unpacking base resupply for orbit. (Bah. Dropbox on this Mac that I read the forum on is being weird. Had to make these links on my Win 10 game machine and copy them over here; dunno why).

https://www.dropbox.com/s/nhrhv2js2pq68f2/KSP.log?dl=0

https://www.dropbox.com/s/4xukgv0zfpdp66a/Player.log?dl=0

Mod list per CKAN. Oh, and this is all on KSP 1.8.1, though I've been seeing this behavior for a long time (and without most of these mods).

Astrogator (Astrogator v0.10.0)
B9 Part Switch (B9PartSwitch v2.13.0)
ClickThrough Blocker (ClickThroughBlocker 0.1.9.5)
Community Category Kit (CommunityCategoryKit 5.0.0.0)
Community Resource Pack (CommunityResourcePack 1.3.0.0)
Custom Barn Kit (CustomBarnKit 1.1.20.0)
Easy Vessel Switch (EVS) (EasyVesselSwitch 2.0)
GravityTurn Continued (GravityTurnContinued 2:1.7.7)
KEI (KEI 1.2.10.1)
Kerbal Alarm Clock (KerbalAlarmClock v3.12.0.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.7.1)
Kerbal Inventory System (KIS 1.24)
Kerbal Planetary Base Systems (KerbalPlanetaryBaseSystems v1.6.10)
Kerbal Stats (KerbalStats 3.1.0)
MechJeb 2 (MechJeb2 2.9.1.0)
MissingHistory (MissingHistory 1.8.1)
Module Manager (ModuleManager 4.1.3)
Near Future IVA Props (NearFutureProps 1:0.6.1)
Not So Simple Construction (NotSoSimpleConstruction 1.0.2.2.1)
Precise Maneuver (PreciseManeuver 2:2.4.4)
Progressive Colonization System (ProgressiveColonizationSystem v2.1.0)
ScienceAlert ReAlerted (ScienceAlert 1.9.8.6)
SimpleConstruction Updated (SimpleConstruction 1:4.0.2.3)
SimpleLogistics (SimpleLogistics 2.0.3.1)
Stockalike Station Parts Expansion Redux (StationPartsExpansionRedux 1.3.2)
Toolbar Controller (ToolbarController 1:0.1.9.4)
Tracking Station Evolved (TrackingStationEvolved 5.0)
TriggerAu Flags (TriggerAu-Flags v2.9.3.0)
TRP-Hire (TRPHire 0.6.10.1)
Waypoint Manager (WaypointManager 2.8.1)
Zero MiniAVC (ZeroMiniAVC 1:1.1.0.1)

Share this post


Link to post
Share on other sites
42 minutes ago, rmaine said:

A landing guidance issue that has bugged me for quite a while. Autowarp keeps trying to go, but then immediately resets to warp 1. I often manually "kick" the warp level up by clicking on one of the higher warp levels. It immediately starts going back down to warp 1, but I get at least a bit of time warp in the process, as that takes finite time. (And occasionally I do that too late, resulting in a rapid unplanned disassembly). I have little clue what triggers this. Happens on most, but not all, of my landings.It is not biome changes, as I see it even when I'm over the same biome for quite a while.

Below are links to KSP.log and Player.log from a session I did specially to highlight this. On KSP startup, I immediately used the tracking station to switch to my "base resupply" ship, which I had left in low orbit of Minmus. Picked a landing point (near my base) and told McJeb to land at that point. I did several times do the "manual kick" of the warp level, or I'd have been waiting 15 minutes of real time. :-) The only thing I see suspicious (and I do think it suspicious) in the logs is a lot of mentions of packing and unpacking base resupply for orbit. (Bah. Dropbox on this Mac that I read the forum on is being weird. Had to make these links on my Win 10 game machine and copy them over here; dunno why).

https://www.dropbox.com/s/nhrhv2js2pq68f2/KSP.log?dl=0

https://www.dropbox.com/s/4xukgv0zfpdp66a/Player.log?dl=0

Mod list per CKAN. Oh, and this is all on KSP 1.8.1, though I've been seeing this behavior for a long time (and without most of these mods).

Astrogator (Astrogator v0.10.0)
B9 Part Switch (B9PartSwitch v2.13.0)
ClickThrough Blocker (ClickThroughBlocker 0.1.9.5)
Community Category Kit (CommunityCategoryKit 5.0.0.0)
Community Resource Pack (CommunityResourcePack 1.3.0.0)
Custom Barn Kit (CustomBarnKit 1.1.20.0)
Easy Vessel Switch (EVS) (EasyVesselSwitch 2.0)
GravityTurn Continued (GravityTurnContinued 2:1.7.7)
KEI (KEI 1.2.10.1)
Kerbal Alarm Clock (KerbalAlarmClock v3.12.0.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.7.1)
Kerbal Inventory System (KIS 1.24)
Kerbal Planetary Base Systems (KerbalPlanetaryBaseSystems v1.6.10)
Kerbal Stats (KerbalStats 3.1.0)
MechJeb 2 (MechJeb2 2.9.1.0)
MissingHistory (MissingHistory 1.8.1)
Module Manager (ModuleManager 4.1.3)
Near Future IVA Props (NearFutureProps 1:0.6.1)
Not So Simple Construction (NotSoSimpleConstruction 1.0.2.2.1)
Precise Maneuver (PreciseManeuver 2:2.4.4)
Progressive Colonization System (ProgressiveColonizationSystem v2.1.0)
ScienceAlert ReAlerted (ScienceAlert 1.9.8.6)
SimpleConstruction Updated (SimpleConstruction 1:4.0.2.3)
SimpleLogistics (SimpleLogistics 2.0.3.1)
Stockalike Station Parts Expansion Redux (StationPartsExpansionRedux 1.3.2)
Toolbar Controller (ToolbarController 1:0.1.9.4)
Tracking Station Evolved (TrackingStationEvolved 5.0)
TriggerAu Flags (TriggerAu-Flags v2.9.3.0)
TRP-Hire (TRPHire 0.6.10.1)
Waypoint Manager (WaypointManager 2.8.1)
Zero MiniAVC (ZeroMiniAVC 1:1.1.0.1)

I've had the same thing for a long time, but I noticed every time it drops from warp it adjusts the ship just a fraction.  It's not much, but it adds up.  I believe it's the calculations adjusting in preparation for things like drag if you go into atmosphere, and it treats each landing the same.  I'm no expert though.  Just wanted to let you know you're not crazy for seeing it :P

Share this post


Link to post
Share on other sites

Quick question.. back in the older 1.8.1 verison the mod allowed you to actually turn all the pods to mechjec usable pods.. I was wondering if the code has changed or not.. and if not what is the code ot make it all work again?

 

Space_Coyote

Share this post


Link to post
Share on other sites

I think that was a standalone mod. I still use it in my installs Mechjeb for all. I can't find a forum link to it anymore. I do see that mechjeb version 2.8.2 had Incorporate "MechJebAndEngineerForAll" style functionality, though I guess I never noticed, as I was still using the mechjeb for all mod. I one I have, I've had for several versions of KSP now, and it's always worked.

Share this post


Link to post
Share on other sites
58 minutes ago, Space_Coyote said:

For the Mechjeb and engineer for all might want to try this link

 

https://www.curseforge.com/kerbal/ksp-mods/mechjeb-and-engineer-for-all

 

the latest version they have is 1.5 for version 1.722.. but it could be upgraded to the latest version

(I've tried it and apparently it still works.. amazingly)

 

Space_Coyote

Pretty sure that's the version I have. I have an entire library of mods, every version of every mod I've used in KSP going as far back as KSP version .23. Pretty sure I've got old version copies of some mods that don't exist anymore, that predate the forum purge, though I won't swear to it.

b4ikSYp.png

Share this post


Link to post
Share on other sites

我不能在2.9.2中使用交会自动驾驶仪。为什么?

[Moderator added translation]
I cannot use Rendezvous Autopilot in 2.9.2. why?

Edited by James Kerman
Added translation

Share this post


Link to post
Share on other sites

how can I analyze the flight recording data after each flight so I can make changes to the trajectory. Can I download it to my computer?

Share this post


Link to post
Share on other sites
4 minutes ago, Prathtel said:

how can I analyze the flight recording data after each flight so I can make changes to the trajectory. Can I download it to my computer?

The "Flight Recorder" CSV button will export to GameData\MechJeb2\Export. I should add a message...

12 hours ago, Thave said:

我不能在2.9.2中使用交会自动驾驶仪。为什么?

[Moderator added translation]
I cannot use Rendezvous Autopilot in 2.9.2. why?

I ll need more information to help...

Share this post


Link to post
Share on other sites
42 minutes ago, sarbian said:

The "Flight Recorder" CSV button will export to GameData\MechJeb2\Export. I should add a message...

Ok Thank and is there any way to increase the storage limit. 

Nvm. I found a reddit post you made explaining how to do it. Thanks!

Edited by Prathtel

Share this post


Link to post
Share on other sites

@sarbian, I downloaded the latest release of MJ (on the main page) and found a problem with the ascent profile control.

 

7dnOaeP.png

 

I can't reach the "engage" button. Even worse, whenever I drag it down to hit it, it keeps popping back up. How do I fix it?

 

EDIT: Personally, I suggest removing some features from the ascent autopilot such as:

  • Limit throttle - You're ascending into orbit, so OF COURSE you give it 100%
    • Same case for the "Keep limited throttle over" button
  • Electric limit - Why?
  • (What are the TARG and OPTS buttons on the top for)
  • (What exactly does "Hotstaging" do)
Edited by Mars-Bound Hokie
Adding suggested ascent autopilot features to remove

Share this post


Link to post
Share on other sites
53 minutes ago, Mars-Bound Hokie said:

@sarbian, I downloaded the latest release of MJ (on the main page) and found a problem with the ascent profile control.

 

7dnOaeP.png

 

I can't reach the "engage" button. Even worse, whenever I drag it down to hit it, it keeps popping back up. How do I fix it?

 

EDIT: Personally, I suggest removing some features from the ascent autopilot such as:

  • Limit throttle - You're ascending into orbit, so OF COURSE you give it 100%
    • Same case for the "Keep limited throttle over" button
  • Electric limit - Why?
  • (What are the TARG and OPTS buttons on the top for)
  • (What exactly does "Hotstaging" do)

There are many cases where using electric limit can keep you from running out of electricity during ascent, at the moment you begin your autowarp after engine cut off to circularize the burn.  Smaller vessels in particular.  And in cases where you can't safely have external solar panels (all of mine always break if they aren't stowed safely, especially when using FAR) so this button helps keep it from dropping too far by automatically doing whatever needed to keep above the minimum.  At least that's what I've noticed it do on mine (not sure that's entirely the intention :P ).  Throttle limit, for single stage to orbit is going to help keep you from using too much fuel, and also maintains a bit more control, not everyone uses 100% all the time.  In fact there are many times I've dropped to nearly 30% throttle to keep from burning up on atmospheric exit.  I'm not sure on hotstaging.  Anyway, I just wanted to let you know how some of us do use it. :)

Share this post


Link to post
Share on other sites
1 minute ago, StoneWolfPC said:

There are many cases where using electric limit can keep you from running out of electricity during ascent, at the moment you begin your autowarp after engine cut off to circularize the burn.  Smaller vessels in particular.  And in cases where you can't safely have external solar panels (all of mine always break if they aren't stowed safely, especially when using FAR) so this button helps keep it from dropping too far by automatically doing whatever needed to keep above the minimum.  At least that's what I've noticed it do on mine (not sure that's entirely the intention :P ).  Throttle limit, for single stage to orbit is going to help keep you from using too much fuel, and also maintains a bit more control, not everyone uses 100% all the time.  In fact there are many times I've dropped to nearly 30% throttle to keep from burning up on atmospheric exit.  I'm not sure on hotstaging.  Anyway, I just wanted to let you know how some of us do use it. :)

Thanks for those details. I was also wondering what the "TARG" and "OPTS" buttons are for.

 

Most importantly, how do I reach the "Engage" button?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.