Jump to content

[1.12.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.12.3] [23th August 2021]


sarbian
 Share

Recommended Posts

9 hours ago, vipAvoS said:

If I turn off time acceleration in the MJ while it is adjusting the inclination to reach the landing target, then the acceleration is no longer performed.
But the uncontrolled acceleration of time takes place. Today, while in low orbit of the Moon, I created an intercept maneuver through MJ to save the kerbal and enabled execution. Time began to speed up. And then I decided to slightly correct the maneuver. I pressed the slash (stopped acceleration) and turned off the automatic acceleration in MJ. So what? Right. Time all the same began to accelerate.
Sorry, but in my opinion this is already a clear bug.

Stop mechjeb first  and then deactivate acceleration. The ONLY "bug" i have is when i have to make a staging while in final autoland phase near the surface. If acceleration is enable (autostage OFF) most of the time i don t have time to cancel the warp :)

Link to comment
Share on other sites

47 minutes ago, Starwaster said:

Disable warp in MJ before pressing slash.

That does not always work for me.  I try it every time, but it usually does not work in the "abort landing" context

21 hours ago, LTQ90 said:

Stop mechjeb first  and then deactivate acceleration. The ONLY "bug" i have is when i have to make a staging while in final autoland phase near the surface. If acceleration is enable (autostage OFF) most of the time i don t have time to cancel the warp :)

If clicking "abort landing", closing the landing MJ window, doesn't equate to "stop mecheb", then what does?

Link to comment
Share on other sites

1 hour ago, darthgently said:

That does not always work for me.  I try it every time, but it usually does not work in the "abort landing" context

If clicking "abort landing", closing the landing MJ window, doesn't equate to "stop mecheb", then what does?

abord landing == stop mechjeb. If you have the main mechjeb window open you can see which module is active as it s colored in green. For your information i m running ksp 1.12.2.3167 and mechjeb dev version 2.12.3.0 1101. Maybe you can try your save on a clean install with minimum mods.

Link to comment
Share on other sites

2 hours ago, LTQ90 said:

abord landing == stop mechjeb. If you have the main mechjeb window open you can see which module is active as it s colored in green. For your information i m running ksp 1.12.2.3167 and mechjeb dev version 2.12.3.0 1101. Maybe you can try your save on a clean install with minimum mods.

That was my point.  I am "stopping mecheb" to the best of my ability.  But in many cases, it doesn't stop.  It isn't a big issue for me because I rely on kOS for nearly everything, but I like to compare my scripts to MJ.  Because the warp issue came up I figured I'd chime in with what I've found.  I'm on Debian bullseye, KSP 1.11.2, the latest MJ with a ton of mods and the MJ resurrecting warp issue is the least of the issues I deal with on top of the usual kraken barf.  But I'm not trying to solve a problem I"m having here, just conversing in a thread about a problem that has been brought up by others and others also experience.  I do "clean installs" and add/subtract mods, an submit logs and open issues on git for various mods that are central to my game  but it is very time consuming so don't do so for every issue I find everywhere.  If really pushed I could probably narrow down exactly when this happens for me and submit logs, but I wouldn't be doing it to solve a problem in my life.  I'm fairly sure anyone here can relate to that if they've been running KSP for any time at all

Link to comment
Share on other sites

20 hours ago, darthgently said:

That does not always work for me.  I try it every time, but it usually does not work in the "abort landing" context

If clicking "abort landing", closing the landing MJ window, doesn't equate to "stop mecheb", then what does?

The landing GUI and associated code is a separate issue and there is a definite long standing bug in there in that the landing code isn't checking for conditions (that should result in disabling warp) while currently in warp. The main two conditions being whether or not the option is enabled for warp and whether the landing guidance is still in effect. Either of those should cause warp to be cancelled.  Furthermore, once warp has been enabled, it is still treated as enabled even if the  warp option is disabled IFF landing guidance is still enabled.

The end result being that warp must be disabled (in the Landing Guidance window) AND auto landing must be cancelled before manually stopping warp (and you must manually stop warp). Otherwise, the landing guidance will re-enable warp. 

 

 

Edited by Starwaster
Link to comment
Share on other sites

I just recognized that there is no setting to show the "high space altitude" in any readout.

Actually I try to recreate my typical KER-in-flight layout with MechJeb, because KER has kraken issues here and there and VOID is not to my taste.
MechJeb got a few readout strings that KER does not have, but lacks that one.

Edited by Gordon Dry
Link to comment
Share on other sites

Is anyone else having problems with  MJ in KSP 1.12.2? I have the latest MJ and since KSP 1.12.x MJ don`t save Ascent Settings. On every launch they are at default settings. Also: I cannot open settings. There is a little symbol at the left side but I cannot open them. And last but not least: I cannot move the MJ-Menu. It starts at the left top, over the KSP-time menue. After opening Ascent Guidance or other windows, the Menu switch to the right top.
Log:

https://www.file-upload.net/download-14751185/Player.log.html

Edited by Cheesecake
Link to comment
Share on other sites

1 hour ago, Cheesecake said:

Is anyone else having problems with  MJ in KSP 1.12.2? I have the latest MJ and since KSP 1.12.x MJ don`t save Ascent Settings. On every launch they are at default settings. Also: I cannot open settings. There is a little symbol at the left side but I cannot open them. And last but not least: I cannot move the MJ-Menu. It starts at the left top, over the KSP-time menue. After opening Ascent Guidance or other windows, the Menu switch to the right top.
Log:

https://www.file-upload.net/download-14751185/Player.log.html

KSP 1.12.2. - MechJeb 2.12.3.0
I do not observe any of the above. In this regard, there are no problems at all.

Edited by vipAvoS
Link to comment
Share on other sites

10 hours ago, vipAvoS said:

Checked it out. It helps, but not always. I can't understand the addiction yet ...

Make sure your mouse cursor is not over any MJ window when you press that slash key. That means you have to conscienciously clear the warp setting in the MJ menu and then move the cursor out of the window.

Link to comment
Share on other sites

18 hours ago, LTQ90 said:

How to you target the docking port ?

For me i use DPAI mod, but sometime i had to do it manually. And also confirm the "control from here" for the source docking port.

I do the standard control from here for the approaching ship’s docking port and select “set as target” on the station’s docking port

Link to comment
Share on other sites

On 11/19/2021 at 7:04 AM, Starwaster said:

Make sure your mouse cursor is not over any MJ window when you press that slash key. That means you have to conscienciously clear the warp setting in the MJ menu and then move the cursor out of the window.

Greetings to all.
I promise not to touch on this topic again.
But.
I have been dealing with the problem of automatic time acceleration from MJ for a long time. And I found out the following: if MJ began to accelerate, you CANNOT turn it off by any means! From the word - absolutely!
I have now completely disabled the acceleration function from MJ, and I accelerate the time exclusively by regular means. And all the problems were gone.
I hope the author will pay attention to this bug.
But in any case, many thanks to him for such a wonderful mod!

Link to comment
Share on other sites

On 11/18/2021 at 7:15 PM, LTQ90 said:

How to you target the docking port ?

For me i use DPAI mod, but sometime i had to do it manually. And also confirm the "control from here" for the source docking port.

If using kOS you'd do something like:

SET TARGET TO VESSEL("MyFaveDockCraft").

WAIT UNTIL TARGET:LOADED AND TARGET:UNPACKED AND TARGET:POSITION:DISTANCE < 200.

SET dockport to TARGET:PARTSTAGGEDPATTERN("MyFaveDockPort")[0].

SET TARGET TO dockport.
LOCK STEERING TO -dockport:facing:forevector.
// translate to dock axis 
...
// move forward to port                                                                                
...

 

Link to comment
Share on other sites

On 11/17/2021 at 5:39 PM, Cheesecake said:

Is anyone else having problems with  MJ in KSP 1.12.2? I have the latest MJ and since KSP 1.12.x MJ don`t save Ascent Settings. On every launch they are at default settings. Also: I cannot open settings. There is a little symbol at the left side but I cannot open them. And last but not least: I cannot move the MJ-Menu. It starts at the left top, over the KSP-time menue. After opening Ascent Guidance or other windows, the Menu switch to the right top.
Log:

https://www.file-upload.net/download-14751185/Player.log.html

After some further testing: issue is only occuring when JNSQ is installed.

Link to comment
Share on other sites

 I have noticed that out of the blue mechjeb does not seem to be able to use the dart engine in certain spots.   i did  test to try and solve the issues myself. the test i did is i had my lander separate from the ascent stage. mechjeb ran the dart engines juts fine not issues. so i attach to the launch stage and everything goes fine. but instead of burning the dart engines flat out mechjeb does what looks like juts puffing them. as if hitting shift and then a millisecond later x so it puffs. with a 3 minute burn to do puffing it will take 30 minutes at this rate.   2 days ago there where now issues now it juts started.

 

if i knew i how to load my rocket build i would post both of them so you could see it runs fine on its own but when you put it with the rest of the rocket it craps the bed.

 

with the new update mechjeb is really not doing the best so i am slowly trying to wein myself off mechjeb. but i am on the older side and my reflexes are not the best so having mechjeb run the engines would be so great. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...