Jump to content

[1.12.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.14.1] [1st April 2022]


sarbian
 Share

Recommended Posts

1 hour ago, VoidSquid said:

To be expected, your = Kerbin's and the target's orbit are too close, too similar.

Leave Kerbin's SOI, change the orbit significantly (a few hundred dv are usually good), then try to let MJ calculate a Hohmann transfer.

Your advices are so useful everytime! Did you know that everything in KSP we can do manual without MJ?

I put tiny sattelite close to the Sun with cheats, MJ cannot create maneuver node. As I understand it cannot create maneuver node to anything except celestian bodies.

336s5.png

Edited by Alexoff
Link to comment
Share on other sites

Thank you soooo very much for your kind words, @Alexoff  ;) 

19 minutes ago, Alexoff said:

As I understand it cannot create maneuver node to anything except celestian bodies.

I did capture several asteroids using MJ to calculate the Hohmann transfers and related maneuvers. Also to make a rendezvous with other vessels.

Edited by VoidSquid
Link to comment
Share on other sites

I'm using 1.8.1 as some of my important mods are not updated for 1.9.1 yet, and MJ dev #948 at the moment.

In my last career, I visited all CBs with the help of the advanced transfer planner. By the way, you can use that planner too to make transfers between moons within the same SOI of a planet, e.g. Mun and Minmus, it's the same math here as a transfer between different planets: transfer between bodies that are orbiting the same central CB.

Regarding that asteroid capture: I did encounter the same issue as you did, @Alexoff, when trying to capture an asteroid that had an orbit only slightly different from Kerbin's, the advanced transfer planner was unable to find a solution. Then I left Kerbin's SOI in the hope that that a Hohmann transfer would work, but no, same result, no node could be computed. Finally I made a prograde burn of some 400 m/s, resulting in an epileptic orbit around Sun that was different enough from the asteroid's, and MJ was able to calculate a Hohmann transfer. So yes, I did experience the same issue you have, and could resolve it.

The problem with doing transfers between too similar orbits is kind of similar to calculate where two lines cross each other: if the angle between the two lines is large, it's very easy to see (or calculate) where they cross. But if the angle is quite small, you get a fuzzy area where they are crossing. Pens do have a width, where it mathematically is infinitesimal thin, and math-wise, you're dealing with functions of almost equal magnitudes in the numerator and denominator,  and here the limits of a computer's floating point calculations come into effect. 

On a personal note: your comment  

10 hours ago, Alexoff said:

Your advices are so useful everytime! Did you know that everything in KSP we can do manual without MJ?

did sound a bit snarky to me, hence my a-bit.snarky reply. I understand your frustration, but I just tried to help, not ridiculing you, ok?

And while I think your question here was a rhetorical one, I'd like to answer it anyway:
MJ for me a very useful tool, but still a tool, nothing magic.
Yes, I can do say ascends or calculating and executing maneuver nodes manually (which I had to in my current career before completing the tech tree). For me, it's like in RL: use a computer to offload some boring/repetitive/time consuming tasks, but be able to do them by hand if required. At times, MJ doesn't just do what I want, that's when I do it manually, landings in particular.

Edited by VoidSquid
Link to comment
Share on other sites

MJ is a great set of tools. you just need to understand that each of them has its own application limits. No one will take off using the landing tool , I hope )))) in close orbits, it is more correct to use the approach tool rather than the Hohmann transition.

Link to comment
Share on other sites

Hy guys,

I'm sorry: this has certainly been adressed before: I feel MJ translation to a node (or any other order to change ship orientation) is very slow on some crafts.
It seems to want to use the least possible Monopropellent fuel or electricity; it only starts turning, then let the ship sloooowly rotate, wich can take several minutes. But in some cases, I want it to use all fuel needed, just to go much faster.

How to change this? Is there any option/menu to allow MJ to pivot ships faster?

I think this is not version specific, I had this since KSP 1.6 in RSS/RO and have this still now in KSP 1.9 non-RSS/RO

Link to comment
Share on other sites

1 hour ago, Garlik said:

Hy guys,

I'm sorry: this has certainly been adressed before: I feel MJ translation to a node (or any other order to change ship orientation) is very slow on some crafts.
It seems to want to use the least possible Monopropellent fuel or electricity; it only starts turning, then let the ship sloooowly rotate, wich can take several minutes. But in some cases, I want it to use all fuel needed, just to go much faster.

How to change this? Is there any option/menu to allow MJ to pivot ships faster?

I think this is not version specific, I had this since KSP 1.6 in RSS/RO and have this still now in KSP 1.9 non-RSS/RO

If it did not slow like that, it would probably miss hitting the exact vector, oscillate around the vector or overshoot. Great precision is needed since small errors lead to HUGE changes in outcome when you are doing long range transfers.

Link to comment
Share on other sites

2 hours ago, Garlik said:

How to change this? Is there any option/menu to allow MJ to pivot ships faster?

Open the Attitude Controller and play with the "Maximum Angular Velocity" or Max Stopping Time, depending on the selected Controller.

Link to comment
Share on other sites

I'm having an issue with conflicts.

firespitter and mechjeb are fine on their own, but together they cause the game to softlock on the "Verifying Expansions" part of the loading screen.

I don't want to get rid of either because most of my mods don't work without firespitter and I can't get anywhere without mechjeb.

I tried to find logs but this isn't producing any.

please help!

Link to comment
Share on other sites

24 minutes ago, Oxygentlemen said:

I'm having an issue with conflicts.

firespitter and mechjeb are fine on their own, but together they cause the game to softlock on the "Verifying Expansions" part of the loading screen.

I don't want to get rid of either because most of my mods don't work without firespitter and I can't get anywhere without mechjeb.

I tried to find logs but this isn't producing any.

please help!

See the link in my sig block for description of where you can find the log files and more information about how to report a problem.  KSP always produces logs.  It sounds like an installation or version mismatch problem.

Link to comment
Share on other sites

27 minutes ago, Oxygentlemen said:

I'm having an issue with conflicts.

firespitter and mechjeb are fine on their own, but together they cause the game to softlock on the "Verifying Expansions" part of the loading screen.

I don't want to get rid of either because most of my mods don't work without firespitter and I can't get anywhere without mechjeb.

I tried to find logs but this isn't producing any.

please help!

try this version of Firespitter https://snjo.github.io/

if that does not help then you have some old *.DLL somewhere that you need to delete or update

MechJeb is not the problem. also make sure you have the latest version of MJ or Dev Version links are in the OP

Link to comment
Share on other sites

The mention of MJ rotation sometimes being slow prompts me to comment on something I figured our recently. It isn't really an MJ issue - just that I mostly noticed it because I tend to use MJ to create and execute many of my maneuver nodes. For that matter, I concluded that it isn't actually a bug at all, but KSP being slightly more realistic than I expected in one regard. I should have figured it out long ago, but sometimes I'm a little slow myself. :-)

I'll be set up for a maneuver that's a fair bit in the future, so I'm time warping to it. Start the warp pointed in the right direction, but my orientation drifts off during the warp. Sometimes it drifts off a *LOT* (like 90 degrees). Seems to only be noticeable with large craft (which should have been a hint), which tend to be lumbering to turn back to the right orientation (though I found I can speed that up a bit by temporarily aborting the auto execution of the maneuver and manually doing the turn). Finally dawned on me that what I was seeing was tidal effects because the different ends of the craft were essentially trying to be in slightly different orbits. Of course, that's a real effect; I was just surprised to see the KSP model doing it.

Link to comment
Share on other sites

1 hour ago, dtoxic said:

try this version of Firespitter https://snjo.github.io/

if that does not help then you have some old *.DLL somewhere that you need to delete or update

MechJeb is not the problem. also make sure you have the latest version of MJ or Dev Version links are in the OP

Thank you for responding, I really appreciate the help.

I tried updating firespitter with the link you provided, but no change. How do I effectively search for old *dll's?

Also I looked in the updated 1.8 log spot, still nothing.

Link to comment
Share on other sites

12 hours ago, Oxygentlemen said:

Thank you for responding, I really appreciate the help.

I tried updating firespitter with the link you provided, but no change. How do I effectively search for old *dll's?

Also I looked in the updated 1.8 log spot, still nothing.

Well remove half the mods,start the game if no problem add half of the half removed start again, if there is a problem try and narrow it down, or remove all the mods that have a *.DLL and start adding 2-3 at a time and see when the problem start's to occur

Link to comment
Share on other sites

On 3/17/2020 at 12:26 AM, ansaman said:

If it did not slow like that, it would probably miss hitting the exact vector, oscillate around the vector or overshoot. Great precision is needed since small errors lead to HUGE changes in outcome when you are doing long range transfers.

Yeah thanks, but im 100% sure that is not it ;-)

litterally 10minutes to point to node direction, that is too much :)

IRL This would be realistic, but here, it even prevents MJ to circularize during ascent as the time it takes to point to node: I'm already back in atmo falling back to ground

Link to comment
Share on other sites

On 3/18/2020 at 8:19 AM, dtoxic said:

Well remove half the mods,start the game if no problem add half of the half removed start again, if there is a problem try and narrow it down, or remove all the mods that have a *.DLL and start adding 2-3 at a time and see when the problem start's to occur

after a long day of testing and waiting for the game to load, i finally found the problem

seems to originate from USI kolonisation tools, so i dropped that and everything's working fine.

Link to comment
Share on other sites

When I try to use Landing Guidance the game crashes.  I've tried both "pick a landing spot on the map" and "enter coordinates".  I've zipped up the ksp.log file, but I don't seen an option to attach it here.  Let me know how to send it to you and I'll be happy to do so.

[edit - additional information]

I've been launching with the following command line:

"D:\Kerbal Space Program\KSP_x64.exe" -force-d3d12

That was to solve a known issue with Scatterer.  When I use the normal launcher, Landing Guidance works fine.  I'll still send the ksp.log file if you want to look at it.

Edited by Krymson Skorpyon
Link to comment
Share on other sites

2 hours ago, Krymson Skorpyon said:

When I try to use Landing Guidance the game crashes.  I've tried both "pick a landing spot on the map" and "enter coordinates".  I've zipped up the ksp.log file, but I don't seen an option to attach it here.  Let me know how to send it to you and I'll be happy to do so.

The best approach is to upload a file to a file sharing service, such as DropBox, GoogleDrive, or OneDrive, etc. and share it via a link in the post.

Link to comment
Share on other sites

I've been told that Mechjeb works with Fore by Throttle, yet when I have the RCS thrusters set to fore by throttle, Mechjeb still starts the burn at node time 0 instead of negative something, thus ruining a hohman transfer.  Is there some option I'm missing in mechjeb?  This is with the latest dev build of Mechjeb.

Submitted issue on Github.

Edited by MashAndBangers
Link to comment
Share on other sites

@sarbian got this Nullref spam when undocking a probe in high atmo over Kerbin containing MJ and it stopped when probe was destroyed (crashed)

Spoiler

MuMech.MechJebModuleMenu.<SetupToolBarButtons>b__30_4 () (at <60a690eba429467784b8e3e5237fd03f>:0)
    MuMech.MechJebModuleMenu+<>c__DisplayClass31_0.<CreateFeatureButton>b__0 () (at <60a690eba429467784b8e3e5237fd03f>:0)
    MuMech.MechJebModuleMenu.OnMenuUpdate () (at <60a690eba429467784b8e3e5237fd03f>:0)
    MuMech.MechJebCore.Update () (at <60a690eba429467784b8e3e5237fd03f>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

Here are the logs

https://www.dropbox.com/s/i1xhhd338nmint6/KSP_1.9.1-Win7-X64.rar?dl=0

this is with MechJeb2-2.9.2.0-949

Edit: I think it has to do with Blizzy Toolbar....when disconnected the probe that has MJ is working fine the Probe that does not have MJ thinks it's still active in Blizzy Toolbar (all the selected buttons are still present even thou no MJ is present on that probe/ship) and thus trowing errors, @linuxgurugamer should look at this also because i don't know on which end the error is coming from.

Steps to reproduce..

1. create 2 probes/ships one with MJ part, The other Without

2.dock them in orbit, once docked,enter atmo. and undock. (important they must dock 2 separate ships 2 launches/hyper edits) also note that you have to assign some MJ buttons to Blizzy toolbar so they are visable in flight/map scene before docking

this error is not present when say undocking around moon,it only seems to fire up when entering atmo./around kerbin? and the 2 probes are in physics range, if the probe with the MJ part is destroyed while in physics range (maybe even if not in range) the error spam stops.

 

Edited by dtoxic
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...