Jump to content

[1.12.x] Anatid Robotics / MuMech - MechJeb - Autopilot - [2.14.1] [1st April 2022]


sarbian
 Share

Recommended Posts

17 hours ago, Jimbodiah said:

Running 1.12.3 and pretty much any mechjeb version I try (2.13 to latest stable release) all have the mechjeb menu locked into the top left corner of the screen an no options in the window  other than "custom window settings".   I think I had a 1.12.1 setup without this issue. Am I doing something wrong? I've seen the same issue reported when googling it, but can't find a solution.

edit: found the github issue about this, but am not running Click Through Blocker. Any other mods that cause this issue?

Mechjeb has a settings menu that let's you chose which corner of the screen to put the drop down menu

Link to comment
Share on other sites

Has anyone gotten automated burns to work with engines mounted on robotic parts?

For example, I used the breaking ground servos to create some stowable engines, and while manual burns work fine, any MJ automated ones (for example, landing autopilot or node execution) will only fire for <1s at a time.

The behavior looks similar to what happens when you have engines that are off center and apply a large torque, but these engines are balanced and any torque is very small. 

Servos are locked and autostrutted - the engines aren't moving anywhere while engaged. 

Edit: So this seems to be working after a save/reload. Probably something like the thrust vectors not getting recalculated correctly until you reload the scene 

Edited by AtomicRocketBooster
Resolution
Link to comment
Share on other sites

Does landing assistance not work with latest versions of mechJeb/KSP? Autopilot just seems to do random burns that just mess up orbit

Edited by Fallor
Link to comment
Share on other sites

I would like to build MechJeb. https://github.com/MuMech/MechJeb2/blob/dev/README.md#build provides compilation instructions for Linux and Windows.

The Linux instructions seem impossible to use because the Makefile sets /langversion:8.0 and Mono only has partial C# 7.0 support, unless my understanding is limited.

The Windows instructions - well, perhaps this is down to me not knowing enough about building things on Windows, but there doesn't actually seem to be a point in them where you _build_ anything. Step 3 seems just to be editing something - then what?

Link to comment
Share on other sites

Posted (edited)

All MechJeb release are built on my Jenkins which runs on Linux. dotnet runs fine on Linux and you can use it to build (info).  I did not test it but

./dotnet sdk/6.0.400/MSBuild.dll MechJeb2/MechJeb2.csproj

should build MJ fine with the current tarball of the .NET 6.0 SDK

If you do not want to full dotnet then a simple installation of the Compiler with nuget install Microsoft.Net.Compilers can do the trick, and then you use KSP dll as references.

I just tested with mono 6 and it works fine.

 

On Windows the instruction assume you have Visual Studio installed and know the basis of how to use it. You can find threads to help you with that on the forum.

Edited by sarbian
Link to comment
Share on other sites

Thank you. I think my understanding of what version numbers go with what is still a bit limited, but armed with that I was able to know to try with a later Mono than my distribution supplies and build it OK. Fortunate since I neither have Visual Studio installed nor have any clue how to use it. ;-)

Edited by damerell
Link to comment
Share on other sites

On 8/11/2022 at 1:37 AM, AtomicRocketBooster said:

Has anyone gotten automated burns to work with engines mounted on robotic parts?

For example, I used the breaking ground servos to create some stowable engines, and while manual burns work fine, any MJ automated ones (for example, landing autopilot or node execution) will only fire for <1s at a time.

The behavior looks similar to what happens when you have engines that are off center and apply a large torque, but these engines are balanced and any torque is very small. 

Servos are locked and autostrutted - the engines aren't moving anywhere while engaged. 

Edit: So this seems to be working after a save/reload. Probably something like the thrust vectors not getting recalculated correctly until you reload the scene 

So after more experimentation, this still seems to be a problem.

  • Landing autopilot seems to be able to handle engines mounted on robotics parts (usually - it still acts up sometimes)
  • Maneuver Node autopilot seems to struggle - throttle control is totally wacky, oscillating from 0% to 100% constantly.

You can work around it by using SmartASS node guidance and doing the burns manually, but there's definitely something broken.

Link to comment
Share on other sites

I agree with AtomicRocketBooster, something broke at MJ.
I previously filmed an auto landing video in which MJ did a brilliant job. If interested, this excellent work can be viewed on YouTube (_https://youtu.be/EM493tsV7tk, time 07:00-07:55).
And more recently, I came across the fact that the MJ is late with the start of braking. This is shown in a YouTube video (_https://youtu.be/kIt_sXdE3i8, time 03:55). And it can only be cured with Landertrons (same video, time 06:30, 13:30, and all three landings, time 13:57).
At first I thought it was because of the large landing weight of the ship, 13.6 tons, but the landing of a light ship, about 5 tons, ended the same way.
Something broke at MJ...

+
And further. Earlier, when entering orbit, the MJ also worked perfectly. The difference between the apocenter and the pericenter was a maximum of 200-300 meters. And now it reaches up to 20 kilometers! Nightmare...

Edited by vipAvoS
Link to comment
Share on other sites

Is there any way to have the landing guidance module override Max Q throttling? I like the throttling on ascent, but if i forget to manually turn it off then the engines never throttle up for landing!

Link to comment
Share on other sites

1 hour ago, efmd3 said:

Is there any way to have the landing guidance module override Max Q throttling? I like the throttling on ascent, but if i forget to manually turn it off then the engines never throttle up for landing!

An annoyance for sure, but what I've ended up doing (After innumerable ships lost because of this) is to always uncheck the Max Q option when above 30-40k or so. It's easy to remember because you have the Ascent guidance window still open by that point

Link to comment
Share on other sites

12 hours ago, Forked Camphor said:

An annoyance for sure, but what I've ended up doing (After innumerable ships lost because of this) is to always uncheck the Max Q option when above 30-40k or so. It's easy to remember because you have the Ascent guidance window still open by that point

Yep, I try to remember to disable it at BECO, but I've obviously forgotten a few times and only noticed when my booster hits the ground at a couple hundred m/s, lol.

Even if the landing guidance can't automatically override it, it would be nice to have a toggle in the landing guidance window to avoid the RUD from scrambling to open the utilities window fast enough to save the landing. I realize this is a me problem, but this is the best place to ask for the feature, AFAIK. 

Link to comment
Share on other sites

6 minutes ago, efmd3 said:

Yep, I try to remember to disable it at BECO, but I've obviously forgotten a few times and only noticed when my booster hits the ground at a couple hundred m/s, lol.

Even if the landing guidance can't automatically override it, it would be nice to have a toggle in the landing guidance window to avoid the RUD from scrambling to open the utilities window fast enough to save the landing. I realize this is a me problem, but this is the best place to ask for the feature, AFAIK. 

Of course, I agree with you. I was just giving some alternatives to work around the issue. Another thing that comes to mind is binding a key to the "Pause" function in the Time control mod. It pauses the simulation but you can still use the UI.

Link to comment
Share on other sites

On 8/31/2022 at 12:31 PM, efmd3 said:

Is there any way to have the landing guidance module override Max Q throttling? I like the throttling on ascent, but if i forget to manually turn it off then the engines never throttle up for landing!

I'm sorry, but could you briefly explain what the Max Q parameter is for? I see how this limit works for a while during takeoff, then I turn on the acceleration limit, and Max Q turns off. So I don’t understand what this parameter has to do with landing.

+

In addition, all MJ settings are global and are applied immediately. If you open the "lifting assistant" and change this parameter there, then it will be applied for landing as well.

++

Moreover, you can create a custom window in which you can add this parameter and others you need, both informational and control.

Edited by vipAvoS
+
Link to comment
Share on other sites

25 minutes ago, vipAvoS said:

I'm sorry, but could you briefly explain what the Max Q parameter is for? I see how this limit works for a while during takeoff, then I turn on the acceleration limit, and Max Q turns off. So I don’t understand what this parameter has to do with landing.

+

In addition, all MJ settings are global and are applied immediately. If you open the "lifting assistant" and change this parameter there, then it will be applied for landing as well.

It's "maximum dynamic pressure", in ascent guidance is the maximum pressure allowed to the rocket body (In pascals I believe), beyond that number it starts to throttle. As you said, the parameter is global, so, if you don't remember to deactivate it when you try to land on a body with an atmosphere the limit prevents you (If you are going fast enough) from using your engines for slowing down or doing a propulsive landing for example. A simple solution will be if the limit could differentiate between positive and negative vertical velocity, as it is now it applies to both

Edited by Guest
Link to comment
Share on other sites

On 9/1/2022 at 1:05 PM, Forked Camphor said:

if you don't remember to deactivate it when you try to land on a body with an atmosphere the limit prevents you (If you are going fast enough) from using your engines for slowing down or doing a propulsive landing for example

Thanks for the tip. Perhaps this is what did not allow the MJ to land the booster stage, which I talked about in my previous post.

+

Unfortunately disabling Max Q when landing did not solve the problem. MJ still turned on the engine late.

Edited by vipAvoS
+
Link to comment
Share on other sites

  • 2 weeks later...

Hello, just to inform that the Mechjeb 2.14.0 & 2.14.1 have an issue about the "Launch" options : we cannot limit the trust of the engine.
Even if we chose to limit it at 20-40-60% for example, it is not taken into consideration.

I reverted my Mechjeb to the 2.12.0 version and it works.
But not in the most recent versions (2.14 + 2.14.1).

Regards.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...